Subject: [rtcweb] Mapping between SIP and ROAP/JSEP

From: "Avasarala, Ranjit" <[email-masked]>
Date: Wed, 9 May 2012 14:49:13 +0800

Hi

Is there any interest in the coming up with a mapping between SIP and ROAP/JSEP protocols?  Though JSEP is a set of APIs as of now which map closely with ROAP APIs, ROAP has messages like OFFER,ANSWER and OK which can be mapped to SIP.

Comment?

Thanks

Regards
Ranjit

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Wed, 9 May 2012 06:52:40 +0000

Ranjit,

I agree with you that Interworking document for JSEP to SIP is important for developing the interworking solution. I'll interested in contributing one such draft. Such a draft will help in identify the gap in JSEP to support SIP interworking like UPDATE during early dialog.

Thanks
Partha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Avasarala, Ranjit
Sent: Wednesday, May 09, 2012 12:19 PM
To: [email-masked]
Subject: [rtcweb] Mapping between SIP and ROAP/JSEP

Hi

Comment?

Thanks

Regards
Ranjit

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 09 May 2012 09:01:27 +0200

On 05/09/2012 08:52 AM, Ravindran, Parthasarathi wrote:
>
> Ranjit,
>
> I agree with you that Interworking document for JSEP to SIP is 
> important for developing the interworking solution. I?ll interested in 
> contributing one such draft. Such a draft will help in identify the 
> gap in JSEP to support SIP interworking like UPDATE during early dialog.
>
Since JSEP is an API, and has been implemented, I suggest that the most 
reasonable form of documentation is an opensource SIP implementation on 
top of JSEP, not an internet-draft.

If someone wants to contribute such code, I'm sure we can host it as 
part of webrtc-samples, if that helps - the other piece would be a 
recipe for setting up some opensource SIP server to prove that it 
actually works.

Running code has the advantage that it is easy to test it.

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Wed, 9 May 2012 07:15:18 +0000

Harald,

My guess is that running code already exists in the form of SIP over websocket. The point is not about the running code. The running code will not cover all the offer/answer state machine issues which I'm talking about. The running code is just equivalent to proof of concept but will not cover all the deployable solution and does not cover all the existing offer/answer .

Even though JSEP is projected as API, offer/pr-answer/answer state MUST be traversed in some magic way between two web-browsers for establishing the session and these states are not possible to directly map with RFC 3264 or RFC 3261 (SIP) usage. So, there is a need of interworking document. The point to be noted is that the interworking between JSEP to SIP shall occur at browser or at WebRTC server.

Thanks
Partha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Harald Alvestrand
Sent: Wednesday, May 09, 2012 12:31 PM
To: [email-masked]
Subject: Re: [rtcweb] Mapping between SIP and ROAP/JSEP

I agree with you that Interworking document for JSEP to SIP is important for developing the interworking solution. I'll interested in contributing one such draft. Such a draft will help in identify the gap in JSEP to support SIP interworking like UPDATE during early dialog.
Since JSEP is an API, and has been implemented, I suggest that the most reasonable form of documentation is an opensource SIP implementation on top of JSEP, not an internet-draft.

If someone wants to contribute such code, I'm sure we can host it as part of webrtc-samples, if that helps - the other piece would be a recipe for setting up some opensource SIP server to prove that it actually works.

---

From: Likepeng <[email-masked]>
Date: Wed, 9 May 2012 08:18:31 +0000

I think it is useful to have such a draft which provides a mapping between SIP and ROAP/JSEP protocols.

Previously Cullen has an expired draft related to this:
http://tools.ietf.org/html/draft-jennings-rtcweb-signaling-gateway-00

Some time ago, I submitted a draft to map ROAP with XMPP/Jingle.
http://datatracker.ietf.org/doc/draft-li-rtcweb-roap-jingle-interworking/

I need to update it to reflect the JSEP concept.

I would appreciate if anybody has interest to work with me about this.

Thanks,
Kind Regards
Kepeng
发件人: [email-masked] [mailto:[email-masked]] 代表 Avasarala, Ranjit
发送时间: 2012年5月9日 14:49
收件人: [email-masked]
主题: [rtcweb] Mapping between SIP and ROAP/JSEP

Hi

Comment?

Thanks

Regards
Ranjit

---

From: Justin Uberti <[email-masked]>
Date: Wed, 9 May 2012 22:53:53 -0400

I would be willing to review a JSEP-XMPP draft.

On Wed, May 9, 2012 at 4:18 AM, Likepeng <[email-masked]> wrote:

>  I think it is useful to have such a draft which provides a mapping
> between SIP and ROAP/JSEP protocols.****
>
> ** **
>
> Previously Cullen has an expired draft related to this:****
>
> http://tools.ietf.org/html/draft-jennings-rtcweb-signaling-gateway-00****
>
> ** **
>
> Some time ago, I submitted a draft to map ROAP with XMPP/Jingle.****
>
> http://datatracker.ietf.org/doc/draft-li-rtcweb-roap-jingle-interworking/*
> ***
>
> ** **
>
> I need to update it to reflect the JSEP concept.****
>
> ** **
>
> I would appreciate if anybody has interest to work with me about this.****
>
> ** **
>
> Thanks,****
>
> Kind Regards****
>
> Kepeng****
>
> *发件人:* [email-masked] [mailto:[email-masked]] *代表 *Avasarala,
> Ranjit
> *发送时间:* 2012年5月9日 14:49
> *收件人:* [email-masked]
> *主题:* [rtcweb] Mapping between SIP and ROAP/JSEP****
>
> ** **
>
> Hi****
>
> ** **
>
> Is there any interest in the coming up with a mapping between SIP and
> ROAP/JSEP protocols?  Though JSEP is a set of APIs as of now which map
> closely with ROAP APIs, ROAP has messages like OFFER,ANSWER and OK which
> can be mapped to SIP.****
>
> ** **
>
> Comment?****
>
> ** **
>
> Thanks****
>
> ** **
>
> Regards****
>
> Ranjit****
>
> ** **
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 09 May 2012 21:00:39 -0600

> I would be willing to review a JSEP-XMPP draft.

Same here.

Peter

---

From: Glen Zorn <[email-masked]>
Date: Thu, 10 May 2012 12:42:56 +0700

>> I would be willing to review a JSEP-XMPP draft.

Me, too.