Subject: [rtcweb] TCP vs UDP for media

From: "Young, Milan" <[email-masked]>
Date: Tue, 15 May 2012 23:22:09 +0000

Most of the use cases within WebRTC center around human to human communication, and for such cases RTP transport makes sense.  But there are at least a few use cases where one of the endpoints could be a machine.  Since machines have the ability to buffer and take a quick nap on the job, the "realtime" requirement isn't as critical.  Often, in such cases, the more important consideration is whether all of the media was transmitted.

I'm relatively new to WebRTC, so I apologize if I'm rehashing settled issues.  But I'm wondering if any thought has been given to TCP as a media transport.  If framing and timeouts could be worked out, would other folks besides myself find this useful?
 
Thanks

---

From: Ralph Giles <[email-masked]>
Date: Tue, 15 May 2012 16:38:36 -0700

On 12-05-15 4:22 PM, Young, Milan wrote:

> I'm wondering if any thought has been given to TCP as a media transport.

Where low latency transmission isn't an issue, one can generally fall
back to established TCP-based protocols, like HTTP streaming and
websockets, so we haven't really worried about that angle in the context
of webrtc.

Recording the stream is a requirement, so probably something could be
built using that, merging recordings from each endpoint to fix up any
dropped packets.

 -r

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 15 May 2012 16:46:49 -0700

> built using that, merging recordings from each endpoint to fix up any

Agreed. This seems like something that could be done using just
getUserMedia() plus existing Web technologies.

-Ekr

---

From: "Young, Milan" <[email-masked]>
Date: Wed, 16 May 2012 01:37:54 +0000

Yes, existing web technologies for transport would work fine.  In fact I wrote a demo based on WebSockets, the AudioAPI, and getUserMedia.  But it's a bit cludgy and only transmits PCM audio.

Would my use case for live access to an encoded media stream be a good fit for a revised MediaStreamRecorder?  Would this group the right place to host such an effort?

 Thanks

-----Original Message-----
From: Eric Rescorla [mailto:[email-masked]] 
Sent: Tuesday, May 15, 2012 4:47 PM
To: Ralph Giles
Cc: Young, Milan; [email-masked]
Subject: Re: [rtcweb] TCP vs UDP for media

On Tue, May 15, 2012 at 4:38 PM, Ralph Giles <[email-masked]> wrote:
> websockets, so we haven't really worried about that angle in the 
> context of webrtc.
>

-Ekr

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 16 May 2012 08:43:57 +0200

On 2012-05-16 03:37, Young, Milan wrote:
> Yes, existing web technologies for transport would work fine.  In
> fact I wrote a demo based on WebSockets, the AudioAPI, and
> getUserMedia.  But it's a bit cludgy and only transmits PCM audio.
> 
> Would my use case for live access to an encoded media stream be a
> good fit for a revised MediaStreamRecorder?  Would this group the
> right place to host such an effort?

I think this is something you should take to the W3C. As it appear to be
primarily an API question. Getting access to the content in the JS
application or request the browser to record to a local file which later
can be uploaded it would not be in this WG.

Cheers

Magnus Westerlund
WG chair

> 
> Thanks
> 
> -----Original Message----- From: Eric Rescorla [mailto:[email-masked]]
>  Sent: Tuesday, May 15, 2012 4:47 PM To: Ralph Giles Cc: Young,
> Milan; [email-masked] Subject: Re: [rtcweb] TCP vs UDP for media
> 
>> Where low latency transmission isn't an issue, one can generally
>> fall back to established TCP-based protocols, like HTTP streaming
>> and websockets, so we haven't really worried about that angle in
>> the context of webrtc.
>> 
>> Recording the stream is a requirement, so probably something could
>> be built using that, merging recordings from each endpoint to fix
>> up any dropped packets.
> 
> -Ekr _______________________________________________ rtcweb mailing
> list [email-masked] https://www.ietf.org/mailman/listinfo/rtcweb
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 31 May 2012 09:01:42 -0600

You should take this as a requirement to the [email-masked] list (added to thread). It seem reasonable to want to specify which codec the data returned from getusermedia should use. 

On May 16, 2012, at 12:43 AM, Magnus Westerlund wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb