Subject: [rtcweb] Update of future interim meeting locations

From: Cullen Jennings <[email-masked]>
Date: Mon, 16 Apr 2012 13:45:29 -0600

The CLUE and WebRTC groups are making plans based on WebRTC meeting June 12 and 13 in Stockholm. The chairs believe that picking a different time or locations at this point will not be beneficial so we plan to try and confirm that date. 

I'd like to try and answer the question about locations of RTCWeb interim meetings after the ones currently planned.

First of all, the chairs would are going to declare that there is WG consensus for a 1:1:1 meeting rotation between west coast of north america, europe, and east coast of north america and plan to run approximately equal number of meetings in these locations.  In counting the number of past meetings in a given region, we will include all the face to face RTCWeb and WebRTC meetings as this work is closely joined and a large number of the participants travel to both sets of meetings. The face to face meetings that happen at the main IETF or W3C meetings are included in this count. Collocated meetings will be counted just once as they only require one set of travel to that location.  

Cullen  <RTCWeb co-chair>

---

From: Mary Barnes <[email-masked]>
Date: Mon, 16 Apr 2012 16:04:42 -0500

Just one clarification - I thought the W3C WebRTC group planned to meet on
June 11th and then the IETF RTCWEB WG on June 12-13?

The CLUE WG meeting still plans to meet on June 7-8.

Regards,
Mary.

On Mon, Apr 16, 2012 at 2:45 PM, Cullen Jennings <[email-masked]> wrote:

>
> The CLUE and WebRTC groups are making plans based on WebRTC meeting June
> 12 and 13 in Stockholm. The chairs believe that picking a different time or
> locations at this point will not be beneficial so we plan to try and
> confirm that date.
>
> I'd like to try and answer the question about locations of RTCWeb interim
> meetings after the ones currently planned.
>
> First of all, the chairs would are going to declare that there is WG
> consensus for a 1:1:1 meeting rotation between west coast of north america,
> europe, and east coast of north america and plan to run approximately equal
> number of meetings in these locations.  In counting the number of past
> meetings in a given region, we will include all the face to face RTCWeb and
> WebRTC meetings as this work is closely joined and a large number of the
> participants travel to both sets of meetings. The face to face meetings
> that happen at the main IETF or W3C meetings are included in this count.
> Collocated meetings will be counted just once as they only require one set
> of travel to that location.
>
> Cullen  <RTCWeb co-chair>
>
>
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 16 Apr 2012 15:18:36 -0600

Mary, I think you are correct that the dates being considered are 

Clue - June 7 and 8 

WebRTC - June 11

RTCWeb - June 12 and 13

Sorry for confusion. 

On Apr 16, 2012, at 3:04 PM, Mary Barnes wrote:

> Just one clarification - I thought the W3C WebRTC group planned to meet on June 11th and then the IETF RTCWEB WG on June 12-13?  
>

---

From: "Roni Even" <[email-masked]>
Date: Tue, 17 Apr 2012 00:38:11 +0300

Hi,

I would like to suggest that the RTCweb meeting will be on the 11 and 12
followed by the webrtc allowing people to attend CLUE on the 7,8 and RTCweb
without having to stay one more extra day after the weekend.

Thanks

Roni Even

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mary Barnes
Sent: Tuesday, April 17, 2012 12:05 AM
To: Cullen Jennings
Cc: [email-masked]
Subject: Re: [rtcweb] Update of future interim meeting locations

Regards,

Mary. 

The CLUE and WebRTC groups are making plans based on WebRTC meeting June 12
and 13 in Stockholm. The chairs believe that picking a different time or
locations at this point will not be beneficial so we plan to try and confirm
that date.

participants travel to both sets of meetings. The face to face meetings that
happen at the main IETF or W3C meetings are included in this count.

Cullen  <RTCWeb co-chair>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 17 Apr 2012 16:57:40 -0400

On Mon, Apr 16, 2012 at 3:45 PM, Cullen Jennings <[email-masked]> wrote:
> consensus for a 1:1:1 meeting rotation between west coast of north
> america, europe, and east coast of north america and plan to run
> approximately equal number of meetings in these locations.  In
> counting the number of past meetings in a given region, we will
> include all the face to face RTCWeb and WebRTC meetings as this work
> is closely joined and a large number of the participants travel to
> both sets of meetings. The face to face meetings that happen at the
> main IETF or W3C meetings are included in this count. Collocated
> meetings will be counted just once as they only require one set of
> travel to that location.

Cullen,

Thanks for this clarification. Just to be totally sure I understand,
do you mean the following algorithm?

   For an interim meeting at time X, sum up all the prior meetings
   for each of the regions. The region with the fewest prior
   meetings is then selected for the next interim. [0]

Is this what you guys have in mind?

-Ekr

[0] For extra credit, ties need to be resolved somehow. I can
suggest a mechanism if you need one :)

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 17 Apr 2012 17:06:22 -0400

>   meetings is then selected for the next interim. [0]

Which implies that  Paris doesn't count.

Regards
Marshall

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 17 Apr 2012 17:09:47 -0400

> Which implies that  Paris doesn't count.

That's certainly not what I meant. Perhaps it would help to rewrite
"next interim" as "interim X". Concretely, to select an interim meeting
in mid-September, I would expect to count meetings up to and
including Vancouver.

-Ekr

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 17 Apr 2012 16:15:33 -0500

>in mid-September, I would expect to count meetings up to and

why don't Paris and Boston (I think that was the last interim, though 
that might have been CLUE) count here?

James

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 17 Apr 2012 17:28:40 -0400

On Tue, Apr 17, 2012 at 5:15 PM, James M. Polk <[email-masked]> wrote:
> why don't Paris and Boston (I think that was the last interim, though that
> might have been CLUE) count here?

They would. That's why I said "Up to and including". Paris was before
September 2012.

Obviously I'm being unclear. Here's a slightly more formal description.

Each scheduled or past meeting is represented as a tuple [region, date].
E.g., Paris would be something like [Europe, 20120325]

To select an interim at date X, take the subset of all meetings with date < X
and count the number in each region. To just make up some data, this
would look like:

{
  'Europe':1,
  'West Coast':2:,
  'East Coast':0
}

Then, select the region with the smallest number of meetings for the
interim at date X.
So, in this case, the interim would be held on the East Coast.

For additional concretenss, iff we were executing this algorithm to select this
interim, we would be building a table of all meetings up through Paris. I.e.,
the last two would be IETF 83 and the Jan/Feb Interim in Mountain View.
[I'm assuming for the purposes of this discussion that we are not counting
CLUE interims, since the chairs referred to "RTCWeb and WebRTC".

One detail: you need to select the interims in chronological order because the
previous interim selections obviously affect the next ones.

Best,
-Ekr

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 17 Apr 2012 15:33:16 -0600

> suggest a mechanism if you need one :)

Yes - that is what I was thinking and I had not really thought much about ties. So unless you want a maximally self serving tie breaking algorithm of selecting the location closest to YYC, it would be great if someone could suggest the tie breaking algorithm. 

Cullen

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 17 Apr 2012 16:39:17 -0500

At 04:28 PM 4/17/2012, Eric Rescorla wrote:
>Obviously I'm being unclear.

No, I think I knew what you wanted to get to the first time, but what 
you have below articulates it quite nicely though.

And, as you pointed out, we need a means for solving for ties - 
mostly because the goal of this is to have a tied once a year between 
3 (if we keep the 1:1:1 format), then once a year between 2, right?

James

>Here's a slightly more formal description.
>

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 17 Apr 2012 16:44:20 -0500

At 04:33 PM 4/17/2012, Cullen Jennings wrote:

>Yes - that is what I was thinking and I had not really thought much 
>about ties. So unless you want a maximally self serving tie breaking 
>algorithm of selecting the location closest to YYC, it would be 
>great if someone could suggest the tie breaking algorithm.

how about the previous and next IETF meetings disqualify that 
location (and potentially each location). Something like that should 
work in favor of covering the currently least travelled to location 
(in theory).

I.e., last was Europe, next is West Coast NA, that means this interim 
must be on east coast NA (sorry Magnus  ;-)

perhaps this one ought to be that Europe now can't be for a year, 
because it is getting two RTCweb meetings in a row (Paris in March 
and Stockholm in June).

James

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 17 Apr 2012 17:48:14 -0400

> Yes - that is what I was thinking and I had not really thought much about ties. So unless you want a maximally self serving tie breaking algorithm of selecting the location closest to YYC, it would…

I would suggest picking the region (in the equivalence set)
we were at least recently in the case of ties.

-Ekr

---

From: "Jim Barnett" <[email-masked]>
Date: Tue, 17 Apr 2012 15:47:55 -0700

Possible tie-breaking algorithm:

  If season==summer ==> Europe
  elsif season==winter ==> west coast
  elsif season==sorta-in-between ==> east coast

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Cullen Jennings
Sent: Tuesday, April 17, 2012 5:33 PM
To: Eric Rescorla
Cc: [email-masked]
Subject: Re: [rtcweb] Update of future interim meeting locations

> [0] For extra credit, ties need to be resolved somehow. I can suggest 
> a mechanism if you need one :)
> 

Yes - that is what I was thinking and I had not really thought much
about ties. So unless you want a maximally self serving tie breaking
algorithm of selecting the location closest to YYC, it would be great if
someone could suggest the tie breaking algorithm. 

Cullen

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 18 Apr 2012 09:27:22 +0200

1) I'd like to let the chairs have some flexibility
2) It's important when we start counting, too

So far, my current list of meetings for this WG starts off with the 
October 2010 unofficial get-together, and has 1 interim meeting on it: 
Jan/Feb 2012, in Mountain View.

Inbetween are 5 meetings at IETFs including the BOF.

That makes my count:

NA-West: 2 (both interims)
NA-East: 1
Europe: 2
Asia: 2

The next 3 IETF meetings are 1 NA-West and 2 NA-East, so after that set 
plus the upcoming Europe interim, we'll have:

NA-West: 3
NA-East: 3
Europe: 3
Asia: 2

Not too uneven. But just after the upcoming interim, it will seem like 
the maths of the situation should definitely force the chairs to 
schedule an NA-East interim; I'd like the chairs to have leeway about that.

On 04/17/2012 10:57 PM, Eric Rescorla wrote:
> On Mon, Apr 16, 2012 at 3:45 PM, Cullen Jennings<[email-masked]>  wrote:

---

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 18 Apr 2012 08:57:48 +0000

This is all getting a little silly isn't it? :)
The real issue is we have two WG chairs from NA-West and one from Europe - there is no fair representation from NA-East!!  (kidding)

-hadriel

Sent from my iPhone

On Apr 18, 2012, at 3:27 AM, "Harald Alvestrand" <[email-masked]> wrote:

> So far, my current list of meetings for this WG starts off with the October 2010 unofficial get-together, and has 1 interim meeting on it: Jan/Feb 2012, in Mountain View.
> 
> The next 3 IETF meetings are 1 NA-West and 2 NA-East, so after that set plus the upcoming Europe interim, we'll have:
> 
> NA-West: 3
> NA-East: 3
> Europe: 3
> Asia: 2
> 
> Not too uneven. But just after the upcoming interim, it will seem like the maths of the situation should definitely force the chairs to schedule an NA-East interim; I'd like the chairs to have leeway about that.
>

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 18 Apr 2012 08:00:43 -0700

> 1) I'd like to let the chairs have some flexibility

Frankly, I'm a lot less interested in the chairs having some flexibility than
predictability.

As it stands now, we're in the position of being less than 8 weeks out
from the proposed interim and still not knowing whether it's happening
or when or where it will be. Cullens last message says that the chairs will
"try and confirm" Stockholm for June 12-13, but I for one don't
want to plan a couple thousand dollars worth of travel on
"try and confirm."

We know precisely when the IETF and W3C meetings are for the next
year or so, so there's really nothing that stops the chairs from promulgating
a policy and then announcing the locations of the meetings now.

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 18 Apr 2012 17:26:58 +0200

Hi,

Totally agree with Eric what I want is to be able to plan my time and budget well in advance and the main thing I need to know is the date.

If the choice is between Europe, NA-West and NA-East then flight costs and time tend not to be very variable.

The main variable is actually hotel costs so just choose somewhere that is close to a major international airport and that has reasonable hotel prices and let us know well in advance.

Regards
Andy

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Eric Rescorla
> Sent: 18 April 2012 16:01
> To: Harald Alvestrand
> Cc: Cullen Jennings; [email-masked]

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 18 Apr 2012 10:10:40 -0600

+1 Eric and Andy. 

I don't think the chairs need flexibility - Flexible chairs tend to not be a pretty unstable.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 18 Apr 2012 10:30:25 -0600

> The real issue is we have two WG chairs from NA-West and one from Europe - there is no fair representation from NA-East!!  (kidding)

I nominate Hadriel for chair :-)

---

From: Martin Thomson <[email-masked]>
Date: Wed, 18 Apr 2012 11:22:05 -0700

> I nominate Hadriel for chair :-)

Seconded.  It sounds like one of the NA-West chairs would have to step
down to make this work though ;)

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 18 Apr 2012 13:55:31 -0600

> down to make this work though ;)

Note my phrasing was "chair", not "co-chair"

---

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 18 Apr 2012 22:06:43 +0000

> I nominate Hadriel for chair :-)

Oh yes I would make a very unstable chair...

My solution for interims would be to split the difference between all the locations, by having every interim in Hawaii, and making it last exactly two hours: one hour on Monday morning, one on Friday night.
;)

-hadriel