Subject: Re: [rtcweb] I'd like to discuss my proposal (jingle-web) at next WG session

From: Ted Hardie <[email-masked]>
Date: Thu, 8 Mar 2012 08:27:47 -0800

Hi Suzuki-san,

Given that this apparently revisits some decisions that were already
made, the chairs would like to see working group discussion of the
draft before allocating agenda time to it for the upcoming meeting.

best regards,

Ted Hardie for the Chairs

On Wed, Feb 29, 2012 at 7:34 PM, HIro Suzuki
<[email-masked]> wrote:
> Hello RTCWeb WG members,
>
>
> It's my first post to this ML, and at Feb 28th, I submitted my ID
> from IETF ID submit tool. This ID's file name is
> "draft-suzuki-rtcweb-jingle-web-00.txt" and this ID provides my proposal
> to realize one of solutions of RTCWeb by using XMPP Jingle as a signaling
> protocol.
>
> Following paragraph is abstract of my ID, and I'd like to discuss my
> proposal at RTCWeb WG session in next Paris meeting.
>
>
> ---
> Abstract:
>  XMPP Jingle specification defines an XMPP protocol extension for
>  managing peer-to-peer media sessions between two users. And XMPP
>  Jingle can manage multi contents simultaneously in one Jingle
>  stream, but in the XMPP world there is no common way to layout
>  variable multi contents on each display. In this document, a
>  solution to this issue is provided by using Web browser's layout
>  function.
>
>  This document describes a new concept to realize one of solutions
>  of RTCWeb. Of course, &quot;Web Browser&quot; is used for Web application's
>  frontend for real-time communication, and XMPP Jingle specification
>  (XEP-166) is used as signaling protocol. And a simple mapping
>  manner between jingle contents and HTML graphical elements enables
>  to unite Web browser&#39;s layout function and Jingle&#39;s media content
>  management function to realize RTCWeb functions.
> ---
>
>
> Best Regards,
> Yoshihiro Suzuki
> ([email-masked])
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 8 Mar 2012 14:48:06 -0800

In general, Jingle extensions are within the purview of the XSF, rather than IETF and the DOM is owned by W3C. 

So other than the question of mandatory signaling implementation in browsers (which as Ted noted, has already been discussed), it seems to me that much of this document is out of scope not only of RTCWEB, but the IETF.  

> Date: Thu, 8 Mar 2012 08:27:47 -0800
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]
> Subject: Re: [rtcweb] I'd like to discuss my proposal (jingle-web) at next	WG session
> 
> Hi Suzuki-san,
>

---

From: HIro Suzuki <[email-masked]>
Date: Thu, 15 Mar 2012 19:14:21 +0900

Hi Bernard,

Jingle extensions are discussed in XSF, and DOM specification would be discussed in
W3C, as you says.

But if there are any numbers of media streams between peers, and if there are any
numbers of "<video/>" tags or "<div/>" tags with <video/> tag, (both case is possible
in Jingle spec. and HTML spec.) how can both browsers map between any numbers
of media/RTP streams and "<div/>" elements in DOM in consistent manner. I think
mapping information between media/RTP streams and HTML/DOM elements should
be signaled.

Current JSEP draft (draft-ietf-rtcweb-jsep-00) specified to make abstracted signaling
by JavaScript between both peers, and in this specification signaling procedures and
signaling state machine is well defined.  But the current draft specifies these mapping
information?  When set of media/RTP streams changes, correspondent mapping
information should be updated and signaled at the same time, I think.

This issue is more important in the use-case of multi user conference, to keep same
view on all participants' web browser, mapping information between media/RTP
streams and HTML/DOM elements should keep consistency between all participant.

Maybe how to store this mapping information is specified in PeerConnection API, and
how to get media/RTP stream identification information, how to set this identification
information to DOM elements in DOM tree, and vice versa.

My I-D describes how to signal mapping information in Jingle, and proposes two
mapping manner, and this proposal can be applied to multi user conference too.
I think JSEP draft can expand to manage this mapping information.

Cheers,
Hiro