Subject: [rtcweb] RTCP consent approach comment

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Tue, 20 Mar 2012 01:06:40 +0000

Eric,

Sec 4.2.3 mentions about RTCP consent approach is not adopted for

1) Small window attack of RTP
2) Tough for legacy non-RTCP endpoint to implement RTCP

I think that small window attack of RTP is possible in ICE as well in case attacker has access to offer SDP and the second reason is funny to recommend non-RTCP endpoint to implement ICE instead of implementing RTCP because this reason is equivalent of asking the person to buy cake who is struggling to buy bread.

The missing information is that NAT traversal is not possible using RTCP mechanism. Could you please add "NAT traversal" as the one of the reason for not adopting RTCP consent approach.

Thanks
Partha

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 20 Mar 2012 11:19:33 +0100

> The missing information is that NAT traversal is not possible using RTCP mechanism. Could you please add "NAT traversal" as the one of the reason for not adopting RTCP consent approach.
Ravindran,

the section already limits itself to "... cases where the legacy 
endpoint has a public address...." - in those cases, NAT traversal is 
not necessary, so I don't believe your comment applies.

Can you explain why you see a window of attack in the ICE case? I don't 
understand that comment.

> Thanks
> Partha
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>