Subject: Re: [rtcweb] Use-case document - additional recording use case

From: "Avasarala, Ranjit" <[email-masked]>
Date: Wed, 7 Mar 2012 14:07:38 +0800

Hi Stefan

Could we add a use case related to session recording? The use case would be

4.2. x Simple Video Recording Service

4.2. x.1 Description

The user who has joined a video communication service wants to record the communication data from the web browser.

4.2.x.1.1  Derived requirements

TBD

I also feel there is a need for a API requirement - the Web API should provide a means to record the incoming media - both audio & video or audio only or video only

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stefan Hakansson LK
Sent: Tuesday, March 06, 2012 2:59 PM
To: [email-masked]
Subject: [rtcweb] Use-case document

Hi!

The Use-case document
(<http://datatracker.ietf.org/doc/draft-ietf-rtcweb-use-cases-and-requirements/?include_text=1>)
will expire in early April.

The editors propose to add a new use-case when updating to -07. The new use-case is about large sessions and is inspired by input made earlier by Arno Bakker
(http://www.ietf.org/mail-archive/web/rtcweb/current/msg00530.html) and recently by Harald Alvestrand (http://lists.w3.org/Archives/Public/public-webrtc/2012Feb/0066.html).

Proposed text for the new use-case:

On-line lecture
===============

A lecture is given on-line by a very popular lecturer. The attendance is very large. Because of this it is not really feasible to have direct audiovisual feedback (for e.g. questions) for every participant, instead participants can request the floor by clicking a button, and gets a signal when audio and video has been set up (and the lecturer is ready to take the question). The question is heard by all participants (not only the lecturer).

Participants can join and leave the lecture at any time (i.e. they do not need to be there at the start to be able to connect).

The service is operated by the university of the lecturer. It is set up such that all participants connect to a central node. The university can not invest much in HW, so the processing required (per participant) must be minimized.

New requirement:

- It must be possible to set up media streams and encryption in such a way that processing in a central node is minimized (no transcoding required, no decryption/re-encryption for every outgoing flow - just simple forwarding).

Let us know what you think. If there is support we will add this use-case, if not we will just make a new revision of the document (with no major changes to the content).

Stefan for the editors
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Stefan Hakansson LK <[email-masked]>
Date: Tue, 20 Mar 2012 11:58:28 +0100

Hi Ranjit,

recording was discussed at length last fall (and is to some extent 
captured in the document) without really concluding.

This fact, and the fact that there was really no support for your 
proposal makes me think we should not add this use-case (at least not now).

Br,
Stefan

On 03/07/2012 07:07 AM, Avasarala, Ranjit wrote:
> I also feel there is a need for a API requirement - the Web API should provide a means to record the incoming media - both audio&  video or audio only or video only
>
> Regards
> Ranjit
>