Subject: [rtcweb] Draft Agenda for WebRTC at IETF83

From: Cullen Jennings <[email-masked]>
Date: Thu, 1 Mar 2012 10:22:13 -0700

Given we are still before the draft deadline, this is a very draft agenda. Roughly speaking the plan is to spend the first session on security and second session on other things. 

Cullen, Magnus, & Ted

Agenda 

First Session   -------------------

Admin Update - 10 min 
- update from mmusic, avtcore, and other WG 

W3C Update - 10 min

Identity Proxy  - 50 min 

What to do about RTP and/or SDES - 80 min 

Second Session  -----------------------

Admin - 10 min 
- scheduling of next interim meeting 

Signaling - 60 min  

Data Channel - 30  min

Codec Selection - 50 min

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 1 Mar 2012 10:26:27 -0700

Uh, note the subject should have been RTCWeb not WebRTC. Sorry.

On Mar 1, 2012, at 10:22 AM, Cullen Jennings wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Igor Faynberg <[email-masked]>
Date: Thu, 01 Mar 2012 13:46:40 -0500

Thanks, Cullen!

I always wanted security to be on the agenda for the first session (to 
stimulate more discussions in between) , and I am happy that this is 
happening now.

Igor

On 3/1/2012 12:22 PM, Cullen Jennings wrote:
> Cullen, Magnus,&  Ted

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 01 Mar 2012 19:58:30 +0100

Good to get things out early!

Some other things that may want to be on the agenda, either as reporting 
from other groups or as items to discuss whether to take up elsewhere:

- SDP updates: msid and bundle - our use of those functions being 
defined in MMUSIC
- Use of multiplexing functions described by AVTCORE
- Congestion control as discussed in the ICCRG meeting
- RTP feature profiling: What do we use? (mandatory  / permitted / 
recommended-against)
- SDP feature profiling: What do we use? (same alternatives)
- Video resolution negotiation per SSRC: What are the alternatives? Can 
we recommend one?

And of course:

- Implementation feedback that should lead to specification updates, if any

---

From: Stefan Hakansson LK <[email-masked]>
Date: Mon, 5 Mar 2012 15:19:19 +0100

> - Video resolution negotiation per SSRC: What are the alternatives? Can
I assume that you include re-negotiation as well (i.e. if the display 
size is changed during the session) in this topic.

I think all the above are important topics, and we could also consider 
touching on:
- Mute/hold signaling (per SSRC)
- How to convey label/id of a MediaStreamTrack over a PeerConnection

I don't know if it is appropriate to use meeting time for this, or if it 
should be done on the list, but these are things we need to sort out.

Stefan

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 5 Mar 2012 08:29:17 -0700

Another possible topic is the Behave chairs would prefer we deal with the STUN and TURN URIs in RTCWeb.

---

From: Igor Faynberg <[email-masked]>
Date: Mon, 05 Mar 2012 10:43:08 -0500

One question:  How do the STUN and TURN matters in the RTCWeb 
environment differ from those in non-RTCWeb environments?

In other words, what will RTCWeb do differently?

Igor

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 05 Mar 2012 07:59:06 -0800

On 03/05/2012 07:43 AM, Igor Faynberg wrote:
> One question:  How do the STUN and TURN matters in the RTCWeb environment
> differ from those in non-RTCWeb environments?

It is not about STUN/TURN, it is about STUN/TURN *URI*, i.e. how the STUN/TURN
server is provisioned.

>>> Given we are still before the draft deadline, this is a very draft
>>> agenda. Roughly speaking the plan is to spend the first session on
>>> security and second session on other things.
>>> 
>>> Cullen, Magnus,&  Ted
>>> 
>>> 
>>> 
>>> Agenda
>>> 
>>> Admin Update - 10 min - update from mmusic, avtcore, and other WG
>>> 
>>> W3C Update - 10 min
>>> 
>>> Identity Proxy  - 50 min
>>> 
>>> Admin - 10 min - scheduling of next interim meeting
>>> 
>>> Signaling - 60 min
>>> 
>>> Data Channel - 30  min
>>> 
>>> Codec Selection - 50 min
>>> 
>>> 
>>> 
>>> 
>>> 
>>> 
>>> 
>>> _______________________________________________ rtcweb mailing list 
>>> [email-masked] https://www.ietf.org/mailman/listinfo/rtcweb
>> _______________________________________________ rtcweb mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/rtcweb
> _______________________________________________ rtcweb mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/rtcweb
> 

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: Igor Faynberg <[email-masked]>
Date: Mon, 05 Mar 2012 17:21:50 -0500

Ah, I have not followed this discussion on Behave.

I will be interested in learning what has transpired there.

Igor

On 3/5/2012 10:59 AM, Marc Petit-Huguenin wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.12 (GNU/Linux)
>
> iQIcBAEBCAAGBQJPVOLJAAoJECnERZXWan7EYEIP/3X6eq+RTgD4H7AxEZQ1mLXY
> Pp9MboW4uf47IYd54E0nJLQhIggRLjnARElLSQ2MtuBIQOOUb5LwpGUiuMuuWHO9
> 7QWHUhWrE3aKjFWAjWrEEmeGVDt+Y9dqTAYFCunfuWevVQOVPUXtJ+YRuPzyq8Wj
> VxWniXgCaS78JCruqamWVvmuvR3W/elfAhFf8Q5jM2dlSZNg1dQ/HEQgBjttYS0r
> 0L47yEIDtI3srfb0dIHe1E/bRg0UMDkxC14pfhpHB8pkg7Qh6qrS5ZBwh7HV7g/W
> S04T+pdz4I1oXP3SXu48mjkyrzd85SqZpATitBIrS6xXScTcvjcXVE2es0baBD1i
> ZPeyzc59b3DhK+wQH2HrM3b9ZljakfJIYl3KB8bOIbgeuI+R0R52swDxPXWfXtJJ
> PWhTbSSdlOSHAD3X8/L8EiFHEt2EO1MNF+RiSX8XCHpT5YQfV8wI8tM3Ujg5e6dL
> 7L5rfsR/KYnxF9zL2NWa7WOlcUKWyCabLIB69HBXEngYg/LtJOQAM/n1BiNsl0jb
> 766TADKA+2YBtnnB68Fdm3ZayHHTwPEfwZTR3Aj+r6Jqs5hKlcFDCG+z4xmKKO5Y
> JP+31BixA/o7XKOCGeCf5WGEZwrXg4PSLW+/2zQreDCmcrbOV/gfNCwySTNu8VrC
> fq7frHeDNcRi1Re001I6
> =ebgo
> -----END PGP SIGNATURE-----

---

From: Martin Thomson <[email-masked]>
Date: Mon, 5 Mar 2012 16:28:27 -0800

> Another possible topic is the Behave chairs would prefer we deal with the STUN and TURN URIs in RTCWeb.

That's great, but I don't see how rtcweb can use them.  I suspect that
WebRTC could, maybe some implementations might, but if the idea is to
poke STUN/TURN configuration into the browser, then rtcweb has very
little to say about the matter.