Subject: [rtcweb] Section 5.2.1

From: Bernard Aboba <[email-masked]>
Date: Fri, 17 Feb 2012 17:46:08 -0800

Section 5.2.1 in the JSEP-02 draft raised a question:

"This step will also cause encoder resources to be allocated, based on the codecs specified in |offer|."

[BA] Should the answerer allocate encoding resources based on the codecs specified in the answer, as opposed to the offer? 

setRemoteDescription(SDP_OFFER, offer) sets the SRTP keys used to receive, then setLocalDescription(SDP_ANSWER, answer)
causes transmission of media by the answerer.

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 17 Feb 2012 19:48:09 -0800

Other (related) questions

Section 6.1.3:

"Session descriptions generated by createAnswer must be immediately usable by setRemoteDescription; "

setRemoteDescription(SDP_ANSWER, answer) called by the offerer (Section 5.3.1), but on the Answerer, it is setLocalDescription(SDP_ANSWER, answer) (Section 5.2.5).  Which side is the above sentence referring to?

Section 6.1.6:

"Changes to the state of media transmission will only occur when a final answer is successfully applied.".  

Setting PRANSWER aside, is this statement only valid for the offerer? Or does it imply that setRemoteDescription is to be called with an SDP_ANSWER on the Answerer?

Some nits:

Page 6: s/it provides/provides/
Page 16: duplicate 3rd paragraph
Page 17: duplicate 3rd paragraph

On Feb 17, 2012, at 17:46, "Bernard Aboba" <[email-masked]> wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Justin Uberti <[email-masked]>
Date: Mon, 20 Feb 2012 23:54:27 -0500

On Fri, Feb 17, 2012 at 10:48 PM, Bernard Aboba
<[email-masked]>wrote:

> setRemoteDescription(SDP_ANSWER, answer) called by the offerer (Section
> 5.3.1), but on the Answerer, it is setLocalDescription(SDP_ANSWER, answer)
> (Section 5.2.5).  Which side is the above sentence referring to?
>

This should have said setLocalDescription.

> Setting PRANSWER aside, is this statement only valid for the offerer? Or
> does it imply that setRemoteDescription is to be called with an SDP_ANSWER
> on the Answerer?
>

The statement by itself is true for either side, but setRemoteDescription
specifically will only be called with a final answer by the offerer.

> Page 17: duplicate 3rd paragraph

Thanks for pointing these out. I'm away on vacation this week, but will
incorporate these comments when I get back.

> [BA] Should the answerer allocate encoding resources based on the codecs
> specified in the answer, as opposed to the offer?
>
> setRemoteDescription(SDP_OFFER, offer) sets the SRTP keys used to receive,
> then setLocalDescription(SDP_ANSWER, answer)