Subject: Re: [rtcweb] Generic IdP doc posted

From: "Zeltsan, Zachary (Zachary)" <[email-masked]>
Date: Thu, 2 Feb 2012 16:20:28 -0600

Eric,

At the yesterday's call I had a couple of questions regarding your presentation on RTCWEB identity service.
(The audio was not good, so I am asking using email).

Section 4 (draft-rescorla-rtcweb-generic-idp) explains that a browser need to instantiate an IdP proxy for interactions with an IdP.
According to Figure 1, there are connections between Bob's (B) browser and IdP A, and between Alice's (A) browser and IdP B.
Question 1: 
Is it a correct assumption that Bob's browser need to instantiate two different proxies --  one for interacting with Bob's IdP B and another for interacting with Alice's IdP A? (A question regarding the Alice's browser is similar).

The diagram in section 5.5.2 (OAuth example) depicts the interactions between Alice's browser and IdP, and Bob's browser and IdP.
Question 2: 
Does the diagram show the IdP A?
The draft states "similarly, Bob's PeerConnection instantiates an IFRAME to talk to the IdP".
Should not the Bob's PeerConnection instantiate two IFRAME's -- one for talking to IdP A and another for talking to IdP B?

Wit thanks,
Zachary Zeltsan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Rescorla
Sent: Monday, January 23, 2012 8:38 PM
To: [email-masked]
Subject: [rtcweb] Generic IdP doc posted

Since Taipei, I have spent a bunch of time working through the
details of how to make generic IdP-based authentication work for
WebRTC calls. This was very handwavy in Taipei but I believe I now
have solutions that will work for all the major issues (which isn't to
say that there isn't much left to improve), but this is still at
the individual submission stage. The draft is at:

http://tools.ietf.org/html/draft-rescorla-rtcweb-generic-idp-00

Comments welcome.

I have a prototype implementation of most of the basic concepts
(though in JS rather than integrated with the browser), so I hope
to have something (though probably something clunky) to demo next
week.

Best,
-Ekr
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 2 Feb 2012 14:30:59 -0800

> (The audio was not good, so I am asking using email).

No worries. Thanks for writing.

> Is it a correct assumption that Bob's browser need to instantiate two different proxies --  one for interacting with Bob's IdP B and another for interacting with Alice's IdP A? (A question regardin…

Yes. One might imagine that you could get away with only one if they were the
same IdP, but if you're using WebIntents (which seems increasingly
likely) then you would get two proxies by default.

> Should not the Bob's PeerConnection instantiate two IFRAME's -- one for talking to IdP A and another for talking to IdP B?

Yep.

Best,
-Ekr