Subject: [rtcweb] Joint JSEP draft posted

From: Justin Uberti <[email-masked]>
Date: Thu, 16 Feb 2012 00:53:42 -0500

I've just uploaded a -02 version of the JSEP draft, to which Cullen
Jennings has agreed to sign on as a co-author. This draft includes a few
specific changes suggested by Cullen to ensure that JSEP can be used to
create applications that are RFC 3264-compliant, if desired.

The draft is available at
http://tools.ietf.org/html/draft-uberti-rtcweb-jsep-02. Please refer to
this latest version of the document when responding to the JSEP call for
consensus.

Best regards,
--justin

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 15 Feb 2012 22:22:16 -0800

Justin and I spent a bunch of time trying to figure out what was the important properties of JSEP and worked to preserver all of theses while at the same time dealing with some of the concerns I had previously around we were defining something that would take a long time to define. I very happy with this version as I think it can meet a wide range of needs and move forward quickly.

On Feb 15, 2012, at 21:53 , Justin Uberti wrote:

> I've just uploaded a -02 version of the JSEP draft, to which Cullen Jennings has agreed to sign on as a co-author. This draft includes a few specific changes suggested by Cullen to ensure that JSEP can be used to create applications that are RFC 3264-compliant, if desired. 
> 
> The draft is available at http://tools.ietf.org/html/draft-uberti-rtcweb-jsep-02. Please refer to this latest version of the document when responding to the JSEP call for consensus.
> 
> Best regards,
> --justin
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 16 Feb 2012 07:22:48 +0100

Hi,

Yesterday I sent out some questions on jsep-01, and I do believe they apply also to -02.

JSEP-01: SDP_PRANSWER and FEDEX use-case
JSEP-01: Associating ICE candidates with m- lines
JSEP-01: Release of non-needed ICE candidates

Regards,

Christer

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Justin Uberti
Sent: 16. helmikuuta 2012 7:54
To: [email-masked]; [email-masked]
Cc: Cullen Jennings (fluffy)
Subject: [rtcweb] Joint JSEP draft posted

Best regards,
--justin

---

From: Justin Uberti <[email-masked]>
Date: Thu, 16 Feb 2012 21:49:09 -0500

Thanks for your questions. As they came in as I was preparing -02 for
publication, I did not try to resolve them in -02.

On Thu, Feb 16, 2012 at 1:22 AM, Christer Holmberg <
[email-masked]> wrote:

> **
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Justin Uberti
> *Sent:* 16. helmikuuta 2012 7:54
> *To:* [email-masked]; [email-masked]
> *Cc:* Cullen Jennings (fluffy)
> *Subject:* [rtcweb] Joint JSEP draft posted
>

---

From: "Jim Barnett" <[email-masked]>
Date: Fri, 17 Feb 2012 08:09:56 -0800

This is just a detail, but I have a question about the sample app in section 8.  I’m wondering about the following call to maybeSignal ()

   navigator.webkitGetUserMedia(

           {"audio": true, "video": true}, function (localStream) {

       selfView.src = webkitURL.createObjectURL(localStream);

       pc.addStream(localStream);

       maybeSignal(isCaller);

     }

As I read the code in both the offerer and the answerer cases,  startICE() will not have been called yet, so hasCandidates will be false and maybeSignal will return immediately without doing anything.  Am I missing something?

-          Jim

Sent: Thursday, February 16, 2012 12:54 AM

Best regards,

--justin