Subject: [rtcweb] JSEP-01: Release of non-needed ICE candidates

From: Christer Holmberg <[email-masked]>
Date: Wed, 15 Feb 2012 15:26:30 +0100

Hi,

Assume my SIP JS app gets an offer, and some ICE candidatates, generates and sends a SIP SDP offer.

Later, the browser provides additional ICE candidates (using the ice callback function).

My SIP JS app is not interested in the additional ICE candidates.

Q1: Is it possible for the JS app to inform the browser that it does not need the additional ICE candidates? For example, if my app is given turn candidates, which I am not going to use (read: offer to the remote party), there is really no need for the browser to maintain the connection with the turn server.

Q2: Do we assume that the browser at some point (e.g. when the associated answer is provided) will be able to release resources associated with non-needed ICE candidates?

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 15 Feb 2012 18:28:29 +0100

Hi,

My use-case is not about whether the app wants turn candidates or not - it is about that fact that it at some point decides to send the SIP SDP offer towards the remote party, even if it has not received all candidates that is previously specified.

Maybe the browser, due to some network and/or configuration error, isn't even able to contact a turn server. Will it inform the app about that, or will it simply not provide turn candidates?

Regards,

Christer

________________________________________
From: Jim Barnett [[email-masked]]
Sent: Wednesday, February 15, 2012 5:43 PM
To: Christer Holmberg; [email-masked]; [email-masked]
Subject: RE: [rtcweb] JSEP-01: Release of non-needed ICE candidates

In section 6.1.9 of the latest JSEP draft, the startICE() function allows the JS app to specify which types of candidates it wants,  so your app can avoid getting turn candidates in the first place.  I would also assume that the browser could/would release un-needed resources when setRemoteDescription is called.

-          Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, February 15, 2012 9:27 AM
To: [email-masked]; [email-masked]
Subject: [rtcweb] JSEP-01: Release of non-needed ICE candidates

Hi,

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Thu, 16 Feb 2012 21:59:59 -0500

On Wed, Feb 15, 2012 at 12:28 PM, Christer Holmberg <
[email-masked]> wrote:

>
> Hi,
>
> My use-case is not about whether the app wants turn candidates or not - it
> is about that fact that it at some point decides to send the SIP SDP offer
> towards the remote party, even if it has not received all candidates that
> is previously specified.
>
> Maybe the browser, due to some network and/or configuration error, isn't
> even able to contact a turn server. Will it inform the app about that, or
> will it simply not provide turn candidates?
>

Right now, it will simply not provide STUN or TURN candidates if it can't
contact the appropriate server.

> In section 6.1.9 of the latest JSEP draft, the startICE() function allows
> the JS app to specify which types of candidates it wants,  so your app can
> avoid getting turn candidates in the first place.  I would also assume that
> the browser could/would release un-needed resources when
> setRemoteDescription is called.
>
>
> -          Jim
>
> Q1: Is it possible for the JS app to inform the browser that it does not
> need the additional ICE candidates? For example, if my app is given turn
> candidates, which I am not going to use (read: offer to the remote party),
> there is really no need for the browser to maintain the connection with the
> turn server.
>
> Q2: Do we assume that the browser at some point (e.g. when the associated
> answer is provided) will be able to release resources associated with
> non-needed ICE candidates?
>
> Regards,
>
> Christer
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>