Subject: [rtcweb] Incoming Call for RTCWeb using Websocket extention or HTTP custom-make signaling protocol

From: "Khan, Sohel" <[email-masked]>
Date: Mon, 6 Feb 2012 19:42:38 +0000

My question pertains to RTCWeb Incoming call.
Please assume for this discussion,  RTCWeb  system uses Websocket extention or HTTP custom-make signaling protocol.
Also, please assume that a NAT or multiple NAT exist between the RTCWeb server and the RTC  Web client (Receiver).
Here, the sender of the call is Alice and receiver of the call is Bob.
We would like to discuss the signaling protocol between the RTC Web Server to Bob

|RTC Web Server|----->|NAT|--->RTC Web-Client (receiver).

Sorry, I could not attend the interim meeting. I reviewed the interim meeting presentations and could not understand Incoming RTC session to receiver through a NAT, when the RTCWeb client system is built using Websocket extention or HTTP custom-make signaling protocol.

Is there any proposal in this scenario?
Sincerely appreciate your help.

Thank you.

Sohel Khan

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 07 Feb 2012 18:37:06 -0800

On 02/06/2012 11:42 AM, Khan, Sohel wrote:
> Please assume for this discussion,  RTCWeb  system uses Websocket 
> extention or HTTP custom-make signaling protocol.
>
> Also, please assume that a NAT or multiple NAT exist between the 
> RTCWeb server and the RTC  Web client (Receiver).
>
> |RTC Web Server|---à|NAT|-àRTC Web-Client (receiver).
>

Please read draft-ietf-rtcweb-overview-02 section 3 - the WG decided 
some time ago that the precise protocol for communicating between the 
Web server (or the SIP server in your other note) was out of scope for 
this standardization effort; the standardized parts are limited to the 
syntax and semantics of the data exchanged over the peer-to-peer 
connection (media path) and the semantics that are exposed through the 
API exposed by the browser.

Discussion of protocols for signalling should be taken as examples, not 
as candidates for standardization in this group.

                 Harald