Subject: [rtcweb] JSEP - When do resource reservations happen ?

From: Cullen Jennings <[email-masked]>
Date: Thu, 26 Jan 2012 12:04:53 -0700

Here is one question about JSEP that I hope you can respond to quickly, it's really just a clarification on how JSEP works but it seems very important to really analyzing how JSEP will work. 

A lot of operations require allocating resources, such as UDP ports, DSPs, etc. Are those allocated when you invoke createOffer() or when you invoke setLocalDescription()? So, say you only have one DSP, if someone calls createOffer() in tab A, does that make the DSP unavailable in tab B?

Thanks, Cullen

---

From: Justin Uberti <[email-masked]>
Date: Fri, 27 Jan 2012 14:51:21 -0500

Resources are allocated on setLocal/RemoteDescription().
createOffer/Answer() do not change state.

On Thu, Jan 26, 2012 at 2:04 PM, Cullen Jennings <[email-masked]> wrote:

>
> Here is one question about JSEP that I hope you can respond to quickly,
> it's really just a clarification on how JSEP works but it seems very
> important to really analyzing how JSEP will work.
>
> A lot of operations require allocating resources, such as UDP ports, DSPs,
> etc. Are those allocated when you invoke createOffer() or when you invoke
> setLocalDescription()? So, say you only have one DSP, if someone calls
> createOffer() in tab A, does that make the DSP unavailable in tab B?
>
> Thanks, Cullen
>
>