Subject: [rtcweb] JSEP - Question about ICE trickle stats

From: Cullen Jennings <[email-masked]>
Date: Thu, 26 Jan 2012 12:43:26 -0700

It seems to me there are a roughly three types of addresses used for ICE/RTP in something like Hangouts. The local address, the NAT (server reflexive) address, and the relayed address. A browser always knows the local addresses but the NAT and relay take a bit longer thus the argument for trickle. In trying to model how this all works it would be really nice to know on a deployment such as Hangouts some of the following stats:

What percentage of media flows end up sending RTP via the relay? What percentage does the server reflexive address get used? and what percentage have the far end sending directly to the local address? 

What is the average time to get a relay address? to find the server reflexive address? 

What is the typical RTT for messages from one browser to the other browser for the signaling data?

Having a rough of idea of the above would be really helpful in looking at timing of various parts.

Justin, Any chance you can provide some of these measurements?

---

From: Justin Uberti <[email-masked]>
Date: Fri, 27 Jan 2012 15:11:09 -0500

On Thu, Jan 26, 2012 at 2:43 PM, Cullen Jennings <[email-masked]> wrote:

>
> It seems to me there are a roughly three types of addresses used for
> ICE/RTP in something like Hangouts. The local address, the NAT (server
> reflexive) address, and the relayed address. A browser always knows the
> local addresses but the NAT and relay take a bit longer thus the argument
> for trickle. In trying to model how this all works it would be really nice
> to know on a deployment such as Hangouts some of the following stats:
>
> What percentage of media flows end up sending RTP via the relay? What
> percentage does the server reflexive address get used? and what percentage
> have the far end sending directly to the local address?
>
> Some of this data is easy to get, some of it is a bit trickier. Some of it
is also a bit sensitive. If you have a particular question you're looking
to answer, such as the typical time the offerer would need to wait to get
local+stun+turn candidates, I can try to see if I can get the data to
answer it.

Also, note that the mean in many of these cases may not be the right value
to look at, since the standard deviation can be very large (i.e. the worst
10% is much much worse than the mean)