Subject: [rtcweb] AGENDA for the Interim meeting

From: Ted Hardie <[email-masked]>
Date: Wed, 18 Jan 2012 09:03:04 -0800

January 31st, 2012

The Interim will be held at the Google campus in Mountain View, CA, in
building GWC5.  This building does not normally have staffed
reception, but there will be someone from 8:00 to 9:00 with badges for
everyone who has notified the chairs of their attendance.  If you did
not send your name in, please go to GWC6, ask for a badge with Ted
Hardie as your local host and have the staff contact Ted.  If you
arrive outside this time but did let the Chairs know you were coming,
please IM or email [email-masked], and so he can come out of the
meeting room with your badge.

January 31st, 2012
8:00-9:00 Breakfast
9:00-12:00 JSEP
12:30-1:00 ROAP (1)
12:0-1:30 Lunch
1:30-2:30 ROAP (2)
2:30-4:30 Signaling resolution
4:30-5:30 Data Channel 1
5:30-Close Demos of existing systems

February 1st, 2012
8:00-9:00 Breakfast
9:00-10:00 Data channel 2
10:00-12:30 Security
12:30-1:30 Lunch

Transition to WEBRTC at this point.
Reply

regards,

Cullen, Magnus, Ted

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 20 Jan 2012 11:03:39 +0100

I wonder if it's possible to drill down on this agenda a bit more...

as it stands, we're spending 6 hours on just the question of JSEP and 
ROAP, with no internal structure, no specific input documents, and no 
proposal for what the decision should be.
Given that all participants will have read the input documents carefully 
before the meeting, this might not be the optimal use of time.

We might structure this differently, as in:

Division of labor between JS and browser: ROAP vs JSEP
==================================
Input documents: ....

Output decisions: One of
- Make the browser stateless wrt offer/answer, keep ICE state in browser 
(JSEP)
- Make the browser keep state wrt offer/answer and ICE (ROAP)
- We don't have enough information to decide

Stuff that is already decided, or where no alternatives exist:
- Format for describing states: the SDP format is used in both current 
proposals.
- ICE state maintenance: This will be done in the browser (both 
proposals, timing, and security)
- (more can be added here)

Stuff that may be flagged as needing clarification / further work:
- Matching between ICE connections and RTP sessions / m-lines in JSEP
- (more can be added here)

Structure of session:

- Principles presentations: 10 minutes per proposal (max)
- Q&A on proposal details (clarification, not decision): 1 hour
- Break (15 min)
- Decision session:
   - Identifying what factors are important to people
   - Making a decision
- Available slack time, in case debate runs longer: 4 hours.

Of course, this depends on having people read the documents beforehand.

On 01/18/2012 06:03 PM, Ted Hardie wrote:
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 20 Jan 2012 10:59:25 -0800

I agree with Harald that the agenda seems lopsided, and that more structure is needed. 

However, even with more structure I'd be concerned about the relative time allocations. 

While I realize that the impact goes beyond W3C API, spending 6 hours on
 this at an IETF RTCWEB interim seems excessive to me, particularly when
 there are so many open issues that fall clearly on the IETF side of the
 fence, some of which we might even be able to come to consensus on. 

Perhaps we should more clearly delineate the division of labor between W3C and IETF on things like ROAP vs. JSEP.