Subject: Re: [rtcweb] Codec Draft

From: Rob Glidden <[email-masked]>
Date: Sat, 17 Dec 2011 11:14:16 -0800

Chris:

No, not at all, I'm saying something altogether different: I am saying 
all these kinds of characterizations supporting old text, however 
framed, cast wrong procedural net, for multiple reasons.

Proposed new text is straightforward and should be unobjectionable:

"The REQUIRED video codec should be a royalty-free codec which has been 
specified by a recognized standards process such as MPEG or other 
due-process standards group and provide reviewable substantiation of its 
royalty-free status."

Rob

On 12/16/2011 5:35 PM, Chris Blizzard wrote:
> ----- Original Message -----
>> From: "Rob Glidden"<[email-masked]>
>> To: "Chris Blizzard"<[email-masked]>
>> Cc: "Harald Alvestrand"<[email-masked]>, [email-masked], "Cary Bran"<[email-masked]>
>> Sent: Thursday, December 15, 2011 10:45:59 AM
>> Subject: Re: [rtcweb] Codec Draft
>> Chris:
>>
>> "MPEG-LA-is-a-monopolist" characterization casts wrong procedural net,
>> among reasons pending lawsuits -- one more reason to be accurate and
>> follow procedure.
>>
> Sorry for the follow-up, but just to be clear, this is not what I said.  What I said is this:
>
>>> To get at the heart of the issue, I think that many people would
>>> like to use H.264 support as the default. It's lower-friction and
>>> widely deployed. But that's entirely up to the rights holders for
>>> that technology. That's why there's a date and a specific call-out
>>> to MPEG LA as the monopoly rights holder in the text. It's up to
>>> them to decide, and they have three months from tomorrow to do so.
>>>
>>> --Chris
>>>
> MPEG LA is the monopoly licensor for H.264.  Patents are legal government-sponsored monopolies and they license many of the patents for that technology.  (Although they clearly disallow the assertion that they have all of them via their license!)  "Monopolist" as you put it has a somewhat criminal tone in normal usage and would be the result of their actions with that monopoly in place.  I want to be clear that I did not mean that and that's your interpretation, not mine.
>
> --Chris
>

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 18 Dec 2011 10:49:04 +1000

On Dec 18, 2011, at 5:14 , Rob Glidden wrote:

> "The REQUIRED video codec should be a royalty-free codec which has been specified by a recognized standards process such as MPEG or other due-process standards group and provide reviewable substantiation of its royalty-free status."

I sort of agree with the sentiment of this but the problem is that it is often not practically possible to figure out if any given codec is royalty free or not and the IETF explicitly does not take on the task of trying to figure out if a given technology actually infringes on a given patent or not. I don't think a requirement like that would really fit inside the IETF process.

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 18 Dec 2011 23:12:11 +0100

On 12/17/2011 08:14 PM, Rob Glidden wrote:
> "The REQUIRED video codec should be a royalty-free codec which has 
> been specified by a recognized standards process such as MPEG or other 
> due-process standards group and provide reviewable substantiation of 
> its royalty-free status."
The long parse of that is (as I read it):

* Royalty-free is a requirement.
* Specified (not just blessed) by an acceptable standards process is a 
requirement.
* MPEG's process is an acceptable standards process.
* There has to be documentation of royalty-free status that can be reviewed.

Implicit in the statement (given that this is the only statement) is:

* There is no reason to talk about the technical quality of the codec.
* The form of IPR documentation, or the amount of review, can be left 
unspecified. This can be read as an implicit assumption that MPEG's 
currently specified IPR process is "good enough".
* It is OK to wait until such a royalty-free codec exists before 
emitting the specification.

Of these seven points, there is only one I'm sure I agree with.

              Harald

>> MPEG LA is the monopoly licensor for H.264.  Patents are legal 
>> government-sponsored monopolies and they license many of the patents 
>> for that technology.  (Although they clearly disallow the assertion 
>> that they have all of them via their license!)  "Monopolist" as you 
>> put it has a somewhat criminal tone in normal usage and would be the 
>> result of their actions with that monopoly in place.  I want to be 
>> clear that I did not mean that and that's your interpretation, not mine.
>>
>> --Chris
>>
>
>

---

From: Rob Glidden <[email-masked]>
Date: Mon, 19 Dec 2011 10:42:06 -0800

Harald:

These points seem good input for elaboration and liaison statement.

Should be easy to connect dots; it appears a proposer of one of the MPEG 
tracks may be rtcweb co-chair's employer.

Rob

 From Resolutions, the 98th SC 29/WG 11 Meeting, 2011-11-28/12-02, 
Geneva, Switzerland  [SC 29/WG 11 N 12254 
<http://www.itscj.ipsj.or.jp/sc29/open/29view/29n12421c.htm>:

3.11 Part 29 Web Video Coding

3.11.1 The Requirements and Video subgroups thank Apple, Cisco, 
Fraunhofer HHI, Magnum Semiconductor, Polycom, and RIM for their 
response to the CfP on Internet Video Coding.

3.11.2  The Requirements subgroup recommends that proponents of 
technology for Web Video Coding further improve the support for their 
proposal in order to meet market needs as identified in the IVC CfP.

15.3.3 The Requirements subgroup recommends that MPEG members make WG 11 
aware of market developments in the space addressed by IVC.

On 12/18/2011 2:12 PM, Harald Alvestrand wrote:
>> No, not at all, I'm saying something altogether different: I am 
>> saying all these kinds of characterizations supporting old text, 
>> however framed, cast wrong procedural net, for multiple reasons.
>>
>> been specified by a recognized standards process such as MPEG or 
>> other due-process standards group and provide reviewable 
>> substantiation of its royalty-free status."

---

From: Rob Glidden <[email-masked]>
Date: Mon, 19 Dec 2011 10:52:43 -0800

Cullen:

This seems a worthy point to raise in a liaison to ISO SC29/WG11 and and 
perhaps to proposers of the MPEG tracks.

There's also a resolution that MPEG members make WG 11 aware of market 
developments in the space.

Rob

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 19 Dec 2011 14:04:28 -0500

On Sat, Dec 17, 2011 at 2:14 PM, Rob Glidden <[email-masked]> wrote:
> Chris:
>
> No, not at all, I'm saying something altogether different: I am saying all
> these kinds of characterizations supporting old text, however framed, cast
> wrong procedural net, for multiple reasons.
>

I like this text, except that "royalty-free" is like "non-encumbered
by patents" and other such text - you can never be sure.
All you can want is one that _claims_ to be royalty-free, and the text
should reflect that IMO.

I also don't think that "and provide" scans very well as is.

So, how about

"The REQUIRED video codec should be a codec which has been both
 specified and asserted to be royalty-free by a recognized standards
process such as MPEG or other
due-process standards group and should provide reviewable substantiation of its
royalty-free status."

Regards
Marshall

>> government-sponsored monopolies and they license many of the patents for
>> that technology.  (Although they clearly disallow the assertion that they
>> have all of them via their license!)  "Monopolist" as you put it has a
>> somewhat criminal tone in normal usage and would be the result of their
>> actions with that monopoly in place.  I want to be clear that I did not mean
>> that and that's your interpretation, not mine.
>>
>> --Chris
>>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 29 Dec 2011 08:49:59 +1100

When the CODEC WG was formed there was interesting discussion around the point of making RF required. 

Lets say we have two proposals on the table, A and B. Some person of dubious morals decides they don't like proposal A. They make an IETF IPR disclosure on A that says that their employer *might* have IPR on A and they have not yet decided on licensing terms. At that point proposal A is removed from the table even thought much of the WG may not believe that the IPR being claimed is actually valid. The important thing is we leave give the participants of the WG the information we know about the IPR status yet at the same time allow them to decisions about if they want to go forward with proposal A or B. 

The above attack was a key part of they the codec WG charter uses the word "preferred" instead of "required". 

On a side note, has any SDO ever done a "reviewable substantiation of royalty-free status" for anything? I'd love to see one. 

On a separate note about the MPEG work on RF codecs …I think this is great to see any SDO taking this on. However, Lets say it takes 1/2 year to get going, then 1.5 years to finish the standard, then 2 years to get into chip sets, then another 2 years to get in enough chipsets of widely distributed products that it becomes interesting in the fact that a larger percentage of devices can do it … we are looking many years out. The timeline I just gave was much faster than the adoption of H.264 which is likely the mostly hazily invested in codec ever from point of adoption. My point is, I don't think the browser are going to wait for this new codec as the mandatory to implement codec for WebRTC. However, clearly WebRTC should be able to negotiate a new codec like this is both sides support it. My prediction is we will see development of royalty free video codecs at SDOs. IMHO none of the current SDOs have a process and IPR rules that both allows the open source community and individual contributors to participate while at the same time ensuring enough secrecy that ideas could not be "poached" by patent trolls and  ensuring that employers of participants where bound to an RF agreement. W3C is likely the closet model to allow something like this.