Subject: Re: [rtcweb] I-D Action: draft-lennox-rtcweb-rtp-media-type-mux-00.txt

From: Colin Perkins <[email-masked]>
Date: Mon, 14 Nov 2011 00:04:48 +0800

Jonathan,

A more compelling argument for reporting from all SSRCs may be that various AVPF and RTCP XR packets make no sense unless sent from the SSRC corresponding to the correct media type. Sending just those, but not regular RTCP reports, will cause havoc to the RTCP participant timeout rules, and SSRC collision detection, unless you signal and heavily special-case the code. This doesn't seem worth it, for tiny bandwidth savings.

Reporting on yourself is harder to defend, I agree, but the potential to confuse monitoring equipment (and given the activity in XRBLOCK, someone must care about that…), and the additional signalling needed, again seem to outweigh the bandwidth cost.

Colin

On 27 Oct 2011, at 23:57, Jonathan Lennox wrote:
> Hi, Colin --
> 
> Thanks for taking a look my draft!
> 
> I saw this recommendation in the multiplex-architecture draft, after I finished my own (I didn't get a chance to read any other -00 drafts before finishing my own before the deadline).
> 
> I think this is an AVTCore issue, so I'm following up there...further discussion should probably just be on AVTCore, unless there are WebRTC-specific issues.
> 
> 
> The multiplexing-architecture draft in general is a very good draft -- it's extremely thorough and useful -- but I admit to not being very convinced by that section of it.
> 
> At small numbers of sources, self-reporting and cross-reporting does indeed use a fairly small amount of bandwidth, but the problem is that their bandwidth usage is quadratic in the number of sources, since every source must report on every other. So as the number of sources grows, they begin to consume all RTCP bandwidth sending redundant or trivial information.
> 
> And this for the sake of third-party monitors, which (personally) I've never seen deployed outside a research environment, and seem architecturally dubious to me, at least for offer-answer negotiated streams. (IPTV and other declarative-SDP architectures are probably different.)
> 
> On Oct 27, 2011, at 11:12 AM, Colin Perkins wrote:
> 
>> Jonathan,
>> 
>> Thanks for submitting. This is a good draft.
>> 
>> One comment: Section 3.1 suggests that a source generating multiple RTP streams, with multiple SSRCs, should not send RTCP reports for its own media, and should pick a single SSRC to use when sending reports on other media. I agree that this would save a small amount of bandwidth, but I think the savings are negligible, it complicates the monitoring model, and so is a mistake. We talk about this in draft-westerlund-avtcore-multiplex-architecture-00 (Section 9, in particular).
>> 
>> Cheers,
>> Colin
> 
> --
> Jonathan Lennox
> [email-masked]
> 
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

-- 
Colin Perkins
http://csperkins.org/

---

From: Jonathan Lennox <[email-masked]>
Date: Sun, 13 Nov 2011 16:17:13 -0500

Colin,

I believe this would work under the logic I describe in media-type-mux: you still send RR or SR packets for every source, you just treat your sources other than the reporting source as though they're "disconnected" receivers, i.e. don't include redundant reports in their SRs/RRs.

The number of SR/RR packets is linear in the number of sources in a session -- it's the number of reports that's quadratic, and thus problematic.

If there's a need for some XR reports to choose a reporting source that has the same media type as the source being reported on, that should be fine.

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]] 
Sent: Monday, November 14, 2011 12:05 AM
To: Jonathan Lennox
Cc: [email-masked]; IETF AVTCore WG
Subject: Re: [rtcweb] I-D Action: draft-lennox-rtcweb-rtp-media-type-mux-00.txt

Jonathan,

Reporting on yourself is harder to defend, I agree, but the potential to confuse monitoring equipment (and given the activity in XRBLOCK, someone must care about that...), and the additional signalling needed, again seem to outweigh the bandwidth cost.

Colin

-- 
Colin Perkins
http://csperkins.org/