Subject: [rtcweb] SDES in browser [was: RTCWeb Forking usecase [was: draft-kaplan-rtcweb-sip-interworking-requirements-00]]

From: Christer Holmberg <[email-masked]>
Date: Sat, 29 Oct 2011 23:43:28 +0200

Hi,

> If we want to support SDES for interop with SIP, which I think we do, then what we could do is mandate the Browsers support both SDES and DTLS-SRTP, 

I am not sure the browser itself would need to support SDES. It may be enough if SDES is implemented in the JavaScript App, the API then allows the App to provide keys to the browser, and the browser would use those keys for media encryption instead of triggering DTLS-SRPT.

And, if the JavaScript App does not provide any keys to the browser, DTLS-SRTP could be used as default.

Regards,

Christer

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Sun, 30 Oct 2011 00:34:20 +0200

> And, if the JavaScript App does not provide any keys to the browser, DTLS-SRTP could be used as default.

Note that it would require some kind of standarized JavaScript WebRTC
API callback.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 30 Oct 2011 08:32:22 +0100

Hi,

>> I am not sure the browser itself would need to support SDES. It may be enough if SDES is implemented in the JavaScript App, the API then allows the App 
>>to provide keys to the browser, and the browser would use those keys for media encryption instead of triggering DTLS-SRPT.
>>
> Note that it would require some kind of standarized JavaScript WebRTC API callback.

I thought API requirements are part of what we are trying to specify :)

Regards,

Christer