Subject: [rtcweb] RTCWeb Terminology

From: Hadriel Kaplan <[email-masked]>
Date: Sat, 22 Oct 2011 17:13:04 +0000

Howdy,
this may seem like a silly question, but what are the actual names and capitalization schemes for the overall architecture, mechanism/protocol, API and such?

I believe the Working Group names are "RTCWEB" in IETF and "WEBRTC" in W3C.  But in the W3C it appears the name of the API doc is "WebRTC".

Is the overall thing "RTCWEB", "RTCWeb", "RTCweb", or "rtcweb"?  I've seen all 4 uses in IETF drafts.  Meanwhile in W3C they call the overall architecture and protocol "WEBRTC" in the "WebRTC" document.  Which is it?

Is the Browser API itself an "RTCWeb API" or "WebRTC API" or what?

The draft-ietf-rtcweb-overview draft has a terminology section but does not cover this.

I know this is silly, but I've gotten the question several times from customers and marketing folks. (plus it would be nice to be consistent in both IETF and W3C docs)

I apologize if this question has already been asked and answered.  I googled but found conflicting terms and usage in those results as well.

-hadriel

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Sat, 22 Oct 2011 19:18:38 +0200

2011/10/22 Hadriel Kaplan <[email-masked]>:
> Is the overall thing "RTCWEB", "RTCWeb", "RTCweb", or "rtcweb"?  I've seen all 4 uses in IETF drafts.

And also "RTC-Web".

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Likepeng <[email-masked]>
Date: Mon, 24 Oct 2011 01:18:24 +0000

> And also "RTC-Web".

I prefer this one.

Kind Regards
Kepeng
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of I?aki Baz Castillo
Sent: Sunday, October 23, 2011 1:19 AM
To: Hadriel Kaplan
Cc: [email-masked]; [email-masked]
Subject: Re: [rtcweb] RTCWeb Terminology

And also "RTC-Web".

-- 
Iñaki Baz Castillo
<[email-masked]>
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Cavigioli, Chris" <[email-masked]>
Date: Sun, 23 Oct 2011 21:10:00 -0700

Very good question - been bugging me too.  -chris 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
Sent: Saturday, October 22, 2011 10:13 AM
To: [email-masked]; [email-masked]
Subject: RTCWeb Terminology

Howdy,

-hadriel

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 24 Oct 2011 09:03:38 -0600

I don't think there is an answer to this yet so I guess we need to figure it out.  I'm ore concerned about the long term explanation to people outside W3C or IETF. Hadriel, with you marketing hat on, you have any suggestions of what we should call the whole thing?

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 24 Oct 2011 08:05:57 -0700

How about SuperAwesomeWebCalling (TM).

-Ekr

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 24 Oct 2011 16:56:18 +0000

> I don't think there is an answer to this yet so I guess we need to figure it out.  I'm ore concerned about the long term explanation to people outside W3C or IETF. Hadriel, with you marketing hat o…

Web 4.0.  ;)

I asked a couple other folks and the consensus seems to be: "WebRTC" for the whole thing.

The rationale is that it's still the Web but with native real-time-communication support, as opposed to real-time-communication but with web support.  For example if you wrote a book about how to write Web-apps for it, you would probably use the term "WebRTC" in the book title.  Another rationale was that it follows the naming scheme for WebM and WebP.

For the API, the consensus was it would be confusing to people if we weren't consistent with W3C docs.

So I propose the following:

WebRTC: the whole shebang
WebRTC API: the JS<->Browser API.

-hadriel
p.s. personally I've gotten used to the term "RTCWeb", but it may be because of my IETF focus rather than W3C/Web focus.

---

From: Adrian Georgescu <[email-masked]>
Date: Mon, 24 Oct 2011 19:01:28 +0200

WebRTC sounds great!

Adrian

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 24 Oct 2011 11:18:19 -0600

+1

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 24 Oct 2011 19:21:02 +0200

> WebRTC sounds great!

And just involves changing the name of the WG, the maillist, the
project domain and all the existing drafts. :)

But I agree.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Victor Pascual Avila <[email-masked]>
Date: Mon, 24 Oct 2011 19:32:27 +0200

+1

-- 
Victor Pascual Ávila

---

From: Cary Bran <[email-masked]>
Date: Mon, 24 Oct 2011 13:52:34 -0700

+1

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 24 Oct 2011 18:13:14 -0700

Google's been using "WebRTC" (capitalized as such) for their opensource 
implementation of the technologies involved too.

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Tue, 25 Oct 2011 10:04:03 +0530

+1

>From: [email-masked]
[mailto:[email-masked]]
>On Behalf Of Adrian Georgescu
>Sent: Monday, October 24, 2011 10:31 PM
>To: Hadriel Kaplan
>Cc: Cullen Jennings; [email-masked]; [email-masked]
>>> I don't think there is an answer to this yet so I guess we need to
>figure it out.  I'm ore concerned about the long term explanation to
>people outside W3C or IETF. Hadriel, with you marketing hat on, you
have
>any suggestions of what we should call the whole thing?
>>
>> Web 4.0.  ;)
>>
>> The rationale is that it's still the Web but with native real-time-
>communication support, as opposed to real-time-communication but with
>web support.  For example if you wrote a book about how to write Web-
>apps for it, you would probably use the term "WebRTC" in the book
title.
>Another rationale was that it follows the naming scheme for WebM and
>WebP.
>>
>> p.s. personally I've gotten used to the term "RTCWeb", but it may be
>because of my IETF focus rather than W3C/Web focus.
>>
>>
>
>

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 26 Oct 2011 11:17:47 -0600

With my chair hat on ... 

I'd like to declare we currently have consensus for Hadriel's proposal that the technology should be referred to as "WebRTC" and the API as the "WebRTC API". The IETF WG name is still RTCWeb, the mailing list is still [email-masked], the IETF drafts should still have "-rtcweb-" in them to indicate the WG name. 

Cullen <RTCWeb CoChair>

---

From: Ralph Giles <[email-masked]>
Date: Wed, 26 Oct 2011 10:33:56 -0700

> I'd like to declare we currently have consensus for Hadriel's proposal that the technology should be referred to as "WebRTC" and the API as the "WebRTC API". The IETF WG name is still RTCWeb, the m…

Sounds appropriate to me!

 -r

---

From: Igor Faynberg <[email-masked]>
Date: Wed, 26 Oct 2011 13:42:05 -0400

Having passed this milestone, maybe it is time to start a Terminology RFC?

Igor

On 10/26/2011 1:17 PM, Cullen Jennings wrote:
> Cullen<RTCWeb CoChair>

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 26 Oct 2011 12:56:44 -0500

Hadriel

now that you named it, you have to fix it (or otherwise make it work) ...

;-)

James

At 12:17 PM 10/26/2011, Cullen Jennings wrote:

>With my chair hat on ...
>
>I'd like to declare we currently have consensus for Hadriel's 
>proposal that the technology should be referred to as "WebRTC" and 
>the API as the "WebRTC API". The IETF WG name is still RTCWeb, the 
>mailing list is still [email-masked], the IETF drafts should still 
>have "-rtcweb-" in them to indicate the WG name.
>
>Cullen <RTCWeb CoChair>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 26 Oct 2011 19:58:39 +0200

Why does Hadriel care - an SBC can always change the terminology ;) 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of James M. Polk
Sent: 26. lokakuuta 2011 20:57
To: Hadriel Kaplan
Cc: [email-masked]
Subject: Re: [rtcweb] Consensus Call: RTCWeb Terminology

Hadriel

;-)

James

At 12:17 PM 10/26/2011, Cullen Jennings wrote:

>With my chair hat on ...
>
>I'd like to declare we currently have consensus for Hadriel's proposal 
>that the technology should be referred to as "WebRTC" and the API as 
>the "WebRTC API". The IETF WG name is still RTCWeb, the mailing list is 
>still [email-masked], the IETF drafts should still have "-rtcweb-" in 
>them to indicate the WG name.
>
>Cullen <RTCWeb CoChair>
>
>

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 26 Oct 2011 14:14:27 -0500

>Why does Hadriel care - an SBC can always change the terminology ;)

very nice!

---

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 26 Oct 2011 19:29:05 +0000

I think you mean a WebSBC.

;)

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 26 Oct 2011 21:48:12 +0200

> I think you mean a WebSBC.

I'll be happy if I never see a "WebRTC ALG Router" :)

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 26 Oct 2011 20:09:11 +0000

Agreed - ALGs are bad.  B2BUAs, on the other hand, are quite useful. ;)

---

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 26 Oct 2011 20:11:33 +0000

> Having passed this milestone, maybe it is time to start a Terminology RFC?

I propose we do that in draft-ietf-rtcweb-overview, which already has a terminology section, but needs the new terminology added.
I think people would naturally gravitate to reading an "Overview" document first, so having the terminology within it makes sense methinks.

-hadriel

---

From: Daryl Malas <[email-masked]>
Date: Wed, 26 Oct 2011 15:33:20 -0600

I agree with Hadriel.  I think including all general WebRTC terminology in
the overview is the right thing to do.

--Daryl

On 10/26/11 2:11 PM, "Hadriel Kaplan" <[email-masked]> wrote:

>I propose we do that in draft-ietf-rtcweb-overview, which already has a
>terminology section, but needs the new terminology added.
>I think people would naturally gravitate to reading an "Overview"
>document first, so having the terminology within it makes sense methinks.
>
>-hadriel
>

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 26 Oct 2011 15:29:32 -0700

> I'd like to declare we currently have consensus for Hadriel's proposal that the technology should be referred to as "WebRTC" and the API as the "WebRTC API". The IETF WG name is still RTCWeb, the m…

As -overview editor, I'm happy to include this definition.

Just because I have to write it in a terminology list, I wonder how I 
should define it.

Is it an effort? A technology? A project?

It should be something like:

WebRTC
      A <something> that <someting> to enable peer to peer audio and 
video between browsers
     on the Internet.
     Components of WebRTC include a protocol profile, defined in the 
IETF, of which this document
     gives an overview, and an API, defined in the W3C, and specified in 
<reference>

Suggestions for the <something>s (or alternate formulations) would be 
most welcome.

                  Harald

---

From: Jim McEachern <[email-masked]>
Date: Thu, 27 Oct 2011 02:20:55 +0000

How about this?

WebRTC
      A collaborative standards effort between the IETF and W3C that specifies a JavaScript API and architectural context, to enable real-time peer to peer audio, video and data communication between browsers
     on the Internet.
     Components of WebRTC include a protocol profile, defined in the IETF, of which this document
     gives an overview, and an API, defined in the W3C, and specified in <reference>

Jim

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Harald Alvestrand
> Sent: Wednesday, October 26, 2011 6:30 PM
> To: [email-masked]
> Subject: [rtcweb] WebRTC definition (Re: Consensus Call: RTCWeb
> Terminology)
> 
> > I'd like to declare we currently have consensus for Hadriel's proposal that
> the technology should be referred to as "WebRTC" and the API as the
> "WebRTC API". The IETF WG name is still RTCWeb, the mailing list is still
> [email-masked], the IETF drafts should still have "-rtcweb-" in them to
> indicate the WG name.
> 
> Just because I have to write it in a terminology list, I wonder how I should
> define it.
> 
>       A <something> that <someting> to enable peer to peer audio and video
> between browsers
>      on the Internet.
>      Components of WebRTC include a protocol profile, defined in the IETF, of
> which this document
> Suggestions for the <something>s (or alternate formulations) would be most
> welcome.
> 
>                   Harald
> 
> 
> 
> > Cullen<RTCWeb CoChair>
> >
> >

---

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 27 Oct 2011 04:41:25 +0000

How about:

WebRTC
     A technology and platform that enables real-time, interactive peer to peer audio, video and data communication between browsers on the Internet.  Components of WebRTC include a protocol profile, defined in the IETF, of which this document gives an overview, and an API, defined in the W3C, and specified in <reference>.

-hadriel