Subject: [rtcweb] Fwd: I-D Action: draft-lennox-rtcweb-rtp-media-type-mux-00.txt

From: Jonathan Lennox <[email-masked]>
Date: Mon, 24 Oct 2011 21:01:51 -0400

Hello all --

Jonathan Rosenberg and I have written a draft (as promised at the Québec IETF) describing RTP-level procedures for multiplexing multiple media types into a single RTP session.

Comments are welcome.

Begin forwarded message:

> From: "[email-masked]" <[email-masked]>
> Date: October 24, 2011 7:27:40 PM EDT
> To: "[email-masked]" <[email-masked]>
> Subject: I-D Action: draft-lennox-rtcweb-rtp-media-type-mux-00.txt
> Reply-To: "[email-masked]" <[email-masked]>
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : Multiplexing Multiple Media Types In a Single Real-Time Transport Protocol (RTP) Session
> 	Author(s)       : Jonathan Lennox
>                          Jonathan Rosenberg
> 	Filename        : draft-lennox-rtcweb-rtp-media-type-mux-00.txt
> 	Pages           : 11
> 	Date            : 2011-10-24
> 
>   This document describes mechanisms and recommended practice for
>   transmitting media streams of multiple media types (e.g., audio and
>   video) over a single Real-Time Transport Protocol (RTP) session,
>   primarily for the use of Real-Time Communication for the Web
>   (rtcweb).
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-lennox-rtcweb-rtp-media-type-mux-00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-lennox-rtcweb-rtp-media-type-mux-00.txt
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 

--
Jonathan Lennox
[email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Thu, 27 Oct 2011 16:12:23 +0100

Jonathan,

Thanks for submitting. This is a good draft.

One comment: Section 3.1 suggests that a source generating multiple RTP streams, with multiple SSRCs, should not send RTCP reports for its own media, and should pick a single SSRC to use when sending reports on other media. I agree that this would save a small amount of bandwidth, but I think the savings are negligible, it complicates the monitoring model, and so is a mistake. We talk about this in draft-westerlund-avtcore-multiplex-architecture-00 (Section 9, in particular).

Cheers,
Colin

On 25 Oct 2011, at 02:01, Jonathan Lennox wrote:
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

-- 
Colin Perkins
http://csperkins.org/

---

From: Jonathan Lennox <[email-masked]>
Date: Thu, 27 Oct 2011 11:57:53 -0400

Hi, Colin --

Thanks for taking a look my draft!

I saw this recommendation in the multiplex-architecture draft, after I finished my own (I didn't get a chance to read any other -00 drafts before finishing my own before the deadline).

I think this is an AVTCore issue, so I'm following up there...further discussion should probably just be on AVTCore, unless there are WebRTC-specific issues.

The multiplexing-architecture draft in general is a very good draft -- it's extremely thorough and useful -- but I admit to not being very convinced by that section of it.

At small numbers of sources, self-reporting and cross-reporting does indeed use a fairly small amount of bandwidth, but the problem is that their bandwidth usage is quadratic in the number of sources, since every source must report on every other. So as the number of sources grows, they begin to consume all RTCP bandwidth sending redundant or trivial information.

And this for the sake of third-party monitors, which (personally) I've never seen deployed outside a research environment, and seem architecturally dubious to me, at least for offer-answer negotiated streams. (IPTV and other declarative-SDP architectures are probably different.)

--
Jonathan Lennox
[email-masked]