Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-rtp-usage-01.txt

From: [email-masked]
Date: Mon, 31 Oct 2011 15:24:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Real-Time Communication in WEB-browsers Working Group of the IETF.

	Title           : Web Real-Time Communication (WebRTC): Media Transport and Use of RTP
	Author(s)       : Colin Perkins
                          Magnus Westerlund
                          Joerg Ott
	Filename        : draft-ietf-rtcweb-rtp-usage-01.txt
	Pages           : 28
	Date            : 2011-10-31

   The Web Real-Time Communication (WebRTC) framework aims to provide
   support for direct interactive rich communication using audio, video,
   collaboration, games, etc. between two peers&#39; web-browsers.  This
   memo describes the media transport aspects of the WebRTC framework.
   It specifies how the Real-time Transport Protocol (RTP) is used in
   the WebRTC context, and gives requirements for which RTP features,
   profiles, and extensions need to be supported.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-rtcweb-rtp-usage-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-rtcweb-rtp-usage-01.txt

---

From: Colin Perkins <[email-masked]>
Date: Mon, 31 Oct 2011 23:12:37 +0000

> http://www.ietf.org/internet-drafts/draft-ietf-rtcweb-rtp-usage-01.txt

We've updated our draft on RTP Requirements for RTC-Web, and renamed it to better reflect the content. Changes in this version include:

- Update title, rewrite Abstract and Introduction, and restructure the draft
- Update section on Rate Control and Media Adaptation
- Update section on Use of RTP: Core Protocols
- Add some initial discussion of multiplexing several RTP sessions onto a single lower-layer transport, primarily referencing other drafts for the content.
- Address comments by Harald Alvestrand from the mailing list (29 August 2011)
- Update Security Considerations

The main technical changes are in Section 8, and focus on the requirements for Rate Control and Media Adaptation, the limitations of RTCP when used for this purpose without RTP/AVPF, and interoperability with legacy systems. There are also smaller technical changes, and numerious editorial fixes, throughout.

-- 
Colin Perkins
http://csperkins.org/