Subject: [rtcweb] Layers in draft-jesup-rtcweb-data-00

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 26 Oct 2011 20:28:51 +0000

Howdy,
Just to make sure I understand this right, the choice isn't really this:

        +------+                    +------+
        |WEBAPP|                    |WEBAPP|
        +------+                    +------+
        | DTLS |                    | SCTP |
 +-------------+             +-------------+
 | STUN | SCTP |             | STUN | DTLS |
 +-------------+             +-------------+
 |    UDP      |             |    UDP      |
 +-------------+             +-------------+

But rather this:

        +------+                        +------+
        |WEBAPP|                        |WEBAPP|
        +------+------+------+          +------+------+------+
        | DTLS | Audio| Video|          | SCTP | Audio| Video|
 +---------------------------+   +---------------------------+
 | STUN | SCTP |S/RTP |S/RTP |   | STUN | DTLS |S/RTP |S/RTP |
 +---------------------------+   +---------------------------+
 |         Mux/Demux         |   |         Mux/Demux         |
 +---------------------------+   +---------------------------+
 |            UDP            |   |            UDP            |
 +---------------------------+   +---------------------------+

[Note: "S/RTP" = SRTP/SRTCP or RTP/RTCP, "Mux/Demux" = tiny logic to mux/demux]

Because the audio/video streams may be using the same UDP port, right?

And the two "S/RTP" boxes may be just one box depending on how the MMUSIC multiplexing decision turns out.

So if we want to choose the left one, because we expect/want that someday the Operating System provides a SCTP/UDP stack in the kernel, and I think we do, could it do so while demuxing and letting STUN, RTP, and DTLS go up to the app layer?  (i.e., given a socket/BIO/FD model)  I have no idea about such things... just asking.

-hadriel

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 26 Oct 2011 22:31:55 +0200

Hi,

> And the two "S/RTP" boxes may be just one box depending on how the MMUSIC multiplexing decision turns out.

In MMUSIC we will discuss how to negotiate multiplexing using SDP, but how the multiplexing itself is actually done I think will be discussed elsewhere (avtcore?).

Regards,

Christer

---

From: Michael Tüxen <[email-masked]>
Date: Wed, 26 Oct 2011 22:45:00 +0200

> Just to make sure I understand this right, the choice isn't really this:
This is not possible today. The demultiplexing seems to be specific to this scenario.
Not sure it fits. For demuxing you use the first byte to distinguish STUN from DTLS and SRTP.
The first byte us the high order byte of the source port. Once could require
SCTP to use source ports with the high order byte > 192. That might work.
However, you would need to get the Mux/Demux into the kernel. Could be done
using a socket option. But I'm not sure it really fits. Maybe Randy has an
opinion.

Best regards
Michael
> 
> -hadriel
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>