Subject: [rtcweb] New Milestones for RTCWEB WG

From: Magnus Westerlund <[email-masked]>
Date: Tue, 2 Aug 2011 14:16:43 +0200

WG,

As raised in the WG meeting last week we plan to submit new milestones.
These is to make the time line a bit more realistic to actually be meet.
They also try to adjust to the picked document structure.

Here they are:
Oct 2011 Send Use Cases (draft-ietf-rtcweb-use-cases-and-requirements),
Overview (draft-ietf-rtcweb-overview), Security and Privacy Documents
(I-D) to W3C

Dec 2011 Send Use Cases (draft-ietf-rtcweb-use-cases-and-requirements)
document to IESG for publication as Informational

Apr 2012 Send W3C input on what requirements the current solution has on
API(s)

May 2012 Send Overview (draft-ietf-rtcweb-overview), Security and
Privacy Model documents to IESG for publication as Informational

May 2012 Send Signalling and Negotiation, and NAT Traversal to IESG for
publication as Proposed Standard

Jun 2012 Send Media Transport, Media Processing, and Codecs to IESG for
publication as Proposed Standard

Jun 2012 Send Datagram Transport for non-media data to IESG for
publication as Proposed Standard

These will soon be submitted for official publication. If you have any
issues please raise them on the list and we can discuss them.

cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Wed, 3 Aug 2011 17:42:44 +0530

Hi Magnus, 

The current RTCWeb overview, usecase & requirement document does not have architecture diagrams. Please clarify which one of the RTCWeb WG item below will cover RTCWeb architecture.

Thanks
Partha 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Magnus Westerlund
> Sent: Tuesday, August 02, 2011 5:47 PM
> To: [email-masked]
> Subject: [rtcweb] New Milestones for RTCWEB WG
> 
> WG,
> 
> Oct 2011 Send Use Cases 
> (draft-ietf-rtcweb-use-cases-and-requirements),
> May 2012 Send Overview (draft-ietf-rtcweb-overview), Security 
> and Privacy Model documents to IESG for publication as Informational
> 
> May 2012 Send Signalling and Negotiation, and NAT Traversal 
> to IESG for publication as Proposed Standard
> 
> Jun 2012 Send Media Transport, Media Processing, and Codecs 
> to IESG for publication as Proposed Standard
> 
> Jun 2012 Send Datagram Transport for non-media data to IESG 
> for publication as Proposed Standard
> 
> These will soon be submitted for official publication. If you 
> have any issues please raise them on the list and we can discuss them.
> 
> cheers
> 
> Magnus Westerlund
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Stefan Håkansson LK <[email-masked]>
Date: Thu, 4 Aug 2011 10:07:35 +0200

As one of the webrtc chairs I have the generic comment that the sooner information is available the better. In particular, webrtc is planning a f2f meeting at the W3C TPAC (Oct 31 and Nov 1). To get the most out of that meeting it would be good if the Use Cases and Sec/Priv documents are available, and if there can be some advance info on what reqs the "current solution" has on the API(s) by then.

Cheers,
Stefan
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Magnus Westerlund [[email-masked]]
Sent: Tuesday, August 02, 2011 2:16 PM
To: [email-masked]
Subject: [rtcweb] New Milestones for RTCWEB WG

WG,

Here they are:

cheers

Magnus Westerlund

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 08 Aug 2011 14:55:39 +0200

On 08/03/11 14:12, Parthasarathi R (partr) wrote:
> Hi Magnus,
>
> The current RTCWeb overview, usecase&  requirement document does not have architecture diagrams. Please clarify which one of the RTCWeb WG item below will cover RTCWeb architecture.
If draft-ietf-rtcweb-overview does not describe the architecture in 
sufficient detail, it needs updating. It is the document in the document 
hierarchy that should have this role.

Some parts of it are not explicit because no consensus has been 
forthcoming, others because I have not understood yet what people need 
to hear.

What do you think it should say?