Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-use-cases-and-requirements-01.txt

From: Randell Jesup <[email-masked]>
Date: Wed, 03 Aug 2011 10:22:15 -0400

>  A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-rtcweb-use-cases-and-requirements-01.txt

>4.2.6.  Multiparty video communication
>
>4.2.6.1.  Description
>
>    In this use case the simple video communication service is extended
>    by allowing multiparty sessions.  No central server is involved - the
>    browser of each participant sends and receives streams to and from
>    all other session participants.  The web application in the browser
>    of each user is responsible for setting up streams to all receivers.
>
>    The audio sent by each participant is a mono stream.  However, in
>    order to enhance intelligibility, the web application pans the audio
>    from different participants differently when rendering the audio.
>    This is done automatically, but users can change how the different
>    participants are placed in the (virtual) room.

Note that this covers the request from Arno for peer-to-peer distribution.

Also, I would remove the audio is mono reference.  I see no need to add 
that restriction.

-- 
Randell Jesup
[email-masked]

---

From: Arno Bakker <[email-masked]>
Date: Thu, 4 Aug 2011 09:32:22 +0200

> Note that this covers the request from Arno for peer-to-peer distribution.

Yes. But perhaps we should rephrase requirement F11 to

"The browser MUST be able to transmit streams to
at least one peer"

(peer could be other browser or relay server) to more properly highlight 
the problem of insufficient upload in larger
sessions.

CU,
     Arno