Subject: [rtcweb] Fwd: New Version Notification for draft-ietf-rtcweb-overview-01.txt

From: Harald Alvestrand <[email-masked]>
Date: Wed, 24 Aug 2011 17:08:24 +0200

A few drawings, some more definitions, and a link to the W3C API spec.

If people are quick with comments, I can get another version done before 
our September 7 meeting; version numbers are cheap.

                Harald

-------- Original Message --------
Subject: 	New Version Notification for draft-ietf-rtcweb-overview-01.txt
Date: 	Wed, 24 Aug 2011 07:37:14 -0700
From: 	[email-masked]
To: 	[email-masked]
CC: 	[email-masked]

A new version of I-D, draft-ietf-rtcweb-overview-01.txt has been successfully submitted by Harald Alvestrand and posted to the IETF repository.

Filename:	 draft-ietf-rtcweb-overview
Revision:	 01
Title:		 Overview: Real Time Protocols for Brower-based Applications
Creation date:	 2011-08-24
WG ID:		 rtcweb
Number of pages: 17

Abstract:
    This document gives an overview and context of a protocol suite
    intended for use with real-time applications that can be deployed in
    browsers -&quot;real time communication on the Web&quot;.

    It intends to serve as a starting and coordination point to make sure
    all the parts that are needed to achieve this goal are findable, and
    that the parts that belong in the Internet protocol suite are fully
    specified and on the right publication track.

    This work is an attempt to synthesize the input of many people, but
    makes no claims to fully represent the views of any of them.  All
    parts of the document should be regarded as open for discussion,
    unless the RTCWEB chairs have declared consensus on an item.

    This document is a candidate to become a work item of the RTCWEB
    working group.

The IETF Secretariat

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 25 Aug 2011 10:50:50 -0500

>If people are quick with comments, I can get another version done before our
September 7 meeting;

Some wording about the standards for the signaling between the two Web
servers in Fig.2 would help.
Even if only stating this is out of scope for the rtcweb WG.
(Or does this WG really cover only the single Web server case?)
Leaving many folks scratching their heads...

Thanks, Henry

On 8/24/11 10:08 AM, "Harald Alvestrand" <[email-masked]> wrote:

>  If people are quick with comments, I can get another version done before our
> September 7 meeting; version numbers are cheap.
>  
>                 Harald
>  
> A new version of I-D, draft-ietf-rtcweb-overview-01.txt has been successfully
> submitted by Harald Alvestrand and posted to the IETF repository.
> 
>    browsers - &quot;real time communication on the Web&quot;.
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Colin Perkins <[email-masked]>
Date: Tue, 30 Aug 2011 16:39:37 +0100

Harald,

This looks good. I just have two very minor comments regarding Section 5:

- The correct reference for SRTP is RFC3711, not RFC3550 (the security mechanism in RFC3550 is not compatible with SRTP).

- I agree with the sentiment that "SRTP is used for transport of all real-time media", however this leaves open the choice of RTP profile (there are several that use SRTP). It might be useful to reference draft-perkins-rtcweb-rtp-usage, since that addresses this question.

Cheers,
Colin

On 24 Aug 2011, at 16:08, Harald Alvestrand wrote:
> If people are quick with comments, I can get another version done before our September 7 meeting; version numbers are cheap.
> 
>                Harald
> 

-- 
Colin Perkins
http://csperkins.org/

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 31 Aug 2011 09:45:20 +0200

On 08/30/11 17:39, Colin Perkins wrote:
> - The correct reference for SRTP is RFC3711, not RFC3550 (the security 
> mechanism in RFC3550 is not compatible with SRTP).
Oops! Will fix.
>
> - I agree with the sentiment that "SRTP is used for transport of all 
> real-time media", however this leaves open the choice of RTP profile 
> (there are several that use SRTP). It might be useful to reference 
> draft-perkins-rtcweb-rtp-usage, since that addresses this question.
Hopefully, draft-perkins-rtcweb-rtp-usage will be 
draft-ietf-rtcweb-rtp-usage soon. I'll put in the pointer.

>> If people are quick with comments, I can get another version done 
>> before our September 7 meeting; version numbers are cheap.
>>
>>                Harald
>>
>> [email-masked] <mailto:[email-masked]>