Subject: [rtcweb] Relation of Mozilla WebAPI announced today to RTCWEB/WebRTC work?

From: Dan York <[email-masked]>
Date: Tue, 23 Aug 2011 13:53:19 -0400

Can anyone from Mozilla please comment on how the "WebAPI" announced today with the goal to " provide a basic HTML5 phone experience within 3 to 6 months" relates to the work happening in RTCWEB/WebRTC?

http://hacks.mozilla.org/2011/08/introducing-webapi/

https://wiki.mozilla.org/WebAPI
	
It's not clear from the blog entry or site whether this is a project that will in fact be implementing RTCWEB/WebRTC ideas (as part of the larger framework) or if this is something separate?

Thanks,
Dan

-- 
Dan York, CISSP, Director of Conversations
Voxeo Corporation   http://www.voxeo.com  [email-masked]
Phone: +1-321-710-9193  skype: danyork  sip:[email-masked]

Join the Voxeo conversation:
Blogs: http://blogs.voxeo.com
Twitter: http://twitter.com/voxeo  http://twitter.com/danyork
Facebook: http://www.facebook.com/voxeo

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Tue, 23 Aug 2011 10:59:59 -0700

> Can anyone from Mozilla please comment on how the "WebAPI" announced
> today with the goal to " provide a basic HTML5 phone experience within 3
> to 6 months" relates to the work happening in RTCWEB/WebRTC?

This is more along the lines of getting access to the APIs needed to 
instruct a mobile phone to initiate a phone call, rather than to host 
that call inside the browser. Presumably also with some way to detect 
that your on a device that supports that capability at all.

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 23 Aug 2011 20:28:56 +0200

> that your on a device that supports that capability at all.
The blog post sounds like a virtual clone of the W3C Device API charter.

Is that your planned venue for standardizing these APIs?

I can't say I'm overly happy with the amount of imagination spent on the 
name, but the effort seems to make sense!

                      Harald

---

From: Christopher Blizzard <[email-masked]>
Date: Tue, 23 Aug 2011 11:33:51 -0700

On 8/23/2011 11:28 AM, Harald Alvestrand wrote:
> I can't say I'm overly happy with the amount of imagination spent on 
> the name, but the effort seems to make sense!

We're not part of the device API working group (only Opera participates 
in that group from the major browser vendors.)

--Chris

--Chris

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Tue, 23 Aug 2011 11:41:53 -0700

> Is that your planned venue for standardizing these APIs?

I'm not sure that's been worked out yet, but before I say too many 
incorrect things, let me CC Jonas so he can correct me.

> name, but the effort seems to make sense!

Well, I didn't name the thing, but keep in mind that initiating phone 
calls is only one small part of the total effort.

---

From: Dan York <[email-masked]>
Date: Tue, 23 Aug 2011 15:03:39 -0400

Tim,

On Aug 23, 2011, at 1:59 PM, Timothy B. Terriberry wrote:

> This is more along the lines of getting access to the APIs needed to instruct a mobile phone to initiate a phone call, rather than to host that call inside the browser. Presumably also with some way to detect that your on a device that supports that capability at all.

Thanks for the reply... and yes that makes sense.  I was thinking of "a basic HTML5 phone experience" as having a real-time "phone" conversation via HTML5, rather than putting pieces into HTML5 to have it work better on phone *devices*.

Thanks,
Dan

---

From: Jonas Sicking <[email-masked]>
Date: Tue, 23 Aug 2011 17:01:44 -0700

On Tue, Aug 23, 2011 at 11:41 AM, Timothy B. Terriberry
<[email-masked]> wrote:
> I'm not sure that's been worked out yet, but before I say too many incorrect
> things, let me CC Jonas so he can correct me.

I'm working on a more detailed blog post which mentions our
standardization strategy. The short story is that we absolutely want
all of these APIs to be standardized. Our plan is to bring the APIs to
W3C once we've experimented enough with them to feel good about them.
Which group this ends up in depends on the API.

> Well, I didn't name the thing, but keep in mind that initiating phone calls
> is only one small part of the total effort.

Indeed. I'm not a big fan of the name either. But the goal is indeed
to be much broader than just applications for phone and SMS.

/ Jonas