Subject: Re: [rtcweb] draft-alvestrand-one-rtp-00.txt and profile

From: Christer Holmberg <[email-masked]>
Date: Sun, 14 Aug 2011 21:13:16 +0200

Hi Harald,

Section 3 of the draft says that the profile of the sections MUST be the same, but there is no justification.

Could you please explain the reason behind that MUST?

Regards,

Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 14 Aug 2011 22:15:29 +0200

The profile affects the protocols available (such as tmmbr, or whether it is rtp or something completely different. Some parameters may be meaningless under a different profile. So making profile dependent on TOGETHER support looked strange to me. Do you see any case where different profiles would be critical?
-- 
Sent from my Android phone with K-9 Mail. Please excuse my brevity.

Christer Holmberg <[email-masked]> wrote:

Hi Harald,

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Aug 2011 09:57:36 +0200

Hi,

There are discussions in other SDOs about using AVPF for video and AVP for audio, within a session.

However, those discussions are not within the context of multiplex.

Regards,

Christer

________________________________
From: Harald Alvestrand [mailto:[email-masked]]
Sent: 14. elokuuta 2011 23:15
To: Christer Holmberg; [email-masked]
Subject: RE: draft-alvestrand-one-rtp-00.txt and profile

Hi Harald,

Regards,

Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 15 Aug 2011 10:33:38 +0200

> However, those discussions are not within the context of multiplex.
I added the following text:

The reason for the requirement for systematic proto is that there are 
many combinations that don't make sense (for instance "RTP/AVPF" in one 
section and "RTP/SAVP" in another would make encryption and availability 
of TMMBR depend on the outcome of negotiation, which seems strange). The 
cases where combinations make sense (RTP/AVPF with UDP/FEC for instance) 
also usually require that separate RTP sessions be used. [[QUESTION IN 
DRAFT: Are there sensible combinations?]]

Makes sense?
> Regards,
> Christer
>
>     ------------------------------------------------------------------------
>     *From:* Harald Alvestrand [mailto:[email-masked]]
>     *Sent:* 14. elokuuta 2011 23:15
>     *To:* Christer Holmberg; [email-masked]
>     *Subject:* RE: draft-alvestrand-one-rtp-00.txt and profile
>
>     The profile affects the protocols available (such as tmmbr, or
>     whether it is rtp or something completely different. Some
>     parameters may be meaningless under a different profile. So making
>     profile dependent on TOGETHER support looked strange to me. Do you
>     see any case where different profiles would be critical?
>     --

---

From: Colin Perkins <[email-masked]>
Date: Mon, 22 Aug 2011 17:49:30 +0100

On 15 Aug 2011, at 09:33, Harald Alvestrand wrote:
> The reason for the requirement for systematic proto is that there are many combinations that don't make sense (for instance "RTP/AVPF" in one section and "RTP/SAVP" in another would make encryption and availability of TMMBR depend on the outcome of negotiation, which seems strange). The cases where combinations make sense (RTP/AVPF with UDP/FEC for instance) also usually require that separate RTP sessions be used. [[QUESTION IN DRAFT: Are there sensible combinations?]]
> 
> Makes sense?
>> 

The only combinations I can think of that make sense are RTP/AVP with RTP/AVPF, and RTP/SAVP with RTP/SAVPF. It's not clear why you'd bother though, since the AVPF variant behaves the same as the AVP variant if you don't use the feedback.

-- 
Colin Perkins
http://csperkins.org/