Subject: [rtcweb] DSCP and media

From: Cullen Jennings <[email-masked]>
Date: Wed, 20 Jul 2011 10:59:32 -0700

Many home NATs support DSCP based QoS and it does help. I think that the IETF should recommend that some default DSCP for audio and video from the browser as well as suggest there should be an API to set the DSCP for different media steam. 

Cullen <with my individual contributor hat on>

---

From: Dzonatas Sol <[email-masked]>
Date: Wed, 20 Jul 2011 11:34:56 -0700

On 07/20/2011 10:59 AM, Cullen Jennings wrote:
> Cullen<with my individual contributor hat on>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>    

XML entities with DNA-like name sequences, I knew there was some use for 
these non-aspects. If DSCP is t.co or G.co aware, then 
&co.G.sequence...; is possible for speedy QoS. I haven't found any 
reason for AOT and JIT namespaces to conflict in such entities. It's 
just not as automated as some desire, yet could be universally 
coincidental. No need to make these "far" synopsis any harder for 
internationalization of such namespaces.

Glad ICE continues to support direct IPv4 override, hypervisors still 
need this mode for games.

-- 
--- http://twitter.com/Dzonatas_Sol ---
Web Development, Software Engineering
Ag-Biotech, Virtual Reality, Consultant

---

From: Justin Uberti <[email-masked]>
Date: Wed, 20 Jul 2011 15:39:04 -0400

Can you go into more detail about what these NATs do with the DSCP markings?

I'm not convinced we want to expose a generic API for this (too easy to
misuse), but I think it definitely makes sense for implementations to set
appropriate markings on audio and video packets, including different levels
on individual video packets when using hierarchical prediction structures.

On Wed, Jul 20, 2011 at 1:59 PM, Cullen Jennings <[email-masked]> wrote:

>
> Many home NATs support DSCP based QoS and it does help. I think that the
> IETF should recommend that some default DSCP for audio and video from the
> browser as well as suggest there should be an API to set the DSCP for
> different media steam.
>

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 20 Jul 2011 13:43:04 -0700

I think we're talking about things like support of WFA WMM.  Not a NAT function per se. 

Some info on how this is implemented in the OS is available here. 

Whether this actually accomplishes anything in practice is a subject of debate. 

From: [email-masked]
Date: Wed, 20 Jul 2011 15:39:04 -0400
To: [email-masked]
CC: [email-masked]
Subject: Re: [rtcweb] DSCP and media

Can you go into more detail about what these NATs do with the DSCP markings?
I'm not convinced we want to expose a generic API for this (too easy to misuse), but I think it definitely makes sense for implementations to set appropriate markings on audio and video packets, including different levels on individual video packets when using hierarchical prediction structures.

rtcweb mailing list

[email-masked]

---

From: Justin Uberti <[email-masked]>
Date: Wed, 20 Jul 2011 17:09:34 -0400

OK, that's what I suspected.

Ensuring that this is handled properly by the RTCWEB platform can only help
things.

On Wed, Jul 20, 2011 at 4:43 PM, Bernard Aboba <[email-masked]>wrote:

> Some info on how this is implemented in the OS is available here<http://blogs.msdn.com/b/wndp/archive/2006/06/28/650363.aspx>.
>
>
> Whether this actually accomplishes anything in practice is a subject of
> debate<http://www.smallnetbuilder.com/wireless/wireless-features/30837-does-wi-fi-multimedia-wmm-really-do-anything-part-3?start=1>.
>
>
> ------------------------------
> From: [email-masked]
> _______________________________________________ rtcweb mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 20 Jul 2011 14:25:16 -0700

As Bernard points out there is the qos marking for the wireless networks and local networks but what I am mostly interested in is the device (typically an NAT) that is sequencing the packets on to the broadband uplink from my home to my ISP. Lots of NATs support some simple set of priorities and send the higher priority packets ahead of the lower priority. My view is this was largely done for the online gaming people but in many cases it does help voip. Many of the voip devices do take advantage of it - there is pretty much no downside for setting the DSCP. The cases where I see it helping are things like the following: I have a 128Kbps uplink, I am trying to send an 80Kbps audio stream, and at the same time I email a 25 MB powerpoint file. With QoS, typically the audio gets it's 80k and email gets the rest. WIthout QOS, the audio gets packet loss.  It helps in cases where the uplink is the congested part of the network. It does not help if your downlink is the problem. Keep in mind most people have much faster downlink than uplink. It's easy to run your own experiments and try this out - just get a nat with support and turn it on and off and see how things go. It also helps with wireless but I have not done a lot of experimenting with that - my wireless is so much faster than my broadband that it has not been a problem but I heard rumors that it can help file transfer over the lan not impact voip - I just don't know as much about this sort of use case. 

To your point about too risky to expose a generic API. I'm on the fence. You could be right but it's sort of hard to decide why if it too risking to let some JS send an packet with higher priority, that it is OK to let is send normal priority ones. It would be interesting to talk about the risk, and what we might do to mitigate them. One point of view is that rate shaping and policing of packets can never be done by the endpoint and needs to be done by network router and switches. The people that buy into this don't see it as any worse that the JS can set the DSCP than the fact that a think app on my notebook computer can set the DSCP.  

The other issue is that it is not clear what values you should set the DSCP to. If you read the appropriate RFCs, you will come to the conclusion that they are pretty confused on the topic. If you look at the values being used by Cisco, the mapping from 802.11, and Microsoft, you would notice they are not the same and there may be some uh "gaming the system" going on. One of the things this WG could do would be to come up with some clear guidance on what values to use for browsers and when to use them. 

> Cullen <with my individual contributor hat on>

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 20 Jul 2011 14:37:25 -0700

As I recall, there was some conflict between the DSCP mappings defined within WMM and those recommended in RFC 4594.  There was some discussion of how to fix this in WFA and DLNA.  Fred would probably know the current status. AFAIK this is still an issue. 

> From: [email-masked]
> Date: Wed, 20 Jul 2011 14:25:16 -0700
> To: [email-masked]
> CC: [email-masked]
> As Bernard points out there is the qos marking for the wireless networks and local networks but what I am mostly interested in is the device (typically an NAT) that is sequencing the packets on to the broadband uplink from my home to my ISP. Lots of NATs support some simple set of priorities and send the higher priority packets ahead of the lower priority. My view is this was largely done for the online gaming people but in many cases it does help voip. Many of the voip devices do take advantage of it - there is pretty much no downside for setting the DSCP. The cases where I see it helping are things like the following: I have a 128Kbps uplink, I am trying to send an 80Kbps audio stream, and at the same time I email a 25 MB powerpoint file. With QoS, typically the audio gets it's 80k and email gets the rest. WIthout QOS, the audio gets packet loss.  It helps in cases where the uplink is the congested part of the network. It does not help if your downlink is the problem. Keep 
>  in mind most people have much faster downlink than uplink. It's easy to run your own experiments and try this out - just get a nat with support and turn it on and off and see how things go. It also helps with wireless but I have not done a lot of experimenting with that - my wireless is so much faster than my broadband that it has not been a problem but I heard rumors that it can help file transfer over the lan not impact voip - I just don't know as much about this sort of use case. 
>

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 20 Jul 2011 14:39:26 -0700

> As I recall, there was some conflict between the DSCP mappings defined within WMM and those recommended in RFC 4594.  There was some discussion of how to fix this in WFA and DLNA.  Fred would proba…

Fred, James - do you guys know status of mapping DSCP to WMM ?

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 20 Jul 2011 15:25:49 -0700

On Jul 20, 2011, at 15:13 , Fred Baker wrote:

> 
> On Jul 20, 2011, at 2:39 PM, Cullen Jennings wrote:
> 
>> 
> Define "WMM"?

The "Wireless Multimedia Extensions from Wi-FI. It's been awhile since I looked at this but I seem to recall that 802.11e had four levels of priority, something like voice, video, background, and best effort. And 802.1p had 8 levels, and some confusion on status of mapping between them and DSCP.

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 20 Jul 2011 15:32:46 -0700

The specific issue was the mapping between IEEE 802.1p and DSCP included in the WMM appendix.  This wasn't included in IEEE 802.11e (thankfully).  The appendix was included prior to publication of RFC 4594, and was incompatible with it.  As I recall, the WMM mapping was as follows:

PJLIB Traffic Type     IP DSCP  WMM  802.1p  
 BEST_EFFORT  0x00     BE (Bulk Effort)    0    
 BACKGROUND   0x08     BK (Bulk)     2    
 VIDEO        0x28     VI (Video)      5    
 VOICE        0x30     VO (Voice)      6    
 CONTROL      0x38     VO (Voice)      7    

> Date: Wed, 20 Jul 2011 15:25:49 -0700
> CC: [email-masked]; [email-masked]; [email-masked]; [email-masked]
> To: [email-masked]
> 
>

---

From: Dzonatas Sol <[email-masked]>
Date: Fri, 22 Jul 2011 15:19:02 -0700

Chair,

I claimed yesterday that I wouldn't post here today, this date, unless there was something included to spend at-least one trillion worth of transient dollars.

Found one.

[...QoS...]

> The other issue is that it is not clear what values you should set the DSCP to. If you read the appropriate RFCs, you will come to the conclusion that they are pretty confused on the topic. If you…

Silverlight/Moonlight crashes or hangs in Crome/book. This means the 
"browser based run-time tests" are unfair. I could finger if I was a 
judge, yet I am clearly not one.

I can define "stupid" simply by [A-Z]+pyramidal-shape found, and I have 
already declared that elsewhere for good causes. If judges want to use 
graphene or the silver pen is their choice on the minutes, yet I seen 
why some question anti-truth/anti-trust when that choice is already 
tainted. I doubt anything like "auto-jury" is any game, yet still looks 
stupid like "Gaming the system."

Tax the debt makes sense to me. Any clue? Or two?

Filed: Friday.

--