Subject: [rtcweb] Possible new use case

From: "Elwell, John" <[email-masked]>
Date: Tue, 26 Jul 2011 22:14:29 +0200

(Not sure whether this should go to the W3C list,  but trying the IETF list to start with)

I raised this during the WEBRTC session on Saturday.

Does anyone have any interest in adding a use case concerning recording of real-time media at a remote recorder? I noticed something on local recording in the proposed APIs, but remote recording might have other impacts, e.g.,
- taking a stream from a capture device (mic, camera) and sending it not only to the remote browser but also to a remote recorder;
- taking a stream from the remote browser and sending it to a remote recorder (as well as rendering locally);
- possibly mixing the two streams (in case of audio) and sending as a single mixed stream to the recording device.

John

John Elwell
Tel: +44 1908 817801 (office and mobile)
Email: [email-masked]
http://www.siemens-enterprise.com/uk/

Siemens Enterprise Communications Limited.
Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15 0DJ.
Registered No: 5903714, England.

Siemens Enterprise Communications Limited is a Trademark Licensee of Siemens AG.

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 28 Jul 2011 15:24:44 -0700

Hi John,

I am interested in this use case and would be interested in seeing it
added.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Elwell, John
> Sent: Tuesday, July 26, 2011 4:14 PM
> To: [email-masked]
> Subject: [rtcweb] Possible new use case
> 
> Does anyone have any interest in adding a use case concerning
recording of real-time media at a remote
> recorder? I noticed something on local recording in the proposed APIs,
but remote recording might have
> other impacts, e.g.,
> - taking a stream from a capture device (mic, camera) and sending it
not only to the remote browser
> but also to a remote recorder;
> - taking a stream from the remote browser and sending it to a remote
recorder (as well as rendering
> locally);
> - possibly mixing the two streams (in case of audio) and sending as a
single mixed stream to the
> recording device.
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Roy Yue(PeiYu)" <[email-masked]>
Date: Thu, 28 Jul 2011 23:01:38 +0000

Hi folks,

+1
I am also interested in such use cases.

Regards,
Roy

________________________________________
发件人: [email-masked] [[email-masked]] 代表 Charles Eckel (eckelcu) [[email-masked]]
发送时间: 2011年7月29日 6:24
到: Elwell, John; [email-masked]
主题: Re: [rtcweb] Possible new use case

Hi John,

Cheers,
Charles

Behalf Of Elwell, John