Subject: [rtcweb] Possible New Cases - Emergency Services Call & Text

From: Paul Beaumont <[email-masked]>
Date: Sat, 30 Jul 2011 12:03:09 +0100

This was mentioned is the initial RTCWeb session at IETF 81 but just to make sure it has been captured and understood.

(1) Please can a separate use case be added for an Emergency Services telephony call (eg 999 in UK, 112 in EU, 911 in NA, etc). 

(2) Please can a further separate use case be added for an Emergency Services real time text (eg 18000 in UK, via TextDirect operator to ES operator for hearing impaired persons). FYI today this is a low speed in-band voice band data call on the text leg. Presumably the replacement would be some kind of Presence/Messaging replacement with assured delivery or similar.

Please note these are treated differently today in current networks and I would suggest we aim to preserve the capabilities - subject to discussion in the community, in the right WG - eg ECRIT. These are, using legacy terminology ...

A). Prioritisation in processing of Emergency Services calls above Ordinary Calls, particularly when server in overload.

B). Marking of Emergency Services calls to a specific A-/Calling Party Category to allow them to be identified downstream.

C). Release control modified to B-/Called Party Control with changed RTCWeb browser client behaviour along with indication as to "Off Hook" and "On Hook".

Paul

---

From: Henry Sinnreich <[email-masked]>
Date: Sat, 30 Jul 2011 07:26:09 -0500

Scratching my head why you did not even mention the SOS URL,
http://www.ietf.org/rfc/rfc5031.txt

> Please note these are treated differently today in current networks and I
> would suggest we aim to preserve the capabilities - subject to discussion in
> the community, in the right WG - eg ECRIT. These are, using legacy terminology
> ...

Subject to discussion in yet another WG?

Henry

On 7/30/11 6:03 AM, "Paul Beaumont" <[email-masked]> wrote:

> This was mentioned is the initial RTCWeb session at IETF 81 but just to make
> sure it has been captured and understood.
> 
> (1) Please can a separate use case be added for an Emergency Services
> telephony call (eg 999 in UK, 112 in EU, 911 in NA, etc).
> 
> (2) Please can a further separate use case be added for an Emergency Services
> real time text (eg 18000 in UK, via TextDirect operator to ES operator for
> hearing impaired persons). FYI today this is a low speed in-band voice band
> data call on the text leg. Presumably the replacement would be some kind of
> Presence/Messaging replacement with assured delivery or similar.
> 
> Please note these are treated differently today in current networks and I
> would suggest we aim to preserve the capabilities - subject to discussion in
> the community, in the right WG - eg ECRIT. These are, using legacy terminology
> ...
> 
> A). Prioritisation in processing of Emergency Services calls above Ordinary
> Calls, particularly when server in overload.
> 
> B). Marking of Emergency Services calls to a specific A-/Calling Party
> Category to allow them to be identified downstream.
> 
> C). Release control modified to B-/Called Party Control with changed RTCWeb
> browser client behaviour along with indication as to "Off Hook" and "On Hook".
> 
> Paul
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 31 Jul 2011 08:31:40 -0400

> (1) Please can a separate use case be added for an Emergency Services telephony call (eg 999 in UK, 112 in EU, 911 in NA, etc).
I am skeptical to adding this use case. The most important issues and 
complications that ES brings to the table are with call setup, which I 
believe is outside of what RTCWEB should be focusing on. As long as 
there is nothing special about the media plane issues here, I would 
prefer not to take it on.
> A). Prioritisation in processing of Emergency Services calls above Ordinary Calls, particularly when server in overload.
Are you talking about prioritization in the control plane (out of scope) 
in the media plane, or both? Note that the media plane doesn't 
necessarily have any servers in it.
> B). Marking of Emergency Services calls to a specific A-/Calling Party Category to allow them to be identified downstream.
Same question here.
> C). Release control modified to B-/Called Party Control with changed RTCWeb browser client behaviour along with indication as to "Off Hook" and "On Hook".
Does the "hook" map to anything we currently have in our APIs or concepts?

---

From: Randell Jesup <[email-masked]>
Date: Sun, 31 Jul 2011 17:22:23 -0400

On 7/31/2011 8:31 AM, Harald Alvestrand wrote:
>> This was mentioned is the initial RTCWeb session at IETF 81 but just 
>> to make sure it has been captured and understood.
>>

The main media-plane issues that we should focus on (as opposed to the 
services built with it)
are ones that involve making capabilities available to the application, 
such as the aforementioned
ability to turn off VAD or to force a change from a "voice" codec to a 
more "general" codec (and
maybe to allow in this case automatic activation of the camera, but 
that's slightly arguable AND
with the one exception of VRS-911 there's no current support for cameras 
in 911 centers.  Most
of the rest of the requirements fall on the application/service.

-- 
Randell Jesup
[email-masked]