Subject: [rtcweb] Presentations for meeting today

From: Cullen Jennings <[email-masked]>
Date: Wed, 8 Jun 2011 07:34:15 -0600

I have been uploading them to the wiki page at 

http://trac.tools.ietf.org/wg/rtcweb/trac/wiki

Scroll to the bottom of that web page and you can find them. 

Still missing a few ...

---

From: Igor Faynberg <[email-masked]>
Date: Fri, 10 Jun 2011 18:01:23 -0400

A question.

When SIP is implemented in an application within the present RTCweb 
architecture, how exactly could we use WebSockets for SUBSCRIBE/NOTIFY?

It appears to me that the only way to achieve that is to open a 
persistent connection.  Am I right? 

If so, is it not a problem, given the potential duration of such 
connections and potential tie-up of network resources?

If not, how else could that be done?

With many thanks,

Igor

---

From: Justin Uberti <[email-masked]>
Date: Fri, 10 Jun 2011 15:29:24 -0700

On Fri, Jun 10, 2011 at 3:01 PM, Igor Faynberg <
[email-masked]> wrote:

> It appears to me that the only way to achieve that is to open a persistent
> connection.  Am I right?
>

Yes, that is correct. This is how asynchronous web applications work today.

> connections and potential tie-up of network resources?

An unused TCP/WebSockets connection consumes very few resources.

> ______________________________**_________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/rtcweb<https://www.ietf.org/mailman/listinfo/rtcweb>
>

---

From: "Avasarala, Ranjit" <[email-masked]>
Date: Sat, 11 Jun 2011 17:09:41 +0800

Hi

Any idea how the initial SIP signaling would take place between an RTC web application and SIP server?

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Igor Faynberg
Sent: Saturday, June 11, 2011 3:31 AM
To: [email-masked]
Subject: [rtcweb] How do we implement SIP event subscription in RTCweb?

A question.

With many thanks,

Igor
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Salvatore Loreto <[email-masked]>
Date: Mon, 13 Jun 2011 17:44:52 +0300

On 6/11/11 1:29 AM, Justin Uberti wrote:
>
>
> On Fri, Jun 10, 2011 at 3:01 PM, Igor Faynberg 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     A question.
>
>     When SIP is implemented in an application within the present
>     RTCweb architecture, how exactly could we use WebSockets for
>     SUBSCRIBE/NOTIFY?
>

more there is also the intention in the HyBi wg to work on a MUX 
extension to the WebSocket protocol

-- 

Salvatore Loreto
www.sloreto.com

---

From: Igor Faynberg <[email-masked]>
Date: Mon, 13 Jun 2011 14:05:32 -0400

That part I thought was easy: The application will send REGISTER.

I was worried about keeping a persistent connection, but Justin (to whom 
many thanks for answering my query right away!) assures me that this is 
not a problem, and so far no one said anything otherwise.

Igor

---

From: Christopher Blizzard <[email-masked]>
Date: Mon, 13 Jun 2011 11:09:00 -0700

On 6/13/2011 11:05 AM, Igor Faynberg wrote:
> I was worried about keeping a persistent connection, but Justin (to 
> whom many thanks for answering my query right away!) assures me that 
> this is not a problem, and so far no one said anything otherwise. 

The larger issue is that we need a way to do connections & applications 
outside of the single page context.  How do you signal from a service 
when someone might not have a web page open?  This is a problem that's 
outside of the scope of both the IETF and W3C groups, but it's a problem 
in any case.

--Chris

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 14 Jun 2011 13:27:15 +0200

On 06/13/11 20:09, Christopher Blizzard wrote:
> The larger issue is that we need a way to do connections & 
> applications outside of the single page context.  How do you signal 
> from a service when someone might not have a web page open?  This is a 
> problem that's outside of the scope of both the IETF and W3C groups, 
> but it's a problem in any case.
Isn't this the "Web Application / Background Page" problem - that is, 
having stuff run in the browser when no pages are open?
I believe there are W3C groups hard at work on that; we should punt it 
to them if we can.

                Harald

---

From: Igor Faynberg <[email-masked]>
Date: Tue, 14 Jun 2011 09:43:24 -0400

We should, and YOU are the best person to do that, since you are already 
there (and with a lot of clout).

But... what can we do in the IETF?

Igotr

Harald Alvestrand wrote:
>> from a service when someone might not have a web page open?  This is 
>> a problem that's outside of the scope of both the IETF and W3C 
>> groups, but it's a problem in any case.