Subject: [rtcweb] Use-case grouping

From: Christer Holmberg <[email-masked]>
Date: Tue, 21 Jun 2011 14:39:38 +0200

Hi,

It's nice to see the amount of use-cases people have submitted :)

Now, since many of the use-cases are related to each other, and in order to get a better and easy-to-read structure of the document, I would like to suggest to devide the use-cases into different "use-case groups".

Below is a proposed grouping, and examples of use-cases which would be listed in each group. I have only used the existing use-cases, and the ones suggested by Cullen, but I am aware that more use-cases have been proposed :)

Telephony use-cases:

    - Telephony terminal use-case (draft)
    - Call fedex use-case (Cullen)

Video conferenceing use-cases:

    - With central server (draft)
    - Without central server (draft)
    - Hockey (draft)
    - Screen re-size (Cullen)

Embedded voice communicatoin use-case:

   - Multiparty on-line game with voice communication (draft)

Bandwidth/QoS/mobility use-cases:

   - NIC Change (Cullen)
   - QoS Marking (Cullen)

Later, we can of course modify/add/remove groups, but I think the grouping above would be a good start, and I think all the use-cases so far proposed would fit into one of those groups.

Comments?

Regards,

Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 21 Jun 2011 17:30:00 +0200

Seems to me sensible to have groupings.

The use case I don't see a place for at the moment is the single 
point-to-point call; the proposed use case I don't see mentioned below 
is my suggestion for "interoperable calling".

So this might require more tuning.

On 06/21/11 14:39, Christer Holmberg wrote:
> Now, since many of the use-cases are related to each other, and in 
> order to get a better and easy-to-read structure of the document, I 
> would like to suggest to devide the use-cases into different "use-case 
> groups".
> Below is a proposed grouping, and examples of use-cases which would be 
> listed in each group. I have only used the existing use-cases, and the 
> ones suggested by Cullen, but I am aware that more use-cases have been 
> proposed :)
> Telephony use-cases:
> Later, we can of course modify/add/remove groups, but I think the 
> grouping above would be a good start, and I think all the use-cases so 
> far proposed would fit into one of those groups.
> Comments?
> Regards,
> Christer
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 21 Jun 2011 08:59:11 -0700

Yes, I like this grouping.

> Later, we can of course modify/add/remove groups, but I think the grouping above would be a good start, and I think all the use-cases so far proposed would fit into one of those groups.

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 21 Jun 2011 19:10:44 +0200

Hi Harald,

We could add a "Point-to-point", or "Browser-to-browser", use-case group.

Regards,

Christer

________________________________
From: [email-masked] [[email-masked]] On Behalf Of Harald Alvestrand [[email-masked]]
Sent: Tuesday, June 21, 2011 6:30 PM
To: [email-masked]
Subject: Re: [rtcweb] Use-case grouping

The use case I don't see a place for at the moment is the single point-to-point call; the proposed use case I don't see mentioned below is my suggestion for "interoperable calling".

Hi,

Telephony use-cases:

   - NIC Change (Cullen)
   - QoS Marking (Cullen)

Comments?

Regards,

Christer

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Lu, Hui-Lan (Huilan)" <[email-masked]>
Date: Wed, 22 Jun 2011 09:25:30 -0500

"Point-to-point" seems more flexible. Such a group would allow us to address use cases invovling devices (such as IP phones or mobile phones) which don't have a browser.

Huilan 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: Tuesday, June 21, 2011 1:11 PM
> To: Harald Alvestrand; [email-masked]
> From: [email-masked] [[email-masked]] On 
> Behalf Of Harald Alvestrand [[email-masked]]
> The use case I don't see a place for at the moment is the 
> single point-to-point call; the proposed use case I don't see 
> mentioned below is my suggestion for "interoperable calling".
> 
> Now, since many of the use-cases are related to each other, 
> and in order to get a better and easy-to-read structure of 
> the document, I would like to suggest to devide the use-cases 
> into different "use-case groups".
> 
> Below is a proposed grouping, and examples of use-cases which 
> would be listed in each group. I have only used the existing 
> use-cases, and the ones suggested by Cullen, but I am aware 
> that more use-cases have been proposed :)
> 
> 
> Telephony use-cases:
> 
> Later, we can of course modify/add/remove groups, but I think 
> the grouping above would be a good start, and I think all the 
> use-cases so far proposed would fit into one of those groups.
> 
> Comments?
> 
> Regards,
> 
> Christer
> 
> 
>