Subject: [rtcweb] 3D Plugin?

From: "Christian Hoene" <[email-masked]>
Date: Thu, 14 Apr 2011 16:00:09 +0200

Hi,

I was wondering whether somebody plan to add a 3D rendering plugin into the
RTC-web browser?
Any plan about this or is it out of scope?

With best regards,
 Christian Hoene

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 14 Apr 2011 16:02:12 +0200

> Any plan about this or is it out of scope?

Are there any additional requirements on RTCWEB than seeing it as an
media type with some media type specific signalling, most likely as part
of the RTP payload type used to carry the data between the peers?

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: David Singer <[email-masked]>
Date: Thu, 14 Apr 2011 08:35:02 -0700

> of the RTP payload type used to carry the data between the peers?

It's hard to tell from such a brief message, alas.

But perhaps we are in agreement.  I am envisaging markup/DOM that makes the camera and microphone visible, the ability to connect them and the audio/video elements to modules that do real-time communication, javascript APIs control the markup and those modules. I expect that the modules will instantiate discovery, signalling/connectivity, actual real-time streaming, encode/decode, and monitoring.

Within that, I am expecting there to be initial modules defined and probably mandated to do an initial set of protocols, probably the classic RTP/SIP for signalling and flows, and that those modules will be spec'd with 'enough' NAT/firewall handling to work most of the time. Connection to TURN servers should probably be possible. Other modules are possible; explore, refine, develop, prototype, etc.

So, on the subject of 3D: if your browser supports a stereo video media type for rendering in the video element, and for capture by a camera, and your codecs can encode/decode that type, and RTP encapsulate it, and your protocol modules carry it (and it should be transparent)...why not?

Quite a few use-cases do not need arbitrary discovery.  
* I bring up a web page from an organization that offers to connect me to a department at that organization (e.g. customer support), in an integrated context. The 'server cloud' at that corporation does not need to 'discover' a customer support rep's IP address, it can know it.
* I am on a cloud-service based portal page (like a yahoo, google, etc. page), which has frames for email, chat, news, and video-phone. The page indicates that someone in my (cloudbased) address book is online and call-able. It already knows that and where they are, and has put a 'green phone' icon next to them. No discovery is needed.

Indeed, what makes the browser attractive is that it offers an integrating service environment, and doing a classic 'blind call' to an address in my address book, where full discovery is needed ('is fred online', 'what is his IP address?' etc.) is not obviously benefiting much from this. Videophone applications already do this (quite well).

David Singer
Multimedia and Software Standards, Apple Inc.