Subject: Re: [quicwg/base-drafts] Version 0 is Version Negotiation (#968)

From: ianswett <[email-masked]>
Date: Fri, 01 Dec 2017 06:06:20 -0800

ianswett commented on this pull request.

Two small comments, but looks good.

> @@ -302,7 +302,7 @@ deployed and used concurrently. Version negotiation is described in
 
 QUIC versions are identified using a 32-bit unsigned number.
 
-The version 0x00000000 is reserved to represent an invalid version.  This
+The version 0x00000000 is reserved to represent version negotiation.  This
 version of the specification is identified by the number 0x00000001.

OT Q: Why isn't version 0 represented by the number 0x00000000?

> @@ -768,7 +780,7 @@ constant:
 
 * the location and size of the Packet Number field in long headers, and

I thought I removed this from the invariants?  If I missed it, shouldn't it be removed now?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/968#pullrequestreview-80504147

---

From: ianswett <[email-masked]>
Date: Fri, 01 Dec 2017 06:08:02 -0800

> @@ -543,6 +544,17 @@ the server supports, as shown below.
 ~~~
 {: #version-negotiation-format title="Version Negotiation Packet"}
 
+The value in the Unused field is selected randomly by the server. The Connection
+ID field echoes the corresponding value from the triggering client packet.  This
+allows clients some assurance that the server received the packet and that the
+Version Negotiation packet is in fact from the server.  The Version field MUST
+be set to 0x00000000.  The remainder of the Version Negotiation packet is a list
+of 32-bit versions which the server supports.
+
+A Version Negotiation packet is never explicitly acknowledged in an ACK frame by

It doesn't have a packet number anymore, so how could it be acknowledged?  Maybe change to "cannot be explicitly acknowledged.."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/968#pullrequestreview-80505408

---

From: Mike Bishop <[email-masked]>
Date: Fri, 01 Dec 2017 15:26:47 -0800

MikeBishop commented on this pull request.

 

I'm a little confused by the question.  Are you asking why it's spelled out?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/968#discussion_r154472641

---

From: Mike Bishop <[email-masked]>
Date: Fri, 01 Dec 2017 23:28:14 +0000 (UTC)

@MikeBishop pushed 1 commit.

a048e84  Ian's comments, minus 0x00000000

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/968/files/70d4edf88e6b1d92a4adda43ec4d914bc456c961..a048e84fc6768ae19931e98f56af19925eca0fc0

---

From: ianswett <[email-masked]>
Date: Sat, 02 Dec 2017 00:22:57 +0000 (UTC)

I misread these two sentences as "The version 0x00000000 is reserved to represent an invalid version.  This(Ian's misinterpretation: the version negotiation version) version of the specification is identified by the number 0x00000001."

So I misinterpreted the use of the word "This", which is partly a product of the small snippet Github displays, but possibly it makes sense to clarify this now that the spec uses two versions?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/968#discussion_r154478586

---

From: ianswett <[email-masked]>
Date: Sat, 02 Dec 2017 00:25:02 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/968#pullrequestreview-80656254

---

From: janaiyengar <[email-masked]>
Date: Sun, 03 Dec 2017 21:51:30 +0000 (UTC)

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/968#pullrequestreview-80714682

---

From: janaiyengar <[email-masked]>
Date: Mon, 04 Dec 2017 22:35:01 +0000 (UTC)

Merged #968.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/968#event-1371527751