Subject: [quicwg/base-drafts] Don't create multiple connections from the same ClientHello (#1005)

From: Martin Thomson <[email-masked]>
Date: Fri, 08 Dec 2017 05:11:29 +0000 (UTC)

The TLS draft mentioned "Server Stateless Retry" a few times.  Now it doesn't.  That's a minor point.

I have also added a section that deals with the potential for Retry to be sent multiple times with different values.  A stateless version of NSS will generate a different cookie in response to every ticket it receives.  The difference is due to the need to generate a nonce for self-encryption.  That means that the client could end up with many HelloRetryRequest messages to work from.  

A client shouldn't proceed with more than one handshake here or we are well into the territory of violating some of the basic assumptions in the TLS security analysis (that ClientHello.random is a nonce).
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1005

-- Commit Summary --

  * Fixup HRR/Retry section a little

-- File Changes --

    M draft-ietf-quic-tls.md (25)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1005.patch
https://github.com/quicwg/base-drafts/pull/1005.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1005

---

From: Marten Seemann <[email-masked]>
Date: Thu, 07 Dec 2017 21:13:56 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1005#pullrequestreview-82068286

---

From: janaiyengar <[email-masked]>
Date: Fri, 08 Dec 2017 05:30:37 +0000 (UTC)

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1005#pullrequestreview-82069641

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Dec 2017 21:30:41 -0800

@martinthomson pushed 1 commit.

79003d0  Remove mention of Server Stateless Retry/Client Initial/Cleartext packets.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1005/files/bd53b2a5f717b8285f599876277e46d3b1ba33eb..79003d0edb48a2aa4b854083b86ab06b03d725a0

---

From: janaiyengar <[email-masked]>
Date: Thu, 07 Dec 2017 21:32:37 -0800

Still LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1005#pullrequestreview-82069816

---

From: Sean Turner <[email-masked]>
Date: Fri, 15 Dec 2017 11:52:01 +0000 (UTC)

seanturner approved this pull request.

lgtm - time to merge?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1005#pullrequestreview-83786925

---

From: MikkelFJ <[email-masked]>
Date: Fri, 15 Dec 2017 12:27:52 +0000 (UTC)

Is there a way to know that extra HelloRetryRequests originate from the initial Client packet, and not as a result of the client trying to connect again, but still fails? In the first case additional retry packets should be dropped, but in the second case the connection should probably by aborted. Or can this simply be dealt with by the triving eventually timing out on connection attempts?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1005#issuecomment-351994030

---

From: Martin Thomson <[email-masked]>
Date: Fri, 15 Dec 2017 21:11:38 +0000 (UTC)

Merged #1005.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1005#event-1390338453