Subject: [quicwg/base-drafts] Server's initial plaintext packet should be PMTU sized (#1010)

From: janaiyengar <[email-masked]>
Date: Tue, 12 Dec 2017 01:46:32 +0000 (UTC)

Sec 9 should include this, without which the PMTU discovery that happens with client + server handshake packets is not complete.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1010

---

From: Christian Huitema <[email-masked]>
Date: Tue, 12 Dec 2017 22:41:23 -0800

I was thinking, what about DOS amplification attacks, if the server plaintext is larger than the client initial? But in fact, the server plain text is already larger than the client initial -- certificates are large enough to often require two packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1010#issuecomment-351298407

---

From: Christian Huitema <[email-masked]>
Date: Wed, 13 Dec 2017 06:43:19 +0000 (UTC)

OTOH, I would not call that PMTU discovery. You are speaking about the minimum MTU of 1532/1552 bytes, right?

Another way to see that is that the server should assume that the "guaranteed" MTU is at most the size of the largest packet that it sent during the handshake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1010#issuecomment-351298713

---

From: janaiyengar <[email-masked]>
Date: Wed, 13 Dec 2017 07:02:48 +0000 (UTC)

@huitema: Yes, exactly. There's no text right now for the server to know what it's max packet size ought to be. I was going to suggest that the server use the size of the client's first packet, unless it knows that the PMTU in the server -> client direction is smaller, in which case, it uses a smaller size. Either ways, this ought to become the max packet size for the server.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1010#issuecomment-351302072