Subject: Re: [quicwg/base-drafts] More detailed stream states (#894)

From: ianswett <[email-masked]>
Date: Fri, 01 Dec 2017 14:29:48 +0000 (UTC)

ianswett commented on this pull request.

> @@ -2675,201 +2676,291 @@ created, it MUST close the connection with error code STREAM_STATE_ERROR.
 Stream ID 0 (0x0) is reserved for the cryptographic handshake.  Stream 0 MUST
 NOT be used for application data, and is the first client-initiated stream.
 
-A QUIC endpoint MUST NOT reuse a Stream ID.  Streams MUST be created
-in sequential order.  Open streams can be used in any order.  Streams
-that are used out of order result in lower-numbered streams in the
-same direction being counted as open.
+A QUIC endpoint MUST NOT reuse a Stream ID.  Open streams can be used in any

Fair enough, make sure to find and close the issue this was discussed in then.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/894#discussion_r154357810

---

From: ianswett <[email-masked]>
Date: Fri, 01 Dec 2017 06:29:56 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/894#pullrequestreview-80511349

---

From: Martin Thomson <[email-masked]>
Date: Mon, 04 Dec 2017 00:00:30 +0000 (UTC)

@MikeBishop, what do you think is remaining here?  I'm happy to consider splitting frames into two categories, but that's something I'd prefer to do as a separate change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/894#issuecomment-348831482

---

From: Mike Bishop <[email-masked]>
Date: Mon, 04 Dec 2017 19:09:10 +0000 (UTC)

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/894#pullrequestreview-80953760

---

From: Martin Thomson <[email-masked]>
Date: Mon, 04 Dec 2017 14:46:11 -0800

Merged #894.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/894#event-1371544006