Subject: [quicwg/base-drafts] Are random packet number skips still relevant for opportunistic ACK protection? (#1030)

From: MikkelFJ <[email-masked]>
Date: Thu, 21 Dec 2017 09:58:54 +0000 (UTC)

Do we still need to randomly skip packet numbers to protect against opportunistic ACK's know that handshakes are protected by connection ID encryption and considering there are no protection against early connection close injection for on-path attackers?

Having a predictable linear packet number space, aside from infrequent connection migrations, simplifies certain data strutures and large unexpected gaps can also be used by the receiver to detect abuse or massive failure.

Transport 5.4.1:
> The first Initial packet that is sent by a client contains a randomized packet number. All subsequent packets contain a packet number that is incremented by one, see (Section 5.7).

Transport 8.16:
> A sender MAY intentionally skip packet numbers to introduce entropy into the connection, to avoid opportunistic acknowledgement attacks. The sender SHOULD close the connection if an unsent packet number is acknowledged. The format of the ACK frame is efficient at expressing even long blocks of missing packets, allowing for large, unpredictable gaps.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1030

---

From: Marten Seemann <[email-masked]>
Date: Thu, 21 Dec 2017 02:18:05 -0800

The changes to the handshake don't change anything to the opportunistic ACK attack. This attack was always only possible by doing an unverified connection migration.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1030#issuecomment-353313729