Subject: [quicwg/base-drafts] Appendix on GQUIC transition (#1006)

From: martinduke <[email-masked]>
Date: Fri, 08 Dec 2017 09:17:10 -0800

We're pretty close to settling on a wire image, I think. It would be useful for the transport draft (and eventually the RFC) to have an appendix covering issues with simultaneous support of GQUIC versions and QUIC v1.

I believe all the entities actually trying to support GQUIC are heavily involved in the working group. However, I imagine there are quite a lot of middleboxes out there doing some basic ID/classification (if not more) on GQUIC today, and will need some guide on how to simultaneously handle two packet header formats, etc.

If people are opposed to an appendix, I suppose a short-lived internet draft would also get the job done. In any case, I'd like to see a placeholder sooner rather than later.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1006

---

From: ianswett <[email-masked]>
Date: Fri, 08 Dec 2017 11:30:47 -0800

I suspect this would be valuable.  I tend to think it'd be better as a separate doc, since it hopefully will have little relevance by the time QUIC v2 comes around, but it could also just be removed in the v2 transport doc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1006#issuecomment-350351316

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 13 Dec 2017 01:37:12 +0000 (UTC)

There's the operability document...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1006#issuecomment-351253224

---

From: ianswett <[email-masked]>
Date: Tue, 12 Dec 2017 19:01:12 -0800

Good point, I'm happy with that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1006#issuecomment-351267486