Subject: [quicwg/base-drafts] Size of Transport Parameter Values (#1033)

From: martinduke <[email-masked]>
Date: Thu, 28 Dec 2017 18:53:15 +0000 (UTC)

A number of things I found confusing when (finally) implementing Transport Parameters (7.4 of the transport draft)

1) Figure 6 indicates that the opaque value varies over the range of a 16-bit integer, but the values are 0, 8, 16, or 32 bits depending on the parameter.
2) Given that the length of the value is type-dependent, I'm not sure how an endpoint can "ignore transport parameters that it does not support" (Sec 7.4.3). How would I skip it if I don't know how long it is?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1033

---

From: martinduke <[email-masked]>
Date: Thu, 28 Dec 2017 19:54:07 +0000 (UTC)

I've read the TLS presentation language and realize that the format resolves these issues.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1033#issuecomment-354348621

---

From: martinduke <[email-masked]>
Date: Thu, 28 Dec 2017 19:54:07 +0000 (UTC)

Closed #1033.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1033#event-1403933055