Subject: Re: [quicwg/base-drafts] One packet type in invariants (#963)

From: ianswett <[email-masked]>
Date: Fri, 01 Dec 2017 14:01:39 +0000 (UTC)

I'm a pretty big fan of this change on a high level.  In particular, it forces implementations to actually implement version specific parsing, and the removal of the packet number reinforces the idea that everything after the version is not an invariant.

I'll note: If we have a version, and then there's only one defined type byte value, but it's valid to grease the type byte for that version, we end up with the type byte being random :)  So I favor randomizing the type byte, but could live without it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/963#issuecomment-348501914

---

From: Christian Huitema <[email-masked]>
Date: Sat, 02 Dec 2017 20:22:07 +0000 (UTC)

OK, so I actually did an implementation of the version dependent header parsing. I agree that once this version dependent parsing is done, using version=0 to define renegotiation packets makes sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/963#issuecomment-348717465

---

From: Christian Huitema <[email-masked]>
Date: Sun, 03 Dec 2017 06:47:58 +0000 (UTC)

Some implementation experience. In the current state, greasing the version ID is a bit hard. The server will correctly handle a version ID that it does not understand, and will copy the incoming version ID into the version field of the negotiation packet's header. But the client that does the greasing has to make a wild guess -- it cannot really parse the type field, because this is version dependent, and it cannot really predict what kind of encoding the server used. Testing V==0 would be cleaner.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/963#issuecomment-348744490

---

From: janaiyengar <[email-masked]>
Date: Sun, 03 Dec 2017 13:50:27 -0800

@huitema: Thank you for trying out an implementation and for sharing what you learned, that is very helpful!

Based on the discussion here, and in the interest of moving forward, I will merge #968 tomorrow, which will close this issue. (As always, please re-open this issue if you think further discussion is needed.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/963#issuecomment-348817657

---

From: janaiyengar <[email-masked]>
Date: Mon, 04 Dec 2017 22:35:02 +0000 (UTC)

Closed #963 via #968.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/963#event-1371527752