Subject: [quicwg/base-drafts] Make figures comply with 65-character limit (#1031)

From: Mike Bishop <[email-masked]>
Date: Sun, 24 Dec 2017 20:07:04 +0000 (UTC)

In preparation for a hopefully-better linting approach, I found that the current linter is actually allowing slightly more characters than it says it is and we have a few longish figure lines.  No non-whitespace changes, but in recovery I did have to split two things across lines.  Ian, if you'd rather do intermediate calculations here, go for it.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1031

-- Commit Summary --

  * Make figures comply with 65-character limit

-- File Changes --

    M draft-ietf-quic-http.md (60)
    M draft-ietf-quic-recovery.md (116)
    M draft-ietf-quic-tls.md (12)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1031.patch
https://github.com/quicwg/base-drafts/pull/1031.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1031

---

From: Mike Bishop <[email-masked]>
Date: Sun, 24 Dec 2017 12:50:28 -0800

@MikeBishop pushed 1 commit.

359d24a  Figure bit numbers aligned

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1031/files/3aad6bc6aedf5a18186273427fc16734848285ee..359d24a20d177abf30184eddf783a56c3b327ab3

---

From: janaiyengar <[email-masked]>
Date: Mon, 25 Dec 2017 03:31:36 -0800

janaiyengar approved this pull request.

LGTM, with one suggestion

> +    // min_rtt ignores ack delay.
+    min_rtt = min(min_rtt, latest_rtt)
+    // Adjust for ack delay if it's plausible.
+    if (latest_rtt - min_rtt > ack_delay):
+      latest_rtt -= ack_delay
+      // Only save into max ack delay if it's used
+      // for rtt calculation and is not ack only.
+      if (!sent_packets[ack.largest_acked].ack_only)
+        max_ack_delay = max(max_ack_delay, ack_delay)
+    // Based on {{?RFC6298}}.
+    if (smoothed_rtt == 0):
+      smoothed_rtt = latest_rtt
+      rttvar = latest_rtt / 2
+    else:
+      rttvar = 3/4 * rttvar + 1/4 *
+        abs(smoothed_rtt - latest_rtt)

how about:
```
rttvar_sample = abs(smoothed_rtt - latest_rtt)
rttvar = 3/4 * rttvar + 1/4 * rttvar_sample
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1031#pullrequestreview-85481449

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Dec 2017 16:46:53 +0000 (UTC)

08428a1  Jana's suggested rewording

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1031/files/359d24a20d177abf30184eddf783a56c3b327ab3..08428a1725a4c30f0ec6ef1c26b631b867992ee1

---

From: ianswett <[email-masked]>
Date: Wed, 27 Dec 2017 07:31:28 -0800

ianswett approved this pull request.

Thanks for the cleanup Mike, Recovery LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1031#pullrequestreview-85689898