Subject: [quicwg/base-drafts] STREAM_ID_BLOCKED and distinguishing unidir/bidir (#979)

From: Lars Eggert <[email-masked]>
Date: Fri, 01 Dec 2017 07:59:04 -0800

Now that we have unidirectional streams, how is the receiver of a STREAM_ID_BLOCKED frame supposed to tell which stream type to send a MAX_STREAM_ID for? Or is there an assumption here that raising MAX_STREAM_ID applies to both unidir and bidir streams?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/979

---

From: ianswett <[email-masked]>
Date: Fri, 01 Dec 2017 16:23:46 +0000 (UTC)

A given stream ID refers to exactly one stream, which is either uni or bidi, not both.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/979#issuecomment-348539345

---

From: Lars Eggert <[email-masked]>
Date: Fri, 01 Dec 2017 16:56:05 +0000 (UTC)

Right, but since STREAM_ID_BLOCKED doesn't contain an ID, the receiver doesn't know which limit to raise. When you *receive* a MAX_STREAM_ID, you know for which type it is, but when you receive a STREAM_ID_BLOCKED,  you don't.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/979#issuecomment-348548302

---

From: Mike Bishop <[email-masked]>
Date: Fri, 01 Dec 2017 17:04:09 +0000 (UTC)

#927 / #928 already addresses this, albeit as an accidental by-product.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/979#issuecomment-348550422

---

From: Lars Eggert <[email-masked]>
Date: Fri, 01 Dec 2017 09:07:56 -0800

Closed #979.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/979#event-1368039436

---

From: Lars Eggert <[email-masked]>
Date: Fri, 01 Dec 2017 17:07:57 +0000 (UTC)

Perfect, thanks

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/979#issuecomment-348551475