Subject: [quicwg/base-drafts] Move back to draft 07 style type byte (#995)

From: ianswett <[email-masked]>
Date: Wed, 06 Dec 2017 14:25:59 +0000 (UTC)

Un-does most of the changes in PR #956, to give time for more discussion and avoid causing implementers potentially unnecessary work.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/995

-- Commit Summary --

  * Move back to draft 07 style type byte

-- File Changes --

    M draft-ietf-quic-transport.md (34)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/995.patch
https://github.com/quicwg/base-drafts/pull/995.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995

---

From: ekr <[email-masked]>
Date: Wed, 06 Dec 2017 14:58:38 +0000 (UTC)

@martinthomson @ianswett are you planning to issue a -09 with this change? Should we use that for ID3? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-349664491

---

From: ianswett <[email-masked]>
Date: Wed, 06 Dec 2017 07:00:19 -0800

@ekr If this lands, then I believe the answer is yes(along with complete change logs).  But that's subject to @martinthomson and @janaiyengar 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-349664997

---

From: janaiyengar <[email-masked]>
Date: Wed, 06 Dec 2017 07:47:10 -0800

janaiyengar approved this pull request.

Please wait for @martinthomson's response, but LGTM. (I'm happy to bring this change back in once we agree on list -- it's a small enough text change.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#pullrequestreview-81566269

---

From: janaiyengar <[email-masked]>
Date: Wed, 06 Dec 2017 07:49:50 -0800

@ekr: I'd like for @martinthomson to take a look at this PR, and if it lands, then we'll issue a draft-09.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-349680649

---

From: Mike Bishop <[email-masked]>
Date: Wed, 06 Dec 2017 19:00:38 +0000 (UTC)

MikeBishop approved this pull request.

I'm ambivalent here -- it does sound like the discussion isn't finished, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#pullrequestreview-81631165

---

From: Lars Eggert <[email-masked]>
Date: Wed, 06 Dec 2017 20:28:25 +0000 (UTC)

So I did implement the current -08 scheme already... :-(

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-349764623

---

From: Colin Perkins <[email-masked]>
Date: Thu, 07 Dec 2017 12:00:25 +0000 (UTC)

The discussion hasn't finished, but I thought there was consensus that some form of multiplexing was needed. This change looks like a step backwards.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-349947343

---

From: Marten Seemann <[email-masked]>
Date: Thu, 07 Dec 2017 12:39:23 +0000 (UTC)

I agree that it's better to first get this right, and then change all the implementations. There's no benefit from changing the same code over and over again.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-349955493

---

From: janaiyengar <[email-masked]>
Date: Thu, 07 Dec 2017 14:02:23 -0800

@csperkins There was no formal consensus, but that's not the bar for getting changes into the draft. That said, we're still discussing the form and what we want to mux with, so the discussion is clearly not necessarily going to yield this outcome. In the meanwhile, implementations are required to use these new types for interop, and will likely have to change it again when we figure out the "right" answer. Given this is not the agreed upon answer yet, what does this PR get you?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-350108087

---

From: Christian Huitema <[email-masked]>
Date: Fri, 08 Dec 2017 07:14:13 +0000 (UTC)

I have implemented the changes in Picoquic. Going back to the previous format would not help me one bit. Besides, the PR is *not* going back to the previous format -- it still does changes like merging server clear text and client clear text in a single code, removing the code point for renegotiation, and shifting all the other long header types by one. So it does not actually save much work for someone going from -07 to -08.

Useless, negative in fact.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-350190993

---

From: Christian Huitema <[email-masked]>
Date: Fri, 08 Dec 2017 07:17:14 +0000 (UTC)

huitema requested changes on this pull request.

Please don't do that. It will cause trouble for those implementers who already have draft 08 done, and will not actually save that much work for the other ones. Even with that change, the format of the long header will change, due to removal of renegotiation. So you don't win much...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#pullrequestreview-82080620

---

From: Marten Seemann <[email-masked]>
Date: Fri, 08 Dec 2017 07:24:49 +0000 (UTC)

@huitema: Client and Server Cleartext were merged into a single codepoint a long time before #956.

This PR is very helpful for people who have a deployment of gQUIC, since it's easy to demultiplex the old format with gQUIC, which is a big pain with #956. I don't know about the others maintaining a gQUIC deployments, but I don't see the point of going through the trouble to implement a new demultiplexing scheme for this change, just to change it again once we agree on yet another type byte format.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-350192754

---

From: Marten Seemann <[email-masked]>
Date: Fri, 08 Dec 2017 07:25:21 +0000 (UTC)

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#pullrequestreview-82081614

---

From: ianswett <[email-masked]>
Date: Fri, 08 Dec 2017 16:21:35 +0000 (UTC)

@huitema At this point, I think there are enough people who have implemented 08 that this should only be landed once we have a plan for greasing the type byte.

@marten-seemann Given we're not yet greasing, I think you can use the trick of looking at the nonce bit on the server side to differentiate GQUIC from IETF QUIC(No client to server packet ever has the nonce bit set to true in GQUIC).  We haven't done this yet in GQUIC, but I don't anticipate this will be a huge change?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-350305062

---

From: ianswett <[email-masked]>
Date: Fri, 08 Dec 2017 16:28:20 +0000 (UTC)

Slight tweak to my last comment.  Apparently @janaiyengar asked implementers their preference on the slack channel.  I'm happy to let implementers decide.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-350306873

---

From: janaiyengar <[email-masked]>
Date: Tue, 12 Dec 2017 01:11:51 +0000 (UTC)

Based on implementer input on the slack channel, the general sense seems to be that folks have implemented the changes this PR reverts, so we aren't going to merge this PR. Please note that there's active discussion on the question of packet types, which continues on #426. Please share further thoughts there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-350912122

---

From: Mike Bishop <[email-masked]>
Date: Mon, 18 Dec 2017 18:14:25 +0000 (UTC)

Given that we've agreed not to do this, I'm closing it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#issuecomment-352512604

---

From: Mike Bishop <[email-masked]>
Date: Mon, 18 Dec 2017 18:14:26 +0000 (UTC)

Closed #995.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/995#event-1392657510