Subject: Re: [quicwg/base-drafts] Renumber packet types and invert Connection ID Flag (#956)

From: Roni Even <[email-masked]>
Date: Wed, 06 Dec 2017 04:43:16 -0800

My understanding from the meeting was that there is no need to multiplex short header with stun so the change of the type values for the short header is a surprise and I did not see any discussion on the QUIC mailing list about this change. It is not mentioned also in the Singapore meeting notes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/956#issuecomment-349628497

---

From: Colin Perkins <[email-masked]>
Date: Wed, 06 Dec 2017 13:03:40 +0000 (UTC)

We certainly need to demux QUIC short header packets with STUN, to maintain bindings. 

Changing the packet type values doesn't prevent the spin bit, although it might change which bit is used as the spin bit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/956#issuecomment-349633315

---

From: Brian Trammell <[email-masked]>
Date: Wed, 06 Dec 2017 13:06:03 +0000 (UTC)

Note also that #989 would give us more degrees of freedom in the short header first octet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/956#issuecomment-349633864

---

From: ekr <[email-masked]>
Date: Wed, 06 Dec 2017 07:20:51 -0800

Colin is right here. You have to multiplex short headers with STUN b/c of consent checks, as well as candidates you learn about late

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/956#issuecomment-349671268

---

From: janaiyengar <[email-masked]>
Date: Wed, 06 Dec 2017 15:21:51 +0000 (UTC)

Can we please continue this discussion on #426?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/956#issuecomment-349671583