Subject: [quicwg/base-drafts] Requirement of PMTU > 1280 (#1014)

From: janaiyengar <[email-masked]>
Date: Wed, 13 Dec 2017 07:18:24 +0000 (UTC)

The draft currently requires that QUIC require a network path supporting a MTU of at least 1280 octets. Specifically, "An endpoint MUST NOT reduce its MTU below this number, even if it receives signals that indicate a smaller limit might exist."

This text needs justification or needs to be removed. (I can't recall why this was added in.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1014

---

From: Patrick McManus <[email-masked]>
Date: Wed, 13 Dec 2017 15:27:10 +0000 (UTC)

by justification I don't know if you just mean "a good reason" or "text describing the good reason". I think only the former is required in most cases.

anyhow - I recall a few reasons
1] we intentionally restrict ourselves to v6 capable networks as a reasonable cost of 2017 internet admission
2] mtu across the internet is therefore practically 1280-1500 for many cases
3] pmtud is hard and error prone. If you'd like to opt-out of that trouble, 1280 gets you most of the way to pmtu in practice... while 576 doesn't have that property.
4] Having a substantial minimum made the padded-initial possible and easy

I don't recall it being any deeper than that..  but it seems better than no minimum

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1014#issuecomment-351424624

---

From: MikkelFJ <[email-masked]>
Date: Wed, 13 Dec 2017 09:11:15 -0800

Some may read the text as if packets can never be smaller than 1280, which is not the case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1014#issuecomment-351457938