Subject: Re: [quicwg/base-drafts] Add a MESSAGE frame optimized for sub-MTU payloads (#814)

From: Igor Lubashev <[email-masked]>
Date: Tue, 19 Dec 2017 20:38:07 -0800

> Immediately passed up to the application, so no QUIC transport flow control is necessary.

So MESSAGE frames are congestion controlled but not flow controlled?  That means a receiver that is slower than the sender and the network will be dropping MESSAGEs, and that's ok?  It looks similar to UDP, of course, but it may be an opportunity to devise some feedback to let the sender make an intelligent decision about not causing "buffer bloat" on the receiver and wasting bandwidth on MESSAGEs that will likely be dropped.

Note: since MESSAGE frames can share a packet with STREAM frames, the packets have to be ACKed by the receiver, even if MESSAGEs end up being dropped.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/814#issuecomment-352962869

---

From: Lars Eggert <[email-masked]>
Date: Wed, 20 Dec 2017 08:34:08 +0000 (UTC)

Is this something required for QUICv1? If not, I would propose shelving it for now.

(This is not a statement about the quality of the proposal.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/814#issuecomment-352998642

---

From: ianswett <[email-masked]>
Date: Wed, 20 Dec 2017 06:06:31 -0800

In my opinion, no partial reliability proposals are a requirement for v1, since one can do partial reliability today, it's just suboptimal in some ways.

Note this is already tagged quicv2 :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/814#issuecomment-353071737