Subject: [quicwg/base-drafts] Parsing Ack Delay without ack_delay_exponent (#1007)

From: Patrick McManus <[email-masked]>
Date: Fri, 08 Dec 2017 18:20:41 -0800

>Once the TLS handshake is complete, this is indicated to QUIC along with any final handshake octets that TLS needs to send. TLS also provides QUIC with the transport parameters that the peer advertised during the handshake.

Unfortunately Handshake (and Retry) packets can contain ACK frames and be delivered before the transport parameters are provided to QUIC. The ack delay field of the ACK frame cannot be interpreted without the ack_delay_exponent from the transport parameters. This brings back memories of flow control and stream 0.

There are several ways to resolve this, but I'll suggest that non protected packets that contain ACK frames are always encoded with the default ack_delay_exponent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1007

---

From: ianswett <[email-masked]>
Date: Sun, 10 Dec 2017 16:53:33 +0000 (UTC)

Agreed, and I might expand that to include 0RTT packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1007#issuecomment-350561805

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Dec 2017 13:12:58 -0800

Cleartext, yes, defaults.

The problem with 0-RTT is that it uses transport parameters from the ticket or previous session.  We might want to consistently apply transport parameters, rather than mix and match.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1007#issuecomment-350581998

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Dec 2017 11:25:26 -0800

Closed #1007 via #1009.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1007#event-1382135959