Subject: [quicwg/base-drafts] Do you need to supply max_early_data in NST to enable 0-RTT (#942)

From: ekr <[email-masked]>
Date: Fri, 17 Nov 2017 01:42:39 +0000 (UTC)

In TLS 1.3, servers have to opt-in to early data by sending "max_early_data". We need to clarify whether this is required in QUIC. I believe @martinthomson 's view is "no" but we need to decide one way or the other.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/942

---

From: Martin Thomson <[email-masked]>
Date: Fri, 17 Nov 2017 02:15:30 +0000 (UTC)

We should be clear about this, but the intent is to use the connection-level flow control window advertised in the transport parameters that are attached to the session ticket.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/942#issuecomment-345125022

---

From: Martin Thomson <[email-masked]>
Date: Fri, 17 Nov 2017 02:16:25 +0000 (UTC)

Oh, we also agreed that max_early_data was needed to signal that the server is willing to accept 0-RTT.  We probably need to say that too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/942#issuecomment-345125175

---

From: ekr <[email-masked]>
Date: Fri, 17 Nov 2017 02:18:27 +0000 (UTC)

So you would say max_early_data = what?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/942#issuecomment-345125511

---

From: Martin Thomson <[email-masked]>
Date: Fri, 17 Nov 2017 02:20:26 +0000 (UTC)

Anything non-zero would work.  Maybe 1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/942#issuecomment-345125813

---

From: ekr <[email-masked]>
Date: Fri, 17 Nov 2017 02:25:26 +0000 (UTC)

I would suggest 2^{32}-1, because that signals  "TLS is OK with anything"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/942#issuecomment-345126531

---

From: Martin Thomson <[email-masked]>
Date: Fri, 17 Nov 2017 02:50:42 +0000 (UTC)

WFM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/942#issuecomment-345130234