Subject: [quicwg/base-drafts] Specify new error type, "closed by peer"? (#973)

From: Christian Huitema <[email-masked]>
Date: Thu, 30 Nov 2017 00:13:13 +0000 (UTC)

The updated text in Section 7.9.3, "Immediate Close" states that: "_After receiving a closing frame, endpoints enter a draining period. An endpoint that receives a closing frame MAY send a single packet containing a CONNECTION_CLOSE frame before entering a draining period, but MUST NOT send further packets, which could result in a constant exchange of closing frames until the closing period on either peer ended_."

That's fine, but what error type should the peer use? No error? Should we specify a "closed by peer" error type?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/973

---

From: Mike Bishop <[email-masked]>
Date: Thu, 30 Nov 2017 00:16:48 +0000 (UTC)

I think we'd discussed using NO_ERROR for this.  0x0 is analogous to STOPPING, used on a stream in response to a STOP_SENDING.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/973#issuecomment-348040721

---

From: janaiyengar <[email-masked]>
Date: Thu, 30 Nov 2017 21:25:24 -0800

Closed #973 via #974.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/973#event-1367040827