Subject: Re: [quicwg/base-drafts] SetLossDetectionAlarm issue with TLP (#537)

From: ianswett <[email-masked]>
Date: Mon, 13 Nov 2017 06:47:06 +0000 (UTC)

The early return ensures we don't set an alarm if there's no retransmittable data in flight.

If we get to the TLP section, retransmittable_packets_outstanding is 1 or larger.  So the else is for the >1 case.  I did just add a comment to that effect and use retransmittable_packets_outstanding in the first condition for consistency.

Does that make sense?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/537#issuecomment-343828629

---

From: ianswett <[email-masked]>
Date: Mon, 13 Nov 2017 06:47:46 +0000 (UTC)

Oh, I see your confusion.  retransmittable_packets_outstanding is an int, not a bool.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/537#issuecomment-343828733

---

From: ianswett <[email-masked]>
Date: Mon, 13 Nov 2017 06:49:04 +0000 (UTC)

I just renamed it to num_retransmittable_packets_outstanding, which I think should fix your confusion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/537#issuecomment-343828937

---

From: ianswett <[email-masked]>
Date: Mon, 13 Nov 2017 06:49:05 +0000 (UTC)

Closed #537.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/537#event-1338082604