Subject: Re: [quicwg/base-drafts] We have two things called "frame" (#128)

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Nov 2017 02:58:32 +0000 (UTC)

The above solution has proven to be sufficient for now.  Though if anyone wants to make a case for QUIC vesicles, feel free to reopen.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-344130984

---

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Nov 2017 02:58:34 +0000 (UTC)

Closed #128.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#event-1340030440

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 14 Nov 2017 06:58:08 +0000 (UTC)

As someone that has written an I-D that needs to reference both QUIC Transport and HTTP documents, I have struggled with ensuring the correct frame-type is being used.

I have so far used the convention <x> <[ QUIC | HTTP/2 ]> frame. Changing the order is not problematic. I think there would be benefit in defining a consistent style, this can help both readers and writers of specifications.

 Furthermore, I recently took the position that HTTP/2 is the wrong term when talking about HTTP/QUIC frames. I will address this, should I call them HTTP/QUIC or would the abbreviation HQ frame also be ok?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-344163868

---

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Nov 2017 14:54:17 +0000 (UTC)

Reopened #128.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#event-1341022433

---

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Nov 2017 14:54:17 +0000 (UTC)

I agree with you on that position, and one of my first editorial changes to the draft was to excise all occurrences of the term "HTTP/2 over QUIC."  HTTP/2 and HTTP/QUIC are not the same protocol.  Just as h2 is the ALPN token and a convenient shorthand for HTTP/2, hq (or HQ) is a perfectly reasonable shorthand for HTTP/QUIC.  I tend to write it out in anything official, mostly to avoid anyone thinking I'm talking about headquarters.

I'm fine adding protocol frame naming to our notational conventions.  Reopening to track that suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-344283458

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 15 Nov 2017 05:47:38 +0000 (UTC)

SGTM, thanks Mike.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-344492563

---

From: Mike Bishop <[email-masked]>
Date: Tue, 28 Nov 2017 23:50:33 +0000 (UTC)

Closed #128 via #937.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#event-1362527529