Subject: Re: [quicwg/base-drafts] Move padding to the crypto layer (#197)

From: ianswett <[email-masked]>
Date: Sat, 11 Nov 2017 22:00:21 +0000 (UTC)

At some point, we changed padding to be a single byte to allow for padding to be placed between frames at the request of @larseggert  This seems like a useful feature and we'd remove that if we got rid of padding entirely, so I don't think QUIC padding is going away.

Given that, this issue becomes 'sometimes move padding to the crypto layer', which is going to make congestion control and bytes in flight counting potentially more complex, since sometimes we'll do padding in one place and sometimes the other.  

This is orthogonal to #837, since we need to decide how we want QUIC to work with padding.  Where to put the padding doesn't change that.  If we want padding that counts towards bytes in flight and one that doesn't, we can use PADDING and PING for the two different cases(or other approaches).

Given the above, @ekr is there a reason to keep this open?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/197#issuecomment-343697029

---

From: ekr <[email-masked]>
Date: Sun, 12 Nov 2017 02:29:13 +0000 (UTC)

I can live with closing this.

On Sat, Nov 11, 2017 at 2:00 PM, ianswett <[email-masked]> wrote:

> At some point, we changed padding to be a single byte to allow for padding
> to be placed between frames at the request of @larseggert
> <https://github.com/larseggert> This seems like a useful feature and we'd
> remove that if we got rid of padding entirely, so I don't think QUIC
> padding is going away.
>
> Given that, this issue becomes 'sometimes move padding to the crypto
> layer', which is going to make congestion control and bytes in flight
> counting potentially more complex, since sometimes we'll do padding in one
> place and sometimes the other.
>
> This is orthogonal to #837
> <https://github.com/quicwg/base-drafts/issues/837>, since we need to
> decide how we want QUIC to work with padding. Where to put the padding
> doesn't change that. If we want padding that counts towards bytes in flight
> and one that doesn't, we can use PADDING and PING for the two different
> cases(or other approaches).
>
> Given the above, @ekr <https://github.com/ekr> is there a reason to keep
> this open?
>
> —
> You are receiving this because you were mentioned.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/197#issuecomment-343697029>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oVbmpisB83_gkhrqJl6aWKnM0OBeks5s1hjzgaJpZM4LqqX1>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/197#issuecomment-343709000

---

From: ianswett <[email-masked]>
Date: Sun, 12 Nov 2017 02:30:36 +0000 (UTC)

Closed #197.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/197#event-1337439759