Subject: [quicwg/base-drafts] Remove remnants of the limit on ACK blocks (#966)

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Nov 2017 10:36:37 +0000 (UTC)

Closes #906
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/966

-- Commit Summary --

  * Remove remnants of the limit on ACK blocks

-- File Changes --

    M draft-ietf-quic-recovery.md (8)
    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/966.patch
https://github.com/quicwg/base-drafts/pull/966.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/966

---

From: ianswett <[email-masked]>
Date: Wed, 29 Nov 2017 13:36:20 +0000 (UTC)

ianswett approved this pull request.

Looks good, but one suggested improvement to the existing wording while you're there.

> @@ -130,7 +130,7 @@ important to the loss detection and congestion control machinery below.
   machinery of QUIC underneath.
 
 * ACK frames contain acknowledgment information.  QUIC uses a SACK-based

Now that I read this, I don't think we want to use the word SACK here, since that has some baggage from TCP.  How about "ACK frames contain one or more ranges of acknowledged packets."?

> @@ -238,7 +238,7 @@ retransmission ambiguity problem.  QUIC acknowledgments also explicitly encode
 the delay between the receipt of a packet and its acknowledgment being sent, and
 together with the monotonically-increasing packet numbers, this allows for
 precise network roundtrip-time (RTT) calculation.  QUIC's ACK frames support up

remove "up"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/966#pullrequestreview-79841105

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Nov 2017 20:56:02 +0000 (UTC)

@martinthomson pushed 1 commit.

b4fc67a  Tweakin'

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/966/files/acd1d83dc42d36c495a34ebc69369fe2edeb2419..b4fc67ab539760330ab38bd2f09fed03437e6f97

---

From: janaiyengar <[email-masked]>
Date: Wed, 29 Nov 2017 15:31:29 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/966#pullrequestreview-80034297

---

From: janaiyengar <[email-masked]>
Date: Wed, 29 Nov 2017 15:31:47 -0800

Merged #966.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/966#event-1364639596