Subject: Re: [quicwg/base-drafts] Remove initial packet number randomization (#850)

From: Marten Seemann <[email-masked]>
Date: Sat, 11 Nov 2017 12:19:58 +0000 (UTC)

After some discussion at the Singapore Hackathon: The reason why #693 solves this, is because the client-chosen connection ID is used for the AEAD. This also applies in the case where the server directly replies with a Cleartext and uses a server-chosen connection ID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/850#issuecomment-343660908

---

From: janaiyengar <[email-masked]>
Date: Thu, 16 Nov 2017 06:17:35 +0000 (UTC)

On whether initial packet number should be 0 or 1, with the new packet number encoding, we end up needing only 62 bis for the packet number, which means you can use a signed int for representing it and < 0 as a sentinel value. I'll be ok with either 0 or 1 as the initial value. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/850#issuecomment-344826979

---

From: ianswett <[email-masked]>
Date: Thu, 16 Nov 2017 06:24:58 +0000 (UTC)

Q on this.  Should we allow using other initial packet numbers to make sure middleboxes don't assume all handshake packets are <20 or some magic number?

Admittedly, the type byte is a lot more useful than packet number to identify handshake packets, but it's worth considering.

Besides that, I'm greatly in favor of this and would like it to land ASAP.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/850#issuecomment-344828156