Subject: [quicwg/base-drafts] Disparity between initial_max_stream_id and MAX_STREAM_ID (#951)

From: Lucas Pardue <[email-masked]>
Date: Tue, 21 Nov 2017 15:49:39 +0000 (UTC)

First off, I don't know if this is really an issue. 

With the introduction of varint and unidirectional streams, there seems to be a disparity between the initial_max_stream_id TransportParameter

> The initial maximum stream ID parameter contains the initial maximum stream number the peer may initiate, encoded as an unsigned 32-bit integer. 

and MAX_STREAM_ID

>ID of the maximum unidirectional or bidirectional peer-initiated stream ID for the connection encoded as a variable-length integer. The limit applies to unidirectional steams if the second least signification bit of the stream ID is 1, and applies to bidirectional streams if it is 0.

Which one is "better"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/951

---

From: Mike Bishop <[email-masked]>
Date: Tue, 21 Nov 2017 22:20:32 +0000 (UTC)

Closed #951.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/951#event-1352979483

---

From: Mike Bishop <[email-masked]>
Date: Tue, 21 Nov 2017 22:20:32 +0000 (UTC)

Duplicate of #909.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/951#issuecomment-346180102