Subject: [quicwg/base-drafts] Early retransmit and time reordering time calculation (#945)

From: Subodh Iyengar <[email-masked]>
Date: Sat, 18 Nov 2017 01:18:48 +0000 (UTC)

delay_until_lost is currently described as 

> 9/8 * max(latest_rtt, smoothed_rtt) for early retransmit

however in the text it mentions that we should wait 1/4 of an rtt for early retransmit.

So it seems like the calculation should really be

`delay_until_lost = 1/4 * max(latest_rtt, smoothed_rtt)`

since effectively

> loss_time = unacked.time_sent + delay_until_lost

Similarly time loss detection should also be adjusted to not be 

> (1 + time_reordering_fraction) *  max(latest_rtt, smoothed_rtt)

but 

` time_reordering_fraction * max(latest_rtt, smoothed_rtt)`

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/945

---

From: Subodh Iyengar <[email-masked]>
Date: Sat, 18 Nov 2017 01:44:57 +0000 (UTC)

actually nvm, it looks like the purpose here is to wait at least 1rtt since the packet is transmitted and then a little bit more.

In any case the 2 text and the code should be kept in sync and it should be 1.25 * srtt for the loss_time

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/945#issuecomment-345408840