Subject: [quicwg/base-drafts] include debug infos in BLOCKED, STREAM_BLOCKED and STREAM_ID_BLOCKED (#928)

From: Marten Seemann <[email-masked]>
Date: Tue, 14 Nov 2017 04:46:52 +0000 (UTC)

Fixes #927.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/928

-- Commit Summary --

  * include debug infos in BLOCKED, STREAM_BLOCKED and STREAM_ID_BLOCKED

-- File Changes --

    M draft-ietf-quic-transport.md (41)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/928.patch
https://github.com/quicwg/base-drafts/pull/928.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/928

---

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Nov 2017 05:25:16 +0000 (UTC)

MikeBishop commented on this pull request.

> @@ -2123,7 +2123,21 @@ unable to due to connection-level flow control (see {{blocking}}). BLOCKED
 frames can be used as input to tuning of flow control algorithms (see
 {{fc-credit}}).
 
-The BLOCKED frame does not contain a payload.
+The BLOCKED frame is as follows:
+
+~~~
+ 0                   1                   2                   3
+ 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
++-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
+|                         Offset (i)                         ...
++-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
+

You need another `~~~` here to end the figure.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/928#pullrequestreview-76333703

---

From: Marten Seemann <[email-masked]>
Date: Tue, 14 Nov 2017 05:33:20 +0000 (UTC)

marten-seemann commented on this pull request.

Fixed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/928#discussion_r150741069

---

From: ianswett <[email-masked]>
Date: Tue, 14 Nov 2017 06:31:11 +0000 (UTC)

ianswett commented on this pull request.

Two comments on formatting, but I think this looks good.

 Stream ID:
 
 : A variable-length integer indicating the stream which is flow control blocked.
 
+Offset:
+
+: A variable-length integer indicating the current offset of data sent on the
+stream.

nit: I think you need to align 'stream' with 'A' for correct formatting?

+: A variable-length integer indicating the stream ID of highest stream that
+could be openend.

same nit on getting the right formatting

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/928#pullrequestreview-76338034

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Nov 2017 07:19:34 +0000 (UTC)

martinthomson requested changes on this pull request.

+The BLOCKED frame contains a single field.

current is ambiguous.  I presume that the intent is to signal the offset at which the blocking occurred.

 Stream ID:

+Offset:
+

Same point here about "current"

Typo on opened.

I think that we need to be really crisp about this.  Is this the value of MAX_STREAM_ID?  The alternative would be to signal the stream ID of the stream you wanted to create (which would be bad).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/928#pullrequestreview-76347727

---

From: Marten Seemann <[email-masked]>
Date: Tue, 14 Nov 2017 08:17:46 +0000 (UTC)

No, that wasn't my intention. It should be the same value as sent in the MAX_STREAM_ID frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/928#discussion_r150762005

---

From: Marten Seemann <[email-masked]>
Date: Tue, 14 Nov 2017 09:40:52 +0000 (UTC)

I pushed the fixes. Please have another look.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/928#issuecomment-344200342