Subject: Re: [quicwg/base-drafts] ALTSVC Frame (#371)

From: Lucas Pardue <[email-masked]>
Date: Wed, 08 Nov 2017 15:45:08 +0000 (UTC)

ALTSVC frame support came up in a recent conversation and it took me a bit of time to remember that this issue (and the @MikeBishop draft) existed. 

Would it make sense to adopt the document as part of the QUIC WG activity? Or perhaps incorporate the text into draft-ietf-quic-http.

I fear there may be some intellectual interop problems when talking about ALTSVC. For example with draft-ietf-quic-http we describe how ALTSVC can be used to discover HTTP/QUIC but only really for H2 connections prior to HTTP/QUIC, you can't use ALTSVC frames inside a HTTP/QUIC connection unless you're aware that the QUIC extension frame exists. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/371#issuecomment-342857822

---

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Nov 2017 04:15:17 +0000 (UTC)

I'm inclined to say this is still the job of httpbis.  However, I understand that one of our beloved chairs (@mnot) sees one of the httpbis chairs pretty frequently, and might be able to convince him to move this along if we need it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/371#issuecomment-344141420