Subject: [quicwg/base-drafts] Include blocking state in BLOCKED / STREAM_BLOCKED / STREAM_ID_BLOCKED (#927)

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Nov 2017 04:04:28 +0000 (UTC)

This has been suggested a couple times, most recently by @marten-seemann in #924:  If the flow control debug frames included the value of the block the sender is hitting, it simplifies a couple things:

  - The receiver can know whether they've unblocked the sender already
  - Differences between the two sides' view of the connection window can be identified
  - Retransmission logic might be easier, since it becomes easier to identify whether the state has changed

Splitting this off to unblock the other PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/927

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Nov 2017 07:23:54 +0000 (UTC)

This duplicates #452, which @MikeBishop shouldn't have closed with #924.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/927#issuecomment-344168465