Subject: Re: [quicwg/base-drafts] Allow handshake errors to be reported with CONNECTION_CLOSE (#891)

From: Christian Huitema <[email-masked]>
Date: Sat, 04 Nov 2017 23:09:38 +0000 (UTC)

huitema commented on this pull request.

> @@ -1287,6 +1287,13 @@ Similarly, there is no need to increase the number of allowed streams until the
 handshake completes.

+### Handshake Failures
+
+The `CONNECTION_CLOSE` frame MAY be sent by either endpoint during the handshake
+to signal a fatal error with connection establishment.  A `STREAM` frame
+carrying a TLS alert MAY be included in the same packet.
+

Maybe we should add a note in the next section, "Denial of Service with Unprotected Packets". Sending "connection close" frames in Server Clear Text or Client Clear Text packets would be another way to deny connection. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/891#pullrequestreview-74268182

---

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Nov 2017 23:52:44 +0000 (UTC)

@martinthomson pushed 1 commit.

bd75555  CONNECTION_CLOSE can be sent in Handshake packets

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/891/files/307070e2244d5e3fdb35f28f3f3229f55a554a8a..bd75555956d1518fd617ffc1a74654c3af81df13

---

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Nov 2017 23:55:40 +0000 (UTC)

martinthomson commented on this pull request.

 handshake completes.

+### Handshake Failures
+

I'll do that separately: see https://github.com/quicwg/base-drafts/pull/908/files

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/891#discussion_r149832713

---

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Nov 2017 23:55:55 +0000 (UTC)

@seanturner, PTAL

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/891#issuecomment-343001611

---

From: Mike Bishop <[email-masked]>
Date: Sat, 11 Nov 2017 08:31:48 +0000 (UTC)

Why is this in the TLS draft?  If we're allowing CONNECTION_CLOSE in Handshake packets, shouldn't that be in the Transport doc?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/891#issuecomment-343649477

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 Nov 2017 04:12:35 +0000 (UTC)

The TLS doc contains all the packet protection stuff, which includes rules about what can be sent and when.  The plan is to move this text to -transport eventually.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/891#issuecomment-345587128

---

From: ianswett <[email-masked]>
Date: Tue, 28 Nov 2017 20:00:14 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/891#pullrequestreview-79637612

---

From: Martin Thomson <[email-masked]>
Date: Tue, 28 Nov 2017 21:07:24 +0000 (UTC)

Merged #891.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/891#event-1362278299