Subject: [quicwg/base-drafts] Early retransmit code (#934)

From: Subodh Iyengar <[email-masked]>
Date: Wed, 15 Nov 2017 19:58:48 +0000 (UTC)

If we're in the early retransmit mode, a loss_time is set. If the timer is not yet fired, however we send a packet when the timer is armed, the largest_sent_packet changes. When the timer does fire before this new packet is acked, largest_sent_packet != largest_acked_packet, so delay_until_lost == infinite and none of the packets will be declared lost, however we would instead set a TLP alarm. 

Is this intentional? Seems a bit weird.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/934

---

From: Martin Thomson <[email-masked]>
Date: Thu, 16 Nov 2017 03:14:08 +0000 (UTC)

Note: Questions are better asked on the mailing list.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/934#issuecomment-344802690

---

From: Subodh Iyengar <[email-masked]>
Date: Thu, 16 Nov 2017 07:27:34 +0000 (UTC)

Ya it was a bit fuzzy on whether this was a bug in the draft, so I raised this as an issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/934#issuecomment-344838448