Subject: [quicwg/base-drafts] QUIC ack frames now store more than 255 ack ranges (#906)

From: ianswett <[email-masked]>
Date: Wed, 08 Nov 2017 02:09:03 +0000 (UTC)

The existing text in the transport and recovery draft indicates QUIC ack frames can ack up to 255 ranges.  Now that we're using variable length integers, we can ack more than that.  

I'm not sure if that's a good thing or a bad thing, but at the least, we should update the text to be self-consistent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/906

---

From: Ryan Hamilton <[email-masked]>
Date: Thu, 09 Nov 2017 20:27:33 +0000 (UTC)

More than 255 ACK ranges in a packet seems excessive to me. (Honestly 16 is probably fine). I'd be inclined to revert this field back to single byte and limit the number of ranges to 255. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/906#issuecomment-343281093

---

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Nov 2017 21:15:02 +0000 (UTC)

There is value in uniformity.  No one has to *use* that many ranges (noting that 255 would be enough to overflow a packet anyway if abuse was the goal).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/906#issuecomment-343293709

---

From: ianswett <[email-masked]>
Date: Thu, 09 Nov 2017 21:49:46 +0000 (UTC)

Just because we use varints, doesn't mean we always have to, particularly for things which are only a byte.  Reading a byte is really not that difficult, so I think the uniformity value is minimal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/906#issuecomment-343302737

---

From: ianswett <[email-masked]>
Date: Sat, 11 Nov 2017 07:21:33 +0000 (UTC)

Well, let's stick with this for now, but fix the text before 08 to make it consistent?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/906#issuecomment-343646539

---

From: janaiyengar <[email-masked]>
Date: Wed, 29 Nov 2017 15:31:47 -0800

Closed #906 via #966.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/906#event-1364639598