Subject: [quicwg/base-drafts] Make initial_max_stream_id_x optional (#970)

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Nov 2017 21:09:49 +0000 (UTC)

Out of discussion in #958, making initial_max_stream_id_x optional would allow for setting a value of zero.  The current definition requires a valid stream ID, which prevents the minimum being set so that no streams are permitted.  Having no streams as a default might seem crazy, but it is most efficient.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/970

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Nov 2017 21:14:07 +0000 (UTC)

Also, it's not especially crazy to omit the values, because MAX_STREAM_ID can be sent after the handshake is complete.  It is crazy to omit the values for 0-RTT though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/970#issuecomment-347998160

---

From: janaiyengar <[email-masked]>
Date: Wed, 29 Nov 2017 16:25:46 -0800

I prefer to have explicit intent with max_stream_id of 0 in transport params, but this works too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/970#issuecomment-348042219

---

From: Martin Thomson <[email-masked]>
Date: Thu, 30 Nov 2017 01:01:17 +0000 (UTC)

Closed #970 via #971.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/970#event-1364735255