Subject: [quicwg/base-drafts] initial_max_stream_id and, uni and bidi streams (#909)

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Sat, 11 Nov 2017 01:03:38 +0000 (UTC)

Now we have separate uni and bidirectional stream ID spaces, but initial_max_stream_id in transport parameter does not say it applies to 1) both, or 2) uni only, or 3) bidi only.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909

---

From: Mike Bishop <[email-masked]>
Date: Sat, 11 Nov 2017 05:32:17 +0000 (UTC)

Yeah, we'll need two of those, I suppose.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-343642380

---

From: Marten Seemann <[email-masked]>
Date: Sat, 11 Nov 2017 05:37:04 +0000 (UTC)

That will be really useful. An implementation that doesn't want to do uni-directional streams can just send 0 for the uni max stream ID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-343642534

---

From: ianswett <[email-masked]>
Date: Sat, 11 Nov 2017 05:39:30 +0000 (UTC)

The max_stream_id was intended to apply to the type of stream it is(uni or bidi).  It's necessary to have separate max stream ids for uni and bidi because otherwise you could easily end up in a situation where you have thousands of potentially usable stream ids of one type and a small number of the other.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-343642628

---

From: Mike Bishop <[email-masked]>
Date: Sat, 11 Nov 2017 09:56:15 +0000 (UTC)

Are you suggesting that the max_stream_id transport parameter just occur twice?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-343653511

---

From: ianswett <[email-masked]>
Date: Sat, 11 Nov 2017 13:27:11 +0000 (UTC)

I missed that this was the initial max_stream_id in transport params.  So disregard my previous statement.

I guess it appearing twice makes the most sense then?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-343664698

---

From: Mike Bishop <[email-masked]>
Date: Sat, 11 Nov 2017 20:26:37 +0000 (UTC)

> An endpoint MUST treat receipt of duplicate transport parameters as a connection error of type TRANSPORT_PARAMETER_ERROR.

So do we want to delete this prohibition (and replace it with rules about how other duplicates are processed, special-case this parameter as exempt from the prohibition, or have two instances of the parameter? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-343691835

---

From: ianswett <[email-masked]>
Date: Sat, 11 Nov 2017 21:17:59 +0000 (UTC)

Special cases are bad, so I'd rather not do that.  We could allow a transport param be a list of stream ids?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-343694825

---

From: Marten Seemann <[email-masked]>
Date: Sun, 12 Nov 2017 00:13:46 +0000 (UTC)

Why not create a new transport parameter? Seems the cleanest solution to me. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-343703990

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Thu, 23 Nov 2017 05:31:11 +0000 (UTC)

I'm fine to either listing 2 values, or introducing new transport parameter.
In my personal opinion, I'm lean to new transport parameter.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#issuecomment-346534724

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Nov 2017 00:43:09 +0000 (UTC)

Closed #909 via #958.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/909#event-1362585901