Subject: Re: [quicwg/base-drafts] IP Anycast with server IP+Port renegotiation (#560)

From: Lucas Pardue <[email-masked]>
Date: Mon, 20 Nov 2017 15:33:58 +0000 (UTC)

This ticket seems relevant to the connection migration topic discussed in Singapore. I'm not sure if it came up during the actual session but may provide another example usage beyond NAT rebinding and mult-interface single path.

It may be beyond the scope of "minimal connection migration" and be a candidate for a v2 label?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-345731436

---

From: Igor Lubashev <[email-masked]>
Date: Mon, 20 Nov 2017 20:15:22 +0000 (UTC)

Just to add another related use case -- migrating to another IP immediately after receiving Client Initial, ie before the completion of the handshake.

That can be used for migration off anycast to unicast of the same sever. It can also be used for migration to a better server based on client's IP and SNI of the connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-345817619