Subject: Re: [quicwg/base-drafts] Add some suggestions for RFC 4821 probe packets. (#849)

From: Martin Thomson <[email-masked]>
Date: Mon, 06 Nov 2017 08:59:22 +0000 (UTC)

I need to confirm that PADDING frames generate acknowledgments.  I think that they do, but the text needs to be clearer.  This is the best I could find:

> A receiver that is only sending ACK frames will not receive acknowledgments for its packets. Sending an occasional MAX_DATA or MAX_STREAM_DATA frame as data is received will ensure that acknowledgements are generated by a peer. Otherwise, an endpoint MAY send a PING frame once per RTT to solicit an acknowledgment.

Is it possible to rephrase this so that it mentions frame types that we know generate acknowledgments (like PING)?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/849#issuecomment-342084969

---

From: ianswett <[email-masked]>
Date: Wed, 08 Nov 2017 02:32:54 +0000 (UTC)

@martinthomson The current text intends to say ALL frames generate acknowledgements except ACK frames.  Hence only packets that only contain ACK_FRAMEs do not generate acknowledgements.  

I'd rather no call out every frame that is expected to cause an ACK_FRAME to be sent, since it's all minus 1.

I need to clarify this and other text after discussion in Seattle, so I sent out PR #907

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/849#issuecomment-342690911

---

From: martinduke <[email-masked]>
Date: Wed, 08 Nov 2017 23:52:35 +0000 (UTC)

@martinduke pushed 1 commit.

766b2da  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/849/files/54c56d6dd4466443116a0bed94b0dd8dfd0952c8..766b2da03d35a34ccbc3fc8c0ceb98f48982913c