Subject: [quicwg/base-drafts] Handshake packets should be retransmitted based on the last sent handshake packet (#962)

From: ianswett <[email-masked]>
Date: Tue, 28 Nov 2017 14:24:18 +0000 (UTC)

Instead of using time_of_last_sent_packet, handshake packets should use time_of_last_sent_handshake_packet(to be defined), because if the handshake hasn't completed, protected packets will not be acknowledged, because they cannot be decrypted and processed.  The only other valid frames to send pre-handshake are acks and connection close.  Acks do not cause an acknowledgement and connection closes are terminal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/962

---

From: Subodh Iyengar <[email-masked]>
Date: Wed, 29 Nov 2017 17:45:30 -0800

+1, this is a follow up to my comment in your PR?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/962#issuecomment-348056206