Subject: Re: [quicwg/base-drafts] Handshake errors (#608)

From: Martin Thomson <[email-masked]>
Date: Tue, 28 Nov 2017 21:07:24 +0000 (UTC)

Closed #608 via #891.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#event-1362278300

---

From: Subodh Iyengar <[email-masked]>
Date: Wed, 29 Nov 2017 06:16:29 +0000 (UTC)

When implementing this, I'm sending CONNECTION_CLOSE in a plaintext packet if the TLS handshake has not finished yet. I ran into a case where the cert validation failed, however I wasn't really able to indicate this with a reasonable error code. Should we have an error code for TLS_ERROR or HANDSHAKE_ERROR

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-347764022

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Nov 2017 09:45:12 +0000 (UTC)

Like TLS_HANDSHAKE_FAILED (0x201)?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-347806437

---

From: janaiyengar <[email-masked]>
Date: Wed, 29 Nov 2017 23:02:53 +0000 (UTC)

HANDSHAKE_ERROR sounds like the right error code to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-348026231

---

From: janaiyengar <[email-masked]>
Date: Wed, 29 Nov 2017 15:04:43 -0800

Ah, didn't see Martin's message (stale tab) -- yes, TLS_HANDSHAKE_FAILED (defined in draft-ietf-quic-tls) sounds right.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-348026656

---

From: Subodh Iyengar <[email-masked]>
Date: Thu, 30 Nov 2017 21:57:41 +0000 (UTC)

ah completely missed that, thanks :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-348334023