Subject: [quicwg/base-drafts] Is fallback to TCP part of QUIC invariant ? (#955)

From: emile <[email-masked]>
Date: Wed, 22 Nov 2017 17:29:47 +0000 (UTC)

Currently QUIC headers don't provide the information for on-path troubleshooting of the network performance. When the QoS decreases badly endpoints fallback from QUIC to TCP. This behavior enable network troubleshooting  with legacy TCP monitoring tools. 
Will the endpoints support the fallback to TCP for all the versions of the QUIC protocol  ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/955

---

From: ianswett <[email-masked]>
Date: Wed, 22 Nov 2017 17:31:53 +0000 (UTC)

This is not an invariant.  There already are cases when QUIC does not need to fall back to TCP on private networks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/955#issuecomment-346421485

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Nov 2017 23:20:36 +0000 (UTC)

Closed #955.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/955#event-1355011906