Subject: Re: [quicwg/base-drafts] Number of loss detection timers (#575)

From: ianswett <[email-masked]>
Date: Mon, 13 Nov 2017 08:20:39 +0000 (UTC)

Are you thinking of the case when all acks are getting lost?  If so, we should hit the CWND limit pretty quickly and start timing out.  If only some acks are getting lost, it shouldn't matter.

There is a bug in the current text I believe which is that SetLossDetectionAlarm() is using now in cases when it should be using time_of_last_sent_packet.  This could cause acks to unnecessarily delay TLPs.  That is fixed in PR #923 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/575#issuecomment-343844714

---

From: Subodh Iyengar <[email-masked]>
Date: Tue, 14 Nov 2017 01:41:28 +0000 (UTC)

I was more thinking of a case where we don't hit the cwnd limit quickly, that is packets are being trickled into the network by the sender just as the timer is about to fire., however thinking about it some more, this is a case which should probably not be in the realm of the loss detection, but of connection termination, the idle timer would fire and close the connection. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/575#issuecomment-344118063

---

From: ianswett <[email-masked]>
Date: Tue, 14 Nov 2017 02:07:37 +0000 (UTC)

Closed #575.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/575#event-1339982137

---

From: ianswett <[email-masked]>
Date: Tue, 14 Nov 2017 02:07:37 +0000 (UTC)

Agreed.  I'm going to close this and we can track other improvements to the timeout text in PR #923 and if we can't figure out something there, we can open a new issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/575#issuecomment-344122553