Subject: [quicwg/base-drafts] max_data and max_stream_data are inconsistent with transport params (#895)

From: Subodh Iyengar <[email-masked]>
Date: Sun, 22 Oct 2017 19:04:03 +0000 (UTC)

max_data and max_stream_data seem to be inconsistent between the stream flow control and transport parameters 

In transport params they are encoded as 32 bit values and in  the MAX_STREAM_DATA it is a 64 bit value. Similarly now MAX_DATA is a 64 bit value in octets, however initial_max_data is a 32 bit value expressed in KB. It's not a big deal to implement, but just a bit weird.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/895

---

From: Martin Thomson <[email-masked]>
Date: Sun, 22 Oct 2017 21:24:56 -0700

I think that the intent was to specify both in the same units, and one got missed by both patch author and editors.  I'll fix that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/895#issuecomment-338544599

---

From: Martin Thomson <[email-masked]>
Date: Sun, 22 Oct 2017 21:25:56 -0700

Closed #895 via 166101d77d7c872ea228e19eb5c7fd9de19b9a04.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/895#event-1304869636

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Oct 2017 04:26:24 +0000 (UTC)

Reopened #895.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/895#event-1304869883

---

From: Martin Thomson <[email-masked]>
Date: Sun, 22 Oct 2017 21:27:39 -0700

Oh, I missed the 32/64 thing.  I agree that it's odd.  Then there's the possibility of using a varint.  I await feedback from implementers on this one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/895#issuecomment-338544868

---

From: Subodh Iyengar <[email-masked]>
Date: Mon, 23 Oct 2017 17:17:11 +0000 (UTC)

I implemented 32/64, and it wasn't too bad, since these parsers are necessarily different, and 32 bits should technically be enough even for connection flow control since this is just an initial offset, however it just seems that having these 2 be different is error prone.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/895#issuecomment-338731500