Subject: [quicwg/base-drafts] Re-randomization for packet numbers (#823)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Oct 2017 17:53:45 +0000 (UTC)

The draft is pretty inconsistent about what packet number to use in response to version negotiation or stateless retry.  Since no one implements re-randomization, just move to an increment-by-one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/823

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Wed, 04 Oct 2017 02:21:38 +0000 (UTC)

FYI, ngtcp2 client does re-randomization on Server Stateless Retry Packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/823#issuecomment-334032570

---

From: Patrick McManus <[email-masked]>
Date: Thu, 12 Oct 2017 20:01:39 +0000 (UTC)

I actually think the re-randomization requirement creates a bug because it can create 2 packets with the same number and the same cid but different contexts.

consider a client that sends out a CI (0) and a retransmitted CI(1) then receives a retry (0).. it will generate a new CI with a random number to honor the retry. it could be CI(1) again as its random.. if a retry(1) arrives it is ambiguous whether the retry applies to the first flight of CI or the second.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/823#issuecomment-336249523

---

From: Martin Thomson <[email-masked]>
Date: Fri, 13 Oct 2017 03:44:40 -0700

Closed #823 via #824.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/823#event-1292032848