Subject: Re: [quicwg/base-drafts] Need to distinguish Client Initial Packet with client Connection ID from one with server Connection ID (#577)

From: Martin Thomson <[email-masked]>
Date: Thu, 19 Oct 2017 20:02:21 -0700

The current design has Client Initial (or just Initial) packets including a client-chosen connection ID always.  Is this still a problem @igorlord?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/577#issuecomment-338093248

---

From: Igor Lubashev <[email-masked]>
Date: Thu, 19 Oct 2017 20:22:47 -0700

Closed #577.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/577#event-1302294509

---

From: Igor Lubashev <[email-masked]>
Date: Fri, 20 Oct 2017 03:22:47 +0000 (UTC)

No. This is no longer an issue. The current design has exactly two packet types that carry client-chosen connection id: "Client Initial" and (client's) "0-RTT" packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/577#issuecomment-338095714