Subject: Re: [quicwg/base-drafts] Specify AEAD-based protection of cleartext packets (#693)

From: janaiyengar <[email-masked]>
Date: Thu, 05 Oct 2017 14:24:07 -0700

>From discussion in Seattle: AEAD protect all cleartext packet types, leave Stateless Reset and Version Negotiation as they are. EKR to produce PR for AEAD protection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/693#issuecomment-334596369

---

From: Lars Eggert <[email-masked]>
Date: Sun, 08 Oct 2017 06:42:03 +0000 (UTC)

Could @ekr in the process also add some text that makes it clear(er) that Stateless Reset and Version Negotiation are special? See #840.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/693#issuecomment-334986822

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Oct 2017 00:02:50 +0000 (UTC)

Closed #693 via a0c571b42e22bdbf2f8e49f9fec03c2be6816ab5.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/693#event-1285102574

---

From: Patrick McManus <[email-masked]>
Date: Tue, 10 Oct 2017 07:26:23 -0700

does this mean we can get rid of the initial packet number randomization
now that this serves as proof-of-onpath?

On Mon, Oct 9, 2017 at 8:02 PM, Martin Thomson <[email-masked]>
wrote:

> Closed #693 <https://github.com/quicwg/base-drafts/issues/693> via a0c571b
> <https://github.com/quicwg/base-drafts/commit/a0c571b42e22bdbf2f8e49f9fec03c2be6816ab5>
> .
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/693#event-1285102574>, or mute
> the thread
> <https://github.com/notifications/unsubscribe-auth/AAP5s4o7Ge52eXAZOknJn8IRD65rB7xHks5sqrQngaJpZM4OfFhh>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/693#issuecomment-335490348

---

From: Ryan Hamilton <[email-masked]>
Date: Tue, 10 Oct 2017 10:01:35 -0700

> now that this serves as proof-of-onpath?

​I love it!​

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/693#issuecomment-335540818

---

From: Christian Huitema <[email-masked]>
Date: Tue, 10 Oct 2017 10:21:55 -0700

But if we remove packet number randomization, do we start with SN=0 or SN=1?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/693#issuecomment-335546509

---

From: ianswett <[email-masked]>
Date: Tue, 10 Oct 2017 10:23:53 -0700

1.  We really should ban 0.  It's a pain.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/693#issuecomment-335547027

---

From: janaiyengar <[email-masked]>
Date: Tue, 10 Oct 2017 17:30:48 +0000 (UTC)

Ha, interesting. Removing randomization SGTM. And yes, please, please SN=1. 0 is special. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/693#issuecomment-335548922