Subject: Re: [quicwg/base-drafts] What to ack in an ACK frame (#764)

From: ianswett <[email-masked]>
Date: Sun, 01 Oct 2017 18:21:25 -0700

We'll discuss this Wednesday, but the general rule is as you outlined in your comment:

"Yes, it is clear that we should not include Ack blocks that have already been acked, and that we SHOULD include timestamps exactly once per packet. "

Additionally, one should never retransmit the exact same ACK frame, and instead should always send the most up to date ACK information.  Additionally, 'loss' of an ACK frame should not cause the sending of a new ack frame, just as it does not in TCP.  Should this be called out explicitly in the transport draft?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/764#issuecomment-333421216

---

From: MikkelFJ <[email-masked]>
Date: Mon, 02 Oct 2017 11:48:41 -0700

Sorry if this is covered, just a response to Ians latest comment: It makes sense to ack the the same block multiple times because, say, four out of hundred packets might be retransmitted. As they are received, the entire range can be acked as a single range going forward. Then you just don't re-ACK the oldest fully covered range rather than all covered ranges.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/764#issuecomment-333628488