Subject: [quicwg/base-drafts] Specify use of packet number length in Stateless Reset packet (#889)

From: Christian Huitema <[email-masked]>
Date: Wed, 18 Oct 2017 09:53:44 -0700

The description of the stateless reset packet in the transport draft is somewhat inconsistent:
~~~
 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+
|0|C|K|  00001  |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                                                               |
+                     [Connection ID (64)]                      +
|                                                               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                     Packet Number (8/16/32)                   |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
~~~
On one hand, the first octet specifies type 0x01, which corresponds to a 1 octet encoding of the Packet Number. On the other hand, the packet number encoding specifies potential values of 1, 2, or 4 bytes.

Is it allowed to use type 0x02 or 0x03 when sending packet numbers of length 2 or 4 bytes?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/889

---

From: ianswett <[email-masked]>
Date: Mon, 23 Oct 2017 13:24:42 +0000 (UTC)

Closed #889 via #890.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/889#event-1305612160