Subject: [quicwg/base-drafts] Exit Draining Period Early (#869)

From: Nick Banks <[email-masked]>
Date: Thu, 12 Oct 2017 18:19:35 -0700

If a client closes the connection (via a CONNECTION_CLOSE or APPLICATION_CLOSE), it immediately enters the draining period. If it receives either an ACK for that packet or a CONNECTION_CLOSE in response, it can assume the server no longer needs any additional information and can immediately exit the draining period and clean up all remaining state (close the socket).

I believe the same would be true if the server originated the close (though reordered packets may arrive afterwards still). In other words, if one side initiates the close, it should be able to immediately clean up local state in response to receiving some acknowledgement that the other side received the close, so long as it can correctly handle any packets that come in afterwards.

The peer that receives the close frame must still go through the draining period though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/869

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Oct 2017 04:51:56 +0000 (UTC)

Closed #869 via #870.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/869#event-1309101460