Subject: Re: [quicwg/base-drafts] Graceful shutdown (#604)

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Oct 2017 03:47:56 +0000 (UTC)

@hardie, has this been addressed by recent changes? That is, the application decides, but signals to the transport (and any intermediaries with keys) using APPLICATION_CLOSE when it has concluded its shutdown.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/604#issuecomment-338540882

---

From: hardie <[email-masked]>
Date: Mon, 23 Oct 2017 18:51:03 +0000 (UTC)

@martinthomson I'm not sure if you're referring to a PR or the published docs.  If the published docs, transport looks like it covers APPLICATION_CLOSE but the HTTP mapping doc doesn't mention it and 7.1 seems to be using the HTTP application error codes with CONNECTION_CLOSE.  So I think it would need a PR to cover APPLICATION_CLOSE.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/604#issuecomment-338759823

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Oct 2017 18:07:42 -0700

@hardie, thanks for checking HTTP.  This issue was specifically about the generic issue though.  Can we say that sending APPLICATION_CLOSE when a connection is "done" is sufficiently generic a signal?

I'll open an editorial PR on the HTTP spec to correct the error(s) there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/604#issuecomment-338840648

---

From: hardie <[email-masked]>
Date: Tue, 24 Oct 2017 15:51:54 +0000 (UTC)

On Mon, Oct 23, 2017 at 6:07 PM, Martin Thomson <[email-masked]>
wrote:

> @hardie <https://github.com/hardie>, thanks for checking HTTP. This issue
> was specifically about the generic issue though. Can we say that sending
> APPLICATION_CLOSE when a connection is "done" is sufficiently generic a
> signal?
>
> As a generic, I think this is fine.

> I'll open an editorial PR on the HTTP spec to correct the error(s) there.
Personally, I would close this issue when that PR is merged, but up to you.

> —
> You are receiving this because you were mentioned.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/604#issuecomment-338840648>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABVb5O12G6KrHriS0kc7-MbtYD9GLKKvks5svThcgaJpZM4NykgT>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/604#issuecomment-339038170