Subject: [quicwg/base-drafts] clients always must regenerate client hello (#826)

From: jpinner-lyft <[email-masked]>
Date: Tue, 03 Oct 2017 14:59:58 -0700

The text in Sec 7.1 that details client handling of a version negotiation packet is not accurate:

"Though the contents of a packet might not change in response to version negotiation, a client MUST increase the packet number it uses on every packet it sends."

In particular because the transport parameters must be updated to reflect the version negotiation, the contents of the client initial packet must change. Also the first packet number will never be acknowledged so increasing the packet number by one to signify a retransmission does not make sense.

In particular the packet number should be reinitialized as specified in Sec 5.4.1 since as stated above, new contents must be created.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/826

---

From: Subodh Iyengar <[email-masked]>
Date: Mon, 23 Oct 2017 18:21:06 +0000 (UTC)

+1

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/826#issuecomment-338751002