Subject: [quicwg/base-drafts] Version negotiation responses and FNV-1a protection (#840)

From: Lars Eggert <[email-masked]>
Date: Thu, 05 Oct 2017 22:31:24 +0000 (UTC)

Reading the specs, it wasn't clear to me that version negotiation responses are not protected by FNV-1a. This should IMO be explicitly called out.

draft-tls says
> QUIC adds an integrity check to all cleartext packets.
and draft-transport says
> Cleartext packets are sent during the handshake prior to key negotiation.
Neither if which made it obvious to me that a version negotiation response was excluded.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/840

---

From: jpinner-lyft <[email-masked]>
Date: Fri, 06 Oct 2017 21:07:34 +0000 (UTC)

Not saying that this couldn't be more clear in the spec; however, Sec. 5.3 defines the version negotiation packet and Sec 5.4 defines the "cleartext" packets and list the requirement for including an integrity check. Subsections 5.4.1 through 5.4.4 then define the four "cleartext" packets.

Again I agree that the fact that the spec defines "cleartext packets" as not all packets that are not encrypted is confusing.

Does this become moot point if FNV-1a is replaced with an AEAD cipher?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/840#issuecomment-334870474

---

From: Martin Thomson <[email-masked]>
Date: Mon, 09 Oct 2017 17:02:46 -0700

Closed #840 via a0c571b42e22bdbf2f8e49f9fec03c2be6816ab5.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/840#event-1285102576