Subject: [quicwg/base-drafts] Need a way to send big values in stream 0 (#825)

From: ekr <[email-masked]>
Date: Tue, 03 Oct 2017 18:45:15 +0000 (UTC)

Currently we have a set of bad properties:

- You can't MAX_STREAM_DATA in stream 0
- Stream 0 is stream-level flow controlled
- People have big certs

When you put these all together, we are going to have problems. There are a number of options:

1. Allow MAX_STREAM_DATA
2. Exempt stream 0 from flow control
3. Prohibit big certs
4. Have a fixed flow control window refreshed by the ACK.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/825

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Oct 2017 19:45:32 +0000 (UTC)

Note that this is only a problem for the Server Cleartext.  Client Initial is fixed in size. Client Cleartext is sent after the 1-RTT keys are available, so the server can send MAX_STREAM_DATA.

The other idea was to split flow control for stream 0 across the handshake: MAX_STREAM_DATA can be sent by the client (and server) in the clear, but any flow control is reset once the handshake completes (the consumed flow control on the stream is reset, the final offset is set back to the initial value, and maybe also the stream offset goes back to zero).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/825#issuecomment-333956530

---

From: jpinner-lyft <[email-masked]>
Date: Tue, 03 Oct 2017 20:27:45 +0000 (UTC)

It seems like a minimal change here would be to add an additional transport parameter for max stream data on stream 0 that the client can send. This should be sufficient for a client to advertise a maximum size it for the server handshake it is willing to accept.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/825#issuecomment-333968044