Subject: Re: [quicwg/base-drafts] Negotiate use of timestamps in ACK frame (#774)

From: IngJohEricsson <[email-masked]>
Date: Mon, 09 Oct 2017 03:50:10 -0700

I have found ACK timestamps quite useful, these makes it possible to implement LEDBAT style congestion controls, which we believe can be useful for e.g. low priority transport in wireless access. It is however not strictly necessary to have a timestamp for each and every packet in the ACKs. In addition I don't see either that a floating point representation is necessary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/774#issuecomment-335123546

---

From: ianswett <[email-masked]>
Date: Mon, 09 Oct 2017 14:03:41 +0000 (UTC)

There was fairly strong consensus at the Seattle interim that timestamps should be negotiable in some way and when they are present, should be part of the QUIC ack frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/774#issuecomment-335167480