Subject: [quicwg/base-drafts] multiple cleartext types (#822)

From: jpinner-lyft <[email-masked]>
Date: Tue, 03 Oct 2017 17:37:46 +0000 (UTC)

There is no value and additional validation cost in prescribing cleartext packet types for each direction of communication.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/822

---

From: ianswett <[email-masked]>
Date: Tue, 03 Oct 2017 10:40:31 -0700

One benefit is that if the network routes packets incorrectly, it's easy for the server to drop the client's packets and client to drop the server's.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/822#issuecomment-333922028

---

From: jpinner-lyft <[email-masked]>
Date: Tue, 03 Oct 2017 10:59:38 -0700

If there is a concern about directionality I think it would be preferable to mirror the directionality inferred in the encrypted packets by using hashes based on the packet direction similar to what's done for the encryption keys today.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/822#issuecomment-333927499

---

From: ianswett <[email-masked]>
Date: Tue, 03 Oct 2017 13:19:33 -0700

I'm happy with that as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/822#issuecomment-333965788

---

From: janaiyengar <[email-masked]>
Date: Tue, 31 Oct 2017 22:44:03 +0000 (UTC)

Closed #822 via 503b694528cb8e5481c3f8cabecb7da5c30ed696.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/822#event-1319861924