Subject: [quicwg/base-drafts] Enter draining after receiving a stateless reset (#868)

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Oct 2017 17:29:07 -0700

If a client receives a stateless reset, it makes sense for it to stick around
in the draining period so that you can absorb any further stateless reset
packets that might have been sent by the server.  The server might have
received multiple packets, so it might also generate multiple resets.

Closes #867.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/868

-- Commit Summary --

  * Enter draining after receiving a stateless reset

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/868.patch
https://github.com/quicwg/base-drafts/pull/868.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/868

---

From: janaiyengar <[email-masked]>
Date: Fri, 13 Oct 2017 01:04:06 +0000 (UTC)

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/868#pullrequestreview-69104562

---

From: janaiyengar <[email-masked]>
Date: Thu, 12 Oct 2017 18:04:15 -0700

Merged #868.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/868#event-1291426387

---

From: ekr <[email-masked]>
Date: Thu, 12 Oct 2017 18:08:37 -0700

Hmm... I'm not following this. If the server is sending a stateless reset, that means that the server has lost state. The draining period seems to contemplate that the client would send ACKs and the like (https://github.com/quicwg/base-drafts/pull/868), but that's not useful to the server, because even if it has in-flight packets, it cannot process them. So, all that is necessary is that the client discard further stateless reset packets. Is your concern that the client will be sending ICMP unreachables rather than discarding them silently?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/868#issuecomment-336322657

---

From: janaiyengar <[email-masked]>
Date: Thu, 12 Oct 2017 18:13:49 -0700

The client may have sent an entire RTT's worth of data, and will likely receive more than just one Stateless Reset in response.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/868#issuecomment-336323366

---

From: janaiyengar <[email-masked]>
Date: Fri, 13 Oct 2017 01:15:11 +0000 (UTC)

Sorry -- that wasn't a complete response.

As you say, this just means that the client hangs around gathering any dangling stateless resets in the network. It's avoids strange side-effects, like the ICMP unreachables that you indicate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/868#issuecomment-336323543

---

From: ekr <[email-masked]>
Date: Fri, 13 Oct 2017 02:13:19 +0000 (UTC)

But you *also* drop packets during the idle period, whereas the draining period is clearly intended per the text to have you send packets.

@janaiyengar @martinthomson: I disagree with this change and I don't think it should have been merged (it's not just within editor's discretion). How would you like to handle this? I can file a new issue or mail the list, or...?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/868#issuecomment-336330940

---

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Oct 2017 19:52:19 -0700

Please file an issue.  I don't understand your concern, so perhaps you should expand on it some more.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/868#issuecomment-336335959