Subject: Re: [quicwg/base-drafts] CONTINUATION/END_HEADERS (#76)

From: Patrick McManus <[email-masked]>
Date: Tue, 31 Oct 2017 10:57:57 +0000 (UTC)

I just looked at this data again and now there is some data from release channel firefox (the earlier data point was limited to pre-release users). There is a tiny bit of CONTINUATION.. on the order of 1 in 100k HEADERS.. of those, > 99% are less than 64KB. But there is an existence proof of something that doesn't fit. (whether or not that's an error later in the stack, I don't know. I wouldn't be surprised.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/76#issuecomment-340728183

---

From: Mike Bishop <[email-masked]>
Date: Tue, 31 Oct 2017 10:48:57 -0700

Good to know.  We’ve recently been hitting a slow but stready stream of >16KB total size Cookie issues, God help us all, which would also force an HTTP/2 CONTINUATION.

Of course, if we were to go to variable-length integers for the length field as well, this would be moot – HEADERS frames would always be sufficiently large, albeit too large.

From: Patrick McManus [mailto:[email-masked]]
Sent: Tuesday, October 31, 2017 3:58 AM
To: quicwg/base-drafts <[email-masked]>
Cc: Mike Bishop <[email-masked]>; Mention <[email-masked]>
Subject: Re: [quicwg/base-drafts] CONTINUATION/END_HEADERS (#76)

—
You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fissues%2F76%23issuecomment-340728183&data=02%7C01%7CMichael.Bishop%40microsoft.com%7C77e5c8dddf4f46c8980308d5204e3e27%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636450442785400378&sdata=x1XPPWQY7Vps23Fy3OksDOTn98dToPVORd5tyavL5ec%3D&reserved=0>, or mute the thread<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fnotifications%2Funsubscribe-auth%2FAEE2haFZ4mkvXoG1BeuAQPDXDzL7EogZks5sxv00gaJpZM4LIIca&data=02%7C01%7CMichael.Bishop%40microsoft.com%7C77e5c8dddf4f46c8980308d5204e3e27%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636450442785400378&sdata=P4oATrqancXwpDLmIxgkyu04IWauUH6p2mnNUKiv0kA%3D&reserved=0>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/76#issuecomment-340846248

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 01 Nov 2017 01:01:01 +0000 (UTC)

At Previous Employer™️, we had to up header block sizes to 128K IIRC, as we regularly came across things that big in internal HTTP calls. Don't assume that the browser sees everything...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/76#issuecomment-340949194

---

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Nov 2017 03:14:59 +0000 (UTC)

I didn't change the frame length in #888, but it is an easy fix.  Can anyone suggest a reason not to?  It makes everything simpler and we no longer have to worry about keeping these frames small for multiplexing reasons.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/76#issuecomment-340966844