Subject: [quicwg/base-drafts] Remove packet number re-randomization requirement (#824)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Oct 2017 17:54:23 +0000 (UTC)

I don't believe that anyone actually implemented this, and it is
unnecessary.

Closes #823.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/824

-- Commit Summary --

  * Remove packet number re-randomization requirement

-- File Changes --

    M draft-ietf-quic-transport.md (29)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/824.patch
https://github.com/quicwg/base-drafts/pull/824.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/824

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Oct 2017 23:09:09 +0000 (UTC)

MikeBishop approved this pull request.

Fine, but moot if we take #850.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/824#pullrequestreview-68452953

---

From: janaiyengar <[email-masked]>
Date: Tue, 10 Oct 2017 16:10:51 -0700

janaiyengar commented on this pull request.

> @@ -907,9 +896,9 @@ When the client receives a Version Negotiation packet from the server, it should
 select an acceptable protocol version.  If the server lists an acceptable
 version, the client selects that version and reattempts to create a connection
 using that version.  Though the contents of a packet might not change in
-response to version negotiation, a client MUST increase the packet number it
-uses on every packet it sends.  Packets MUST continue to use long headers and
-MUST include the new negotiated protocol version.
+response to version negotiation, a client MUST increase the packet number by one

This requirement of increment by 1 is broken around migration. This should probably make an exception for that, with a pointer to Section 7.6... but that's probably an overkill. How about "a client MUST increase the packet number by one for every packet it sends in response to version negotiation."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/824#pullrequestreview-68453199

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Oct 2017 16:42:01 -0700

martinthomson commented on this pull request.

Right, though you won't be migrating during version negotiation, so your fix works.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/824#discussion_r143880909

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Oct 2017 16:43:32 -0700

@martinthomson pushed 1 commit.

cd25f2a  Reword to narrow increment scope

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/824/files/9b71bae4c3ee0153715b0b9a5a5b3eddc32554d2..cd25f2ad734eae4b3712e66440b241f035f98f66

---

From: janaiyengar <[email-masked]>
Date: Thu, 12 Oct 2017 22:19:49 +0000 (UTC)

This is fine, but I would just close it. We've agreed that we don't need randomization.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/824#issuecomment-336292494

---

From: janaiyengar <[email-masked]>
Date: Thu, 12 Oct 2017 15:19:59 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/824#pullrequestreview-69081166

---

From: Martin Thomson <[email-masked]>
Date: Fri, 13 Oct 2017 03:05:41 +0000 (UTC)

ff18a21  Merge branch 'master' into pn-randomize

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/824/files/cd25f2ad734eae4b3712e66440b241f035f98f66..ff18a21c2b81d73ac868d3772b48ef8f99f37e64

---

From: Martin Thomson <[email-masked]>
Date: Fri, 13 Oct 2017 03:44:35 -0700

Since #850 isn't resolving, I'm going to merge this and then we can continue to fight about whether 0 is special or not at our leisure.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/824#issuecomment-336417809

---

From: Martin Thomson <[email-masked]>
Date: Fri, 13 Oct 2017 10:44:40 +0000 (UTC)

Merged #824.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/824#event-1292032845