Subject: [quicwg/base-drafts] Use immediate close for application close (#854)

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Oct 2017 23:27:34 +0000 (UTC)

At the Seattle interim we concluded that it was important to signal a close to intermediaries (those that have the keys, that is).  This allows application endpoints to reach an agreed close state and then terminate the transport without leaving the middlebox on a timer.

In short, once the application protocol has reached a terminal state, it will signal using APPLICATION_CLOSE (some code, maybe NO_ERROR).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/854

---

From: Ryan Hamilton <[email-masked]>
Date: Wed, 11 Oct 2017 03:21:01 +0000 (UTC)

Does this preclude silent close?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/854#issuecomment-335670650

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Oct 2017 05:32:32 +0000 (UTC)

I think that the sort of close you have in mind relies on the timeout.  That is, neither side explicitly closes the connection, but they just don't get back to it.

What this covers is more the case where you have agreed to finish a certain set of requests - for example - and you are probably actively exchanging data up to the point where you are done.  This says that if you want to drop the idle timer, you need to send a message (see the issue for more discussion on why that might be needed).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/854#issuecomment-335687822

---

From: Ryan Hamilton <[email-masked]>
Date: Thu, 12 Oct 2017 03:45:48 +0000 (UTC)

Gotcha. Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/854#issuecomment-336012671

---

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Oct 2017 16:09:59 -0700

Closed #854 via #855.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/854#event-1291323549