Subject: Re: [quicwg/base-drafts] Multiple connections on the same port (#714)

From: Martin Thomson <[email-masked]>
Date: Fri, 20 Oct 2017 03:05:33 +0000 (UTC)

With the recent changes to packet protection, packets for different connections are cryptographically distinct.  However, that means a bunch of trial decryption for those packets from the server that are reordered.  I think that we really want to make sure that we want this feature.  It might be something we can defer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/714#issuecomment-338093660

---

From: MikkelFJ <[email-masked]>
Date: Fri, 20 Oct 2017 08:43:25 +0000 (UTC)

Possible solution:

- The Clear Text packets could carry the client connection ID unencrypted in both directions and expose the server chosen ID as a separate field to inform the client about future 1-RTT transmissions.
- 1-RTT encrypted packets would carry the server chosen ID in both directions.
- If there is no connection ID in the packets, multiple connections on same port would not be supported. It would make the server clear text header larger, but that is likely an acceptable cost.
- Some implementations or configurations may require the connection ID to always be present.
- 0-RTT must also be considered, which I have not done here.

This would simplify connection lookup when the connection ID is always present because there is no need for separate 5-tuple mappings, which require extra work for high speed interfaces such as netmap and might not be possible without on some non-UDP links without extra pre-header.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/714#issuecomment-338145180

---

From: Martin Thomson <[email-masked]>
Date: Fri, 20 Oct 2017 02:12:39 -0700

Another solution: don't change anything and have at most one outstanding connection setup running at a time on the same 5-tuple.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/714#issuecomment-338151768

---

From: MikkelFJ <[email-masked]>
Date: Fri, 20 Oct 2017 10:13:11 +0000 (UTC)

That would hurt special cases such as links multiplexing many application clients where there is only one port open. For example, it may be convenient to only have one port for netmap driven server to server, or for non-UDP setups.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/714#issuecomment-338166084