Subject: [quicwg/base-drafts] Stateless Reset Format is hard to implement (#820)

From: ekr <[email-masked]>
Date: Tue, 03 Oct 2017 17:35:51 +0000 (UTC)

The issue is that part of the token is in what you would otherwise interpret as the sequence number field, which means that you need special serializers and deserializers. It would be better to just have a random sequence number (which is what this effectively is anyway) and then the token in the body.  In fact, that's so obviously better that when I implemented this, I totally missed it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/820

---

From: ekr <[email-masked]>
Date: Tue, 03 Oct 2017 18:07:45 +0000 (UTC)

It would also make things easier if it were the last N bytes of the packet, because then you wouldn't need to parse an invalid packet header in order to find the data.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/820#issuecomment-333929824

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Oct 2017 11:09:37 -0700

Conveniently, the last N bytes is the authentication tag and N = 16.  So I like this idea.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/820#issuecomment-333930349

---

From: Christian Huitema <[email-masked]>
Date: Fri, 06 Oct 2017 15:35:50 +0000 (UTC)

I don't see a problem with moving the data to the end, but it won't solve the implementation issues. The problem is that the sequence number is unpredictable, so there is a 50% chance that the randomly chosen  sequence number picked by the server will be considered a reply by the client. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/820#issuecomment-334790582

---

From: ekr <[email-masked]>
Date: Fri, 06 Oct 2017 16:07:05 +0000 (UTC)

Correct. You need to check for SR if either replay or AEAD fail

On Fri, Oct 6, 2017 at 8:35 AM, Christian Huitema <[email-masked]>
wrote:

> I don't see a problem with moving the data to the end, but it won't solve
> the implementation issues. The problem is that the sequence number is
> unpredictable, so there is a 50% chance that the randomly chosen sequence
> number picked by the server will be considered a reply by the client.
>
> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/820#issuecomment-334790582>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oRvRg5c9t0fRIjFu5SdDpZwrgfx4ks5spkjTgaJpZM4Psft3>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/820#issuecomment-334799215

---

From: janaiyengar <[email-masked]>
Date: Thu, 12 Oct 2017 14:56:33 -0700

Closed #820 via #842.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/820#event-1291215598