Subject: [quicwg/base-drafts] Version Negotiation when Version = 0 (#816)

From: Mike Bishop <[email-masked]>
Date: Mon, 02 Oct 2017 14:11:44 -0700

`The version 0x00000000 is reserved to represent an invalid version`, but what is the expected behavior when a server receives it?  Should it initiate version negotiation, or should it reject the incoming message entirely?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/816

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Oct 2017 12:30:24 -0700

We don't need special handling for this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/816#issuecomment-333952498

---

From: janaiyengar <[email-masked]>
Date: Fri, 13 Oct 2017 19:36:08 +0000 (UTC)

I agree -- I think this is fine as is. A server will send a VN packet in response to it, or if it's seen in a VN packet, it will simply be ignored. I'll close this, but @MikeBishop please reopen if you think we should discuss this further.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/816#issuecomment-336547804

---

From: janaiyengar <[email-masked]>
Date: Fri, 13 Oct 2017 19:36:09 +0000 (UTC)

Closed #816.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/816#event-1292905630

---

From: Mike Bishop <[email-masked]>
Date: Fri, 13 Oct 2017 13:59:36 -0700

Reopened #816.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/816#event-1293023309

---

From: Mike Bishop <[email-masked]>
Date: Fri, 13 Oct 2017 13:59:36 -0700

> A server will send a VN packet in response to it...

The origin of this issue is that not all current implementations *do* send VN in response to version 0, so there is some difference of interpretation in the spec.  Maybe we decide that the spec is perfectly clear and any implementation behaving that way simply has a bug -- that's a reasonable position.  But I think it's also a reasonable reading of the current spec to ignore or CONNECTION_CLOSE a packet purporting to be in "an invalid version."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/816#issuecomment-336565967

---

From: janaiyengar <[email-masked]>
Date: Sat, 14 Oct 2017 05:22:19 +0000 (UTC)

I see. You're suggesting that we should articulate one precise behavior in this case. I probably don't really care which one, but I'm fine with that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/816#issuecomment-336611252