Subject: [quicwg/base-drafts] Stream open as a signal (#901)

From: Martin Thomson <[email-masked]>
Date: Thu, 26 Oct 2017 01:47:12 +0000 (UTC)

We currently don't allow for an empty STREAM frame unless it closes the stream.  But that prevents mapping of TCP-based protocols that rely on the connection open as a signal to a server to start transmission.  In protocols where a server speaks first, the client initiates the connection (i.e., stream), and the opening of that connection/stream signals to the server to start sending.

Should we permit the sending of an empty STREAM frame at the beginning of a stream as well as the end?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/901

---

From: ekr <[email-masked]>
Date: Wed, 25 Oct 2017 21:07:43 -0700

Actually you could send MAX_STREAM_DATA.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/901#issuecomment-339545497

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Oct 2017 22:55:10 -0700

That seems like a bit of an abuse.  We permit MAX_STREAM_DATA to open a stream only because it might be reordered ahead of STREAM/STREAM_BLOCKED.  On the other hand, we could put STREAM_BLOCKED in that same bucket if an empty STREAM frame was permissible - in other words, you might tolerate receiving STREAM_BLOCKED ahead of STREAM, but it's not the way you open a stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/901#issuecomment-339559416

---

From: ekr <[email-masked]>
Date: Thu, 26 Oct 2017 13:05:32 +0000 (UTC)

I don't disagree that it's a bit of an abuse. I'm just pointing out that the protocol permits it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/901#issuecomment-339659380

---

From: ianswett <[email-masked]>
Date: Thu, 26 Oct 2017 06:22:26 -0700

This seems like a reasonable idea to me.  And yes, using MAX_STREAM_DATA or another frame is definitely an abuse, even if it is permitted.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/901#issuecomment-339664008

---

From: Patrick McManus <[email-masked]>
Date: Thu, 26 Oct 2017 14:06:53 +0000 (UTC)

I think martin's suggestion is the right thing to do - allow offset 0 to be empty

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/901#issuecomment-339677512

---

From: Nick Banks <[email-masked]>
Date: Thu, 26 Oct 2017 07:15:53 -0700

I also think it seems reasonable to allow an offset 0 frame to be empty.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/901#issuecomment-339680308

---

From: ekr <[email-masked]>
Date: Thu, 26 Oct 2017 07:17:31 -0700

I'm fine with this, but then I'd still like to understand the status when
you *do* get MAX_STREAM_DATA and/or have an implicitly opened stream
because stream n+4 was opened.

On Thu, Oct 26, 2017 at 7:15 AM, Nick Banks <[email-masked]>
wrote:

> —
> You are receiving this because you commented.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/901#issuecomment-339680308>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oYgdLs1lF3SWsA2i7oV3M5UGPOGpks5swJQYgaJpZM4QG5U3>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/901#issuecomment-339680827