Subject: [quicwg/base-drafts] Limit MAX_DATA to the integer range (64 or 62 depending..) (#873)

From: Patrick McManus <[email-masked]>
Date: Fri, 13 Oct 2017 20:08:17 +0000 (UTC)

dimitry and @martinthomson  had a bit of a discussion on this in August: https://www.ietf.org/mail-archive/web/quic/current/msg02117.html

tl;dr - max-data is effectively a 74 bit integer.. plausibly much bigger than required, extremely hard to do integration testing with so presumably buggy as its > common native types.. at terrabit rates it would take years to transfer 64/62 bits (the obvious alternative) worth of flow controlled bytes.

I think this is an architectural issue because the bug risk for interop failure in long deployed systems is significant.

The existing arrangement falls short of accommodating the full sized packets across the whole packet number space anyhow. (to say nothing of dreaming of bigger MTUs) If we're going to keep it supersized then +16 bits makes a lot more sense to me than +10.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/873

---

From: Martin Thomson <[email-masked]>
Date: Sat, 14 Oct 2017 09:05:49 +0000 (UTC)

Closed #873 via #874.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/873#event-1293335315