Subject: Re: [quicwg/base-drafts] ECN echo encoding, detailed packet level or ECN marked bytes (#805)

From: mirjak <[email-masked]>
Date: Mon, 09 Oct 2017 02:57:20 -0700

Alternatively, one could also add ECN information per ACK block, basically saying that all packets in this block were marked with this ECN codepoint. This however only makes sense under the assumptions that most packets are marked with the same codepoint (usually ECT(0) today) and only a few packets are e.g. CE marked. In this case you probably have the same number of ACK blocks as with loss today. But I'm not sure if this assumption still holds in the future with things like L4S or if used in data centers with some congestion control similar to DCTCP.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/805#issuecomment-335113047

---

From: IngJohEricsson <[email-masked]>
Date: Mon, 09 Oct 2017 10:33:38 +0000 (UTC)

Yes, this option was also listed in fig 2 in https://tools.ietf.org/id/draft-johansson-quic-ecn-01.txt . I have done some minimal inspection of L4S ECN marking patterns with DCTCP as congestion control. If the bootleneck is configured to ECN mark packets that are queued up more than a fixed value (say 2ms) you tend to get a periodic marking pattern, which could indicate that the alternative Mirja suggests can actually work, at least with one flow. Things get more complicated with multiple flows and also with the dualQ implemenetations that are suggested by Koen De Schepper and Bob Briscoe, in which case one see more random ECN marking, also my laymans impelmentation of an ECN marker for TCP HULL exhibit a random marking pattern.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/805#issuecomment-335120312

---

From: janaiyengar <[email-masked]>
Date: Fri, 13 Oct 2017 12:58:09 -0700

Discussion to continue in ECN design team (https://github.com/quicwg/base-drafts/wiki/ECN-in-QUIC).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/805#issuecomment-336552578