Subject: [quicwg/base-drafts] Clients don't drain after stateless reset (#867)

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Oct 2017 17:28:56 -0700

I think that this was just an error.  A stateless reset isn't necessary singular: the server might send multiple as it receives multiple packets.  So it makes sense for the client to stick around and absorb packets for a while.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/867

---

From: janaiyengar <[email-masked]>
Date: Thu, 12 Oct 2017 18:04:15 -0700

Closed #867 via #868.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/867#event-1291426388

---

From: ekr <[email-masked]>
Date: Fri, 13 Oct 2017 02:19:14 +0000 (UTC)

I think this needs to be re-opened. See my comments in #868

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/867#issuecomment-336331662

---

From: ianswett <[email-masked]>
Date: Fri, 13 Oct 2017 13:21:25 +0000 (UTC)

I tend to agree.  There is nothing useful the client can do after receiving a stateless reset and there's nothing to send.

The most complex case I can imagine is a client using the same port for multiple QUIC connections, so the port is still listening.  In such a case, it would have to continue discarding incoming stateless reset packets, but that's true of any 'junk' packet not associated with an open connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/867#issuecomment-336450652

---

From: ianswett <[email-masked]>
Date: Fri, 13 Oct 2017 06:21:31 -0700

Reopened #867.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/867#event-1292259467

---

From: ianswett <[email-masked]>
Date: Fri, 13 Oct 2017 14:08:54 +0000 (UTC)

Ok, closing this because EKR already opened #871 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/867#issuecomment-336463004

---

From: ianswett <[email-masked]>
Date: Fri, 13 Oct 2017 14:08:55 +0000 (UTC)

Closed #867.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/867#event-1292349032