Subject: [quicwg/base-drafts] HTTP header compression: static table fit for QUIC (#904)

From: Lucas Pardue <[email-masked]>
Date: Mon, 30 Oct 2017 13:51:24 +0000 (UTC)

The HTTP header compression mechanism is still TBC but as I understand it, the proposals keep the same HPACK static table. This was formed from the "most frequent header fields used by popular web sites", and I wonder if that is still the case for today's web. For example, perhaps we'll see more usage of `alt-svc` in HTTP/QUIC, in order to keep the session active.

One benefit to keeping the static table would be to allow implementation to reuse of their object representation of the table, however I don't know how realistic that would be.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/904

---

From: ianswett <[email-masked]>
Date: Mon, 30 Oct 2017 12:58:43 -0700

Given it looks like the header compression will share little to no code with H2, I think this is worth considering.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/904#issuecomment-340565769

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 30 Oct 2017 13:26:30 -0700

The other question(s) I meant to pose was: given that H2 has now seen deployment experience, is there any telemetry on how the static and dynamic tables have been used? If so, could this be used to identify 'hot' items that make a better case for inclusion in the static table over other entries?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/904#issuecomment-340573366

---

From: Martin Thomson <[email-masked]>
Date: Tue, 31 Oct 2017 01:05:53 +0000 (UTC)

One of the pieces of feedback we've had is that there are some entries that don't have assigned values.  That would be a relatively easy thing to fix.  Also Accept-Encoding: br,gzip is now a thing apparently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/904#issuecomment-340629543