Subject: [quicwg/base-drafts] Introduce draining period for connection termination (#748)

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Aug 2017 17:44:33 -0700

Feedback on what was an editorial change in #721 turned it into a substantial change.  Apparently we are not specifying what different peers do during shutdown in new and interesting ways.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/748

---

From: Christian Huitema <[email-masked]>
Date: Thu, 24 Aug 2017 05:02:22 +0000 (UTC)

I like the new text. It does result in reliable close. Just one nit: if the sender of the connection close receives an ACK for the packet carrying the connection close frame, it is probably OK to exit the draining state sooner.

Of course, when we study multipath, we will have to differentiate between closing a path and closing the connection...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/748#issuecomment-324533524