Subject: [quicwg/base-drafts] Clarify Acks of Acks (#736)

From: Patrick McManus <[email-masked]>
Date: Wed, 16 Aug 2017 08:26:23 -0700

currently section 9 says
> To avoid creating an indefinite feedback loop, an endpoint MUST NOT generate an ACK frame in response to a packet containing only ACK or PADDING frames.

There is some implementation confusion around it.

Consensus seems to be that this means the packet containing only ACK/PADDING does end up referenced in an ACK frame eventually, but the generation of the ACK frame should not be triggered by the receipt of the ACK/PADDING-only packet.

however an alternative explanation, don't include the packet number of the ACK/PADDING-only packet in any ACK frame, is possible. It would be good to be clear.

I've noticed that the phrases like "don't ack acks" contribute to the confusion. Is it true that every packet except VN and Stateless-Retry needs to eventually be acknowledged? If so - that might be a useful clarifier.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/736

---

From: ianswett <[email-masked]>
Date: Wed, 16 Aug 2017 08:29:05 -0700

The consensus is correct.  The packet should be acknowledged in the next ack frame sent, but it should not cause a packet containing an ack frame to be sent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/736#issuecomment-322809298

---

From: Martin Thomson <[email-masked]>
Date: Wed, 16 Aug 2017 18:51:27 -0700

Closed by #739, though Ian's comment wasn't in the precise form that GitHub wanted.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/736#issuecomment-322946857

---

From: Martin Thomson <[email-masked]>
Date: Thu, 17 Aug 2017 01:51:28 +0000 (UTC)

Closed #736.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/736#event-1209352365