Subject: [quicwg/base-drafts] Stateless Retry and Server-Chosen Connection ID (#713)

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Aug 2017 22:31:31 +0000 (UTC)

In Paris, there was discussion about allowing the server to change the Connection ID on a Server Stateless Retry.  However, the spec doesn't actually define how to do this.  Currently, it says to start a new connection, which could be read to imply a newly-random Connection ID.

For load-shedding, it would be nice to enable the server to point the client to a new server, which likely implies carrying it in the HelloRetryRequest.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/713

---

From: janaiyengar <[email-masked]>
Date: Tue, 08 Aug 2017 23:09:29 +0000 (UTC)

>From editors' discussion on this: 

Our joint recollection is that a new Connection ID can be sent along with the HRR, potentially in a TLS extension. The client uses it in the subsequent Client Initial. The server-side load balancer treating it as a client-chosen connection ID, which means that the server that sent the HRR should, if it wants redirection, generate this Connection ID accordingly.

For verification, the server can send a cookie along with HRR that contains the proposed connection ID, which the client echoes in new Client Initial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/713#issuecomment-321106612