Subject: [quicwg/base-drafts] New text in section 7.3.1 of transport spec uses same code for stateless reset and packet length (#726)

From: Christian Huitema <[email-masked]>
Date: Sat, 12 Aug 2017 22:22:22 -0700

The extension code 5 is used twice in section 7.3.1:
> ...
> stateless_reset_token (0x0005):
>    The Stateless Reset Token is used in verifying a stateless reset, see Section 7.8. This parameter is a sequence of 16 octets.
>
> An endpoint MAY use the following transport parameters:
>
> omit_connection_id (0x0004):
>    The omit connection identifier parameter indicates that packets sent to the endpoint that advertises this parameter can omit the connection ID. This can be used by an endpoint where it knows that source and destination IP address and port are sufficient for it to identify a connection. This parameter is zero length. Absence this parameter indicates that the endpoint relies on the connection ID being present in every packet.
> max_packet_size (0x0005):
>    The maximum packet size parameter places a limit on the size of packets that the endpoint is willing to receive, encoded as an unsigned 16-bit integer. This indicates that packets larger than this limit will be dropped. The default for this parameter is the maximum permitted UDP payload of 65527. Values below 1200 are invalid. This limit only applies to protected packets (Section 5.5). 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/726

---

From: Christian Huitema <[email-masked]>
Date: Sat, 12 Aug 2017 22:23:40 -0700

Also, do we expect the token to be provided by both servers and clients?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/726#issuecomment-322022646

---

From: Christian Huitema <[email-masked]>
Date: Mon, 14 Aug 2017 05:51:44 +0000 (UTC)

This is clearly a typo -- the enum above describes the code as 0x0006.

But then, what about "An endpoint MUST include the following parameters in its encoded TransportParameters: ... stateless_reset_token". I cannot see how this applies to clients. The transport parameters of the client are a clear text extension in the clear text client hello. We certainly don't want to send that in clear text!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/726#issuecomment-322105534

---

From: Martin Thomson <[email-masked]>
Date: Wed, 16 Aug 2017 06:23:27 +0000 (UTC)

Closed #726 via #728.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/726#event-1207666721