Subject: [quicwg/base-drafts] Retain use of SETTINGS_ENABLE_PUSH (#718)

From: janaiyengar <[email-masked]>
Date: Wed, 09 Aug 2017 18:02:26 -0700

When pushing, the server currently only pushes after it's heard a MAX_PUSH_ID from the client. It might be useful to retain HTTP/2's SETTINGS_ENABLE_PUSH boolean that indicates push is disabled by the client. Without this boolean, the server has to wait forever to push but can't because it didn't hear anything from the client "yet", and the only way it knows that the client has disabled push is basically silence... which seems not great. (Tertiary point: it might be useful for various debugging/logging purposes to have an explicit disabling.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 Aug 2017 01:20:14 +0000 (UTC)

It's true, this changes the default stance of a server.  In the event that a MAX_PUSH_ID (#711) isn't received, the server simply can't use server push.  If the client really does support push, this error is going to be rare (the packet containing the MAX_PUSH_ID is lost or delayed and the request is still in a position to be understood and responded to).  The only consequence is lost opportunity, the protocol still functions.

We have a similar problem with SETTINGS.  SETTINGS establishes the header table size, so there is a lost (compression) opportunity if it is lost or reordered.

Either way, I think that we'll find out just how much of a problem this is when we get some experience with this.  It might be premature to decide right now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718#issuecomment-321423883

---

From: janaiyengar <[email-masked]>
Date: Thu, 10 Aug 2017 18:19:30 +0000 (UTC)

Marking as parked, since we aren't looking for resolution now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718#issuecomment-321632870