Subject: [quicwg/base-drafts] Encoding of blocksize in ACK frames. (#679)

From: Christian Huitema <[email-masked]>
Date: Tue, 04 Jul 2017 17:06:34 -0700

The text that describe the encoding of block lengths in the ACK frames is a bit too smart for my test. It reads:

> First ACK Block Length:
>
> : An unsigned packet number delta that indicates the number of contiguous additional packets being 
> acknowledged starting at the Largest Acknowledged.

If I look at it with attention, I understand it to mean "the number of continuous packet being acknowledged, not counting the Largest Acknowledged." 

Is this correct? Does highest=5, length=2 means "Acknowledging packets 5, 4 and 3", not just "5 and 4"? If yes, some more direct language would be nice.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/679

---

From: Mike Bishop <[email-masked]>
Date: Mon, 24 Jul 2017 17:46:15 +0000 (UTC)

That's how I read it, yes -- as "additional" packets.  Otherwise zero would be a nonsensical value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/679#issuecomment-317500582

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Jul 2017 01:10:40 +0000 (UTC)

I had the same reading of this as both of you.  However, if we want to allow a larger gap, then having zero length on subsequent ACK blocks might have some utility and consistency with that is perhaps desirable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/679#issuecomment-317598952

---

From: Lars Eggert <[email-masked]>
Date: Tue, 25 Jul 2017 10:06:32 +0000 (UTC)

Understood it this way, too, but had to re-read the sentence a few times. Suggest to add @huitema's example to the draft?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/679#issuecomment-317691772