Subject: [quicwg/base-drafts] Do we need endofearlydata? (#690)

From: Subodh Iyengar <[email-masked]>
Date: Wed, 19 Jul 2017 12:10:05 +0000 (UTC)

In TLS 1.3 end of early data is needed because it prevents truncation of 0-RTT data because of resetting sequence number. However quic does not reset sequence number and the 0-rtt data is sent on different streams from stream 0, so can we get rid of endofearly data?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/690

---

From: ekr <[email-masked]>
Date: Wed, 19 Jul 2017 12:19:42 +0000 (UTC)

On Wed, Jul 19, 2017 at 5:10 AM, Subodh Iyengar <[email-masked]>
wrote:

> In TLS 1.3 end of early data is needed because it prevents truncation of
> 0-RTT data because of resetting sequence number. However quic does not
> reset sequence number and the 0-rtt data is sent on different streams from
> stream 0, so can we get rid of endofearly data?
>

That seems like it's going to make it kind of a pain to use a generic TLS
stack.

-Ekr

—
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/690>, or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oZBXJFVPNBjjt2EJHm6oSGWsz8AHks5sPfIcgaJpZM4Oco0b>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/690#issuecomment-316367833

---

From: Mike Bishop <[email-masked]>
Date: Mon, 24 Jul 2017 10:42:17 -0700

>From the TLS standpoint, QUIC is the app driving it.  If a normal TLS app requests a 0-RTT handshake, but then sends no data during 0-RTT, what happens?  Is there still an EOED?

That's what should happen here.  As far as QUIC is concerned, the app requested a 0-RTT handshake, but never sends any data, either during 0-RTT or 1-RTT.  TLS shouldn't be changing behaviors based on where it's used, but based on what the app does..

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/690#issuecomment-317499477

---

From: ekr <[email-masked]>
Date: Mon, 24 Jul 2017 17:59:58 +0000 (UTC)

On Mon, Jul 24, 2017 at 10:42 AM, Mike Bishop <[email-masked]>
wrote:

> From the TLS standpoint, QUIC is the app driving it. If a normal TLS app
> requests a 0-RTT handshake, but then sends no data during 0-RTT, what
> happens? Is there still an EOED?
>
Yes.

> That's what should happen here. As far as QUIC is concerned, the app
> requested a 0-RTT handshake, but never sends any data, either during 0-RTT
> or 1-RTT. TLS shouldn't be changing behaviors based on where it's used, but
> based on what the app does..
>
Agreed.

-Ekr

> —
> You are receiving this because you commented.
> <https://github.com/quicwg/base-drafts/issues/690#issuecomment-317499477>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1ocXr88pRaEj_7LcPsgDCejkGuI_Iks5sRNd4gaJpZM4Oco0b>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/690#issuecomment-317504685

---

From: Subodh Iyengar <[email-masked]>
Date: Wed, 26 Jul 2017 19:25:52 -0700

ya I think I generally agree, being able to work with an unmodified TLS stack is kind of useful. The reason I asked this question was that when I saw the endofearly data I started scratching my head asking what security property this provides with QUIC, and the answer was really none and it seemed weird being there at that point.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/690#issuecomment-318240228