Subject: Re: [quicwg/base-drafts] Border cases in packet number decoding (#674)

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Jul 2017 16:10:40 -0700

Yes. There is a single case where the decoded value could equally be one of two different values.  Given that this is a corner case, and given that I don't think that the specific answer matters, can someone toss a coin and tell me which one to use?  Failing that, I'll pick Christian's answer (the lower value).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/674#issuecomment-312965279

---

From: ianswett <[email-masked]>
Date: Wed, 05 Jul 2017 14:54:25 +0000 (UTC)

The lower value is fine.  It really should never matter since we'd expect to only receive packets within 1/4 of expressible range, just like TCP sequence numbers aren't supposed to use the entire space.

At some point, Jana and I considered recommending the peer close the connection if the packet number was in the half of the space you don't expect, but we weren't convinced that was actually helpful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/674#issuecomment-313127685