Subject: Re: [quicwg/base-drafts] Non-zero streams in cleartext (#660)

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Jul 2017 16:13:51 -0700

Closed #660.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/660#event-1150077997

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Jul 2017 23:13:51 +0000 (UTC)

https://quicwg.github.io/base-drafts/draft-ietf-quic-tls.html#rfc.section.9.1

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/660#issuecomment-312965514

---

From: MikkelFJ <[email-masked]>
Date: Tue, 04 Jul 2017 22:27:23 -0700

@martinthomson The packet description of clear text does not reflect the TLS text
https://quicwg.github.io/base-drafts/draft-ietf-quic-transport.html#rfc.section.5.4.4

>The payload of this packet contains STREAM frames and could contain PADDING and ACK frames.

The initial packet explicitly mentions that only stream 0 is permitted.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/660#issuecomment-312999557