Subject: [quicwg/base-drafts] What is the actual format of the ACK Delay parameter? (#677)

From: Christian Huitema <[email-masked]>
Date: Mon, 03 Jul 2017 16:19:54 -0700

In the transport spec The ACK specification defines a 16 bit Ack Delay as:

> ACK Delay:
>
> : The time from when the largest acknowledged packet, as indicated in the Largest Acknowledged field, 
> was received by this peer to when this ACK was sent.

Other 16 bit ACK delays are encoded using an ad hoc floating point format. For this field, are we using the floating point format of a 16 bit number of microseconds?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/677

---

From: MikkelFJ <[email-masked]>
Date: Tue, 04 Jul 2017 06:20:21 +0000 (UTC)

I wrote up the precise format of the 16 format used called ufloat16.

https://github.com/quicwg/base-drafts/issues/109

It is a 64-bit unsigned integer word with multiple values mapping to the same value in the ufloat16 format. It has a much higher dynamic range than 16-bit integer, but not the full range of a 64-bit integer - too large values are clamped to a maximum value.

The format is always used in its 64-bit decode form, except that it is possible to do relative comparisons directly on ufloat16 if you need to.

As to the specific use of the format in a given frame field, I suppose all values are 64-bit microseconds relative to either connection start or relative to some other reference point in a frame. It is actually quite good for timestamps where you need limited precision by have an unpredictable range.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/677#issuecomment-312790373

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Jul 2017 23:07:01 +0000 (UTC)

Closed #677.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/677#event-1150075095

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Jul 2017 23:07:02 +0000 (UTC)

Yeah, closing in favour of #109.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/677#issuecomment-312965010