Subject: [quicwg/base-drafts] Re-order the presentation of the various frame types to match (#675)

From: ekr <[email-masked]>
Date: Sat, 01 Jul 2017 19:20:11 +0000 (UTC)

the order of the code points. This just makes it a bit cleaner.

This diff makes Github's review tool very very sad.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/675

-- Commit Summary --

  * Re-order the presentation of the various frame types to match

-- File Changes --

    M draft-ietf-quic-transport.md (858)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/675.patch
https://github.com/quicwg/base-drafts/pull/675.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/675

---

From: Martin Thomson <[email-masked]>
Date: Fri, 07 Jul 2017 01:23:28 +0000 (UTC)

martinthomson commented on this pull request.

> +
+Delta Largest Acked 1..N (opt, repeated):
+
+: This field has the same semantics and format as "Delta Largest Acknowledged".
+  Repeated "Num Timestamps - 1" times.
+
+Time Since Previous Timestamp 1..N(opt, repeated):
+
+: An optional 16-bit unsigned value specifying time delta from the previous
+  reported timestamp.  It is encoded in the same format as the ACK Delay.
+  Repeated "Num Timestamps - 1" times.
+
+The timestamp section lists packet receipt timestamps ordered by timestamp.
+
+
+## STREAM Frame {#frame-stream}

You moved this into the middle of the ACK frame description (see the time format section below).  I'll fix this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/675#pullrequestreview-48502435

---

From: ekr <[email-masked]>
Date: Thu, 06 Jul 2017 18:33:01 -0700

Oops. Thanks

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/675#issuecomment-313563417

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Jul 2017 05:16:17 +0000 (UTC)

Closed #675 via #680.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/675#event-1160021685