Subject: [quicwg/base-drafts] Is Version Negotiation integrity protected in first interop draft? (#706)

From: Christian Huitema <[email-masked]>
Date: Mon, 31 Jul 2017 09:15:44 -0700

I am belatedly finishing the first interop draft implementation, and I have a doubt regarding the version negotiation packet. The text in section 5.4 Cleartext Packets says:

> The payload of cleartext packets also includes an integrity check, which is described in [QUIC-TLS].

The text in section 5.3. Version Negotiation Packet does not say anything about integrity protection. I understand that this will be clarified for future drafts as we resolve issue #693. But I would like to know how other implementations deal with version negotiation packets for the 1st interop. FNV1A or not?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/706

---

From: Patrick McManus <[email-masked]>
Date: Mon, 31 Jul 2017 09:55:49 -0700

no fnv1a on any version-negotiation afaict.. otoh it would probably just look like some versions the client didn't implement ;)

 (the slack is a great place for this kind of interop question)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/706#issuecomment-319130756