Subject: [quicwg/base-drafts] Try to clarify the situation around sending ACKs in response to (#681)

From: ekr <[email-masked]>
Date: Wed, 12 Jul 2017 17:46:12 +0000 (UTC)

ACK-only packets.

This does not seem entirely clear in the text.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/681

-- Commit Summary --

  * Try to clarify the situation around sending ACKs in response to

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/681.patch
https://github.com/quicwg/base-drafts/pull/681.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/681

---

From: ianswett <[email-masked]>
Date: Wed, 12 Jul 2017 17:48:07 +0000 (UTC)

ianswett commented on this pull request.

> @@ -1831,7 +1831,9 @@ Connection ID:
 Receivers send ACK frames to inform senders which packets they have received and
 processed, as well as which packets are considered missing.  The ACK frame
 contains between 1 and 256 ACK blocks.  ACK blocks are ranges of acknowledged
-packets.
+packets. Implementations SHOULD NOT generate ACK packets in response to packets

I'd try for MUST NOT and MUST ACK, though I admit it's a bit difficult to enforce either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/681#pullrequestreview-49567131

---

From: ianswett <[email-masked]>
Date: Wed, 12 Jul 2017 17:48:55 +0000 (UTC)

I'd go for MUST NOT and MUST ACK, though I admit it's a bit difficult to enforce either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/681#pullrequestreview-49567365

---

From: ekr <[email-masked]>
Date: Wed, 12 Jul 2017 18:05:45 +0000 (UTC)

I would be fine with that. I only used SHOULD because the later guidance on ACK tracking is SHOULD.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/681#issuecomment-314850423

---

From: Martin Thomson <[email-masked]>
Date: Fri, 14 Jul 2017 09:07:22 -0700

Merged #681.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/681#event-1164541039