Subject: [quicwg/base-drafts] Add a packet number and offset to connection close (#607)

From: ianswett <[email-masked]>
Date: Wed, 07 Jun 2017 06:24:22 -0700

In Paris, when discussing what error codes to include in the connection close, the idea of optionally specifying a packet number and a byte offset into the packet where the error occurred seems potentially useful for debugging.

This wouldn't allow automated error analysis(unless one saved every packet every sent), but for a given reproducible error, it could help dramatically.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/607

---

From: MikkelFJ <[email-masked]>
Date: Wed, 07 Jun 2017 06:29:16 -0700

While rather useful, I would suggest printing such information to a string without standardizing.

Also, I assume this is fully encrypted, otherwise there could be potential crypto attack concerns. On a releated note: error text is variable length and also open to crypto analysis.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/607#issuecomment-306794705