Subject: Re: [quicwg/base-drafts] Limit the size of packets (#501)

From: ianswett <[email-masked]>
Date: Tue, 06 Jun 2017 07:29:14 -0700

ianswett commented on this pull request.

Two nits

> @@ -1133,6 +1134,14 @@ truncate_connection_id (0x0004):
   length.  Omitting the parameter indicates that the endpoint relies on the
   connection ID being present in every packet.
 
+max_packet_size (0x0005):
+
+: The maximum packet size parameter places a limit on the size of packets that
+  the endpoint is willing to receive, encoded as an unsigned 16-bit integer.
+  The default for this parameter is the maximum permitted UDP payload of 65527.
+  Values below 256 are invalid.  The initial packet from a client is exempt from

1280 not 256?  Also, do we want to mention that the peer is indicating it will drop packets larger than the limit?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/501#pullrequestreview-42333481

---

From: Martin Thomson <[email-masked]>
Date: Tue, 06 Jun 2017 07:59:32 -0700

@martinthomson pushed 1 commit.

e8e9837  Increase minimum to 1252

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/501/files/ae3fa11d3d09a31563c5538771d4f0016089c7c8..e8e98379fa639f27f5722b78ffe9a2c403e590ed

---

From: ianswett <[email-masked]>
Date: Tue, 06 Jun 2017 08:02:32 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/501#pullrequestreview-42344478

---

From: Martin Thomson <[email-masked]>
Date: Tue, 06 Jun 2017 08:04:52 -0700

@ianswett, I forgot to commit the change to make this 1252 (I blame jet lag), but you said two comments and only had one.  Just making sure that you didn't have another one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/501#issuecomment-306515305

---

From: ianswett <[email-masked]>
Date: Tue, 06 Jun 2017 08:55:53 -0700

I only left one comment, but with two issues, one of which was addressed with "This indicates that packets larger than this limit will be dropped" and the other was the 1252 change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/501#pullrequestreview-42362013

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Jun 2017 06:36:35 -0700

Merged #501.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/501#event-1117259494