Subject: [quicwg/base-drafts] Ack frame has two framings that specify a single range (#635)

From: ianswett <[email-masked]>
Date: Fri, 16 Jun 2017 07:40:45 -0700

A single ack range can be specified with or without the "num blocks" byte present.  It would be nice to only have one way to specify a single range.

The obvious options are:
1) Remove the bit that indicates whether num_blocks is present and make it always present.
2) Make the number of blocks read = num_blocks + 1.  
3) Do nothing because we don't care.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/635

---

From: ekr <[email-masked]>
Date: Fri, 16 Jun 2017 08:05:35 -0700

I suggest that we open a bigger issue called "Reconsider ACK Frame Encoding" because this is only one of a bunch of complaints I have about it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/635#issuecomment-309050988

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 20 Jun 2017 16:38:41 -0700

#644 is the Grand ACK Frame issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/635#issuecomment-309921552

---

From: ianswett <[email-masked]>
Date: Tue, 20 Jun 2017 16:39:16 -0700

Closed #635.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/635#event-1131986522