Subject: [quicwg/base-drafts] Transport: Inclusion of multiple Stream Frames for the same Stream ID (#610)

From: Magnus Westerlund <[email-masked]>
Date: Thu, 08 Jun 2017 01:31:06 -0700

draft-ietf-quic-transport-03, Section 8.1 says:

   Stream multiplexing is achieved by interleaving STREAM frames from
   multiple streams into one or more QUIC packets.  A single QUIC packet
   MAY bundle STREAM frames from multiple streams.

The inclusion of multiple stream frames for the same frame is not clear in the above. Is it allowed or not? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/610

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Jun 2017 05:51:44 -0700

I'm not sure that I understand.  Doesn't the final sentence answer your question?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/610#issuecomment-307093665

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 08 Jun 2017 06:12:57 -0700

No, there is a difference between one stream frame per stream ID aggregated in the same packet, and multiple stream frames for the same stream ID. The later is not clear that it is allowed with above formulation. But, I guess that based on what is in the Stream Frame you can have multiple stream frames for the same ID, so this is likely an editorial issue on the above text to make it explicit.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/610#issuecomment-307098885

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Jun 2017 06:15:26 -0700

Oh, now I understand.  Well, that's suboptimal, but permissible.  (You said "multiple stream frames for the same frame", where you meant same stream.)  Do you think that removing "from multiple streams" would clarify this point?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/610#issuecomment-307099549

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 08 Jun 2017 06:20:26 -0700

I would rather be explicit and say; "A single QUIC packet MAY bundle multiple STREAM frames from one or more stream IDs."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/610#issuecomment-307100861

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 03:54:27 -0700

Closed #610 via 80f3af3e7796875452c9181160a36f0b15adc6b0.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/610#event-1121130702