Subject: [quicwg/base-drafts] Frame type word (#619)

From: ekr <[email-masked]>
Date: Fri, 09 Jun 2017 05:12:22 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/619

-- Commit Summary --

  * Clarify mapping of bits to lengths for STREAM frame. Also, re-order
  * WIRE FORMAT CHANGE: Change the order of the bits in the STREAM frame

-- File Changes --

    M draft-ietf-quic-transport.md (12)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/619.patch
https://github.com/quicwg/base-drafts/pull/619.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/619

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Jun 2017 06:08:35 -0700

@janaiyengar, I think that this is a strict improvement.  The current layout has bits in the order DOS and the corresponding fields in the order DSO.  While DOS is a great acronym, I think that the order of the fields makes more sense, so @ekr's suggestion here is quite reasonable.

Now that I look at it, perhaps the most logical order is SOD.  That way you can say "this is a frame for stream S, starting at offset O and of length D". In particular, frames that mention streams would then have the stream ID in the same place, mostly (I'd want to fix RST_STREAM at the same time).

Either way, I think that a consistent order is best.  Also, it would be nice to have this in the implementation draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/619#issuecomment-307383813

---

From: ekr <[email-masked]>
Date: Fri, 09 Jun 2017 07:43:03 -0700

I do agree that SOD would be superior. I was just trying to make the minimal change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/619#issuecomment-307407886

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 03:49:49 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/619#pullrequestreview-43686120

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 03:50:01 -0700

Merged #619.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/619#event-1121124745