Subject: [quicwg/base-drafts] 5-tuple is stable during handshake (#594)

From: Martin Thomson <[email-masked]>
Date: Tue, 06 Jun 2017 05:42:19 -0700

We need to state this as an assumption.  This is particularly relevant in the case where we have version negotiation and a rebalancing of the connection-id-based routing on the server cluster.  We're opting for a hope-based solution here and assuming that the server will be the same (or at least run the same versions) and that the 5-tuple is enough to keep the routing the same.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/594

---

From: MikkelFJ <[email-masked]>
Date: Tue, 06 Jun 2017 05:53:42 -0700

What is the motivation for not simply chaining Connection ID changes? That is if client sends CCID and server changes to a new SCCID, the old CCID could be chained in that packet, and so forth on path changes. It would simplify many things. Except for the initial handshake these chains are not observable from outside the connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/594#issuecomment-306476849

---

From: MikkelFJ <[email-masked]>
Date: Tue, 06 Jun 2017 05:55:45 -0700

Of course, regardless of chaining, it must be a requirement that packets are routable to the recepient, but that is different from requiring a stable 5-tuple.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/594#issuecomment-306477399

---

From: Igor Lubashev <[email-masked]>
Date: Tue, 06 Jun 2017 07:09:57 -0700

This came up as a requirement for settling #588 in Paris.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/594#issuecomment-306497939

---

From: MikkelFJ <[email-masked]>
Date: Tue, 06 Jun 2017 07:18:54 -0700

But if a stable 5-tuple is required, it should probably also be unique. The uniqueness requirement can be avoided with chaining Connection ID's.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/594#issuecomment-306500504