Subject: Re: [quicwg/base-drafts] Variable-length connectionID/routing information in public header (#205)

From: Igor Lubashev <[email-masked]>
Date: Mon, 05 Jun 2017 09:36:28 -0700

It looks like we have 24 bits (bytes 1-3) in each packet header available right now.  We could use them for the purposes of this issue as well as #279.

For example, we can specify byte 2 that is an "Echo Request" and byte 3 as an "Echo Response".  When an endpoint generates a packet, it places "Echo Request" byte from the latest packet received from the peer into its "Echo Response" byte.  This will allow endpoints to characterize peer behavior, detect upstream packet reordering, etc.  If we do not cover these packets by crypto, middleboxes can add them.  If not these bytes, we could have a mechanism to attach such cleartext request/response to packets (though that's the road to header extensions).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/205#issuecomment-306237118

---

From: Igor Lubashev <[email-masked]>
Date: Mon, 05 Jun 2017 10:49:18 -0700

Looks like there is a discussion of a more specific alternative for middle box timing in #269 (#391).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/205#issuecomment-306256183