Subject: [quicwg/base-drafts] Fix stream state machine (#623)

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 08:42:05 -0700

This corrects a few infidelities about the way that stream states
update.  This includes Subodh's excellent suggestion to limit
transitions from idle to only go through open.

Fixes #572, #571.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/623

-- Commit Summary --

  * Fix stream state machine

-- File Changes --

    M draft-ietf-quic-transport.md (107)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/623.patch
https://github.com/quicwg/base-drafts/pull/623.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/623

---

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 09:06:54 -0700

@martinthomson pushed 1 commit.

07dedce  Fix 571 properly

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/623/files/449f4327b3d0c4e042e826f96bbbf34681dac167..07dedceb98466551b797e1a88303d96453aa5299

---

From: MikkelFJ <[email-masked]>
Date: Sat, 10 Jun 2017 09:16:57 -0700

mikkelfj commented on this pull request.

>  endpoint MUST NOT consider the stream state to have changed until all data has
-arrived.
+either been acknowledged or received.

I'm not sure if it is obvious that a RST is also considered acknowledged data here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/623#pullrequestreview-43300897

---

From: MikkelFJ <[email-masked]>
Date: Sat, 10 Jun 2017 09:19:30 -0700

-arrived.

But from the following it seems this also not required.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/623#discussion_r121260763

---

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 09:42:30 -0700

b187587  Allow for RST_STREAM more explicitly.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/623/files/07dedceb98466551b797e1a88303d96453aa5299..b1875874a6b52b8eb8ad5c796d1f0ae39c3f4409

---

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 09:42:53 -0700

martinthomson commented on this pull request.

-arrived.

Thanks for picking up on that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/623#discussion_r121261259

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 05:31:24 -0700

janaiyengar commented on this pull request.

>  endpoint MUST NOT consider the stream state to have changed until all data has
-arrived.
+been acknowledged, received or discarded.

The "arrived" was deliberate -- the stream does not need to hang around in open state until all data is acked. That's a matter of reliability, which should not have anything to do with stream states. I would like to keep stream states decoupled from reliability requirements.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/623#pullrequestreview-43706515

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 05:43:00 -0700

-arrived.

I would suggest that you revert the changes that require receipt of acks for sent data for streams to transition to closed. The other changes LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/623#discussion_r121665382

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Jun 2017 06:24:58 -0700

bb6cee1  Remove the requirement to have stream data acknowledged for close

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/623/files/b1875874a6b52b8eb8ad5c796d1f0ae39c3f4409..bb6cee1e060d5a3a69b53a1d71bbe1d6d8ef6d1e

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Jun 2017 06:26:52 -0700

Merged #623.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/623#event-1121362125