Subject: [quicwg/base-drafts] Stream frame data length wording. (#652)

From: Jānis <[email-masked]>
Date: Wed, 21 Jun 2017 00:37:06 -0700

In current draft there is sentence: "A STREAM frame MUST have either non-zero data length or the FIN bit set."
At least for me this was confusing if it refers to Data Length field + D bit. Wouldn't a better wording be something similar to:  "A STREAM frame MUST have either non-empty Stream Data payload or the FIN bit set." or "A STREAM frame MUST have either some Stream Data payload or the FIN bit set without payload"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/652

---

From: MikkelFJ <[email-masked]>
Date: Wed, 21 Jun 2017 00:44:09 -0700

The idea, I believe, is that generally a stream is closed as soon as possible with as much data as possible in a frame. The idea is not that FIN should be an empty frame. However, sometimes you don't know whether more data will arrive or not, so an empty frame with FIN is permitted. Other empty stream frames are not permitted to be empty because they can be used to abuse flow control limits.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/652#issuecomment-309990871

---

From: Mike Bishop <[email-masked]>
Date: Thu, 22 Jun 2017 08:26:31 -0700

A stream frame's payload MUST NOT be empty, unless the FIN bit is set.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/652#issuecomment-310414460

---

From: Martin Thomson <[email-masked]>
Date: Sun, 25 Jun 2017 15:27:49 -0700

Closed #652 via #657.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/652#event-1137867066