Subject: [quicwg/base-drafts] Streams need not be created in sequential order (#634)

From: janaiyengar <[email-masked]>
Date: Thu, 15 Jun 2017 16:41:01 -0700

Dmitri Tikhonov writes on the mailing list:

"Section 10.1 of draft-ietf-quic-transport-03 states that “Streams MUST be created in sequential order.”  My question is: why mandate stream creation order, since the other side may receive out-of-order packets?  Let the implementation do what it wants with Stream IDs – as long as it does not go over the limit, all should be well.
 
This phrase is a holdover from the previous version; this requirement seems to be unnecessary since issue #435 has been resolved."

I think this is right. Now that we have also replaced concurrent streams, this seems quite unnecessary. This will clean up some more text, but I wanted to air this issue here before turning it into a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/634

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Jun 2017 17:34:32 -0700

In writing up the unidirectional stream proposal, I concluded that this was still a valuable restriction to have.  Besides, creating streams out of order in that model isn't necessary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/634#issuecomment-308901218