Subject: [quicwg/base-drafts] Public Resets should be triggered by only QUIC packets (#599)

From: janaiyengar <[email-masked]>
Date: Wed, 07 Jun 2017 01:02:08 -0700

We don't want an endpoint to send Public Resets in response to random non-QUIC packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/599

---

From: Patrick McManus <[email-masked]>
Date: Wed, 07 Jun 2017 02:54:28 -0700

related to the "we don't want an endpoint to send version negotiation in response to random non-quic packets" (that look like long headers of an unknown version)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/599#issuecomment-306747908

---

From: MikkelFJ <[email-masked]>
Date: Wed, 07 Jun 2017 03:08:09 -0700

> related to the "we don't want an endpoint to send version negotiation in response to random non-quic packets" (that look like long headers of an unknown version)

It can be difficult to decide what is a valid version - if version negotation is protected with CCID validation when received, it cannot do much harm, also because initial packets are much larger. 

However, if no protection is present, a version negotation packet triggered by adversary can force connection close by returning a version that the true client is attempting to connect with.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/599#issuecomment-306751048

---

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 08:21:10 -0700

@janaiyengar, can we close this in favour of #570?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/599#issuecomment-307571454

---

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 08:21:10 -0700

Closed #599.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/599#event-1118271425