Subject: Re: [quicwg/base-drafts] Fix up ACK frame section (#507)

From: ianswett <[email-masked]>
Date: Sun, 04 Jun 2017 13:45:57 -0700

We need largest acknowledged to go to 64 bits, because it's an absolute value, not relative to anything else.  I'm not sure an 8 bit largest acknowledged is that useful, so we could do 16/32/64, but most other things are 8/16/32/64, so I'd favor consistency.

64k is large, but given MTU's aren't increasing as quickly as bandwidth, I think we should enable a 32 bit block length.  A gigabit connection with a 1 second RTT is 89,000 1400 byte packets.

I think we have plenty of space for other frames anyway, so I'd favor changing the 48 bit length to 64 bits in both cases, since I can't come up with a good reason for 48 bits.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507#issuecomment-306065786

---

From: MikkelFJ <[email-masked]>
Date: Sun, 04 Jun 2017 14:10:01 -0700

Why does it have to be absolute? Can there be more than 2^31 bytes in flight? It might be resonable to have 2GB in flight for long fat pipes - but have all other frame formats and semantics been verified to not introduce any limitation here, if that is the case?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507#issuecomment-306067166

---

From: ianswett <[email-masked]>
Date: Mon, 05 Jun 2017 01:24:48 -0700

I think there are good reasons to make it absolute, particularly to support connection migration and/or multipath.

The in flight limit is 2^31 packets, so >2TB with typical packet sizes, which is why we decided not to add a code point for 8 byte packet numbers in the public header.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507#issuecomment-306131823

---

From: MikkelFJ <[email-masked]>
Date: Mon, 05 Jun 2017 01:36:58 -0700

yes, I got confused about packet numbers and bytes - the absolute value is probably beneficial as you suggest and does not apparent harm - I still wonder if the 2^31 constraint elsewhere makes the benefit pointless though, or put in another way - perhaps there are other places that need to allow 64 bit values.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507#issuecomment-306134216

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 20 Jun 2017 17:00:50 -0700

#644 is the ACK frame tracking issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507#issuecomment-309924788