Subject: [quicwg/base-drafts] correct the definition of the ACK FRAME N bit (#633)

From: Patrick McManus <[email-masked]>
Date: Thu, 15 Jun 2017 06:18:35 -0700

* it does not indicate if there is more than 1 range in the frame as
     even if present it may be 0

    * the num blocks field is not in the ack block section at all as stated
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/633

-- Commit Summary --

  * correct the definition of the ACK FRAME N bit

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/633.patch
https://github.com/quicwg/base-drafts/pull/633.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/633

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Jun 2017 16:35:09 -0700

Merged #633.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/633#event-1126027380

---

From: MikkelFJ <[email-masked]>
Date: Thu, 15 Jun 2017 23:13:58 -0700

That doesn't make sense to me. Why would it be optional if the count is 0. That just adds ambiguity. Then it should always be present and the N-bit removed, or it should not be permitted when the count is 0.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/633#issuecomment-308942433

---

From: ianswett <[email-masked]>
Date: Fri, 16 Jun 2017 07:40:59 -0700

>From an editorial perspective, I can see this as an improvement, even though I was initially confused.

I would like to only have one way to represent a single range, so I opened issue #635

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/633#issuecomment-309044183