Subject: Re: [quicwg/base-drafts] Stream ID 24-bit encoding? (#508)

From: ianswett <[email-masked]>
Date: Sun, 04 Jun 2017 13:50:17 -0700

8/16/32/64 would make sense and be more consistent, except we decided there wasn't a use for >32 bit stream ids.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#issuecomment-306066056

---

From: MikkelFJ <[email-masked]>
Date: Sun, 04 Jun 2017 14:36:37 -0700

If you have 100K IOPS each represented by a single frame, your connection will last 12 hours with 32 bit stream identifiers. Moving to 64 bit would mean you can design applications without thinking about this limitation even if it would rarely be hit in praxis.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#issuecomment-306068705

---

From: Lars Eggert <[email-masked]>
Date: Tue, 13 Jun 2017 07:09:22 -0700

-04 still allows "8, 16, 24, and 32 bits". If this is what it's going to be, we can close this issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#issuecomment-308128161

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Jun 2017 07:48:26 -0700

Well, if we want to remove 24, then we can still decide to remove 24.  I'm not a piece of seating, but I'm not seeing much movement toward resolution.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#issuecomment-308141068

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 08:06:51 -0700

I'd like to keep 24 around. My reasoning is that there is a non-zero benefit for having it, and > 32 is  not something we need to engineer for in this version. We can rev a version if we really need > 32. And since we're using 2 bits to represent stream ID size, makes sense to use 4 sizes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#issuecomment-308147190

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 08:07:41 -0700

I'll close the issue; please feel free to open it if you want to change the stream id sizes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#issuecomment-308147427

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 08:07:43 -0700

Closed #508.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#event-1121570747

---

From: MikkelFJ <[email-masked]>
Date: Tue, 13 Jun 2017 08:09:30 -0700

I would like a 64-bit stream id - because it completely removes the need for application logic to care about this limitation since other limits happen much earlier, and because it makes it viable to really throw away small streams on long living connections.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#issuecomment-308148025

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Jun 2017 08:30:10 -0700

@mikkelfj, we have discussed expanding the stream ID space to 64 bits and we explicitly decided not to.  If you have **new** information, please find the issue and add your new information there.  "I would like" isn't really strong enough to cause us to re-litigate the issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/508#issuecomment-308155332