Subject: [quicwg/base-drafts] Proxy context (#622)

From: MikkelFJ <[email-masked]>
Date: Sat, 10 Jun 2017 05:30:03 -0700

Would it make sense to have a X-Forwarded-For parameter at the transport level?

A HTTP/1.1 server could forward to HTTP/QUIC using HTTP headers. X-FORWARDED-FOR is generally useful and sometimes necessary in load balancer contexts.

QUIC could be terminated at an edge server that has access to certificates not available to backend servers. In this case a new QUIC connection may be created from edge server to backend. if the application protocol is not HTTP and the backend wants to filter against blacklists or whitelists, or log traffic, it must pass this information to the edge server. The connection could also be generic port forwarding like SSH -p.

Could this forwaring information meaningfully belong to the transport layer, for example in extended transport parameters? And for non-terminating middle boxes, could this amend the initial client packet with forwarding headers?

I realise that this is can of worms, but it least it is better to shoot it down knowlingly rather than to regret not adding it later on.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/622

---

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 07:54:56 -0700

Closed #622.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/622#event-1118264749

---

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 07:54:56 -0700

This feature is adequately addressed at the HTTP layer for HTTP, and the needs of other applications are best dealt with by adding messages to those protocols.

Note that in many cases, use of this sort of marking is in direct opposition to the goal of having an intermediary, namely privacy.  This is another reason that doing this in an application protocol makes good sense; a generic transport can't reasonably make good decisions about things like privacy.

Consider this one shot down. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/622#issuecomment-307569932