Subject: Re: [quicwg/base-drafts] Allow a client to send Public Reset (#466)

From: Brian Trammell <[email-masked]>
Date: Wed, 07 Jun 2017 05:03:21 -0700

See #215: decided in Paris to make this symmetric.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/466#issuecomment-306774095

---

From: MikkelFJ <[email-masked]>
Date: Thu, 22 Jun 2017 11:59:30 -0700

It appears that a client or server might not always be able to send a reset on the original communication path because the OS might not give access to the ephemeral port required. Perhaps some guidance is needed. I can't wrap my head around whether this is a real concern or not.

If a packet can be sent by other means, each connection could be indexed by the reset token previously received.

There is also the potential case where client and server both use fixed (non-ephemeral) ports in a symmeric p2p configuration, but that is not currently possible due 5-tuple uniqueness requirement, but a symmetric reset would be more important and easier to handle.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/466#issuecomment-310471660