Subject: [quicwg/base-drafts] Explicit End-to-Path Connection/Path End Signal (#602)

From: martinduke <[email-masked]>
Date: Wed, 07 Jun 2017 02:12:21 -0700

As discussed in Paris, there will be a secret signal between endpoints in "Public Reset" situations. The CONNECTION_CLOSE (or silent close) will also be invisible to the path.

This is desirable because it allows endpoints to operate in a maximum-privacy mode. However, a non-spoofable but widely readable end to path connection-is-over (or I'm-done-with-the path) signal or series of signals would, I submit, allow many internet systems to work better. The QUIC standard should specify a means of doing this, which would be optional (SHOULD?).

I think the PLUS working group is working on solutions that are relevant to this problem.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/602

---

From: martinduke <[email-masked]>
Date: Wed, 07 Jun 2017 02:13:16 -0700

This is a descendant of Issue #353.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/602#issuecomment-306738011

---

From: Brian Trammell <[email-masked]>
Date: Wed, 07 Jun 2017 02:14:46 -0700

...well, there's not a PLUS working group, but a lot of thought about how to design mechanisms for this went into the preparation for the PLUS BoF... 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/602#issuecomment-306738397