Subject: Re: [quicwg/base-drafts] Prune transport error codes (#467)

From: Martin Thomson <[email-masked]>
Date: Wed, 07 Jun 2017 05:53:00 -0700

Discussed in Paris; we're going to add the frame-specific codes in *addition* to the generic one.

We'll remove ENHANCE_YOUR_CALM from this one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/467#issuecomment-306785314

---

From: MikkelFJ <[email-masked]>
Date: Wed, 07 Jun 2017 06:14:20 -0700

mikkelfj commented on this pull request.

> @@ -1213,7 +1213,7 @@ server MUST check that it would have sent a version negotiation packet if it had
 received a packet with the indicated initial_version.  If a server would have
 accepted the version included in the initial_version and the value differs from
 the value of negotiated_version, the server MUST terminate the connection with a
-QUIC_VERSION_NEGOTIATION_MISMATCH error.
+VERSION_NEGOTIATION_ERROR error.

I am having some trouble understanding how to send this error https://github.com/quicwg/base-drafts/issues/597 - but it might be resolved with updated PUBLIC_RESET to replace CONNECTION_CLOSE.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/467#pullrequestreview-42597705

---

From: Martin Thomson <[email-masked]>
Date: Tue, 20 Jun 2017 23:25:48 -0700

@janaiyengar, I've rebased and updated this with what we agreed at the interim.  There is now a generic frame format error, and a set of frame-type-specific errors.  I removed ENHANCE_YOUR_CALM.

I went over the error codes that you added back in #521 and I'm going to suggest that we separate those out.  Some depend on the conclusion of #608, and I *think* that the others aren't useful to signal.  I'm sure that I'm wrong about at least one, but we should discuss them separately.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/467#issuecomment-309975900

---

From: ianswett <[email-masked]>
Date: Wed, 21 Jun 2017 11:23:23 -0700

ianswett approved this pull request.

Thanks for rewriting this change.  LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/467#pullrequestreview-45520878

---

From: janaiyengar <[email-masked]>
Date: Wed, 21 Jun 2017 17:16:01 -0700

I'm not sure which ones from #521 are not added in here. I wouldn't remove ones that we need discussion on... If you want to discuss ones that are in #521, please add them back in and have a separate issue on removing them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/467#issuecomment-310239806

---

From: janaiyengar <[email-masked]>
Date: Tue, 27 Jun 2017 15:47:25 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/467#pullrequestreview-46701908

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Jun 2017 15:54:14 -0700

Merged #467.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/467#event-1141444819