Subject: [quicwg/base-drafts] Identify, if possible, a common application protocol pattern for graceful shutdown (#604)

From: hardie <[email-masked]>
Date: Wed, 07 Jun 2017 04:30:51 -0700

Martin Thomson's presentation in Paris proposed a pattern in which the application layer protocol manages graceful shutdown by using timeouts.  It might also define  in its mapping documents an explicit signal from the application protocol to the transport for graceful shutdown.  

After discussion, we agreed to consider an additional pattern, common across applications, that would allow an application protocol to gracefully close a transport without having to define an explicit signal.  Two initial ideas (both with some issues) are closing all streams and forcing idle state by setting the stream maximum to 0.

This issue is to track further discussion of possible patterns that might work for this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/604

---

From: mirjak <[email-masked]>
Date: Wed, 07 Jun 2017 04:34:12 -0700

One or multiple showdown procedures can/should be described in the applicability document (based on one or multiple protocol mechanisms quic provides). Further we already discussed at the last meeting (in Chicago) that we might want another document to describe an (abstract) application interface.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/604#issuecomment-306768234