Subject: Re: [quicwg/base-drafts] Largest sequence number (47b685c)

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Jun 2017 12:59:10 -0700

Isn't this better to factor out the language about when to flip into surrounding text?  I mean, both client and server trigger a change in what they send based on receiving a different value in a packet that also increases their largest received sequence number.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/47b685c7f071a10170b70a0dc816315353688bdb#commitcomment-22794480

---

From: ianswett <[email-masked]>
Date: Tue, 27 Jun 2017 13:12:39 -0700

@martinthomson  I think the extra clarity is worth an extra few words in this case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/47b685c7f071a10170b70a0dc816315353688bdb#commitcomment-22794721

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Jun 2017 14:09:16 -0700

I agree, but I think that you can factor this AND make it a lot clearer at the same time, e.g.,

> An endpoint updates the value of the bit in response to receiving packets from its peer.  Only packets that increase the largest received packet number cause this change, otherwise a single change could be mistakenly recognized as multiple changes when packets containing different values are reordered.  When a packet that increases the largest packet number is received on a given network path an endpoint sets the value that it includes in future packets:
> * a client changes its value to the opposite of the value it receives
> * a server changes its value to the value that it receives 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/47b685c7f071a10170b70a0dc816315353688bdb#commitcomment-22795947

---

From: ianswett <[email-masked]>
Date: Tue, 27 Jun 2017 14:33:28 -0700

Thanks for the text, your suggestion looks good to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/47b685c7f071a10170b70a0dc816315353688bdb#commitcomment-22796473