Subject: [quicwg/base-drafts] stray 0x21 in HKDF-Expand info construction (#665)

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Sun, 25 Jun 2017 18:24:04 -0700

https://quicwg.github.io/base-drafts/draft-ietf-quic-tls.html#rfc.section.5.2.2 describes info parameter for HKDF-Expand.  The struct HKDFLabel does not contain 0x21 ("!"), but its example contains it:

```
 info = (HashLen / 256) || (HashLen % 256) || 0x21 ||
          "tls13 QUIC client 1-RTT secret" || 0x00
```

I couldn't find it in TLSv1.3 draft or RFC 5869.
Is it a practice to insert 0x21 after Length, or just a remnant of earlier draft?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/665

---

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Jun 2017 09:21:10 -0700

This value is incorrect, but it's necessary.  The value changed in a recent PR and I missed the update.  It should be 0x1f - the length of the label string.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/665#issuecomment-311109174

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Mon, 26 Jun 2017 09:34:33 -0700

Thank you. That's make sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/665#issuecomment-311112788

---

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Jun 2017 16:09:26 -0700

Closed #665 via #666.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/665#event-1139578384