Subject: [quicwg/base-drafts] Refer to all octets by number (#651)

From: Martin Thomson <[email-masked]>
Date: Tue, 20 Jun 2017 23:30:28 -0700

Closes #580
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/651

-- Commit Summary --

  * Refer to all octets by number

-- File Changes --

    M draft-ietf-quic-transport.md (14)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/651.patch
https://github.com/quicwg/base-drafts/pull/651.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/651

---

From: Martin Thomson <[email-masked]>
Date: Tue, 20 Jun 2017 23:37:40 -0700

@martinthomson pushed 1 commit.

2ad5aeb  Long line

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/651/files/8f9c8bb7ee425524469d0561b5e66dc1b59c99a2..2ad5aeb7f8ae4b682a44f870de0a7832ea1ab87a

---

From: ianswett <[email-masked]>
Date: Tue, 27 Jun 2017 13:07:47 -0700

ianswett commented on this pull request.

Two small suggestions.

> @@ -461,24 +461,24 @@ This header form has the following fields:
 
 Header Form:
 
-: The most significant bit (0x80) of the first octet of a packet is the header
+: The most significant bit (0x80) of the octet 0 of a packet is the header

This text is a bit redundant to the "Header Form" section above, and the sentence is a bit awkward.  Can you just say "The most significant bit (0x80) of octet 0 is set to 0 for the short header."?

>    form.  This bit is set to 0 for the short header.
 
 Connection ID Flag:
 
-: The second bit (0x40) of the first octet indicates whether the Connection ID
+: The second bit (0x40) of the octet 0 indicates whether the Connection ID

nit: I'd change "the octet 0" to "octet 0", here and below.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/651#pullrequestreview-46662275

---

From: ianswett <[email-masked]>
Date: Wed, 28 Jun 2017 16:20:05 -0700

ianswett approved this pull request.

One more nit, but looks good.

 Long Packet Type:
 
-: The remaining seven bits of first octet of a long packet is the packet type.
-  This field can indicate one of 128 packet types.  The types specified for this
+: The remaining seven bits of octet 0 of a long packet is the packet type.  This

nit: is => are?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/651#pullrequestreview-46993768

---

From: ianswett <[email-masked]>
Date: Wed, 28 Jun 2017 16:22:57 -0700

Long Packet Type:

I think "of a long packet" is redundant given "Long Packet Type:" is the title as well, and it makes the sentence a bit awkward.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/651#discussion_r124680604

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Jun 2017 16:37:39 -0700

e135688  Remove long packet and rely on context instead

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/651/files/7ac65235971bb850eece5bc67bea5788c7391c7d..e135688ddbc77ec47f872754793e87c5428183c0

---

From: Martin Thomson <[email-masked]>
Date: Thu, 29 Jun 2017 09:50:22 -0700

Merged #651.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/651#event-1144593868