Subject: [quicwg/base-drafts] consider making cleartext integrity version independent (#568)

From: Patrick McManus <[email-masked]>
Date: Sat, 03 Jun 2017 05:50:42 -0700

making the cleartext integrity checksum version independent would prevent a lot of version negotiation packets from being generated based on receipt of non-quic (and make it harder to use that as an amplification vector?)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/568

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Jun 2017 18:49:43 -0700

If version negotiation is amplifying, something is badly wrong.

I believe that version negotiation should only be generated for packets that exceed a certain size (because the only packet that it makes sense to send version negotiation in response to is an initial client packet and those are guaranteed* to be pretty big*).  That is, for some version of a guarantee and some version of big.  Note however that we don't have that written down (or even agreed).

As for being able to distinguish noise from QUIC, that's a good reason.  We should discuss that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/568#issuecomment-306012205

---

From: Patrick McManus <[email-masked]>
Date: Sun, 04 Jun 2017 07:02:50 -0700

re: amp - that's a versioning guarantee thing again.. a v1 initial client packet is pretty big.. but a >1 packet received by a v1 server? we have very few rules about the future.. maybe we need a few.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/568#issuecomment-306041911

---

From: Martin Thomson <[email-masked]>
Date: Mon, 05 Jun 2017 02:05:10 -0700

Yes, some constraints on future flexibility seem wise, as long as we can keep it light.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/568#issuecomment-306139819