Subject: [quicwg/base-drafts] Connection Close retransmission (#636)

From: MikkelFJ <[email-masked]>
Date: Sat, 17 Jun 2017 23:21:29 -0700

The connection close is sent as a sort of last resort on errors, but may also a clean shutdown or at least a controlled shutdown. The current transmission and recovery drafts do not appear to guide the behavior in these different schenarios, notably if, how and when to retransmit connection close.

The problem with this is a potentially unnecessary risk of hung connections that wait for long idle timeouts on packet loss. This can badly influence latency sensitive services.

One option would be to send multiple packets a short time apart when possible and practical. The second close packet could be prepared and thus most connection state can be torn down immediately.

The GO_AWAY frame can be use when a shutdown is controlled, but it does not handle any error codes  and does not handle when there really is an unrecoverable error.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/636

---

From: MikkelFJ <[email-masked]>
Date: Sat, 17 Jun 2017 23:27:11 -0700

Closed #636.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/636#event-1128049087

---

From: MikkelFJ <[email-masked]>
Date: Sat, 17 Jun 2017 23:27:10 -0700

This is covered in draft, I just missed it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/636#issuecomment-309259584