Subject: [quicwg/base-drafts] packet number text limitation on 32 bits of packet number (#566)

From: Patrick McManus <[email-masked]>
Date: Thu, 01 Jun 2017 10:40:42 -0700

5.8 introduces the fact that only the least significant bits of a packet number are transmitted and it goes on to say at most 32.

But acks can use 48.

I suggest fixing by just leaving out the number.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566

---

From: mirjak <[email-masked]>
Date: Thu, 01 Jun 2017 15:31:17 -0700

I was about to fill the same issue this afternoon (and then got distracted). We could remove the number completely or say that the internal packet number size must be at least 64 bits

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566#issuecomment-305638771

---

From: Martin Thomson <[email-masked]>
Date: Thu, 01 Jun 2017 16:30:08 -0700

I think that we separately agreed to remove the 48 from the ACK frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566#issuecomment-305648372

---

From: Lars Eggert <[email-masked]>
Date: Fri, 02 Jun 2017 02:29:00 -0700

Yes, see #507 (and #508)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566#issuecomment-305737662

---

From: Lars Eggert <[email-masked]>
Date: Tue, 13 Jun 2017 07:23:16 -0700

-04 still allows 48 bits in the ACK frame?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566#issuecomment-308132789

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Jun 2017 07:49:21 -0700

Only because we didn't get around to making those changes.  We agreed to move fast on -04 and we didn't have a PR for removing 48.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566#issuecomment-308141387

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 07:59:29 -0700

this is a dup of #507 so closing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566#issuecomment-308144821

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Jun 2017 07:59:29 -0700

Closed #566.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566#event-1121553230

---

From: ianswett <[email-masked]>
Date: Tue, 13 Jun 2017 12:02:57 -0700

I didn't realize we were cutting 04 today, but PR #629 has now fixed the 48 bit issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/566#issuecomment-308216225