Subject: [quicwg/base-drafts] Stateless retry relation to version negotiation (#669)

From: MikkelFJ <[email-masked]>
Date: Tue, 27 Jun 2017 01:46:52 -0700

If a server decides to send a version negotiation packet and also a stateless retry, which one should it choose, and should the client retain a negotiated version if it receives a stateless retry? If it does not, the cryptographic context in the retry might not make sense but text says to start new connection state.

Also, retry might be related to which server version is supported, so there could potentially be a lot of ping pong going on. On the other hand, a retry might not know the versions supported by other servers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/669

---

From: MikkelFJ <[email-masked]>
Date: Tue, 27 Jun 2017 01:58:47 -0700

Wasn't mentioned in version negotation nor in Stateless Retry section, but stateless retry packet does section mention it:
"the client MUST remember the results of any version negotiation that occurred "

I keep the issue open for review in case the text can be clarified a bit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/669#issuecomment-311297121

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Jun 2017 11:49:13 -0700

This isn't really a valid question.  The draft is pretty clear that version negotiation happens before stateless retry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/669#issuecomment-311450316

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Jun 2017 11:49:13 -0700

Closed #669.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/669#event-1141091277