Subject: [quicwg/base-drafts] Move version-independent pieces to a "core" document (#615)

From: Mike Bishop <[email-masked]>
Date: Thu, 08 Jun 2017 05:50:18 -0700

Several existing sub-issues around what is version-independent.  I'm proposing that the cross-version envelope of QUIC should be a separate final RFC, and therefore a separate document now.  If we landed that split, it would resolve several other questions about what, specifically, is supposed to be cross-version.

I would argue that version negotiation and everything that's visible outside the encryption envelope belongs in this separate draft.  It's the piece that will ossify, and that we're willing to have ossified.  Everything that's version-dependent belongs in the specific version, which is the Transport draft.

However, I'll note that the current split means that packet protection and framing live inside the version.  That means there's a lot that will need to be re-stated in a new version -- are we okay with that?

See PR #600.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/615

---

From: Martin Thomson <[email-masked]>
Date: Sat, 10 Jun 2017 10:35:43 -0700

I'd prefer not to do this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/615#issuecomment-307579506

---

From: Patrick McManus <[email-masked]>
Date: Sat, 10 Jun 2017 14:33:13 -0700

no more documents please - the crossrefs are hard enough to deal with already

Perhaps a short section in transport recapping the invariants used elsewhere in the doc would be helpful as an alternative?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/615#issuecomment-307591543