Subject: [quicwg/base-drafts] quic-tls is the wrong doc to talk about integrity check for unprotected packets (#617)

From: Lars Eggert <[email-masked]>
Date: Thu, 08 Jun 2017 11:36:54 -0700

I totally missed that the FNV-1a stuff was added to quic-tls. I had not followed that doc recently, because my code doesn't do any TLS yet. Only when I couldn't find anything about FNV-1a in quic-transport did I start to grep through the text, and found section 6 of quic-tls.

IMO that is the wrong document to talk about this, since this has nothing to do with TLS. I would move that section into quic-transport.

Alternatively, quic-transport needs a pointer to that section of quic-tls, because nothing in quic-transport alerts a reader to the existence of the hash.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/617

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Jun 2017 00:07:38 -0700

The plan, provided that people stop opening editorial issues, is to move all of the packet protection stuff to -transport.  Adding the text to -tls draft means that it can be moved with the other pieces.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/617#issuecomment-307313173

---

From: Lars Eggert <[email-masked]>
Date: Fri, 09 Jun 2017 00:27:40 -0700

Sorry, I didn't know that was the plan. It's a good plan. Do it :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/617#issuecomment-307316773

---

From: Patrick McManus <[email-masked]>
Date: Fri, 09 Jun 2017 01:44:56 -0700

purely as a stopgap, transport does say "The payload of cleartext packets
also includes an integrity check, which is described in [QUIC-TLS]
<https://quicwg.github.io/base-drafts/draft-ietf-quic-transport.html#QUIC-TLS>."
which alerts you to the hash.

On Friday, June 9, 2017, Lars Eggert <[email-masked]> wrote:

> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/617#issuecomment-307316773>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AAP5s1gKD_pu28FYhH52MZTzKTByCjzbks5sCPPrgaJpZM4N0dhq>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/617#issuecomment-307332260