Subject: Re: [quicwg/base-drafts] Transport shouldn't be cancelling streams (#485)

From: Mike Bishop <[email-masked]>
Date: Fri, 05 May 2017 10:54:13 -0700

The hazard with that split is that it also quietly eliminates the ability to consider a stream (application) error as fatal to the connection.  If you send me malformed HTTP frames, I might want to stop talking to you.  If application errors *can't* go in the CONNECTION_CLOSE, then I can't communicate why.

On the other hand, if we leave them partitioned with the app at the low end, we could say that only app codes can be in RST_STREAM and that frame has a smaller error space as a result.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/485#issuecomment-299532245

---

From: Martin Thomson <[email-masked]>
Date: Sun, 07 May 2017 16:42:07 -0700

@MikeBishop, I thought of that.  The application would signal its errors in the affected stream then use a new transport code (APPLICATION_ERROR) for the CONNECTION_CLOSE.  Or something like that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/485#issuecomment-299744182

---

From: Mike Bishop <[email-masked]>
Date: Sun, 07 May 2017 19:47:16 -0700

...without reliable delivery of said application error, no?  The problem is that stream data is inherently lossy in the presence of errors.  If we want to change *that*, fine, but it seems like an even bigger change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/485#issuecomment-299760270

---

From: Martin Thomson <[email-masked]>
Date: Sun, 07 May 2017 21:00:59 -0700

If we create a recommendation to follow what Google already does for conection-level errors, it's not an issue.  That is, they retransmit the last packet verbatim, which could include the RST_STREAM frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/485#issuecomment-299767811