Subject: [quicwg/base-drafts] Enumerate rules for not generating acks (#563)

From: janaiyengar <[email-masked]>
Date: Wed, 31 May 2017 11:57:35 -0700

As pointed out by mcmanus@, since there are packet types that echo the packet number, these must not generate acks. This should be explicitly noted. Similarly, it may be helpful to explicitly list the frame types that must not generate acks (all non-retransmittable frames).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/563

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 May 2017 18:41:09 -0700

Maybe it would be better to enumerate the reliability options more generally.  For instance:

The client automatically repairs its Client Initial packet by sending it on a timer.  A server repairs Version Negotiation and Stateless Reject packets by sending one for each packet that it receives, so usually this chains off the client's strategy.  After that, packets are repaired using ACK frames.  All other packets are acknowledged using ACK frames, except those that only contain ACK and PADDING frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/563#issuecomment-305365056