Subject: [quicwg/base-drafts] Rename connection id (#502)

From: Martin Thomson <[email-masked]>
Date: Wed, 03 May 2017 22:29:10 -0700

@britram points out that this ceased to be an identifier some time ago. That doesn't mean that the name needs to change. We all seem capable of dealing with this minor disconnect, after all. But we might want to at least consider giving some thought to finding a more appropriate name. 

This is bike shed territory. I expect that editors will ultimately have to exercise discretion. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502

---

From: Brian Trammell <[email-masked]>
Date: Thu, 04 May 2017 01:41:21 -0700

Either way. I decided to mention it after a discussion with a student here doing some implementation. His design showed evidence of confusion about what this value was for, an effect of taking the implication of identifier semantics as literal and ironclad.

This is editorial, a document usability issue, but I think we have an opportunity here to influence the kinds of errors that will come up in implementations from the document.

> On 04 May 2017, at 07:29, Martin Thomson <[email-masked]> wrote:
> 
> —
> You are receiving this because you were mentioned.
> Reply to this email directly, view it on GitHub, or mute the thread.
> 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299127602

---

From: Martin Thomson <[email-masked]>
Date: Thu, 04 May 2017 01:51:17 -0700

You aren't the only one to have encountered the problem.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299129539

---

From: janaiyengar <[email-masked]>
Date: Thu, 04 May 2017 18:33:39 -0700

I'll admit to not having encountered this problem. What do you think Connection ID is?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299351502

---

From: Martin Thomson <[email-masked]>
Date: Thu, 04 May 2017 18:41:29 -0700

*I* think that the connection ID is just something you put in a packet that allows it to end up in the right place.  Other people attribute greater stability and significance to it.  That is that it identifies the connection.  It doesn't.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299352224

---

From: janaiyengar <[email-masked]>
Date: Thu, 04 May 2017 19:33:05 -0700

There's nothing in the word "identifier" that suggests immutability or that it's the only one. Connection ID identifies connection state at the endpoints and the serving process at load balancers, so it'd be odd to call it anything else.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299357150

---

From: Martin Thomson <[email-masked]>
Date: Thu, 04 May 2017 19:40:30 -0700

There's a common misconception that there is a one-to-one mapping between a thing and its identifier.  For instance, a legal name for a person.

An "address" has all the properties you describe, as does a "locator".  So does an MPLS flow label.  I'm not saying that these are better names, just that there are alternatives that don't have the same baggage.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299357738

---

From: janaiyengar <[email-masked]>
Date: Thu, 04 May 2017 19:53:14 -0700

yes, agreed that they're not better - they all have baggage :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299358759

---

From: Lars Eggert <[email-masked]>
Date: Thu, 04 May 2017 23:07:58 -0700

The CID (or actually sequence of CIDs a connection may use) identifies the connection to the endpoints - but no longer to the network. Maybe stating that somewhere would be helpful?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299390334

---

From: Brian Trammell <[email-masked]>
Date: Fri, 05 May 2017 00:57:58 -0700

+1 to @larseggert -- "connection ID" can tend to imply more than we mean about what it's for.

<bikeshed> I'm a fan of "*something* token" for this design pattern, personally: it's a thing I give you which I expect you to give me back at some point, there's some contract that specifies what I do for you when you give it back to me, but otherwise what I do with it is completely opaque to you. I don't have any good, light-travleing suggestions for *something* though. :/ </bikeshed>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299404871

---

From: Lars Eggert <[email-masked]>
Date: Fri, 05 May 2017 01:11:48 -0700

Why is *something* not *connection*? I think the confusion may stem from the word *identifier*, not the word *connection*.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299407244

---

From: Brian Trammell <[email-masked]>
Date: Fri, 05 May 2017 02:00:23 -0700

Hm, indeed. Certainly much more confusion stems from "identifier". I'd be happy with "connection token".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299415935

---

From: ekr <[email-masked]>
Date: Fri, 05 May 2017 06:31:53 -0700

I'm actually with Jana here.

If we move to a one-CID per packet, I might feel differently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299465261

---

From: janaiyengar <[email-masked]>
Date: Fri, 05 May 2017 18:29:03 -0700

You can have many identifiers for the same thing. There can't be collisions, and that's true of connection IDs. A connection ID maps to a sequence of n packets.

Different folks can imagine it becoming different things. You can think of it as Blah ID (since it identifies something -- a flowlet? a packet? -- we don't know what), or Connection Blah (since it is associated with the connection, we don't know exactly how... perhaps it identifies the entire connection, perhaps it doesn't.)

I think stating that it's a Connection ID, and a client MAY change it over the lifetime of a connection from none to several times is adequate signal to anyone thinking about how to use it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-299607151

---

From: ianswett <[email-masked]>
Date: Fri, 12 May 2017 18:18:09 -0700

If we'd like to be a bit more accurate, it seems like Path ID would be a good option.  We could also head towards something like 'routing token', but that seems more confusing than helpful to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-301216424

---

From: ekr <[email-masked]>
Date: Fri, 12 May 2017 19:14:43 -0700

I suggest we hold off on this terminology issue until we resolve whether we are going to be having a big pile of conn ids. If, for instance, we have a new one for each packet, we might want a different name

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/502#issuecomment-301219220