Subject: [quicwg/base-drafts] QUIC TLS IANA considerations (#532)

From: Sean Turner <[email-masked]>
Date: Tue, 16 May 2017 15:20:05 -0700

Closes #511.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/532

-- Commit Summary --

  * Adding a drafty IANA Considerations section
  * Fixing some spelling and spacing errors
  * Fixing some grammar

-- File Changes --

    M draft-ietf-quic-tls.md (25)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/532.patch
https://github.com/quicwg/base-drafts/pull/532.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/532

---

From: ekr <[email-masked]>
Date: Tue, 16 May 2017 15:33:30 -0700

ekr requested changes on this pull request.

> @@ -1517,8 +1517,25 @@ TLS_FATAL_ALERT_RECEIVED (0xC000001E):
 
 # IANA Considerations
 
-This document has no IANA actions.  Yet.
-
+This document does not create any new IANA registries, but it does utilize the
+following registries;
+
+* QUIC Transport Parameter Registry {{QUIC-TRANSPORT}} - This registry
+uses the Specificatino Required policy {{!RFC5226}}.  IANA is to register the

Is there a need to note the policy, here and below?

> @@ -1517,8 +1517,25 @@ TLS_FATAL_ALERT_RECEIVED (0xC000001E):
 
 # IANA Considerations
 
-This document has no IANA actions.  Yet.
-
+This document does not create any new IANA registries, but it does utilize the
+following registries;
+
+* QUIC Transport Parameter Registry {{QUIC-TRANSPORT}} - This registry
+uses the Specificatino Required policy {{!RFC5226}}.  IANA is to register the
+three values found in {{errors}.
+
+* TLS ExtensionsType Registry {{?I-D.ietf-tls-iana-registry-updates}} - This
+registry uses the Specifiation Required policy {{RFC5226}}.  IANA is to register

Misspelling around specification required

> @@ -1517,8 +1517,25 @@ TLS_FATAL_ALERT_RECEIVED (0xC000001E):
 
 # IANA Considerations
 
-This document has no IANA actions.  Yet.
-
+This document does not create any new IANA registries, but it does utilize the
+following registries;
+
+* QUIC Transport Parameter Registry {{QUIC-TRANSPORT}} - This registry
+uses the Specificatino Required policy {{!RFC5226}}.  IANA is to register the
+three values found in {{errors}.
+
+* TLS ExtensionsType Registry {{?I-D.ietf-tls-iana-registry-updates}} - This
+registry uses the Specifiation Required policy {{RFC5226}}.  IANA is to register
+the quic_transport_parameters extension found in {{quic_parameters}}.  Assigning
+26 to the extensino would be greatly appreciated.  The Recommended column is to

extension

> +* QUIC Transport Parameter Registry {{QUIC-TRANSPORT}} - This registry
+uses the Specificatino Required policy {{!RFC5226}}.  IANA is to register the
+three values found in {{errors}.
+
+* TLS ExtensionsType Registry {{?I-D.ietf-tls-iana-registry-updates}} - This
+registry uses the Specifiation Required policy {{RFC5226}}.  IANA is to register
+the quic_transport_parameters extension found in {{quic_parameters}}.  Assigning
+26 to the extensino would be greatly appreciated.  The Recommended column is to
+be marked Yes.
+
+* TLS Exporter Label Registry {{?I-D.ietf-tls-iana-registry-updates}} - This
+registry uses the Specification Required policy {{RFC5226}.  IANA is requested
+to register "EXPORTER-QUIC 0-RTT Secret" from {{0-rtt-secrets}} and
+"EXPORTER-QUIC client 1-RTT Secret" and
+"EXPORTER-QUIC server 1-RTT Secret" from {{1-rtt-secrets}}.  The DTLS column is
+to be marked Yes.  The Recommended column is to be marked Yes.

Why would DTLS be "Yes"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/532#pullrequestreview-38530543

---

From: Sean Turner <[email-masked]>
Date: Tue, 16 May 2017 15:40:17 -0700

seanturner commented on this pull request.

 # IANA Considerations

I don't think it's strictly required.  Including it will save the chairs chasing down the registry policy, but maybe that's not a good enough reason to include it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/532#discussion_r116875338

---

From: Sean Turner <[email-masked]>
Date: Tue, 16 May 2017 15:43:41 -0700

Whoops

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/532#discussion_r116875845

---

From: Sean Turner <[email-masked]>
Date: Tue, 16 May 2017 15:44:53 -0700

@seanturner pushed 1 commit.

a341c56  Resolving ekr's review comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/532/files/8391d0f42f694860d585ee394d4b906e1549e3ab..a341c561af78ad5fcf46afc1dff5d5889ac0c6ff

---

From: Sean Turner <[email-masked]>
Date: Tue, 16 May 2017 15:46:08 -0700

47bca48  Making exporters Recommended: Yes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/532/files/a341c561af78ad5fcf46afc1dff5d5889ac0c6ff..47bca4846c50db62d6715ec6be5008a47d126a73

---

From: ekr <[email-masked]>
Date: Tue, 16 May 2017 15:52:31 -0700

ekr approved this pull request.

LGTM with the changes below

> @@ -1517,8 +1517,21 @@ TLS_FATAL_ALERT_RECEIVED (0xC000001E):
 
 # IANA Considerations

This should be a colon, not a semicolon

+* QUIC Transport Parameter Registry - IANA is to register the three values found
+in {{errors}.

I am assuming you want }}

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/532#pullrequestreview-38533594

---

From: Sean Turner <[email-masked]>
Date: Tue, 16 May 2017 15:59:52 -0700

f197ab0  Fixing even more errors

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/532/files/47bca4846c50db62d6715ec6be5008a47d126a73..f197ab09e68e7d5165a870b9adf1402637b20658

---

From: Martin Thomson <[email-masked]>
Date: Wed, 17 May 2017 05:05:34 -0700

Merged #532.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/532#event-1085847925