Subject: [quicwg/base-drafts] A server can't send SETTINGS first (#515)

From: Martin Thomson <[email-masked]>
Date: Tue, 09 May 2017 21:14:17 -0700

Stream 1 is a client-initiated stream.  That means that the server can't send its SETTINGS frame to the client until it reads the end of the client handshake and stream 1 is opened.  That's annoying because the server could otherwise send frames to the client after it sends its ServerHello.

In addition to SETTINGS, the server might use this otherwise dead air to send things like ORIGIN frames or secondary certificates.

This would not be a problem if streams were unidirectional ;)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/515

---

From: janaiyengar <[email-masked]>
Date: Wed, 10 May 2017 22:44:13 -0700

Alternatively, Stream 2 is available.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/515#issuecomment-300688409

---

From: janaiyengar <[email-masked]>
Date: Wed, 10 May 2017 22:47:21 -0700

If there are specific things that you'd want the server to be able to send, we could reserve stream 2 for it. But I suppose SETTINGS would need to be received before the client processes things on stream 1, right? In which case, ordering between stream 1 and 2 will become an issue... hm.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/515#issuecomment-300688795