Subject: [quicwg/base-drafts] Limit RTO? (#556)

From: Lucas Clemente <[email-masked]>
Date: Wed, 24 May 2017 07:04:54 -0700

In the current version of the loss recovery draft there's neither a maximum exponent, nor an absolute maximum for the RTO timeout. (In gQUIC these are 10 and 60ms.) Is this an intentional omission?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/556

---

From: ianswett <[email-masked]>
Date: Wed, 24 May 2017 07:17:18 -0700

Good point, in practice GQUIC almost always hits the idle timeout long before those limits are hit, particularly the max exponent.

I think we should say something about a max, and make it clear either there should not be one, or that there should be and what it is.  I can see the benefits of both.

Suggestions?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/556#issuecomment-303737642

---

From: Lucas Clemente <[email-masked]>
Date: Wed, 24 May 2017 07:27:48 -0700

Seems reasonable for the exponent, but I'm not sure the max timeout value can be discarded so easily. 60ms is much shorter than the ICSL, so it should make a difference from time to time, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/556#issuecomment-303740720

---

From: Lucas Clemente <[email-masked]>
Date: Wed, 24 May 2017 07:29:19 -0700

Oh wait, nvm. I though it was 60ms, but it's 60s. Then I agree with you fully.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/556#issuecomment-303741196

---

From: ianswett <[email-masked]>
Date: Wed, 24 May 2017 07:31:46 -0700

Yes, 60ms as a max would be insanely short.  I thought you just mis-typed before.

Should I document the 60s max then?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/556#issuecomment-303741983

---

From: Lucas Clemente <[email-masked]>
Date: Wed, 24 May 2017 07:40:25 -0700

Closed #556.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/556#event-1095713672

---

From: Lucas Clemente <[email-masked]>
Date: Wed, 24 May 2017 07:40:24 -0700

Sorry, just had a brainfart there… I don't think it really makes a difference then, just wanted to make sure it was intentional.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/556#issuecomment-303744790

---

From: MikkelFJ <[email-masked]>
Date: Wed, 24 May 2017 07:40:41 -0700

I haven't read the details, but quic input here: different applications might want different timeouts. 60s sounds fine, but certain low latency applications might want to disconnect if it doesn't get a response much sooner than that and choose another peer. Point being, make room for this in spec.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/556#issuecomment-303744886