Subject: Re: [quicwg/base-drafts] Add skipped packets detection to the OnAckReceived pseudocode (#415)

From: Martin Thomson <[email-masked]>
Date: Sun, 21 May 2017 21:39:41 -0700

martinthomson commented on this pull request.

> @@ -332,6 +332,9 @@ Pseudocode for OnPacketSent follows:
 
 When an ack is received, it may acknowledge 0 or more packets.
 
+The sender MUST abort the connection if it receives an ACK for a packet it
+never sent, see {{QUIC-TRANSPORT}}.

This doesn't say what error to use, if any.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/415#pullrequestreview-39384238

---

From: Martin Thomson <[email-masked]>
Date: Sun, 21 May 2017 21:40:20 -0700

Hmm, also, this is the wrong draft to put that text in.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/415#issuecomment-302997765