Subject: [quicwg/base-drafts] type octet language and public reset value (#527)

From: Patrick McManus <[email-masked]>
Date: Tue, 16 May 2017 11:28:42 -0700

transport commonly refers to a type octet when referring to long header packet types.. (e.g. 0x88) but the type field is defined as 7 bits and the long header packet type table lists values without the high bit (e.g. 0x08). I think we're better off without the type octet concept.

Also, public reset is defined in the table as having value 9, but in 5.6 as having a type octet of 0x88 which is already used by keyphase 1 protected packets. I think 9/0x89 is the intention. I would open a separate issue, but the merge conflict is inevitable :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/527

---

From: janaiyengar <[email-masked]>
Date: Tue, 16 May 2017 14:12:21 -0700

"type field", then? 
or we can go with "type septet" :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/527#issuecomment-301917018

---

From: janaiyengar <[email-masked]>
Date: Tue, 16 May 2017 14:22:02 -0700

I think this change sounds reasonable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/527#issuecomment-301919521

---

From: janaiyengar <[email-masked]>
Date: Tue, 16 May 2017 14:46:37 -0700

Closed #527.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/527#event-1084983013

---

From: janaiyengar <[email-masked]>
Date: Tue, 16 May 2017 14:46:37 -0700

Addressed in #528 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/527#issuecomment-301925255