Subject: [quicwg/base-drafts] Refactor "Packetization and Reliability" section (#505)

From: janaiyengar <[email-masked]>
Date: Thu, 04 May 2017 18:26:44 -0700

This is mostly editorial work, but there's an addition that I recommend. To avoid packets getting dropped in the network later in a connection, all packets in a connection MUST be no larger than the first packet in the connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/505

---

From: ekr <[email-masked]>
Date: Thu, 04 May 2017 18:30:03 -0700

Maybe I'm confused, but doesn't this basically preclude any kind of PMTU discovery. My reasoning is:

1. The first packet MUST be safe to send, so ~1280 bytes.
2. If I can't send any packet later, then I can't probe for higher MTUs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/505#issuecomment-299351119

---

From: Martin Thomson <[email-masked]>
Date: Thu, 04 May 2017 18:40:04 -0700

Yep, this would seem to contradict what we've already decided.  Also, it's hardly editorial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/505#issuecomment-299352081

---

From: janaiyengar <[email-masked]>
Date: Thu, 04 May 2017 19:18:16 -0700

@ekr: Right, sorry, I misspoke. The point was to say that a client should use higher packet sizes only if it's actively doing PMTUD. I wasn't clear in my description.

@martinthomson My intent was different than the words that came out; I don't believe what I just clarified contradicts what we have. I've added a design label and happy to split this issue out into a separate one from the refactor.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/505#issuecomment-299355722

---

From: Martin Thomson <[email-masked]>
Date: Thu, 04 May 2017 19:22:22 -0700

Ahh, I see.  There's a risk that you prohibit PMTUD by making this a MUST, but that's avoidable with the right conditionals.

If you think of the first packet as the first attempt at PMTUD, then this might just be unnecessary.  You detect the PMTU as you are able and send packets within it as you see fit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/505#issuecomment-299356143

---

From: janaiyengar <[email-masked]>
Date: Thu, 04 May 2017 19:49:50 -0700

Yeah, the point was to ensure that an impl that doesn't do mid-connection PMTUD doesn't use an MTU larger than what was used for the first packet. Avoids surprises.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/505#issuecomment-299358498

---

From: Martin Thomson <[email-masked]>
Date: Sun, 07 May 2017 17:41:59 -0700

I notice now that we're discussing what @janaiyengar intended to be a small addition and the original reason for opening this issue was a pure duplicate of #463.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/505#issuecomment-299747750