Subject: [quicwg/base-drafts] sent_packets and duplicate ACKs (#541)

From: Lars Eggert <[email-masked]>
Date: Fri, 19 May 2017 05:33:42 -0700

I'm not sure if the pseudo code around the `sent_packets` association correctly handles the case of duplicate ACKs. It seems that ACKed packets are removed from the association on first ACK, and information about them is therefore not present anymore when a repeated or duplicated ACK arrives?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/541

---

From: ianswett <[email-masked]>
Date: Mon, 22 May 2017 13:07:21 -0700

Yes, currently the pseudocode does nothing to handle track spurious retransmits, because it makes the psuedocode somewhat simpler.  

Adding proper handling is certainly possible, do you think it's worth the extra complexity?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/541#issuecomment-303205932

---

From: Lars Eggert <[email-masked]>
Date: Mon, 22 May 2017 22:30:42 -0700

I don't know. That duplicate ACKs aren't handled make the current pseudo code IMO not very useful. However, complicating it a lot is also not great. Would some comments in the pseudo code be a middle ground? Or at least the text should explain the issue and that the pseudo code is not handling it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/541#issuecomment-303294429