Subject: [quicwg/base-drafts] Fix up ACK frame section (#507)

From: janaiyengar <[email-masked]>
Date: Thu, 04 May 2017 21:39:22 -0700

- largest acked need not be > 32 bits, since Packet Number is at most 32 bits.
- ditto for ack block lengths

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507

---

From: Lars Eggert <[email-masked]>
Date: Thu, 04 May 2017 23:11:44 -0700

So we're going to to 8/16/32 and leave the `LL` codepoint `11` unassigned?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507#issuecomment-299390678

---

From: janaiyengar <[email-masked]>
Date: Fri, 05 May 2017 18:16:42 -0700

For the time being, since it's just silly to have a largest acked of 48 bits when the max packet number size is 32. The ack block lengths also need to be fixed to at most 32 bits since if you can't use more than 32 bits for packet number, you won't be acking > 2^32 packet ranges.

Feel free to suggest better ideas.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507#issuecomment-299606476

---

From: Martin Thomson <[email-masked]>
Date: Sun, 07 May 2017 16:49:44 -0700

Split the last acknowledged size from the block length size and find the points in that space that make sense, e.g.,

0 = the last acknowledged is 8 bits, block lengths are 8 bits
1 = the last acknowledged is 16 bits, block lengths are 8 bits
2 = the last acknowledged is 16 bits, block lengths are 16 bits
3 = the last acknowledged is 32 bits, block lengths are 16 bits

I can't imagine that needing to acknowledge a block of packets that is more than 64k packets long without a single gap is very common.  That's a massive BDP with fantastic loss characteristics.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/507#issuecomment-299744638