Subject: Re: [quicwg/base-drafts] New connection ID message (#232)

From: hardie <[email-masked]>
Date: Mon, 01 May 2017 14:50:47 -0700

On Wed, Apr 26, 2017 at 9:31 PM, Martin Thomson <[email-masked]>
wrote:

> I have a solution for double-migration: require a strictly ordered
> sequence of new connection IDs. Every associated packet number increment
> has to be added. So if you move twice, you will have added a delta twice as
> well. You can't skip a connection ID without also accounting for the packet
> number offset. Then there is no ambiguity.
>
> When you say "strictly ordered" here, you mean ordered according to the
list provided, right?  So you would still allow the connection ID to wrap
if that was the consequence of the new ID plus offset?

Ted

> —
> You are receiving this because you are subscribed to this thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/232#issuecomment-297608881>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABVb5AjhPDNKFsgWiIho9qFwdSmf8Mlxks5r0BoIgaJpZM4LtMob>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#issuecomment-298442325

---

From: Martin Thomson <[email-masked]>
Date: Mon, 01 May 2017 15:26:48 -0700

Ordered in terms of order of delivery, or probably with a number attached (so that packet reordering doesn't cause issues).

The connection ID can't really wrap, it's not a sequence number.  The packet number wouldn't be permitted to wrap either, because that leads to a two-time pad on the AEAD.  2^32 is all you need to ensure that the next number appears to entirely random, so 2^31 on average should be OK.  My hope is that the occasional small gap in packet number won't risk running out entirely (2^64).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#issuecomment-298449310

---

From: janaiyengar <[email-masked]>
Date: Mon, 01 May 2017 18:13:04 -0700

Yes, as I was catching back up on this thread, that is exactly what I was thinking. We need a message that (i) hands out index + connection ID (assuming we may want to send this message more than once, to hand out more connection IDs as needed), and (ii) a packet number delta. The indices of the connection IDs across the observed migration can be used to determine the expected packet number gap.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#issuecomment-298473422

---

From: Martin Thomson <[email-masked]>
Date: Mon, 01 May 2017 18:18:23 -0700

You know, I could write this up, but it would be incomplete.  The third item here is the public reset verifier, which needs to be updated for every new connection.

Of course, if we decide that the verifier has to be in the clear, then we have to create a completely new design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#issuecomment-298474065

---

From: janaiyengar <[email-masked]>
Date: Mon, 01 May 2017 18:47:19 -0700

Hm, good point. If we're in agreement we have something for now, I suggest
then that we wait to see where the Public Reset conversation lands. Let's
not write this up only to go back and revert shortly after.

On Mon, May 1, 2017 at 6:18 PM, Martin Thomson <[email-masked]>
wrote:

> You know, I could write this up, but it would be incomplete. The third
> item here is the public reset verifier, which needs to be updated for every
> new connection.
>
> You are receiving this because you commented.
> <https://github.com/quicwg/base-drafts/issues/232#issuecomment-298474065>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AKjg1BLYYG2K0h92JC3_EtjrVuMp_Vxuks5r1oRfgaJpZM4LtMob>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#issuecomment-298477493

---

From: Martin Thomson <[email-masked]>
Date: Mon, 01 May 2017 18:50:47 -0700

The alternative is to write up a public reset design that we know is bad (even mark it as such).  Then we can write this up and continue to make forward progress.  Stalling on hard issues that don't have consensus can create a log jam.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#issuecomment-298477957

---

From: janaiyengar <[email-masked]>
Date: Mon, 01 May 2017 18:54:29 -0700

I think we have a solution here, which suggests to me that we aren't
stalled on this issue. My hope is that we'll resolve Public Reset in Paris,
and we can discuss this point there as well. Once we have them both
resolved, we write them both up.

But I don't have a strong opinion here and I'm fine with either.

(FWIW, we have a bad PR design -- send it in plaintext with no crypto.)

On Mon, May 1, 2017 at 6:50 PM, Martin Thomson <[email-masked]>
wrote:

> The alternative is to write up a public reset design that we know is bad
> (even mark it as such). Then we can write this up and continue to make
> forward progress. Stalling on hard issues that don't have consensus can
> create a log jam.
>
> —
> <https://github.com/quicwg/base-drafts/issues/232#issuecomment-298477957>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AKjg1BuotTkhgEnhQe0actlIiSGnjFHtks5r1ov2gaJpZM4LtMob>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#issuecomment-298478397

---

From: Martin Thomson <[email-masked]>
Date: Mon, 01 May 2017 18:57:24 -0700

That's a fair point.  I will write this up without a verifier update and patch that in when we resolve on a public reset design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#issuecomment-298478748

---

From: Martin Thomson <[email-masked]>
Date: Tue, 02 May 2017 20:43:37 -0700

Closed #232 via #491.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/232#event-1066624529