Subject: [quicwg/base-drafts] loosen MUST requirement around close-on-ack-of-unsent (#564)

From: Patrick McManus <[email-masked]>
Date: Wed, 31 May 2017 13:10:31 -0700

>  sender MUST close the connection if an unsent packet number is acknowledged

I suggest s/MUST/SHOULD .. doing this as MUST requires keeping the state of every unused packet number for the entire duration of the connection to separate the ack of concern from a duplicated ack.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/564

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 May 2017 18:42:48 -0700

This seems sensible.  Anything other than MUST NOT has the right effect, though I think that SHOULD is a nice spot.

Of course, there are designs that would have us avoid skipping packets entirely, which reduces the state commitment considerably.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/564#issuecomment-305365280