Subject: [quicwg/base-drafts] State bikeshedding time (#520)

From: Martin Thomson <[email-masked]>
Date: Wed, 10 May 2017 23:19:16 -0700

"half-closed (local)" might be a little obtuse.  "write-closed" or "read-only" might be better names.

Release the hounds.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/520

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 11 May 2017 03:51:56 -0700

Would these states become redundant if the "unidirectional streams" concept takes foot

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/520#issuecomment-300754260

---

From: Mike Bishop <[email-masked]>
Date: Tue, 16 May 2017 15:03:32 -0700

Somewhat.  If the unidirectional flavor is pairs of unidirectional streams, these could be defined shorthand for the state of a pair.  If it's completely independent streams in each direction, yes, they're obsolete.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/520#issuecomment-301928993