Subject: Re: [quicwg/base-drafts] Long and short packet type 00? (#487)

From: Martin Thomson <[email-masked]>
Date: Wed, 03 May 2017 21:54:18 -0700

I don't think that we want to reserve these.  Nor do I think that it needs special mention.  We just decided not to use them.

I hear that there are some deployments that route a packet containing a zero octet at the front to other places.  I don't think that we need to endorse that sort of behaviour, but avoiding `00` is cheap.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/487#issuecomment-299096805

---

From: Lars Eggert <[email-masked]>
Date: Wed, 03 May 2017 23:13:55 -0700

Well, those deployments are going to have an issue if we ever assign packet type `00`. Hence it may be better to reserve? (Or are these deployments also using a custom QUIC version?)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/487#issuecomment-299103970

---

From: Martin Thomson <[email-masked]>
Date: Thu, 04 May 2017 00:13:26 -0700

They are currently using a custom version number.  Note that we moved the version number field in some pretty strange ways, so those folks will have a whale of a time sorting out an upgrade path.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/487#issuecomment-299112429

---

From: janaiyengar <[email-masked]>
Date: Thu, 04 May 2017 16:27:02 -0700

The case I'm familiar with is not a QUIC version but a different protocol that uses 00 in the first octet on the same port (443) as a classifier. Since it's specific to a listener on port 443 that receives this other protocol and also QUIC packets, it's easier to avoid 00. In general, my thinking is that 00 is always special to someone, and avoiding 00 in the first octet may be good sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/487#issuecomment-299336323