Subject: Re: [quicwg/base-drafts] Invert the connection ID logic during the handshake (#442)

From: martinduke <[email-masked]>
Date: Fri, 05 May 2017 12:41:47 -0700

> (1) In the initial client packet, this field doesn't "identify" a connection; it's basically just a nonce.
> 
> (2) Server-chosen connection IDs don't actually identify connections either; they contain client-opaque information that can be used by the server or server-adjacent forwarding devices for whatever purpose the server sees fit. This is more a token than an identifier.

Connection IDs also protect us from NAT rebinding, precisely because they identify the connection independent of the 4-tuple.

I agree it would be clear to name the client-originated connection ID something else (do we need this nonce at all?) but we would have to take care that no other mechanism (e.g. public reset generation) needs something called a "connection ID" from the start of the connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/442#issuecomment-299557723

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 May 2017 21:59:03 -0700

#493 is merged, now this can go away.  Yay.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/442#issuecomment-300682555

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 May 2017 21:59:03 -0700

Closed #442.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/442#event-1077584211