Subject: [quicwg/base-drafts] A bunch of editorial cleanup. Short summary: (#438)

From: ekr <[email-masked]>
Date: Thu, 13 Apr 2017 13:06:46 -0700

- Remove a bunch of the "can be used" language because we are
  specifying how to use it.

- Update the 2119 language.

- Clean up the description of key derivation, also shorten
  it.

- Misc other stuff.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/438

-- Commit Summary --

  * A bunch of editorial cleanup. Short summary:

-- File Changes --

    M draft-ietf-quic-tls.md (125)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/438.patch
https://github.com/quicwg/base-drafts/pull/438.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/438

---

From: Martin Thomson <[email-masked]>
Date: Mon, 17 Apr 2017 23:01:26 -0700

martinthomson requested changes on this pull request.

>  ~~~
 
-The client protects (or encrypts) packets with the client packet protection key
-and IV; the server protects packets with the server packet protection key.
+The length of the output is determined by the requirements of the AEAD function
+selected by TLS.  The key length is the AEAD key size.  As defined in Section
+5.3 of {{!I-D.ietf-tls-tls13}}, the IV length is the larger of 8 or N_MIN (see
+Section 4 of {{!RFC5116}}). For any secret S, the corresponding key and
+IV are derived as shown below:

There is an above, but not below.

I think that you mean to move the above code block to below this paragraph and remove the "as shown below:" from the previous one.

>  component of QUIC.  The same design could work for TLS 1.2, though few of the
 benefits QUIC provides would be realized due to the handshake latency in
 versions of TLS prior to 1.3.

 # Notational Conventions
 
-The words "MUST", "MUST NOT", "SHOULD", and "MAY" are used in this document.
-It's not shouting; when they are capitalized, they have the special meaning
-defined in {{!RFC2119}}.
+The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL
+NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED",
+"MAY", and "OPTIONAL" in this document are to be interpreted as
+described in BCP 14 {{!RFC2119}}, {{!I-D.leiba-rfc2119-update}} when, and only when, they
+appear in all capitals, as shown here.

bleargh

> @@ -190,15 +192,10 @@ TLS connection for use by QUIC.  This keying material is used to derive packet
 protection keys.  Details on how and when keys are derived and used are included
 in {{packet-protection}}.
 
-This arrangement means that some TLS messages receive redundant protection from
-both the QUIC packet protection and the TLS record protection.  These messages
-are limited in number; the TLS connection is rarely needed once the handshake
-completes.

I'd kinda like to keep something like this.  We still double-encrypt NST and people will complain (or get it wrong) if we don't explain it somewhere.

 ~~~
    info = (HashLen / 256) || (HashLen % 256) || 0x21 ||
           "TLS 1.3, QUIC client 1-RTT secret" || 0x00
 ~~~
 
-

Please keep extra space between sections.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/438#pullrequestreview-33147704

---

From: ekr <[email-masked]>
Date: Tue, 18 Apr 2017 07:02:01 -0700

ekr commented on this pull request.

 # Notational Conventions

Does this mean you don't want this change, or you are just annoyed that there is a draft on this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/438#discussion_r111960968

---

From: ekr <[email-masked]>
Date: Tue, 18 Apr 2017 07:03:19 -0700

This point is made in #packet-protection

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/438#discussion_r111961295

---

From: ekr <[email-masked]>
Date: Tue, 18 Apr 2017 07:05:33 -0700

@ekr pushed 1 commit.

e62936d  Martin's comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/438/files/48f3c7bae586a2d3ed4ce3f71dc52d6603cbb2e6..e62936dde5b311c15bcc94908a5e998ced019d46

---

From: ekr <[email-masked]>
Date: Tue, 18 Apr 2017 12:16:49 -0700

@martinthomson The reason that Circle is sad here is an overlong line that should be already fixed in trunk and so should go away on merge.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/438#issuecomment-294951253

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 Apr 2017 18:12:42 -0700

Merged by hand.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/438#issuecomment-296503323

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 Apr 2017 18:12:42 -0700

Closed #438.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/438#event-1053961023