Subject: [quicwg/base-drafts] Authenticate public reset with a hash (#460)

From: Martin Thomson <[email-masked]>
Date: Fri, 21 Apr 2017 00:14:51 -0700

This takes @ekr's design from #20 and expands on it quite a bit.  There are a few little wrinkles that I think we might want to discuss a little.

First, this is a one-time password. That means that the combination of key and connection ID can't ever be repeated for a given server instance.  Our 64-bit connection ID space isn't really enough to provide this.  How a server moves to a new static key during operation will be challenging; it probably needs to partition the connection ID space.

Second, transport parameters are encrypted.  #20 made a point of having the verifier in the clear so that intermediaries could validate the Public Reset.  I don't want to create a second TLS extension, but I guess that is the best option we have available to us if this is what is required.  I don't think we should move transport parameters into the clear either.

Closes #215, #20.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/460

-- Commit Summary --

  * Authenticate public reset with a hash
  * Self-review

-- File Changes --

    M draft-ietf-quic-transport.md (75)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/460.patch
https://github.com/quicwg/base-drafts/pull/460.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/460

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Apr 2017 20:53:39 -0700

@martinthomson pushed 1 commit.

90e5c6b  remove second layer of 'for instance'

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/460/files/8d59adcd700539eceba823546bea07ff7dbfbb89..90e5c6b9f6e670ab31af992200d3ad4d95479c09