Subject: [quicwg/base-drafts] Use positive phrasing instead of double negative (#477)

From: Sebastiaan Deckers <[email-masked]>
Date: Thu, 27 Apr 2017 06:19:19 -0700

The setting `SETTINGS_DISABLE_PUSH` is set to `false` by default. This double negation seems needlessly confusing. (*"Setting the push setting to true turns off push?"*)

Suggestion: Renaming it to `SETTINGS_ENABLE_PUSH` and default to `true`. This is easier to understand and matches the parameter defined by HTTP/2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/477

---

From: Mike Bishop <[email-masked]>
Date: Thu, 27 Apr 2017 09:59:51 -0700

The problem is that we've defined Boolean settings in general to be false if not sent, true if sent.  So to have it be "enable push," it either needs to default off or we need to change the polarity of all Boolean settings.  I don't think changing the polarity of settings is an acceptable option since HTTP allows definition of arbitrary settings by extensions, all of which would need to be off by default unless a client supports the extension.

I'm fine switching it back to ENABLE_PUSH and requiring that an extra few bytes be spent if you want things pushed to you, though.  Any objections?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/477#issuecomment-297776148

---

From: Martin Thomson <[email-masked]>
Date: Thu, 27 Apr 2017 17:24:55 -0700

Given that this is the client, which is expected to add padding in the relevant packet, the extra bytes won't be increasing the size of anything.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/477#issuecomment-297874683