Subject: [quicwg/base-drafts] fix priority grouping node ambiguity (#441)

From: Patrick McManus <[email-masked]>
Date: Mon, 17 Apr 2017 22:35:29 -0700

in h2 'phantom' (unopened) streams can be used for grouping nodes for priority purposes. This is simultaneously very useful and very concerning from a resource commitment purpose. I'm aware of some servers looking to limit their use through implicit resource allocations, and I'm aware of some clients looking to use them more agressively (i.e. a grouping node per tab).

Perhaps we should at least make these explicitly negotiated so they can be cleaned up, limited, etc..?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441

---

From: Martin Thomson <[email-masked]>
Date: Mon, 17 Apr 2017 23:14:37 -0700

This is a really useful feature in h2, it's a shame that we currently don't have any ability to support it in hq.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-294697425

---

From: Patrick McManus <[email-masked]>
Date: Tue, 18 Apr 2017 07:19:31 -0700

I think when doing 7540 the http wg decided some kind of grouping was essential for combining 2 uncoordinated groups into one connection. Proxies combining n connections into 1 is one use case, browsers combining n tabs into one connection is pretty much the same problem.

The implicit unopened stream was probably a mistake, but the 'requirement' still makes sense as something quic would need

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-294859539

---

From: Mike Bishop <[email-masked]>
Date: Tue, 18 Apr 2017 11:10:15 -0700

In Chicago, I had a side conversation with someone advocating that we rip out the priority scheme as a whole and enable different schemes to be used on an extension basis.  (Which reminds me, I had promised to send this person the link to one of the alternatives that was proposed in late H2....  Doing that now.)  I think a priority scheme that explicitly provided buckets of streams rather than using phantoms would be reasonable.  However, that feels like it wanders into the realm of work that HTTPbis should be doing, rather than the QUIC WG; when there's not a specific "this doesn't work in QUIC because...", I'm loathe to make fundamental protocol changes without at least a commission from the owning WG.

However, I don't know that I'd say HTTP/QUIC doesn't support the phantoms -- can't you just close the streams you want to use as placeholders without making a request?  Though perhaps we should have text that explicitly states that this is "normal" behavior, just for clarity's sake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-294932961