Subject: [quicwg/base-drafts] Retransmission of handshake frames (#471)

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Apr 2017 21:55:56 -0700

The draft currently says:

> Endpoints MUST retransmit handshake frames if not acknowledged within a time limit. 

I've been trying to be very careful about what it means to retransmit.  We don't retransmit packets, we create new packets; similarly, we don't retransmit frames, we create new frames that contain the data we want.

In the case of the first client packet, we can probably be a little more prescriptive.  The client can send another packet with the same contents, just with the packet number incremented.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/471

---

From: janaiyengar <[email-masked]>
Date: Thu, 27 Apr 2017 22:05:22 -0700

We played fast and loose with using "retransmit" earlier in the life of the
draft. I think it's reasonable to say that the client SHOULD rebundle, as
it always does.

On Wed, Apr 26, 2017 at 9:55 PM, Martin Thomson <[email-masked]>
wrote:

> I've been trying to be very careful about what it means to retransmit. We
> don't retransmit packets, we create new packets; similarly, we don't
> retransmit frames, we create new frames that contain the data we want.
>
> In the case of the first client packet, we can probably be a little more
> prescriptive. The client can send another packet with the same contents,
> just with the packet number incremented.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/471>, or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AKjg1Cox1yKhJ2FZg1viVKkTYoE8pp4Uks5r0B_cgaJpZM4NJuVw>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/471#issuecomment-297907868