Subject: Re: [quicwg/base-drafts] We have two things called "frame" (#128)

From: Mark Nottingham <[email-masked]>
Date: Thu, 27 Apr 2017 21:48:18 -0700

H2 already has frames; maybe the new thing should have the new name. E.g., 'QUIC segments".

YMMV.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-297906141

---

From: Patrick McManus <[email-masked]>
Date: Fri, 28 Apr 2017 06:23:16 -0700

I don't like quic-segments because
1] it implies an ordering (and seqno) and the quic-frames aren't really
ordered unless they are streams
2] the term doesn't line up well with tcp segments (which are 1:1 with
unfragmented IP).. and quic and tcp are at the same 'layer' - so confusion.

The best (but still imperfect) solution I have is to change http frame to
http record. It overlaps with TLS of course (which isn't all that
desirable), but it uses the term pretty much the same way - to provide
delimiters within a QUIC stream.

The other idea I had was "http-control-segments".. I think segment is a
better fit here as compared against renaming all quic frames to quic
segments (again ordering and offset are present) and it emphasizes the
native integration between hq and quic for data but not control.

I'm not especially concerned that we would be changing the h2-frame
language.. HQ doesn't need framing in many of the same places that H2 did
so a change in nomenclature is ok to avoid confusion with the transport.

On Fri, Apr 28, 2017 at 12:48 AM, Mark Nottingham <[email-masked]>
wrote:

> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/128#issuecomment-297906141>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AAP5s58K4M7rtBP3eMwmWWZ3xo2n5V4Nks5r0W-RgaJpZM4LcZBd>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-297996392

---

From: ekr <[email-masked]>
Date: Fri, 28 Apr 2017 07:33:48 -0700

Other colors for this bikeshed:

Records
Blocks
Chunks
Packets
Datagrams

On Fri, Apr 28, 2017 at 6:23 AM, Patrick McManus <[email-masked]>
wrote:

> > H2 already has frames; maybe the new thing should have the new name.
> E.g.,
> > 'QUIC segments".
> >
> > YMMV.
> >
> > —
> > <https://github.com/quicwg/base-drafts/issues/128#issuecomment-297906141
> >,
> > or mute the thread
> > <https://github.com/notifications/unsubscribe-auth/
> AAP5s58K4M7rtBP3eMwmWWZ3xo2n5V4Nks5r0W-RgaJpZM4LcZBd>
>
> > .
> >
>
> —
> <https://github.com/quicwg/base-drafts/issues/128#issuecomment-297996392>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oZmoCxfsXLB4lnrTwYU6KKpVw65nks5r0ehCgaJpZM4LcZBd>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-298014503

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 28 Apr 2017 07:43:53 -0700

A colleague of mine suggested [vesicle](https://en.wikipedia.org/wiki/Vesicle_(biology_and_chemistry))...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-298017192

---

From: ekr <[email-masked]>
Date: Fri, 28 Apr 2017 07:47:19 -0700

Also:

Cell
Fragment

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-298018133

---

From: janaiyengar <[email-masked]>
Date: Fri, 28 Apr 2017 11:55:41 -0700

Why does the HTTP document need to talk about QUIC frames? Those are
QUIC-internal, and HTTP only needs to refer to QUIC streams, right? QUIC
itself doesn't encounter HTTP frames, so QUIC never refers to other
protocol frames.

I think it's fine to reuse frames and streams for the key reason that no
matter what you choose (unless you choose "vesicle"), you're likely to
conflict with some app. "Stream" is even harder, since video/audio might
use it in completely different ways than QUIC, but it's important to note
that the scoping is different. ("A video frame can be mapped to a QUIC
stream, and a video stream is made up of video frames.")

I've always found qualifiers ("QUIC", "HTTP", "video") to be adequate.

On Fri, Apr 28, 2017 at 7:47 AM, ekr <[email-masked]> wrote:

> <https://github.com/quicwg/base-drafts/issues/128#issuecomment-298018133>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AKjg1F_P_0akyepGz7bVe5ULdU_tQYa_ks5r0fv3gaJpZM4LcZBd>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-298079377

---

From: Mike Bishop <[email-masked]>
Date: Fri, 28 Apr 2017 12:11:07 -0700

We might be able to get out of HTTP referencing QUIC frames, but that’s just wording.  The frames represent events which occur.  We currently reference:

  *   On the wire, data is framed into QUIC STREAM frames, but this framing is invisible to the HTTP framing layer. A QUIC receiver buffers and orders received STREAM frames, exposing the data contained within as a reliable byte stream to the application.
  *   (Discussing CONNECT)  All QUIC STREAM frames on the message data stream correspond to data sent on the TCP connection. Any QUIC STREAM frame sent by the client is transmitted by the proxy to the TCP server; data received from the TCP server is written to the data stream by the proxy. Note that the size and number of TCP segments is not guaranteed to map predictably to the size and number of QUIC STREAM frames.
  *   The following error codes are defined by HTTP for use in QUIC RST_STREAM, GOAWAY, and CONNECTION_CLOSE frames.

This doesn’t actually bother me much, because I already have to compare/contrast with HTTP/2 frames.  If they’re HTTP/QUIC frames, I just call them <X> frame.  If they’re something else, I call them <protocol> <X> frames.

From: janaiyengar [mailto:[email-masked]]
Sent: Friday, April 28, 2017 11:56 AM
To: quicwg/base-drafts <[email-masked]>
Cc: Mike Bishop <[email-masked]>; Comment <[email-masked]>
Subject: Re: [quicwg/base-drafts] We have two things called "frame" (#128)

> <https://github.com/notifications/unsubscribe-auth/AKjg1F_P_0akyepGz7bVe5ULdU_tQYa_ks5r0fv3gaJpZM4LcZBd>

—
You are receiving this because you commented.
Reply to this email directly, view it on GitHub<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fissues%2F128%23issuecomment-298079377&data=02%7C01%7CMichael.Bishop%40microsoft.com%7C6940cec6b50444b0a17e08d48e682bf2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636290025442472655&sdata=QYtqr19ugYEtDMgN8C%2Bdp%2BaBKJLm%2FgStgcf2JUat6zo%3D&reserved=0>, or mute the thread<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fnotifications%2Funsubscribe-auth%2FAEE2hRsispmRsKFLC2zuCjv3MFqzD6KDks5r0jYtgaJpZM4LcZBd&data=02%7C01%7CMichael.Bishop%40microsoft.com%7C6940cec6b50444b0a17e08d48e682bf2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636290025442482664&sdata=ao%2BwtgJlZvKAu2tUYsBUjOT9%2Ff%2FgKEIsJ39J0mRQmcU%3D&reserved=0>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/128#issuecomment-298082811