Subject: [quicwg/base-drafts] Reduce the number of offset lengths in a stream frame (#430)

From: ianswett <[email-masked]>
Date: Sun, 02 Apr 2017 05:30:05 -0700

Also fixes #414 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/430

-- Commit Summary --

  * Reduce the number of offset lengths in a stream frame

-- File Changes --

    M draft-ietf-quic-transport.md (29)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/430.patch
https://github.com/quicwg/base-drafts/pull/430.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/430

---

From: Mike Bishop <[email-masked]>
Date: Thu, 13 Apr 2017 14:41:30 -0700

MikeBishop approved this pull request.

LGTM, modulo nits.

>  These bits are parsed as follows:
 
-* The leftmost bit must be set to 1, indicating that this is a STREAM frame.
+* The first two bit must be set to 11, indicating that this is a STREAM frame.

bits, not bit

-* The first two bits must be set to 01 indicating that this is an ACK frame.
+* The first two bits must be set to 101 indicating that this is an ACK frame.

three bits

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/430#pullrequestreview-32745957

---

From: ianswett <[email-masked]>
Date: Thu, 13 Apr 2017 17:24:06 -0700

@ianswett pushed 1 commit.

ba217ff  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/430/files/abd97ecdc35782cc5bc0de38c85cdae3e1e45cad..ba217ff6139d3de9b5c7afa6906a9ea83f9de19d

---

From: ianswett <[email-masked]>
Date: Thu, 13 Apr 2017 18:51:08 -0700

Merged #430.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/430#event-1042852099