Subject: [quicwg/base-drafts] No rules limit the sending of BLOCKED (#451)

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Apr 2017 22:20:11 -0700

In discussions of BLOCKED in HTTP/2, one important limitation was that a sender wouldn't send multiple BLOCKED frames for the same limit.  That is, it would stop sending BLOCKED until it received a WINDOW_UPDATE for the affected limit.

No such restriction applies.  An poor implementation of QUIC could end up generating a LOT of BLOCKED frames.  The above limit would seem to be reasonable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/451

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Apr 2017 19:54:40 -0700

Duplicate of #198 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/451#issuecomment-297597286

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Apr 2017 19:54:40 -0700

Closed #451.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/451#event-1059695811