Subject: [quicwg/base-drafts] Various version negotiation fixes (#474)

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Apr 2017 22:43:35 -0700

1. Version negotiation is stateless (this was implied but not made explicit)

2. Client ignores version negotiation packets if it has already done version negotiation.

3. Client ignores version negotaition packets if they list the version it is using.

Closes #284, #294, #241.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/474

-- Commit Summary --

  * Various version negotiation fixes

-- File Changes --

    M draft-ietf-quic-transport.md (18)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/474.patch
https://github.com/quicwg/base-drafts/pull/474.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/474

---

From: Martin Thomson <[email-masked]>
Date: Thu, 27 Apr 2017 23:17:01 -0700

This is trivial, but closes a bunch of first implementation draft issues.  @janaiyengar, I'd like to merge this before 2017-05-02.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/474#issuecomment-297916644