Subject: Re: [quicwg/base-drafts] Port 443 and IANA ports (#428)

From: Lars Eggert <[email-masked]>
Date: Sat, 01 Apr 2017 21:25:20 -0700

As @ianswett said, QUIC's use of 443/UDP is inline with the current registration. And we're not hijacking this. Just because [Kipp E.B. Hickman](http://home.mcom.com/people/kipp/) is the assignee here does not mean nobody else can use the port for the given protocol. (443/TCP is also assigned to him, and nobody is worried that H2 over TCP has a problem.)

If we *wanted* to, we could see if he is still around and willing to return the ports to be assigned to the IESG. I suspect it is an individual assignment (and not one to the IESG), because the assignment likely predates the first RFC on SSL way back when.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-290963905

---

From: Johann Dirry <[email-masked]>
Date: Wed, 05 Apr 2017 03:42:10 -0700

The port number is defined by the transport layer protocol (ie. UDP+TLS has port 443). QUIC is an application layer protocol and therefore does not define or effect the port number. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-291823133

---

From: "Benjamin M. Schwartz" <[email-masked]>
Date: Fri, 07 Apr 2017 15:02:12 -0700

I think we can avoid this problem by not implicitly recommending a fixed port number: https://github.com/quicwg/base-drafts/pull/424

There's no need for a fixed port number anyway, due to the Alt-Svc bootstrap.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-292662643

---

From: Lars Eggert <[email-masked]>
Date: Sat, 08 Apr 2017 10:21:53 -0700

There is no problem with running QUIC on UDP/443, and there is no issue with saying that this is recommended or allowed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-292732615

---

From: Mike Bishop <[email-masked]>
Date: Wed, 12 Apr 2017 11:05:34 -0700

#424 should have a corresponding issue, and this could be it.  As I read it, the goal is to avoid ossification of the HTTP/QUIC port number by advocating that origins *not* use a consistent port number.  Since Alt-Svc can point you to any port number, unless we have evidence that UDP port numbers are already highly ossified, I don't see an issue with not using 443 for most use-cases.

We would want a default port associated with a new scheme (#253), but we don't yet have that and that wouldn't be the common case regardless.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-293660680

---

From: Martin Thomson <[email-masked]>
Date: Mon, 17 Apr 2017 22:09:10 -0700

I think that both @ianswett and @larseggert covered this.  It will be HTTP on port 443.  However, we should try to officially claim that registration, or at least acknowledge it.

#424 suggests a very different outcome.  It suggests that 443 is at best a convenience, and at worst a horrible error on the part of Google.  On the latter, that would be because the ossification has already happened (I'm not sure if this is true, or that the choice of 443 was unwise, but you can see the logic that leads to that conclusion).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-294680757

---

From: Lars Eggert <[email-masked]>
Date: Tue, 18 Apr 2017 00:44:18 -0700

I will contact IANA and see what the options are to get the port assigned to QUIC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-294716899

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 27 Apr 2017 21:44:36 -0700

FYI: I'm in a discussion both with the current assignee and the IESG about this. Stay tuned.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-297905749