Subject: Re: [quicwg/base-drafts] Given recommendations on when/how often to send ACK frames (#230)

From: acmacm <[email-masked]>
Date: Wed, 01 Mar 2017 16:47:55 -0800

I suggest to make any requirement on ACK reduction simple (1 ACK : N Packets Received). For reasons I'm sorting-through (and may have to wait till Chicago), I suspect that 1:1 should be allowed because feedback helps understand performance. (acmacm is Al Morton)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/230#issuecomment-283520371

---

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Mar 2017 16:54:54 -0800

@acmacm, you can edit your GitHub profile [here](https://github.com/settings/profile) and put your name in.  It won't show on the UI for reasons I don't fully understand, but we'll all eventually make the connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/230#issuecomment-283521494

---

From: Al Morton <[email-masked]>
Date: Wed, 01 Mar 2017 16:57:07 -0800

Thanks Martin!

From: Martin Thomson [mailto:[email-masked]]
Sent: Wednesday, March 01, 2017 7:55 PM
To: quicwg/base-drafts
Cc: MORTON, ALFRED C (AL); Mention
Subject: Re: [quicwg/base-drafts] Given recommendations on when/how often to send ACK frames (#230)

@acmacm<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_acmacm&d=DQMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=2jNl3-3CmU12dNAwUtHJbn69Th9QwFS563VHeqkjVyQ&s=z3fV1W1awuVo_aW34O92SXD3q77NMVsTGbcfsW6emvA&e=>, you can edit your GitHub profile here<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_settings_profile&d=DQMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=2jNl3-3CmU12dNAwUtHJbn69Th9QwFS563VHeqkjVyQ&s=GhEMeGMWeRZ7k-fBQ2Bm49SJGqaGZUawruqkjTmKsBc&e=> and put your name in. It won't show on the UI for reasons I don't fully understand, but we'll all eventually make the connection.

—
You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_quicwg_base-2Ddrafts_issues_230-23issuecomment-2D283521494&d=DQMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=2jNl3-3CmU12dNAwUtHJbn69Th9QwFS563VHeqkjVyQ&s=V0buh__ikJFiPZ5vRphJin2sidrbaa9pbs4bs5gYDkE&e=>, or mute the thread<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_notifications_unsubscribe-2Dauth_AJC8GFNGU9jSIgh1DbgXqJTUlZNX-2DaiCks5rhhNegaJpZM4LtKZ4&d=DQMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=2jNl3-3CmU12dNAwUtHJbn69Th9QwFS563VHeqkjVyQ&s=YkDVCRff7J3NL-RNs9DoPcBjgFaJrOp1foaUBZ1eTF0&e=>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/230#issuecomment-283521888

---

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Mar 2017 19:40:06 -0800

It would be good if someone could provide N.  I hear that GQUIC uses N=2.  I agree that 1:1 should be fine.  I also think that having an ACK on every (live) RTT is valuable as well, especially if you aren't sending anything else (as sometimes happens in HTTP).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/230#issuecomment-283547177

---

From: ianswett <[email-masked]>
Date: Thu, 02 Mar 2017 05:57:52 -0800

1:1 acking is ok as long as that excludes acks.  Acks must be acked at a rate much less than 1:1, I would advise at most 1 ack for every two acks.

GQUIC follows TCP's approach of N=2 with a delayed ack timer, but we use a delayed ack timer of 25ms.  TCP delayed ack timers vary substantially by platform in practice, but tend to default to ~200ms in internet environments.

I think we should recommend a default, for which I'd suggest as TCP/GQUIC's default, as well as the ability to negotiate other values of N and the delayed ack timer.  If we don't want to allow negotiation, we should at least allow the peer to inform the sender of their ack algorithm.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/230#issuecomment-283659819

---

From: Martin Thomson <[email-masked]>
Date: Thu, 02 Mar 2017 14:29:50 -0800

I would have been happy with ANY rationale, but that rationale is excellent Ian, thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/230#issuecomment-283803559