Subject: [quicwg/base-drafts] Separate IANA registries (#376)

From: Mike Bishop <[email-masked]>
Date: Wed, 08 Mar 2017 18:14:14 -0800

Goes a step further than #363 by establishing separate IANA registries for HTTP/2 and HTTP/QUIC.  Fixes #81.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/376

-- Commit Summary --

  * Separate IANA registries

-- File Changes --

    M draft-ietf-quic-http.md (122)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/376.patch
https://github.com/quicwg/base-drafts/pull/376.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/376

---

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Mar 2017 21:44:05 -0800

LGTM.  Obviously others disagree.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/376#issuecomment-285260355

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Mar 2017 17:56:46 -0800

@MikeBishop pushed 44 commits.

b84dc86  The client Finished message can't be protected with 1-RTT keys
ef7f5c3  Add a section on what to do when unprotecting a packet fails (hint: throw it away)
da610a0  Deal with bad key phase changes somehow
28690eb  Adding section on packet protection rules
d136165  Restructure section to better address some of the concerns and add some explanation
97860db  Ian's suggestions.
f287271  @ianswett review comments
e2f3140  Merge pull request #336 from quicwg/ack_protection
1a711c4  Remove QUIC_OVERLAPPING_STREAM_DATA
1b7a0d5  No 64-bit streams, so no TODO.
ae252cd  Send a TLS alert when TLS encounters an error
8e0100e  Move references to RFC5827 to text (#375)
8e1011f  Partial commit of new header format
f91752e  Everything except connection ID.
e8a8746  Connection ID added.
3fae949  Two key phases for long headers
f6fdbd6  Nits.
033002c  Clarifications.
4f1deab  Public reset proof not optional.
6744a7e  Fix formatting of long- and short-form headers
a02c15e  Add version specific fields to short form
caa179a  Nits.
a2e1412  addresses ekr and ianswett comments
f9cd441  addresses mikebishop's and mt's comments
e44463d  Merge pull request #361 from quicwg/header
3b6cf4f  Don't ignore TLS draft...?
f99e4fe  Some formatting and wording fixes to the new headers
b413502  What's a VERSION flag?
6052645  Why didn't my local build catch that?
fb12f13  Remove tls doc from the ignore.
fe4ae43  Merge pull request #379 from quicwg/tls-ignored
c1c1b43  Reword version-independent, version-specific discussion
e82c05b  Merge pull request #380 from quicwg/header_fix
e782069  Being nitpikcy about which connection and alert.
ce4981f  Merge pull request #374 from quicwg/alert_plus_close
128a25e  Merge pull request #337 from quicwg/unprotect_client_finished
081c551  Making it clear that an endpoint using an old key is indeciperable from an attack.
9c2c73e  Merge pull request #345 from quicwg/reorder_old_packets
fb1f97c  Merge pull request #382 from quicwg/overlapping_data
711aadb  HTTP change log
8920788  Merge remote-tracking branch 'origin/master' into http_extensions
f3259b4  Change log for HTTP/2 Considerations
1cdfaeb  Merge branch 'http_extensions' into this_aint_h2
ca50366  Change log for IANA split

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/376/files/2ef27e6ac82859c220634b8a5fc0cad98b6fda93..ca50366dfcb79e8ac679d3b8303325dce1f2e8ef