Subject: [quicwg/base-drafts] Resolve remaining TODOs (#420)

From: ianswett <[email-masked]>
Date: Tue, 28 Mar 2017 21:28:14 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/420

-- Commit Summary --

  * Resolve remaining TODOs

-- File Changes --

    M draft-ietf-quic-recovery.md (20)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/420.patch
https://github.com/quicwg/base-drafts/pull/420.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/420

---

From: janaiyengar <[email-masked]>
Date: Wed, 29 Mar 2017 16:03:32 -0700

janaiyengar commented on this pull request.

> @@ -561,7 +560,16 @@ Pseudocode for DetectLostPackets follows:
 ~~~
 
 ## Discussion
-TODO: Discuss why constants are chosen as they are.
+The majority of constants were derived from best common practices among widely
+deployed TCP implementations on the internet.  Exceptions follow.
+
+A shorter delayed ack time of 25ms was chosen because longer delayed acks can
+delay loss recovery and for the small number of connections where less than
+packet per 25ms is delievered, acking every packet is beneficial to congestion
+control and loss recovery.
+
+The default initial RTT of 100ms was chosen because it's slightl higher than

nit: "it's  slightl" --> "it is slightly"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/420#pullrequestreview-29865748

---

From: janaiyengar <[email-masked]>
Date: Wed, 29 Mar 2017 16:03:50 -0700

janaiyengar approved this pull request.

LGTM, modulo one nit

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/420#pullrequestreview-29865783

---

From: ianswett <[email-masked]>
Date: Wed, 29 Mar 2017 16:34:25 -0700

@ianswett pushed 1 commit.

bdb9c0e  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/420/files/737a4f47c1acc59695d49fbeeda4fa10d7f1cb04..bdb9c0e90e80f8763cbeb04e59f46c182cb303f0

---

From: ianswett <[email-masked]>
Date: Wed, 29 Mar 2017 16:37:09 -0700

Merged #420.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/420#event-1021410988