Subject: [quicwg/base-drafts] Port 443 and IANA ports (#428)

From: Leif Hedstrom <[email-masked]>
Date: Fri, 31 Mar 2017 15:13:57 -0700

While discussing QUIC with some network vendors, a concern was brought up that technically, port UDP port 443 is already assigned. From

https://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xhtml?&page=8

```
https	443	tcp	http protocol over TLS/SSL	[Kipp_E_B_Hickman]	[Kipp_E_B_Hickman]						
https	443	udp	http protocol over TLS/SSL	[Kipp_E_B_Hickman]	[Kipp_E_B_Hickman]		
```

Yes, seems silly and nit picky, but I'm wondering if it'd make sense to try to get 443:UDP assigned to HQ ? The vendor concern is that adding support for special handling of UDP packets on port 443 would have to be absolutely guaranteed to be QUIC. At least that's what I've been told.

The other option would be to add an identifier to every QUIC packet, such that they can uniquely identify it as such.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428

---

From: ianswett <[email-masked]>
Date: Fri, 31 Mar 2017 15:24:00 -0700

IETF QUIC will be HTTP over TLS 1.3 on UDP 443, so I believe that would fit into the current IANA spec?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-290846177

---

From: Leif Hedstrom <[email-masked]>
Date: Fri, 31 Mar 2017 15:35:38 -0700

I think the concern was (but I can check again) that we're sort of hijacking this :). I can't think of anyone or anything that would have used "HTTP over UDP" before, but technically I think they are right in that the port was reserved for that.

I think what might appease these guys is if the RFC explicitly specifies that from hereon, QUIC UDP:443 is "HTTPS over UDP" as registered years ago by the IANA. :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/428#issuecomment-290848008