Subject: Re: [quicwg/base-drafts] why require in order delivery? (#252)

From: MikkelFJ <[email-masked]>
Date: Mon, 13 Mar 2017 11:57:19 -0700

The issue is also how to handle retransmission. Can the core engine skip retransmission of old video frames - they might be large but useless? This requires framing within streams and a timeout criteria. The same applies to game servers. 

It is possible to multiplex over, say 16 streams, to get out of order tolerance, but it is not very user friendly and it does not deal with vasted retransmissions.

A related issue is prioritisation. If a low priority stream is allowed to fill available bandwidth it might fill buffers for several seconds in the pipeline. This hurts low latency transmissions. The flow control algorithm would need to understand this, like https://github.com/bittorrent/libutp

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/252#issuecomment-286208488

---

From: mirjak <[email-masked]>
Date: Tue, 14 Mar 2017 01:11:27 -0700

This sounds like you want streams with partial reliability which is in the charter for later.

Regarding the low latency case: I guess you could open a second connection and use a lower-than-best-effort congestion control for that one. However, I think we should not do this within one connection. My understanding really is that a quic connection is one flow for the network and therefore all packets of a quic flow should operate under the same congestion control domain.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/252#issuecomment-286350008