Subject: [quicwg/base-drafts] Does GOAWAY need an error code (#352)

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Mar 2017 16:38:08 -0800

In writing up a change for GOAWAY, I realize that it doesn't need to signal the error condition that triggered it.  An endpoint that wants to kill a connection can use CONNECTION_CLOSE and the error code that carries.  The purpose of GOAWAY is to signal graceful shutdown and to mark multiple streams as being safe to retry.

If it doesn't need an error code, then the reason phrase can go away as well.

(This might depend on the outcome of discussions that suggest that CONNECTION_CLOSE could be replaced by Public Reset.  Or, it might influence the outcome of that discussion...)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/352

---

From: ianswett <[email-masked]>
Date: Wed, 01 Mar 2017 17:50:02 -0800

I favor removing error code and the reason phrase from GOAWAY, but adding a sender side stream ID as mentioned in #347 

Removing the reason phrase is in #187 as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/352#issuecomment-283531076

---

From: janaiyengar <[email-masked]>
Date: Wed, 08 Mar 2017 11:26:58 -0800

Closed #352 via #355.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/352#event-991920709