Subject: [quicwg/base-drafts] Timestamps in acknowledgment of PING? (#388)

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Mar 2017 15:52:45 -0700

Should we encourage implementations to include a timestamp for the specific packet that contains a PING when acknowledging it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/388

---

From: ianswett <[email-masked]>
Date: Sun, 12 Mar 2017 16:22:04 -0700

PING frames are retransmittable, so the current text in 8.2 indicates one SHOULD include a timestamp.  This seems reasonable.  Is there a reason to do something else?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/388#issuecomment-285986263

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Mar 2017 16:26:52 -0700

The text says: " A receiver SHOULD send a timestamp exactly once for each retransmittable packet recevied."  Which doesn't really directly identify PING.  (Also, typo, and packets arent' retransmittable.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/388#issuecomment-285986594

---

From: ianswett <[email-masked]>
Date: Sun, 12 Mar 2017 17:06:15 -0700

Yes, it should be "for each received packet containing retransmittable frames."

It doesn't directly address PING, but a PING is retransmittable, so I don't think it needs to.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/388#issuecomment-285989372