Subject: Re: [quicwg/base-drafts] Promising more than the client concurrency limit (#281)

From: krasic <[email-masked]>
Date: Thu, 23 Mar 2017 15:20:13 -0700

Apologies for chiming in late.  

But it appears that this issue is a result of "simplifying" the state diagram to its present form as of the -02 mapping.    The previous reserved remote state exactly allowed the number of promises to be larger than the concurrency limit.    There would of course be a separate limit on the number of outstanding PUSH_PROMISES, and a corresponding ENHANCE_YOUR_CALM error when exceeded.   

I would propose adding back the "reserved" state as in the -01 revision.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/281#issuecomment-288878117

---

From: Martin Thomson <[email-masked]>
Date: Sat, 25 Mar 2017 08:06:50 -0700

This has nothing to do with the removal of the reserved state, which had no material effect on the protocol.  As you say, there was no limit on reserved streams.  Though the state doesn't appear, the value is still unlimited.  The problem is that you can't *use* a reserved stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/281#issuecomment-289217447

---

From: krasic <[email-masked]>
Date: Sat, 25 Mar 2017 11:38:43 -0700

Ok, but the state diagram in the -02 mapping draft indicates that a stream can be opened if a higher stream id was received.   In effect, this means opening one stream can imply the opening of others.  This was not the case in the prior state diagram.   Also, the text of prior revisions may have not called it out, but having a limit associated with the number of reserved streams independent of the number of open streams is the natural way to allow promises beyond the concurrency limit, but within a (higher) bound.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/281#issuecomment-289230890

---

From: Martin Thomson <[email-masked]>
Date: Sat, 25 Mar 2017 11:58:21 -0700

The change to have a stream open when a higher-numbered stream is used is a bug fix that was made at the same time as removing reservation.  You have to account for streams that you haven't seen, but are open anyway otherwise you have uneven accounting for concurrent streams.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/281#issuecomment-289232072