Subject: [quicwg/base-drafts] ALTSVC Frame (#371)

From: Mike Bishop <[email-masked]>
Date: Wed, 08 Mar 2017 10:28:40 -0800

As @LPardue has pointed out in the thread for #242, the HTTP/QUIC spec claims to update the IANA registry for "existing" frames.  It really only updates the frames defined in RFC7540; the ALTSVC frame defined in RFC7838 isn't updated.

It would be a simple update, but the question is where it belongs.  Should we:

- Add text in this document to include that frame, because it is "existing"?
- Write a new (very short) document updating RFC7838 with HTTP/QUIC support, following the recommendations in #363?
- Kick it back to the httpbis working group to write exactly the same very short document?

Note that the latter two options probably differ by nothing but the filename of the I-D in question -- the same people will probably end up writing it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/371

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 13 Mar 2017 07:55:46 -0700

I think that option 3 (kickback to httpbis) sets a good precedent for future extensions that want to use HTTP/QUIC. This potentially makes it clearer that drafts in httpbis-land shouldn't expect a free ride from the QUIC WG.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/371#issuecomment-286131770