Subject: Re: [quicwg/base-drafts] Resetting Streams (#165)

From: Lucas Clemente <[email-masked]>
Date: Tue, 07 Mar 2017 09:18:35 -0800

Sorry for taking a while to get to this. The current state of your PR allows a peer to keep sending data, even if it receives a RST_STREAM. I think the issue I raised is mostly resolved with that. Maybe we could add some more language to the HTTP draft, saying that if a RST (with QUIC_RECEIVED_RST) is received, the server should still continue sending its data, see the last bullet point:

- Client starts posting data to /invalid-url
- Server sends 404 header, REQUEST_RESET, starts sending 404 page
- Client received REQUEST_RESET, stops sending data, sends RST_STREAM (with QUIC_RECEIVED_RST as error code)
- Server receives RST_STREAM (QUIC_RECEIVED_RST), but chooses to continue sending its 404 page completely.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/165#issuecomment-284792306

---

From: Mike Bishop <[email-masked]>
Date: Tue, 07 Mar 2017 09:59:27 -0800

There was already a section about clients not discarding responses in that state; I just added a corresponding line about servers not freaking out either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/165#issuecomment-284804037

---

From: Lucas Clemente <[email-masked]>
Date: Tue, 07 Mar 2017 10:03:51 -0800

Cool, thanks! :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/165#issuecomment-284805315