Subject: Re: [quicwg/base-drafts] HTTP extension mechanisms (#242)

From: Lucas Pardue <[email-masked]>
Date: Wed, 08 Mar 2017 04:04:12 -0800

I've reread the section "Existing Frame Types" and have been left a bit muddled. 

The intent seems to be to redefine the the Frame Type Registry table defined in [RFC7540|https://tools.ietf.org/html/rfc7540#section-11.2]. However, the IANA managed [Frame Type Registry|https://www.iana.org/assignments/http2-parameters/http2-parameters.xhtml#frame-type] includes the additional ALTSVC frame, that was registered in RFC7540. 

Although Alt-Svc is a HTTP/2 extension, it seems a bit unfair to leave it out at this stage. Doing so would mean we need an RFC7838 "Update" doc in order to support its use with QUIC. Perhaps that was the intent?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/242#issuecomment-285023655

---

From: Mike Bishop <[email-masked]>
Date: Wed, 08 Mar 2017 08:14:22 -0800

Yeah, I've debated whether to include that here.  It's a dead simple mapping -- 0=>3, everything else the same.  But updating 7838 in the HTTP/QUIC spec feels a bit weird, too.  Maybe I should just spin up a separate I-D for ALTSVC frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/242#issuecomment-285086232

---

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Mar 2017 13:55:04 -0800

I think that it's past time to acknowledge that this isn't anything like h2.  We should do two things:

1. port h2 extensions that matter (like ALTSVC)

2. provide advice for porting h2 extensions

Yeah, that sucks, but we can't provide the same guarantees for extensions, so we can't guarantee that extensions will be be the same.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/242#issuecomment-285182119

---

From: Mike Bishop <[email-masked]>
Date: Wed, 08 Mar 2017 15:57:20 -0800

That's more or less the direction I'm heading in #363, though I've still got the joint IANA frame type / setting registry.  Have a section that talks about where we're similar and where we're different.  There's already advice on porting extensions, though it could probably be expanded.

Are you advocating we simply leave the HTTP/2 registry alone and start fresh?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/242#issuecomment-285209703

---

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Mar 2017 16:04:07 -0800

That's what I'm advocating :)  But I've been advocating that for a while.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/242#issuecomment-285210962

---

From: Mike Bishop <[email-masked]>
Date: Fri, 10 Mar 2017 09:46:30 -0800

Closed #242 via #363.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/242#event-995281208

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 22 Mar 2017 22:03:39 -0700

+1 to starting fresh from me.

Is this really closed?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/242#issuecomment-288618313

---

From: Mike Bishop <[email-masked]>
Date: Thu, 23 Mar 2017 05:32:42 -0700

Closed because there's text addressing it in -02.  The "split registries" has a separate issue, which is not closed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/242#issuecomment-288704384