Subject: [quicwg/base-drafts] Stream1 is not that special (#384)

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Mar 2017 20:48:33 -0800

This stream simply isn't that important.  We should definitely be able to function without the congestion control exemption.  I also removed the flow control exemption in line with other decisions we have made not to exempt stream 1 (it counts toward the concurrent stream limit, for example).  That was harder, but all it takes is realizing that we have default values for flow control that can be used prior to handshake completion.  Those defaults are so abundantly generous that only the most perverse certificate (or PQ key exchange) will get close to overflowing.

Closes #248.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/384

-- Commit Summary --

  * Remove flow control and congestion exemptions for stream 1
  * Limit cryptographic handshake size to 64K

-- File Changes --

    M draft-ietf-quic-transport.md (39)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/384.patch
https://github.com/quicwg/base-drafts/pull/384.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/384

---

From: janaiyengar <[email-masked]>
Date: Fri, 10 Mar 2017 09:41:10 -0800

I think this is fine, since neither of these limits should really cause grevious harm to the connection or the handshake. But it should be discussed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/384#issuecomment-285734825

---

From: ianswett <[email-masked]>
Date: Fri, 10 Mar 2017 09:47:03 -0800

ianswett commented on this pull request.

This seems fine, but I thought we decided to exclude the handshake from connection flow control, due to concerns about the client filling up the flow control with 0RTT data and not being able to complete the handshake?  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/384#pullrequestreview-26335164

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Mar 2017 17:21:17 -0700

Ahh, yes, I had forgotten that little tidbit.  I'll revise this to allow the exception for flow control.

That said, the server has the ability to send an authenticated WINDOW_UPDATE if it accepts 0-RTT (the only case where this matters, because otherwise 0-RTT data doesn't count*****).

** new issue inbound.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/384#issuecomment-285990299