Subject: [quicwg/base-drafts] Specify when multiple ack frames must be used (#423)

From: ianswett <[email-masked]>
Date: Wed, 29 Mar 2017 15:49:57 -0700

Currently the QUIC spec does not discuss sending multiple ack frames in one packet, and the way it's structured implies largest acked must always increase.  There are plans to use a new initial packet number and a new connection ID when migrating, making multiple ack frames valuable, if not strictly necessary, since otherwise you won't be able to continue acking pre-migration packets.

Additionally, this could allow the ack frame to be simpler by making all ack block lengths 1 byte long, instead of the current 1/2/4/6.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/423

---

From: Martin Thomson <[email-masked]>
Date: Thu, 30 Mar 2017 16:16:21 -0700

@ianswett, I like the idea that this could be made simpler.  I had thought of sending multiple frames, but not the fact that it could be a way to make ACK frames smaller and less complicated.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/423#issuecomment-290571690