Subject: [quicwg/base-drafts] Restructuring the QUIC packet header (#406)

From: janaiyengar <[email-masked]>
Date: Tue, 14 Mar 2017 22:18:42 -0700

There are a large number of issues are around the packet header. The simplified/streamlined header proposed in PR 361 can address the following laundry list of issues:
#35: Starting packet number
#56: Extending flags
#119: Server-proposed connection ID
#133: Connection ID in version negotiation
#135: DoS using Version Negotiation Packets
#147: Reflection Attack Resistance
#185: Reliable identification of the initial packet for a connection
#193: Flags section is kind of confusing
#244: Need a NONCE in version negotiation packets
#293: Does the connection ID need to be in a consistent location
#295: Connection ID on a version negotiation packet
#148: QUIC packet header complexity
#170: Connection ID collisions

We may want to change the header further, but it would be good to have consensus on PR 361 as being a good way forward.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/406

---

From: martinduke <[email-masked]>
Date: Wed, 15 Mar 2017 16:18:32 -0700

I think this is a good step in the right direction.

@martinthomson Note that a lot of KEY_PHASE language in the TLS draft has to be revised.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/406#issuecomment-286909823