Subject: [quicwg/base-drafts] Ignoring VERSION (#284)

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Feb 2017 23:14:19 -0800

The text currently says:

> Once a client receives a packet from the server with the VERSION flag unset, it MUST ignore the flag in subsequently received packets.

I don't know how to interpret this.  What should a client do if it receives a packet with the VERSION flag set after completing version negotiation?  Maybe should should mandate ignoring the packet not just the flag.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/284

---

From: Marten Seemann <[email-masked]>
Date: Thu, 09 Feb 2017 23:47:24 -0800

Ignoring the packet is the correct behavior, and is what current implementations do.
Otherwise it would be easy for an attacker to interfere with a connection, since version negotiation packets are not authenticated.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/284#issuecomment-278879055

---

From: Ryan Hamilton <[email-masked]>
Date: Fri, 10 Feb 2017 10:29:37 -0800

That text is definitely unclear. What it's *trying* to say, is that after the client and server have negotiated a version, the client needs to ignore any version negotiation packets its receives. This is because 0-RTT packets sent with the old version may have elicited version negotiation packets which may end up delivered out of order. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/284#issuecomment-279025723

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Feb 2017 15:39:07 -0800

It probably needs to go further and recommend that the client not change its mind more than once.  That is, if it receives a version negotiation packet that would cause it to select a *third* version, that's reason enough to ignore the packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/284#issuecomment-279262904