Subject: [quicwg/base-drafts] Packets or packet numbers (#310)

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Feb 2017 20:25:25 -0800

The text for `DetectLostPackets` claims that `acked_packet` is a packet number, but the code shows it as having a `packet_number` field, as well as a `time_sent` field.  Maybe a TimeSent() lookup function would work, but at the level that this code operates, I think that it would be better to talk about packets in the abstract.  A real implementation might not carry around all the information a packet might accumulate, but that's for real implementations to worry about.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/310

---

From: Martin Thomson <[email-masked]>
Date: Wed, 15 Feb 2017 19:03:32 -0800

FWIW, I've fixed this in #304, but only for this specific function.  The same problem exists in other functions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/310#issuecomment-280217235