Subject: [quicwg/base-drafts] Does PMTU fail really want unauthenticated PUBLIC_RESET? (#327)

From: Patrick McManus <[email-masked]>
Date: Sun, 19 Feb 2017 20:01:15 -0800

section 8 of transport:`

>  If a QUIC endpoint determines that the PMTU between any pair of local and remote IP addresses has fallen below 1280 octets, it MUST immediately cease sending QUIC packets between those IP addresses. This may result in abrupt termination of the connection if all pairs are affected. In this case, an endpoint SHOULD send a Public Reset packet to indicate the failure. 

but PR is defined as being a last resort and it is of course not authenticated.. while it is short, a CONNECTION_CLOSE only packet would also be below minimum MTUs for IPvmumble, and is authenticated and could carry some diagnostic information.

It seems like this error can be authenticated and therefore should be.. and more generally we shouldn't promote error reporting to RST as its interaction with already sent data is very unclear if TCP RST is any kind of corollary.
`

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/327

---

From: Ryan Hamilton <[email-masked]>
Date: Mon, 20 Feb 2017 15:14:18 -0800

Totally agree. CONNECTION_CLOSE seems much more appropriate here.

On Sun, Feb 19, 2017 at 8:01 PM, Patrick McManus <[email-masked]>
wrote:

> section 8 of transport:`
>
> If a QUIC endpoint determines that the PMTU between any pair of local and
> remote IP addresses has fallen below 1280 octets, it MUST immediately cease
> sending QUIC packets between those IP addresses. This may result in abrupt
> termination of the connection if all pairs are affected. In this case, an
> endpoint SHOULD send a Public Reset packet to indicate the failure.
>
> but PR is defined as being a last resort and it is of course not
> authenticated.. while it is short, a CONNECTION_CLOSE only packet would
> also be below minimum MTUs for IPvmumble, and is authenticated and could
> carry some diagnostic information.
>
> It seems like this error can be authenticated and therefore should be..
> and more generally we shouldn't promote error reporting to RST as its
> interaction with already sent data is very unclear if TCP RST is any kind
> of corollary.
> `
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/327>, or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ASp6ysGAx_r74CKslVxw_9LDH23pTQhHks5reRALgaJpZM4MFvch>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/327#issuecomment-281203498

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 Feb 2017 15:34:08 -0800

Duplicate of #289.

(FWIW, my reading of the list is that this is unequivocally good.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/327#issuecomment-281206030

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 Feb 2017 15:34:08 -0800

Closed #327.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/327#event-969916244