Subject: Re: [quicwg/base-drafts] CONTINUATION/END_HEADERS (#76)

From: Patrick McManus <[email-masked]>
Date: Mon, 20 Feb 2017 18:19:49 -0800

fwiw - I've had firefox telemetry looking at the h2 data on this for the last few weeks. It has ~4billion server generated HEADERS samples and 0 CONTINUATIONS

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/76#issuecomment-281226785

---

From: Ryan Hamilton <[email-masked]>
Date: Mon, 20 Feb 2017 18:49:00 -0800

YAGNI time?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/76#issuecomment-281230627

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 Feb 2017 18:50:21 -0800

That's an very interesting data point.  We never got the measurements while developing h2, so we were left with speculation and a few corner cases.  I think that @MikeBishop had one of those perverse cases (was it Kerberos?).  The other was really big URIs.

Since this operates at a different layer and we don't need to constrain frame sizes for head of line blocking reasons, it's tempting to say 16bits of length is OK.  That's four times what we allow in h2.

+1 to YAGNI.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/76#issuecomment-281230820

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 21 Feb 2017 00:48:56 -0800

A couple of observations:

- The places where this is most likely (behind firewalls in enterprises, in non-browser uses of H2) are least likely to show up in telemetry.

- Limiting the size of headers is a semantic change in HTTP; this is not a trivial thing.

- As we discussed in H2, the interop failures here are *really* nasty, especially for intermediaries.

- To me, much more interesting data would be some sense of how well greased CONTINUATION is in H2. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/76#issuecomment-281280734