Subject: Re: [quicwg/base-drafts] Use quic= instead of v= (#235)

From: Mike Bishop <[email-masked]>
Date: Wed, 01 Feb 2017 09:46:52 -0800

MikeBishop commented on this pull request.

>      version-number = 1*8HEXDIG; hex-encoded QUIC version
 
-When multiple versions are supported, the "v" parameter MAY be repeated multiple
-times in a single Alt-Svc entry.  For example, if a server supported both
-version "Q034" and version 0x00000001, it would specify the following header:
+When multiple versions are supported, the "quic" parameter MAY be repeated
+multiple times in a single Alt-Svc entry.  For example, if a server supported
+both version "Q034" and version 0x00000001, it could specify the following

It's still there primarily because I wanted to be able to show the multiple-entry case.  However, it might make more sense to change that to a draft version and leave the ASCII-like versions out entirely.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/235

---

From: Mike Bishop <[email-masked]>
Date: Wed, 01 Feb 2017 09:48:03 -0800

Mm.  Except that the draft versions won't be in the final QUIC RFC, so there won't be any context for that reference once it's eventually published.  Maybe not.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 01 Feb 2017 09:53:08 -0800

-    Alt-Svc: hq=":443";v="x1";v="cQ034"
+    Alt-Svc: hq=":443";quic=1;quic=51303334

Basically, yes.  I've made that explicit in a9e47f2.

---

From: Lars Eggert <[email-masked]>
Date: Wed, 01 Feb 2017 09:53:17 -0800

larseggert commented on this pull request.

We could add that context, or we could add a "note to the RFC Editor" to remove Q034 and the related text on publication.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 01 Feb 2017 09:53:30 -0800

@MikeBishop pushed 1 commit.

a9e47f2  Clarifying example versions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/235/files/6b1b10d3eb02a471214dc507d491402318e724a0..a9e47f2b4b83adbbdbe434b103c307a99a53ab96

---

From: Mike Bishop <[email-masked]>
Date: Wed, 01 Feb 2017 09:56:53 -0800

But then we'd still have to give them something to replace it with, and keeping the "how to do multiple" is worthwhile.  I've expanded slightly, to refer to it as the version that would be rendered in ASCII as `Q034`.  Given that we allow pretty free-form experimentation in that region, I don't know that we need to elucidate *why* a server might support an experimental version.

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 01 Feb 2017 11:08:49 -0800

I suppose you could reserve a version for documentation purposes. E.g
DEADBEEF

On 1 Feb 2017 5:56 p.m., "Mike Bishop" <[email-masked]> wrote:

> *@MikeBishop* commented on this pull request.
> ------------------------------
>
> In draft-ietf-quic-http.md
> <https://github.com/quicwg/base-drafts/pull/235>:
>
> But then we'd still have to give them something to replace it with, and
> keeping the "how to do multiple" is worthwhile. I've expanded slightly, to
> refer to it as the version that would be rendered in ASCII as Q034. Given
> that we allow pretty free-form experimentation in that region, I don't know
> that we need to elucidate *why* a server might support an experimental
> version.
>
> —
> You are receiving this because you commented.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/pull/235>, or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AGRFtQm-YhTz-maPVm_o9JUUXdJpu5Ehks5rYMdlgaJpZM4LuMve>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/235#issuecomment-276750225

---

From: janaiyengar <[email-masked]>
Date: Wed, 01 Feb 2017 16:50:00 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/235#pullrequestreview-19695031

---

From: janaiyengar <[email-masked]>
Date: Wed, 01 Feb 2017 23:21:01 -0800

I think we merge the changes to keep our repo and CL stack sane. The chairs can call consensus and if there's no consensus, we can always roll back.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/235#issuecomment-276885874

---

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Feb 2017 23:30:59 -0800

Yep, I'll press the button so that you can blame me when we realize that don't have consensus.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/235#issuecomment-276887164

---

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Feb 2017 23:31:03 -0800

Merged #235.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/235#event-946000908

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 02 Feb 2017 19:55:30 -0800

@martinthomson (too many martins on this repo!) -- 

`notify-consensus` is only a bookkeeping measure to remind us to tell the list that we closed an issue. 

I think the label you're looking for is `editor-ready`, and it should only be applied by the chairs. Mike did the right thing by pinging me on the issue, sorry I missed the notification.

This is all amenable to changes, of course, but let's see if we can all get on the same page first.

As a reminder, see also:
  https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md#resolving-issues

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/235#issuecomment-277158628