Subject: [quicwg/base-drafts] Does any portion of the QUIC framing require 4 byte alignment? (#292)

From: ianswett <[email-masked]>
Date: Sun, 12 Feb 2017 09:17:46 -0800

@martinthomson Wrote up a public header proposal that implies 4 byte alignment is an important goal of the public header.

Is it necessary, as it does constrain the design space substantially?  And if there are environments it's necessary, is it only a requirement for non-endpoint devices(aka middleboxes), so only applies to the non-protected portion of the packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/292

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Feb 2017 16:28:06 -0800

The answer is no.  That was an emergent property only.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/292#issuecomment-279568555

---

From: janaiyengar <[email-masked]>
Date: Thu, 16 Feb 2017 08:32:44 -0800

I don't think we need this. I'd like to close this issue since I didn't / don't see anyone asking for it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/292#issuecomment-280382679

---

From: ianswett <[email-masked]>
Date: Thu, 16 Feb 2017 08:33:31 -0800

I misinterpreted Martin's proposal as asking for it, so closing this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/292#issuecomment-280382916

---

From: ianswett <[email-masked]>
Date: Thu, 16 Feb 2017 08:33:31 -0800

Closed #292.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/292#event-965288930