Subject: Re: [quicwg/base-drafts] Split LINK into DATA, PUSH_PROMISE, and RESPONSE (ae53ad9)

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Feb 2017 17:52:31 -0800

Ever noticed how delta and direction always have the same value?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/ae53ad9e1459f139ef02beb98f6b4f640b73dfd4#commitcomment-21060267

---

From: Mike Bishop <[email-masked]>
Date: Sun, 26 Feb 2017 22:04:26 -0800

They're a tri-state.  If Delta=0, Direction is ignored (and MUST be zero, I think I said).  Delta=1, Direction=0 is possible, though I couldn't fit it into my example.  For example, consider a RESPONSE frame on server's 25 responding to client's 18.  Delta=1, Direction=0, StreamReference=7.  But I agree, that combination would be surprising in a DATA or PUSH_PROMISE frame, to say the least.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/ae53ad9e1459f139ef02beb98f6b4f640b73dfd4#commitcomment-21061911