Subject: [quicwg/base-drafts] Avoid using Public Reset where possible (#289)

From: Martin Thomson <[email-masked]>
Date: Fri, 10 Feb 2017 00:41:14 -0800

The draft currently says:

> In this case, an endpoint SHOULD send a Public Reset packet to indicate the failure. 

(This is in the context of discovering that the MTU is too small.)

Given that it doesn't take much to send an authenticated CONNECTION_CLOSE in a packet that won't risk breaking even the minimum IPv4 MTU, I think that the first requirement is crazy.  I would change this to "treat this as a connection error of SOME_ERROR_CODE" either defining a new MTU_TOO_SMALL error code, or reusing an existing one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/289

---

From: Ryan Hamilton <[email-masked]>
Date: Fri, 10 Feb 2017 10:23:32 -0800

Completely agree. I think Public Reset should be used as sparingly as possible. Perhaps only the case when a server receives a packet for a connection ID it has no state for. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/289#issuecomment-279024199

---

From: Patrick McManus <[email-masked]>
Date: Mon, 20 Feb 2017 18:15:02 -0800

sorry about the dup - it seems I still have trouble mining the github issue system effectively.

While we're at it the language in 6.4 that allows an endpoint to send a public_reset at any time to abruptly terminate an active connection should be significantly tightened or removed.. we don't want this to become the mechanism to ending things.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/289#issuecomment-281226149

---

From: ianswett <[email-masked]>
Date: Tue, 21 Feb 2017 06:18:23 -0800

Agreed, I think it's important to clarify when connection closes should be sent and when public resets are sent.  I think there's a lot of agreement around this, but there's not much text clarifying it yet.

The rules on processing them could be clarified as well.  ie: Should public resets before handshake completion be ignored, because there's no reason to ever send them?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/289#issuecomment-281356430

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Feb 2017 17:15:16 -0800

Closed #289 via #335.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/289#event-977647748