Subject: [quicwg/base-drafts] Move length-determining fields to the start of STREAM and ACK (#277)

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Feb 2017 19:12:07 -0800

I considered a more violent change here, but decided to start with the simplest move.

I really want to rewrite the ACK section, it's a little obtuse as it is.  I think that it could be made a lot clearer.

Closes #62.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/277

-- Commit Summary --

  * Move length-determining fields to the start of STREAM and ACK

-- File Changes --

    M draft-ietf-quic-transport.md (31)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/277.patch
https://github.com/quicwg/base-drafts/pull/277.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/277

---

From: ianswett <[email-masked]>
Date: Thu, 09 Feb 2017 10:12:47 -0800

ianswett approved this pull request.

Let's do this for now, we can go through and simplify other things later.

> @@ -920,28 +920,29 @@ A STREAM frame is shown below.
  0                   1                   2                   3
  0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
+|       [Data Length (16)]      |
++-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 |                    Stream ID (8/16/24/32)                   ...
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 |                Offset (0/16/24/32/40/48/56/64)              ...

Huh, we have 8 different offsets.  And they 're not even evenly spaced.  That's cute.  

Jana and I can clean that up in our draft, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/277#pullrequestreview-21078130

---

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Feb 2017 15:52:27 -0800

martinthomson commented on this pull request.

  0                   1                   2                   3

Yeah, that's a separate issue.  I can understand why it is that way.  That is, there isn't much value in an 8-bit offset given that you are likely to cram > 8 octets in a single packet, which is the most common case for needing offsets.  That said, I think that we would want to discuss what options make sense.

I can see arguments for 0, 16, and 32 and 64 would avoid the need for rollover calculations.  The other options seem like overoptimizing. varint encoding would be preferable in that case.

---

From: janaiyengar <[email-masked]>
Date: Thu, 16 Feb 2017 14:17:31 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/277#pullrequestreview-22377128

---

From: janaiyengar <[email-masked]>
Date: Thu, 16 Feb 2017 14:17:43 -0800

Merged #277.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/277#event-965844786