Subject: [quicwg/base-drafts] ECN in QUIC (#268)

From: martinduke <[email-masked]>
Date: Wed, 08 Feb 2017 11:06:52 -0800

Given that many of us, when wearing tsvwg hats, are ECN evangelists, it's a little odd that support for this hasn't come up.

I see that there's now an internet-draft on this subject:
[https://tools.ietf.org/html/draft-johansson-quic-ecn-00]

It's debatable if it's better to put the ECE/CWR bits in the ACK frame (as the draft suggests) or in some newly-liberated public flags.

As an added feature/bug, depending on your perspective, service providers interested in enforcing fairness or bandwidth limits could use ECN bits as fairly clean way to do this. With TCP, a common flow-control tool is the receive window, but that is not available here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/268

---

From: martinduke <[email-masked]>
Date: Wed, 08 Feb 2017 11:10:50 -0800

Closed #268.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/268#event-954392930

---

From: martinduke <[email-masked]>
Date: Wed, 08 Feb 2017 11:11:24 -0800

This is a duplicate of #68 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/268#issuecomment-278430377