Subject: [quicwg/base-drafts] Policing packet number size (#285)

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Feb 2017 23:20:35 -0800

>From the document:

> DISCUSS: Should the receiver be required to enforce this rule that the sender MUST NOT exceed the inflight limit? Specifically, should the receiver drop packets that are received outside this window?

As a reminder, we require that the packet number size be determined based on the number of outstanding (undefined, but assumed to be packets that are sent but not yet acknowledged).

A requirement like this would be virtually impossible to enforce.  The receiver would have to know what of its acknowledgments had arrived at the sender in order to know what was outstanding when the sender generated the packet.  That's only possible in a narrow set of cases.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/285

---

From: ianswett <[email-masked]>
Date: Fri, 10 Feb 2017 07:41:29 -0800

I would lean towards not enforcing it.  And if one was going to enforce it, there should be a connection close error associated with it, because debugging silent failures would be virtually impossible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/285#issuecomment-278978101

---

From: janaiyengar <[email-masked]>
Date: Thu, 16 Feb 2017 22:24:17 -0800

Closed #285 via #288.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/285#event-966337467