Subject: Re: [quicwg/base-drafts] Intra-frame padding (#158)

From: Richard Bradbury <[email-masked]>
Date: Fri, 10 Feb 2017 09:18:05 -0800

This proposal sounds like a real boon for zero-copy senders. The cost is greater receiver complexity, which could manifest as lower receiver performance.

A receiver seeing a PADDING frame could hitherto discard the rest of a QUIC packet safely without further consideration and move onto the next packet. With this new approach, it will no longer be safe to do that: the parser must keep parsing 1-byte PADDING frames until it finds a different type of frame, or reaches the end of the packet.

If the PADDING frame included a length, it would be possible to advance a pointer to the start of the next frame in a single parser action. Without a length field, the parser must work through the PADDING frames one by one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/158#issuecomment-279004876

---

From: Mike Bishop <[email-masked]>
Date: Fri, 10 Feb 2017 10:47:13 -0800

(It actually is INTER-, because we're not talking about stopping mid-frame to introduce some padding.  We're talking about having padding between frames, where current that's prohibited.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/158#issuecomment-279030890

---

From: janaiyengar <[email-masked]>
Date: Mon, 13 Feb 2017 16:08:13 -0800

Closed #158 via #276.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/158#event-960570353