Subject: Re: [quicwg/base-drafts] Timestamp Block - Zero indexing? (#102)

From: Anton Barkovsky <[email-masked]>
Date: Mon, 20 Feb 2017 07:58:40 -0800

The "including the First Timestamp" text seems to be gone and now I have no idea how to determine if this first optional timestamp is actually there. Can someone who understands how this is supposed to work please clarify?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/102#issuecomment-281115908

---

From: ianswett <[email-masked]>
Date: Mon, 20 Feb 2017 10:34:53 -0800

If the num_timestamps byte is 0, the timestamp section is not present..  

The currentt text also says "Delta Largest Acked 1..N(opt, repeated)" and Time Since Previous Timestamp 1..N(opt, repeated)" but I believe these should be 0..N.

I'm going to update the timestamp section in the near future, so I'll ensure that's fixed and clarify that if the num timestamps is 0, the timestamp section is absent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/102#issuecomment-281151990

---

From: Anton Barkovsky <[email-masked]>
Date: Mon, 20 Feb 2017 10:50:15 -0800

So if num_timestamps is 1, then one delta and the first timestamp must be present for a total of 40 bytes in this section?

If so, I don't see how 0..N makes sense for the additional timestamps. Maybe there should be text saying that N = num_timestamps - 1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/102#issuecomment-281155812