Subject: Re: [quicwg/base-drafts] PMTUD (#106)

From: martinduke <[email-masked]>
Date: Tue, 07 Feb 2017 16:34:16 -0800

> Policing this will be difficult, if not impossible, if there are extension headers. Userspace implementations might not even learn about them. From what I can tell, there is no limit to the size of extension headers in IPv6, so we can't really require that this enforcement happen.

While I agree that the IP header length is somewhat unpredictable, a user space implementation that doesn't know what's going on will presumably assume the minimum IP header length, and the packet will end up too big, not big enough.

All of the 1st-packet restrictions are meaningless if the implementation is allowed to assume an IP header length > minimum without knowing that that is the case.

Other fixes are in the following commit, though I did not take Martin's suggestions verbatim in every case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/106#issuecomment-278191303

---

From: martinduke <[email-masked]>
Date: Tue, 07 Feb 2017 16:34:56 -0800

@martinduke pushed 1 commit.

cfaeff6  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/106/files/5bf31689873343f75f8e7f7d854c360dc602a884..cfaeff689a7d3d9a8204939c2cdea61f7e75077d

---

From: janaiyengar <[email-masked]>
Date: Tue, 07 Feb 2017 17:33:00 -0800

janaiyengar approved this pull request.

I'd like to editorialize a bit, but let's get this merged and then editorialize. martinthomson@, look good?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/106#pullrequestreview-20665432

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Feb 2017 20:15:51 -0800

Merged #106.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/106#event-953241483

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Feb 2017 20:15:46 -0800

Yes, I will open an issue for the one thing I raised.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/106#issuecomment-278224774