Subject: [quicwg/base-drafts] Clarify meaning/definition of GOAWAY (#347)

From: ianswett <[email-masked]>
Date: Fri, 24 Feb 2017 07:11:02 -0800

GOAWAY has a "Last Good Stream ID", which is "The last Stream ID which was accepted by the sender of the GOAWAY message. If no streams were replied to, this value must be set to 0."

The sender does not specify the last stream id it will use, which I think it should.

I also think the text in "6.6 Connection Termination" should specify that all streams <= the Last Good Stream ID will be completed(fin'd or reset), including delivering any outstanding data. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/347

---

From: Mike Bishop <[email-masked]>
Date: Fri, 24 Feb 2017 13:09:07 -0800

This is probably a vestige from HTTP/2, where the last stream created by the server prior to sending a GOAWAY was deterministic.  You're right, this needs to be explicit in QUIC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/347#issuecomment-282405004