Subject: [quicwg/base-drafts] Remove the quic parameter from Alt-Svc (#297)

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Feb 2017 16:46:45 -0800

Ostensibly, the `quic` parameter is a performance optimization for Alt-Svc.  A client can learn what QUIC version is most likely to succeed and use that version.  That increases the chances that version negotiation succeeds and thereby reduces the chance that the QUIC connection setup costs an extra round trip.

However, alternative services is precisely the point where performance is not critical.  The client already has a perfectly function HTTP/1.1 or HTTP/2 connection to the server.  This is a point where they could afford an additional round trip on connection setup.  @MikeBishop suggested that if we are serious about greasing version negotiation, perhaps we could remove the `quic` parameter from the Alt-Svc header field and force clients to always pick a greased version number for their initial packet.

Advantages: grease more often and version negotiation actually gets a real workout, disadvantages: an extra round trip every time you use Alt-Svc.

This came up in #278.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/297

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Feb 2017 16:48:07 -0800

OK, duplicate of #296.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/297#issuecomment-279572015

---

From: Mike Bishop <[email-masked]>
Date: Mon, 13 Feb 2017 16:50:51 -0800

Race!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/297#issuecomment-279572492

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Feb 2017 16:48:07 -0800

Closed #297.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/297#event-960608037