Subject: Re: [quicwg/base-drafts] Connection ID collisions (#170)

From: janaiyengar <[email-masked]>
Date: Fri, 10 Feb 2017 16:41:21 -0800

Given that we're heading towards server-generated connection IDs, I suggest we close this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170#issuecomment-279104547

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Feb 2017 16:24:03 -0800

I think that we still need to consider this.  The odds are going to be extremely low, because it's only really relevant during version negotiation of the two colliding identifiers.  But we should probably at least acknowledge the problem even if we don't plan to do anything about it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170#issuecomment-279268669

---

From: ianswett <[email-masked]>
Date: Tue, 14 Feb 2017 07:57:26 -0800

We could assume both connection ID and IP/port are all unchanging during the handshake, which would allow the collision to be resolved when the server picks a new connection id.  I believe this solves the collision problem in every case I can imagine.

Yeah for server chosen connection ids!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170#issuecomment-279748226

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Feb 2017 15:16:07 -0800

@ianswett, your point being that if you have a collision on connection ID + source IP + source port then you have won the lottery and you might as well give up (chances are that this is a badly busted client).  Otherwise, the server can pick a new connection ID during the handshake and avoid collisions.  That WFM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170#issuecomment-279867576

---

From: Martin Thomson <[email-masked]>
Date: Wed, 15 Feb 2017 19:02:20 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170#issuecomment-280217051