Subject: Re: [quicwg/base-drafts] Explicit Congestion Notification (ECN) (#68)

From: martinduke <[email-masked]>
Date: Wed, 08 Feb 2017 11:11:57 -0800

I endorse mandatory ECN support in QUIC.

I see that there's now an internet-draft on this subject:
(https://tools.ietf.org/html/draft-johansson-quic-ecn-00)

It's debatable if it's better to put the ECE/CWR bits in the ACK frame (as the draft suggests) or in some newly-liberated public flags.

As an added feature/bug, depending on your perspective, service providers interested in enforcing fairness or bandwidth limits could use ECN bits as fairly clean way to do this. With TCP, a common flow-control tool is the receive window, but that is not available here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/68#issuecomment-278430524

---

From: IngJohEricsson <[email-masked]>
Date: Mon, 20 Feb 2017 05:27:23 -0800

Hi

Thanks for the comment.
As regards to the ECE/CWR bits, I would believe that we have a reasonably good agreement that for QUIC it is best to echo the ECN bits as is. There are three variants in the draft and there is not conclusion which is the best alternative (or if there should be something else)

/Ingemar

From: martinduke [mailto:[email-masked]]
Sent: den 8 februari 2017 20:12
To: quicwg/base-drafts <[email-masked]>
Cc: Ingemar Johansson S <[email-masked]>; Comment <[email-masked]>
Subject: Re: [quicwg/base-drafts] Explicit Congestion Notification (ECN) (#68)

—
You are receiving this because you commented.
Reply to this email directly, view it on GitHub<https://github.com/quicwg/base-drafts/issues/68#issuecomment-278430524>, or mute the thread<https://github.com/notifications/unsubscribe-auth/AKOdGKXZqkAOJaDwg7HfdI3U7RkJrBkkks5rahN9gaJpZM4LDU7v>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/68#issuecomment-281078931