Subject: [quicwg/base-drafts] Skipping packet numbers (#287)

From: Martin Thomson <[email-masked]>
Date: Fri, 10 Feb 2017 00:14:40 -0800

According to @marten-seemann, they occasionally skip a packet number.  This might mess with congestion control if it is done too often, but it seems like a perfectly reasonable thing to do.  The draft currently forbids this.  Maybe it shouldn't.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/287

---

From: ianswett <[email-masked]>
Date: Fri, 10 Feb 2017 07:38:23 -0800

The sender is skipping packet numbers and also doing congestion control, so it shouldn't have any adverse side effects, since it knows which numbers were skipped.

Where is it forbidden in the draft?  In 7.2 it says "A sender MAY intentionally skip packet numbers to introduce entropy into the connection, to avoid opportunistic ack attacks."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/287#issuecomment-278977249

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Feb 2017 15:35:31 -0800

Closed #287.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/287#event-958850753

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Feb 2017 15:35:31 -0800

Nope, you are right, I misread.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/287#issuecomment-279262434