Subject: Re: [quicwg/base-drafts] What do we do if special packets are lost (#241)

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Feb 2017 17:32:10 -0800

There are three cases of interest here: the initial handshake packet from a client (if lost retry on a timer), the version negotiation packet (send in response to every packet that arrives with the wrong version number ...maybe limiting it to those that are plausibly an initial handshake packet), and a public reset (I don't know what the rule might be here, but I suspect there is a timer involved as well).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/241#issuecomment-276839322

---

From: ianswett <[email-masked]>
Date: Thu, 02 Feb 2017 08:21:23 -0800

Agreed on the first two.

Public reset currently is, and I believe should continue to be, like the version negotiation packet.  Send (at most) one per packet received.  Public resets need to be stateless, and timers add state.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/241#issuecomment-277004695