Subject: [quicwg/base-drafts] Refine retransmission rules (#298)

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Feb 2017 16:52:24 -0800

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/298

-- Commit Summary --

  * Refine retransmission rules

-- File Changes --

    M draft-ietf-quic-transport.md (23)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/298.patch
https://github.com/quicwg/base-drafts/pull/298.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/298

---

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Feb 2017 11:19:04 -0800

Might be worth expanding a little bit about what parts of a lost ACK get bundled into new ACK frames.  Most notably, IIUC, while the Ack Block section is simply cumulative, the Timestamp entry only gets sent once per frame.  If an ACK is lost, the next ACK needs to re-send that timestamp, doesn't it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/298#issuecomment-279806779

---

From: ianswett <[email-masked]>
Date: Tue, 14 Feb 2017 11:28:01 -0800

The current approach only sends a given timestamp once, because by the time you realize they're lost, it's been an RTT and they're expected to be useless.  This also makes the logic much simpler.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/298#issuecomment-279809382

---

From: ianswett <[email-masked]>
Date: Tue, 14 Feb 2017 12:31:06 -0800

ianswett commented on this pull request.

One comment on how acks are generated.

-* ACK, STOP_WAITING, and PADDING frames MUST NOT be retransmitted.  New frames
-  of these types may however be bundled with any outgoing packet.
+* ACK, STOP_WAITING, and PADDING frames MUST NOT be retransmitted.  ACK and
+  STOP_WAITING frames are cumulative, so new frames will be created that contain
+  the data from any lost frame.

How about "ACK and STOP_WAITING frames are cumulative, so new frames containing updated information will be sent as described in {#frame-ack}."  One would not actually track what was sent in the ack and retransmit it, since acks are cumulative.

The {#frame-ack} section doesn't have any text on only sending timestamps once, so that should be clarified, but most of the rest of the text is there, so I would tend to keep it there.  I can clarify that text when I do the stop waiting removal, which probably requires me getting an editor setup you and Mike don't hate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/298#pullrequestreview-21854576

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Feb 2017 16:21:41 -0800

@martinthomson pushed 1 commit.

49e0ca0  Updated information in ACK follows rules defined for the frame

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/298/files/11983677875c23cb1d6f54844acdf6c6a7311b9f..49e0ca0c0a5d2bf72f4524e23f82b249bdfc3228

---

From: janaiyengar <[email-masked]>
Date: Thu, 16 Feb 2017 22:26:58 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/298#pullrequestreview-22429605

---

From: janaiyengar <[email-masked]>
Date: Thu, 16 Feb 2017 22:27:03 -0800

Merged #298.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/298#event-966340083