Subject: [quicwg/base-drafts] Editorial issue with STOP_WAITING (#178)

From: Dragana Damjanovic <[email-masked]>
Date: Thu, 19 Jan 2017 03:44:22 -0800

In Section 7.3 (STOP_WAITING Frame), Least Unacked Delta is calculated using the packet ID of the packet carrying the STOP_WAITING frame. This is reasonable. 

In the ACK Frame section:

> An endpoint SHOULD use the "Largest Acked" packet number it received to calculate the "Least Unacked Delta" value in any STOP_WAITING frame it might send.

Maybe I understood it wrong but it suggest to calculate Least Unacked Delta using "Largest Acked".
This should be written in a different way if it meant that the information from an ack (not only "Largest Acked" but also unacked gaps ) is used to decide to send a STOP_WAITING frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/178

---

From: ianswett <[email-masked]>
Date: Thu, 19 Jan 2017 08:27:45 -0800

The intent is to cause the least unacked in the stop waiting to be raised to the most recently received largest acked.

Would it be clearer if the sentence was "The endpoint SHOULD raise the Least Unacked communicated via future STOP_WAITING frames to the most recently received Largest Acked"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/178#issuecomment-273824083

---

From: Dragana Damjanovic <[email-masked]>
Date: Thu, 19 Jan 2017 10:02:45 -0800

Yes, that is clearer. Thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/178#issuecomment-273850746