Subject: [quicwg/base-drafts] What happens with lost packets that are detected when an Ack arrives (#144)

From: Marten Seemann <[email-masked]>
Date: Thu, 12 Jan 2017 21:15:11 -0800

In the loss recovery draft, `OnPacketAcked` is called for every packet that is acked by an incoming Ack frame.
This function calls `DetectLostPackets`, which returns a list of packets that are considered lost. However, this return value is never used in `OnPacketAcked`.

Furthermore, looking at `DetectLostPackets` in detail, it seems to me that it would be sufficient to call that function once (with the largest observed packet as function parameter) when receiving an Ack.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/144

---

From: Marten Seemann <[email-masked]>
Date: Sun, 15 Jan 2017 08:39:35 -0800

It seems like my last point has already been resolved by the recent changes to the draft (`DetectLostPackets` is now called with `ack.largest_acked_packet`).

So this just leaves my original question what happens with the return values of `DetectLostPackets` when called from `OnAckReceived`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/144#issuecomment-272706675

---

From: ianswett <[email-masked]>
Date: Mon, 16 Jan 2017 06:11:27 -0800

Yes, what to do with lost packets is missing. 

Two main things I plan to add:
1) Decide whether to retransmit any frames in the packets.
2) Notify the congestion control interface and pass any lost packets to that.  

I hadn't decided if I was going to use a list of frames to be retransmitted for (1), or keep two numbers, one for the earliest lost packet that hasn't been retransmitted and one for the largest lost packet.  I think the latter is closer to how I'd recommend people implement it and I think may be easier to describe.  Thoughts?

Tell me if I'm missing anything.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/144#issuecomment-272870952