Subject: Re: [quicwg/base-drafts] ALPN Tokens and Alt-Svc (#90)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 03:43:41 -0800

martinthomson approved this pull request.

-   Alt-Svc: quic=":443"; v="34,33"
+## QUIC version hints {#alt-svc-version-hint}

Should we use "Title Case For Headers" or "Sentence case for headers"?

>  on port 443 and, if successful, send HTTP requests using the mapping described
-in this document.
+in this document.  Servers SHOULD list only versions which they support, but MAY

This seems to refer to the example specifically.  but we're now a few paragraphs down.  Either speak generically "the client MAY attempt to establish a QUIC connection on the specified port" or refer to the example directly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/90#pullrequestreview-14914115

---

From: Mike Bishop <[email-masked]>
Date: Tue, 03 Jan 2017 13:54:02 -0800

@MikeBishop pushed 1 commit.

77a0289  Martin's feedback on Alt-Svc

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/90/files/a001407c66dd6566e96f55a287a31836174d1f50..77a028977ea666ecdb1fa6603764dcb97be31911

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jan 2017 16:58:48 -0800

martinthomson commented on this pull request.

-On receipt of this header, a client may attempt to establish a QUIC connection
-on port 443 and, if successful, send HTTP requests using the mapping described
-in this document.
+This document defines the "v" parameter for Alt-Svc, which is used to provide
+version-negotiation hints to HTTP/QUIC clients. Syntax:
+
+    v = quoted-versions
+    quoted-versions = DQUOTE *( version-string "," ) version-string DQUOTE
+    version-string = token; percent-encoded QUIC version
+
+For example, if a server supported both version Q033 and Q034 it would specify
+the following header:
+
+    Alt-Svc: hq=":443"; v="Q034,Q033"

A note to discuss version representation:

You have a character string, I chose to go with just numbers.  Both have merits.  Numbers are simpler, but potentially longer (hexadecimal saves a few octets for larger values if you want to go there), but a four character string can be quite friendly.  You have to pick the right values though or you get a mash of %xx strings.

`Alt-Svc: hq=":443;v=<version>;v=<version>` might be better than creating a micro-syntax for the list.  See also httpwg/http-extensions#281

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/90#pullrequestreview-15426058

---

From: Patrick McManus <[email-masked]>
Date: Wed, 11 Jan 2017 12:22:05 -0800

this is an important one to get in asap - thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/90#issuecomment-271982928

---

From: Mike Bishop <[email-masked]>
Date: Fri, 13 Jan 2017 12:00:27 -0800

@MikeBishop pushed 2 commits.

9859f04  Merge remote-tracking branch 'origin/master' into alpn-alt-svc
6e5abb7  Handle non-token version numbers better

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/90/files/77a028977ea666ecdb1fa6603764dcb97be31911..6e5abb7035fb9964ada7b7527cf30611d9e8527a

---

From: Mike Bishop <[email-masked]>
Date: Fri, 13 Jan 2017 14:05:34 -0800

Merged #90.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/90#event-922901013