Subject: [quicwg/base-drafts] Clarify how post-handshake TLS handshake messages are transmitted (#239)

From: Victor Vasiliev <[email-masked]>
Date: Wed, 25 Jan 2017 22:14:17 -0800

My understanding of the way the mechanism is supposed to work is that once the handshake is finished, QUIC takes over the encryption;  if server wants to send an NST, it needs to send it on stream 1, using TLS record layer on said stream, and said TLS record shall not be encrypted.  If that is so, this should be clarified, because otherwise this can be interpreted as a requirement to double-encrypt streams (on QUIC packet layer with QUIC key, and on TLS record layer with TLS traffic keys).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/239

---

From: Mike Bishop <[email-masked]>
Date: Mon, 30 Jan 2017 09:55:23 -0800

Draft explicitly covers this, and it *is* a requirement to double-encrypt.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/239#issuecomment-276137170

---

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Jan 2017 16:51:58 -0800

If there is any way in which this is unclear, I'm happy to consider a pull request.  It seems perfectly obvious to me:

> TLS is unmodified for this use. This means that TLS will apply confidentiality and integrity protection to its records. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/239#issuecomment-276240475