Subject: [quicwg/base-drafts] Time format (#159)

From: Lars Eggert <[email-masked]>
Date: Mon, 16 Jan 2017 02:45:50 -0800

There already is a "`DISCUSS_AND_REPLACE: Perhaps make this format simpler`" note in the spec about the homegrown floating point format used for ACK timestamps. I just wanted to open a corresponding issue.

It would be really good if an encoding could be used that was either trivial to implement from scratch, or a standard for which code is readily available.

As for the latter, the text in the spec sounds like what is desired is something like the ["binary16" format in IEEE 754-2008](https://en.wikipedia.org/wiki/Half-precision_floating-point_format). I'd be great if this could be used. Compiler support seems spotty/sketchy, e.g., [gcc says this](https://gcc.gnu.org/onlinedocs/gcc/Half-Precision.html):

> The __fp16 type may only be used as an argument to intrinsics defined in <arm_fp16.h>, or as a storage format. For purposes of arithmetic and other operations, __fp16 values in C or C++ expressions are automatically promoted to float. 

And it's only supported form ARM, apparently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/159

---

From: Alessandro Ghedini <[email-masked]>
Date: Mon, 16 Jan 2017 04:45:17 -0800

Isn't this a duplicate of #109?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/159#issuecomment-272853374

---

From: Lars Eggert <[email-masked]>
Date: Mon, 16 Jan 2017 05:55:55 -0800

Probably, although it's a bit terse. (I tried to look if someone had raised this, but didn't find #109.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/159#issuecomment-272867680

---

From: ianswett <[email-masked]>
Date: Mon, 16 Jan 2017 06:23:08 -0800

In #109, which is in the needs discussion list, I propose we switch to scaled uint16s.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/159#issuecomment-272873472

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 19 Jan 2017 18:42:49 -0800

Copied comment over there; closing this as dup.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/159#issuecomment-273962641

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 19 Jan 2017 18:42:49 -0800

Closed #159.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/159#event-930120261