Subject: Re: [quicwg/base-drafts] Short abstract (#92)

From: ianswett <[email-masked]>
Date: Wed, 11 Jan 2017 12:59:23 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/92#pullrequestreview-16234131

---

From: janaiyengar <[email-masked]>
Date: Wed, 11 Jan 2017 22:01:24 -0800

I agree that the abstract should be concise and not have motivation in it. But there's over cutting here -- there's a purpose to the abstract beyond just the title :-) I would at least leave some text about what is in the document. I would add the following in: 

"This document describes the core QUIC protocol, including the conceptual design, wire format, and mechanisms of the QUIC protocol for connection establishment, wire format, and mechanisms of the QUIC protocol for connection establishment, stream multiplexing, stream and connection-level flow control, and data stream multiplexing, stream and connection-level flow control, and data-reliability. Accompanying documents describe QUIC's loss detection and reliability."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/92#issuecomment-272083540

---

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Jan 2017 16:02:08 -0800

What is this?  SEO?

Seriously though, I tried reading that several times before I could get all the way through to the end.  It's too much, even if somehow we could split that first sentence.

I know that you want to give an outline, but you need to concentrate on the MOST important things.  For me, that's the fact that it's a transport protocol and that it's secure and multiplexed.  Happy to add other things.  Though honestly, maybe only one or two things, such as maybe "reliable" or "connection-oriented"; my change took it to three things, which I think is plenty. 

Critically, the following don't belong: connection establishment (implied as necessary), wire format (implied by being a protocol), flow control (implied by multiplexing).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/92#issuecomment-272322823