Subject: Re: [quicwg/base-drafts] Set up the LINK frame (221c3bc)

From: Martin Thomson <[email-masked]>
Date: Sun, 29 Jan 2017 16:16:25 -0800

Nit: "stream 0 in HTTP/2" to avoid the inanimate possessive.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/221c3bc09e9dbee1b3def96f85592843f2afce8a#commitcomment-20656343

---

From: Martin Thomson <[email-masked]>
Date: Sun, 29 Jan 2017 16:24:04 -0800

I think that if we pursue this approach, we should have different frames for responses and pushes.  That avoids having content conditional on the context.

A response wouldn't include headers (unless you collapse LINK+HEADERS, which naturally leads to a separate TRAILERS frame...) and it would reference a request stream absolutely because it's the server referring to a client stream.

A push promise would include a header block, and could encode a stream reference with a difference.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/221c3bc09e9dbee1b3def96f85592843f2afce8a#commitcomment-20656367

---

From: Martin Thomson <[email-masked]>
Date: Sun, 29 Jan 2017 16:25:37 -0800

Note that a push promise would always identify a higher-numbered stream, which saves on the Direction flag.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/221c3bc09e9dbee1b3def96f85592843f2afce8a#commitcomment-20656374

---

From: Mike Bishop <[email-masked]>
Date: Sun, 29 Jan 2017 18:16:23 -0800

I thought about that, but felt like that was too many very similar frames when they all did the same high-level thing.  However, multiple very similar frames would reduce the number of flags and simplify the individual frames, so I'm open to that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/221c3bc09e9dbee1b3def96f85592843f2afce8a#commitcomment-20656780