Subject: Re: [quicwg/base-drafts] Variable-length fields (#40)

From: Brian Trammell <[email-masked]>
Date: Tue, 24 Jan 2017 16:55:06 -0800

(from a side conversation with @ekr) one solution to this on the stream layer would be to use a variable-length integer encoding that embeds the length within the encoded value itself, i.e.:

00bbbbbb = 6 bit unsigned
01bbbbbb bbbbbbbb = 14 bit unsigned
10bbbbbb bbbbbbbb bbbbbbbb bbbbbbbb = 30 bit unsigned
11bbbbbb bbbbbbbb bbbbbbbb bbbbbbbb bbbbbbbb bbbbbbbb bbbbbbbb bbbbbbbb = 62 bit unsigned

(The utility of being able to quickly calculate offsets without parsing an entire header for values in the packet header means, IMO, that it still makes sense to try and use fixed-length fields or, to the extent possible, fixed-structure headers as in #148)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/40#issuecomment-274987873

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Jan 2017 21:56:59 -0800

As discussed in Tokyo, editors to go through their respective headers and come up with proposals to potentially limit variability.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/40#issuecomment-275313579