Subject: [quicwg/base-drafts] Create a firm recommendation on when to send WINDOW_UPDATE (#237)

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Jan 2017 20:07:57 -0800

@ianswett says that we need a hard line recommendation on when a WINDOW_UPDATE is required.  He suggests that once you get to 1/3 of the space you have allocated to flow control remaining, you SHOULD send a WINDOW_UPDATE along with the next ACK.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/237

---

From: Patrick McManus <[email-masked]>
Date: Wed, 25 Jan 2017 20:11:48 -0800

useful for the peer receiving the update to know the update sender has a
rule it needs to follow - removes ambiguity when 'reserving' part of the
window for future high priority data.

On Thu, Jan 26, 2017 at 1:07 PM, Martin Thomson <[email-masked]>
wrote:

> @ianswett <https://github.com/ianswett> says that we need a hard line
> recommendation on when a WINDOW_UPDATE is required. He suggests that once
> you get to 1/3 of the space you have allocated to flow control remaining,
> you SHOULD send a WINDOW_UPDATE along with the next ACK.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/237>, or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AAP5s2HBPj7vuCIwUmDP1DOgbQwx4avuks5rWBwcgaJpZM4LuR8w>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/237#issuecomment-275303904