Subject: [quicwg/base-drafts] Maybe simplify ACK frame (#123)

From: janaiyengar <[email-masked]>
Date: Thu, 05 Jan 2017 14:38:10 -0800

It may be possible to simplify the ACK frame, in particular, the timestamp section. We could conceivably make the "Time from Largest Acked" 16 bits, and simply have N-Timestamp-blocks, including this one. I think this is plausible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/123

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jan 2017 18:00:38 -0800

It could be even simpler if you had a time since the last timestamp.  Start with the timestamp of the largest acked, then each entry is the delta to the last.  That gives you greater resolution overall.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/123#issuecomment-270812009