Subject: [quicwg/base-drafts] Add a hash for unencrypted packets (#167)

From: ianswett <[email-masked]>
Date: Tue, 17 Jan 2017 06:28:17 -0800

QUIC originally specified a 12 byte hash for unencrypted packets.  This was dropped when QUIC crypto was swapped for the TLS 1.3 mapping.

We should add it back, since it is useful in eliminating corrupted packets and random internet junk.  And possibly in preventing reflection attacks mentioned in #147 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/167

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Jan 2017 17:44:26 -0800

Discussed in Tokyo; general support for this. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/167#issuecomment-274995788