Subject: [quicwg/base-drafts] Unknown frame types (#233)

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Jan 2017 15:11:40 -0800

The draft currently says:

> Frames of unknown types are ignored.

Which is basically impossible. The only option an endpoint has when it encounters an unknown frame type is to throw out the entire frame or terminate the connection.  We should pick the latter.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/233

---

From: ianswett <[email-masked]>
Date: Wed, 25 Jan 2017 15:13:03 -0800

You're correct.  That should be removed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/233#issuecomment-275262672

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Jan 2017 15:14:14 -0800

Note that we also have #194 and #62 that might be resolved in one fell swoop.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/233#issuecomment-275262912