Subject: Re: [quicwg/base-drafts] BLOCKED usage requirements (#65)

From: Igor Lubashev <[email-masked]>
Date: Fri, 20 Jan 2017 17:41:45 -0800

Agreed. BLOCKED is described as a useful debugging tool. It should not be a MUST.

In fact, I'd go further and change BLOCKED frame type into DEBUG frame type and allow DEBUG frames to carry key/value pairs. Some keys could be "well-known" (BLOCKED). Others could be user-defined. This could quickly evolve into an even more useful debugging tool, possibly with the clients having an ability to turn up and down transport's "DEBUG levels".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/65#issuecomment-274223098

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 16:47:14 -0800

@igorlord, we have plenty of space for new frame types.  Adding another point of extension in the protocol, especially one that could be rarely used, is likely to cause problems.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/65#issuecomment-274666408