Subject: [quicwg/base-drafts] version negotiation isn't low latency, so remove it (#110)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 16:44:37 -0800

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/110

-- Commit Summary --

  * version negotiation isn't low latency, so remove it

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/110.patch
https://github.com/quicwg/base-drafts/pull/110.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/110

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 16:51:17 -0800

Ahh, I missed a step.  Incoming...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/110#issuecomment-270267965

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 16:53:14 -0800

@martinthomson pushed 1 commit.

3681a71  Roll version negotiation text into low-latency section

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/110/files/bdaa9729956cbe0ba306341920189232538d6cde..3681a716f0302bceb338692186f904fa82f2a4a9

---

From: Mike Bishop <[email-masked]>
Date: Tue, 03 Jan 2017 17:31:02 -0800

MikeBishop commented on this pull request.

I think it's "low latency" in the sense that the client doesn't propose the list and wait for the server to select.  But by that standard, so is TLS  version negotiation....

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/110#pullrequestreview-15045591

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 18:30:49 -0800

:) IPv4 is also low latency by the same measure, it just doesn't really have a "negotiation" piece.

I think that the main point is that it's redundant with the "low latency connection setup" thing.  A truly low latency version negotiation would allow for some progress on the rest of the handshake in parallel.  But that requires a greater commitment to a given packet format.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/110#issuecomment-270281087

---

From: janaiyengar <[email-masked]>
Date: Thu, 05 Jan 2017 12:45:34 -0800

I'd like to leave the section there; I think it's fine to remove the "low-latency" part. As a transport protocol, QUIC supports version negotiation, which is a novelty among IETF transports.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/110#issuecomment-270752557

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jan 2017 17:29:04 -0800

Closed #110.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/110#event-913516157

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jan 2017 17:29:04 -0800

I think that the text is problematic if it remains.  You can say that it has version negotiation, but that doesn't need explanatory text.

For instance, this is not an unqualified advantage: "incentivizes servers to not lag behind clients in deployment of newer versions".  That says to servers that they have to keep up with Google if I want to get the latency benefits of the protocol (at least for first-time connections).

I'll open a separate PR for the text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/110#issuecomment-270807363