Subject: [quicwg/base-drafts] Connection ID collisions (#170)

From: Marten Seemann <[email-masked]>
Date: Tue, 17 Jan 2017 20:42:06 -0800

There's currently no behavior defined for the case of a connection ID collision.
The probability for a collision of two 64 bit numbers is *really small*, if connections IDs are chosen randomly. For example, for a server handling 100,000 concurrent connections, the collision probability is about 3*10^-10.
It might therefore be justified to completely neglect this issue.

According to the current draft, if a client initiates a handshake and chooses an existing connection ID, the server would just silently discard those packets, because it already switched to an encrypted connection and will regard them as undecryptable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170

---

From: ianswett <[email-masked]>
Date: Wed, 18 Jan 2017 07:24:48 -0800

Yes, the packets would be discarded and the connection would fail.  I think that's a good response, given how infrequently it's expected to happen.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170#issuecomment-273505404

---

From: Martin Thomson <[email-masked]>
Date: Wed, 18 Jan 2017 12:53:49 -0800

I agree with @ianswett here.  Given that the same client won't generate a colliding packet number (or it shouldn't), the server could recognize this by observing a change in the remote IP and port.  It could therefore handle the new connection (and propose a new connection ID) if it really wanted to.  But I wouldn't expect them to, it's just so damned unlikely.

The real question here is: do we need to write anything down about this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170#issuecomment-273598504

---

From: martinduke <[email-masked]>
Date: Fri, 20 Jan 2017 14:03:02 -0800

I've edited #169 to consider this possibility as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/170#issuecomment-274191905