Subject: [quicwg/base-drafts] Move references to informational references (#190)

From: ianswett <[email-masked]>
Date: Sun, 22 Jan 2017 17:19:45 -0800

Moves references to informational references, clarifies that SRTT and RTTVar are computed based on an RFC, and adds todos for the congestion control section for anything formerly in the references section.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/190

-- Commit Summary --

  * Move references to informational references

-- File Changes --

    M draft-ietf-quic-recovery.md (128)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/190.patch
https://github.com/quicwg/base-drafts/pull/190.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/190

---

From: Mike Bishop <[email-masked]>
Date: Mon, 23 Jan 2017 22:37:03 -0800

BTW, if they're *not* referenced in the text, why do they need to be in the references?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/190#issuecomment-274722121

---

From: ianswett <[email-masked]>
Date: Tue, 24 Jan 2017 04:34:58 -0800

@ianswett pushed 1 commit.

7024518  Fix informative references (#218)

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/190/files/d8af2bc5036b562b650a1e4c631ff05091f09bf9..7024518cd70a39307f7488f8539b4eccf31d19dc

---

From: ianswett <[email-masked]>
Date: Tue, 24 Jan 2017 04:37:20 -0800

All of these were informational for me when implementing QUIC, so I felt they should be included.  I believe most of them should be referenced in the text, so I'll try to make sure as many as possible are referenced in an updated version of this PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/190#issuecomment-274792227

---

From: ianswett <[email-masked]>
Date: Tue, 24 Jan 2017 04:41:03 -0800

I just reviewed the references that aren't currently in the text, and they're all congestion control related, which is the next section that I plan to properly document, so they should be referenced soon.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/190#issuecomment-274792998

---

From: Mike Bishop <[email-masked]>
Date: Tue, 24 Jan 2017 08:28:20 -0800

Great -- if they're referenced as {{?RFCXXXX}}, you don't need to (and perhaps can't?) have them explicitly in the refs at the top, so remove them from there as you add the inline references.  Or you can reference things that are explicitly in the references as [RFCXXXX] instead.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/190#issuecomment-274855471