Subject: [quicwg/base-drafts] Fix stream identifier size (#209)

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 16:59:08 -0800

The doc defines stream identifiers as "variable-length".  But are they really?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/209

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 17:03:58 -0800

To be clear, it might be encoded using a variable-length encoding, but the actual value is fixed size.  This refers to the following text in the description of the STREAM frame: "Stream ID: A variable-sized unsigned ID unique to this stream, whose size is determined by the `SS` bits in the type byte."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/209#issuecomment-274669402