Subject: Re: [quicwg/base-drafts] Updating transport parameters (#50)

From: Mike Bishop <[email-masked]>
Date: Fri, 13 Jan 2017 14:24:54 -0800

We currently do have SETTINGS, but max number of streams is a QUIC concept, and therefore doesn't currently support changes.  Do we need to?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50#issuecomment-272564744

---

From: Martin Thomson <[email-masked]>
Date: Sun, 15 Jan 2017 13:18:20 -0800

Yes, if we are to keep modularity (application protocol can't set transport parameters), then SETTINGS won't cut it.  If we're OK with the application protocol saying things not just about the local side, but the remote site, we can have SETTINGS do anything within reason.  It seems like it might need an abstraction though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50#issuecomment-272724473

---

From: Martin Thomson <[email-masked]>
Date: Thu, 19 Jan 2017 20:52:03 -0800

See also #181.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50#issuecomment-273977207

---

From: Victor Vasiliev <[email-masked]>
Date: Mon, 23 Jan 2017 12:19:13 -0800

We should not allow changing arbitrary parameter changes mid-connection, since the semantics of such change needs to be carefully thought through.

For parameters that we do want to allow changing, we can define special frame types, but we have to think through how this interacts with the fact that
(1) the new value will arrive asynchronously of the current outgoing streams, meaning that
(2) the sender cannot assume the new value is in effect until it's acknowledged.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50#issuecomment-274604713

---

From: Mike Bishop <[email-masked]>
Date: Mon, 23 Jan 2017 13:28:22 -0800

Yes -- at the app layer, we've had to add per-stream acknowledgement of when setting changes take effect.  In h2, we also discussed (though ultimately didn't) having some settings that can only increase, never decrease.  You can always choose to be more permissive, and you don't need a sync point for that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50#issuecomment-274622619

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jan 2017 22:41:05 -0800

Closed #50.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50#event-934014179

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jan 2017 22:41:05 -0800

Discussed in Tokyo; consensus in the room that we're comfortable with these things not being changeable after handshake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50#issuecomment-274722692