Subject: [quicwg/base-drafts] Encrypt the initial cleartext packets with a deterministic key (#227)

From: Lucas Clemente <[email-masked]>
Date: Tue, 24 Jan 2017 18:05:20 -0800

This is an alternative to #167: We could just encrypt the cleartext data in the initial handshake packets with a deterministic key (e.g. a mixture of a version-dependent key and the initial packet number). The AEAD used there would have to be fixed in the spec.

The goal would be to make it harder for middleboxes to ossify on stuff in the client hello, e.g. SNI, and to detect initial packets (#203). On the other hand, there's additional computational cost for decrypting packets server-side.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/227

---

From: ianswett <[email-masked]>
Date: Tue, 24 Jan 2017 18:07:44 -0800

It's worth noting the AEAD would have to be fixed per QUIC version, but not fixed for all time.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/227#issuecomment-274999347

---

From: Martin Thomson <[email-masked]>
Date: Tue, 24 Jan 2017 20:36:48 -0800

@ianswett, that's only true if we decide to "protect" the version negotiation packet.  Otherwise, it could be version-specific.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/227#issuecomment-275017147

---

From: ianswett <[email-masked]>
Date: Tue, 24 Jan 2017 20:43:48 -0800

Yes, I meant that it should be version-specific, but I said that in a potentially confusing way.

We keep coming back to the theme that the version negotiation packet can't be protected in any way, because we don't want to be stuck with the same protection for all time.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/227#issuecomment-275017911