Subject: [quicwg/base-drafts] "Reason Phrase" in CONNECTION_CLOSE and GOAWAY frames (#187)

From: Igor Lubashev <[email-masked]>
Date: Fri, 20 Jan 2017 18:11:42 -0800

The inclusion of "Reason Phrase" is CONNECTION_CLOSE and GOAWAY frames seems unnecessary and its normative usage uncertain. There is already an error code field (and a robust discussion in #19 and #184 about its values).

"Reason Phrase" seems like optional textual debug information (in what language?). This is actually another case for a generalized DEBUG frame (see #65).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/187

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 16:52:44 -0800

Not sure what your intent is with this issue.  HTTP/2 had an "extra stuff" field in GOAWAY, but not RST_STREAM.

I don't think that this suggests a new frame type; providing the information in-context is more likely to ensure that it is actionable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/187#issuecomment-274667406

---

From: Igor Lubashev <[email-masked]>
Date: Mon, 23 Jan 2017 16:59:22 -0800

I am not hot on this issue and can live with it. HTTP/2 has "extra stuff". TCP does not.  QUIC straddles multiple layers, so from the transport perspective, this "extra stuff" is extra (and streams are now a transport feature). From HTTP perspective it can be justified.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/187#issuecomment-274668587