Subject: [quicwg/base-drafts] Do streams 0 and 1 count towards MSPC? (#201)

From: ekr <[email-masked]>
Date: Sun, 22 Jan 2017 21:14:51 -0800

And if so in which directions?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/201

---

From: Marten Seemann <[email-masked]>
Date: Sun, 22 Jan 2017 21:37:36 -0800

I don't think there's a stream 0 (however, I find the wording in the [Stream Identifiers section](https://github.com/quicwg/base-drafts/blob/master/draft-ietf-quic-transport.md#stream-identifiers-stream-identifiers) a bit confusing, since the 0 that is used as a stream ID in a WINDOW_UPDATE frame for connection-level flow control is just a placeholder).

Since stream 1 is always initiated by the client (it's an odd stream ID), there's no ambiguity towards which MSPC it counts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/201#issuecomment-274404428

---

From: ekr <[email-masked]>
Date: Sun, 22 Jan 2017 21:44:45 -0800

It's ambiguous whether stream 1 counts against the client's allocation

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/201#issuecomment-274405163

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 17:38:32 -0800

There isn't a concrete stream 0, but clearly stream 1 is an issue.

I agree that this is not clear, we probably need to pick an answer.  Note that the HTTP mapping requires a minimum of 3 streams in addition to the crypto stream.  This plays into #186.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/201#issuecomment-274675309

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Jan 2017 20:30:00 -0800

Discussed in Tokyo, editors will decide this, but write it down.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/201#issuecomment-275305573