Subject: [quicwg/base-drafts] Should we grease version negotiation? (#112)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 18:47:10 -0800

Shout out to @davidben and the recently adopted draft-davidben-tls-grease.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112

---

From: janaiyengar <[email-masked]>
Date: Fri, 13 Jan 2017 17:58:36 -0800

Yes! 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#issuecomment-272592841

---

From: ianswett <[email-masked]>
Date: Sat, 14 Jan 2017 11:19:25 -0800

We should grease all the public flag bits to ensure they're all usable in the future.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#issuecomment-272646427

---

From: Mike Bishop <[email-masked]>
Date: Sat, 14 Jan 2017 15:08:42 -0800

So the text would be something like "In version N, the following bits are unused and MAY be set randomly by clients and servers."  In version N+1, where a bit acquires a meaning, we can stop using it for GREASE?  Scoping it to versions seems to neatly sidestep the problem of making things unusable in the future *because* they've been used as grease.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#issuecomment-272660184

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jan 2017 21:30:04 -0800

Closed #112.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#event-933966980

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 21:30:06 -0800

Caveat: we need to ensure that there is a way to grease consistently between the stateless version negotiation packet AND the copy of that in the ServerHello.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#issuecomment-274713709

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jan 2017 21:30:04 -0800

Discussed in Tokyo: consensus in the room.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#issuecomment-274713701

---

From: janaiyengar <[email-masked]>
Date: Mon, 23 Jan 2017 21:32:54 -0800

Reopened #112.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#event-933968728

---

From: janaiyengar <[email-masked]>
Date: Mon, 23 Jan 2017 21:33:43 -0800

I thought martinthomson said to leave this open -- if I misheard, feel free to close.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#issuecomment-274714131

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jan 2017 21:52:25 -0800

That was a different one. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#issuecomment-274716383

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jan 2017 21:52:26 -0800

Closed #112.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#event-933980604

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jan 2017 21:53:12 -0800

Reopened #112.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#event-933981071

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jan 2017 21:53:11 -0800

Oh, no - that was this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/112#issuecomment-274716490