Subject: [quicwg/base-drafts] Should we ossify connection ID? (#133)

From: Martin Thomson <[email-masked]>
Date: Mon, 09 Jan 2017 20:13:43 -0800

When I wrote the section on what can change in different versions, I originally just left an unlabelled slot for the connection ID.  But @marten-seemann observed that the server is required to echo the connection ID in a version negotiation packet.

I don't think that we need the server to echo the connection ID in this case.  That would allow us to restore the 8 octets to a version-specific field.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/133

---

From: Marten Seemann <[email-masked]>
Date: Wed, 25 Jan 2017 20:51:37 -0800

This issue will be solved when we make the changes discussed in #119, since the client won't even pick a connection ID for the first packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/133#issuecomment-275307556