Subject: [quicwg/base-drafts] Separate error spaces (#131)

From: Mike Bishop <[email-masked]>
Date: Fri, 06 Jan 2017 21:57:31 -0800

Builds on #130 to nearly the same end result as #96, to address #74.

Allocates portions of the error space to QUIC, crypto, and the app-layer. The remote knows the QUIC version (which implies the crypto protocol) and the application -- that means it can figure out what set of error codes to use for interpreting each region. If extensions define new error codes, they would want to do so within the appropriate registries to avoid collisions and thereby confusion.

Congestion control doesn't get a region, because the peer doesn't know what algorithm you're using to interpret anything anyway -- that's just a transport error.

At Jana's suggestion, reserving a range instead for local-only error codes (e.g. the QUIC spec's original "failed to write to socket," "tried to send unencrypted data," etc.) that MUST NOT be sent on the wire, but can be used in logs and APIs to avoid having to use a separate return value for non-protocol errors.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/131

-- Commit Summary --

  * Use definition list format for error codes.
  * Remove non-wire-facing and migration-specific error codes
  * Moving crypto errors into TLS document
  * QUIC is capitalized
  * Move HTTP error code to HTTP document
  * Added error code ranges
  * TLS errors in new range
  * Define HTTP-layer error codes in HTTP document

-- File Changes --

    M draft-ietf-quic-http.md (131)
    M draft-ietf-quic-tls.md (88)
    M draft-ietf-quic-transport.md (306)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/131.patch
https://github.com/quicwg/base-drafts/pull/131.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/131

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Jan 2017 14:50:55 -0800

martinthomson approved this pull request.

So this is really a set of concrete changes to the HTTP mapping that add a bunch of appropriate error codes.  I might have quibbled on a few of the choices, but the overall change is such an improvement that I think we should take this and open new issues on those quibbles.

-TODO: Discuss error handling beyond just listing error codes.
+0x0000-0x3FFF:

I wonder if it would be ... nicer ... to allow the application protocol use of the lower portion of the error code space.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/131#pullrequestreview-15635029

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Jan 2017 14:52:48 -0800

martinthomson commented on this pull request.

Oh, and to that end, maybe also move the host local to the same space, so we have: app, host, quic, security.

---

From: Mike Bishop <[email-masked]>
Date: Sun, 08 Jan 2017 16:09:53 -0800

MikeBishop commented on this pull request.

Perfectly happy to do that.  My logic was more "modify as few existing codes as possible."  ;-)

---

From: Mike Bishop <[email-masked]>
Date: Thu, 12 Jan 2017 11:35:46 -0800

@MikeBishop pushed 1 commit.

c1e73f2  Reordering error code ranges, per Martin

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/131/files/13bdc70f3e5fb110d62dad52819f1bb9a28a2f3a..c1e73f2109bc64e938ba7ac1bc55a34a744d1c10

---

From: Mike Bishop <[email-masked]>
Date: Thu, 12 Jan 2017 11:36:01 -0800

Done.

---

From: Mike Bishop <[email-masked]>
Date: Thu, 12 Jan 2017 11:42:54 -0800

dfaff7b  Merge remote-tracking branch 'origin/master' into error_space2

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/131/files/c1e73f2109bc64e938ba7ac1bc55a34a744d1c10..dfaff7b5d7f7f0d04b268404aefb459165f9af44

---

From: Mike Bishop <[email-masked]>
Date: Thu, 12 Jan 2017 11:50:01 -0800

Merged #131.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/131#event-921278410