Subject: [quicwg/base-drafts] Why are reason phrases potentially 65k long? (#199)

From: ekr <[email-masked]>
Date: Sun, 22 Jan 2017 20:58:47 -0800

There is a two byte length field. Surely a 256-byte reason phrase is long enough.

Also, are these in ASCII? UTF-8?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/199

---

From: Igor Lubashev <[email-masked]>
Date: Mon, 23 Jan 2017 05:53:49 -0800

There is a related issue #187.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/199#issuecomment-274493234

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 18:42:50 -0800

256 octets probably won't carry a stack trace :)

This is entirely proprietary, but we could recommend that text (if it is text) be UTF-8.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/199#issuecomment-274685428

---

From: Marten Seemann <[email-masked]>
Date: Mon, 23 Jan 2017 18:45:12 -0800

Since frames cannot be split (except for STREAM frames), there's no way to send more than around 1340 bytes of reason phrase anyway in the general case (IPv6 doesn't support packet fragmentation).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/199#issuecomment-274685747