Subject: [quicwg/base-drafts] Race condition between stream creation and MSPC (#200)

From: ekr <[email-masked]>
Date: Sun, 22 Jan 2017 21:13:54 -0800

Consider the following sequence of events on a stream (assuming that MSPC allows exactly one application data stream in the C-S direction:

```
<---------- Stream Establishment ----------->
<----------------------------------------- FIN
FIN ----------------------------------------->
DATA (stream N+1) -------------------------->
```

If you get reordering between the FIN and the data then the server will see it as exceeding MSPC and send  QUIC_TOO_MANY_OPEN_STREAMS. Ugh.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/200

---

From: Aron-Schats <[email-masked]>
Date: Mon, 23 Jan 2017 06:29:56 -0800

The client should not do that:

https://groups.google.com/a/chromium.org/forum/#!topic/proto-quic/27ee0fWisTc

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/200#issuecomment-274501935

---

From: ekr <[email-masked]>
Date: Mon, 23 Jan 2017 14:05:17 -0800

Well, that needs to go in the spec then.

On Mon, Jan 23, 2017 at 6:29 AM, Aron-Schats <[email-masked]>
wrote:

> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/200#issuecomment-274501935>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oaUt1zctVAwx76e2maMnaqFQvQcpks5rVLllgaJpZM4Lqq0o>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/200#issuecomment-274632434