Subject: [quicwg/base-drafts] Introduce a mechanism to increase initial flow control window for streams (#219)

From: Victor Vasiliev <[email-masked]>
Date: Mon, 23 Jan 2017 22:54:25 -0800

It may be desirable for the client to increase the flow control window mid-connection (it observes that client actually has very high BDP; it decides based on application request by peer that it will send a lot of data; it decides that it trusts the peer for some reason; potentially other options).  Currently, we can bump connection flow control window without an issue, but any new individual streams are stuck with whatever was initially negotiated.  We may want to add a mechanism to increase initial stream flow control window mid-connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/219

---

From: Martin Thomson <[email-masked]>
Date: Tue, 24 Jan 2017 15:45:10 -0800

All of those arguments apply more to the connection-level flow control window.  The initial stream flow control window only determines the distribution of the flow control window.  An endpoint could just make the number bigger from the start.  There aren't many downsides to that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/219#issuecomment-274975919