Subject: [quicwg/base-drafts] Ordering of ACK Frame fields (#168)

From: martinduke <[email-masked]>
Date: Tue, 17 Jan 2017 09:09:44 -0800

Computing the length of an ACK frame is unnecessarily complicated because there are a series of length fields the implementation has to check. These fields are themselves of variable length from the start of the frame because they are placed after ACK frame content. This amounts to a lot of traversing of memory just to just to figure out how much memory to pull to process the ACK.

A simple solution would be to move NumBlocks and NumTS to immediate after the ACK frame flags. This would have no impact on the protocol except to ease implementation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/168

---

From: ianswett <[email-masked]>
Date: Tue, 17 Jan 2017 09:12:06 -0800

Sounds good to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/168#issuecomment-273233374

---

From: ianswett <[email-masked]>
Date: Fri, 20 Jan 2017 07:51:06 -0800

@marten-seemann and @janaiyengar Any reasons why this wouldn't be a good change?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/168#issuecomment-274105457

---

From: Marten Seemann <[email-masked]>
Date: Fri, 20 Jan 2017 08:40:42 -0800

lgtm

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/168#issuecomment-274118444

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Jan 2017 22:23:54 -0800

Subset of #62 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/168#issuecomment-275316337

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Jan 2017 22:23:54 -0800

Closed #168.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/168#event-937325661