Subject: [quicwg/base-drafts] Update the diagrams (#129)

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jan 2017 20:47:54 -0800

@MikeBishop, this should sort out #103 with Jana's comments.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/129

-- Commit Summary --

  * Don't go so wide
  * De-indent a little
  * Take and improve suggestion on regular packet intro
  * Leave definition of AEAD Data to QUIC-TLS
  * The stream frame just contains fields
  * Timestamps are packet receive times
  * As with STREAM, so with BLOCKED: no payload

-- File Changes --

    M draft-ietf-quic-transport.md (61)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/129.patch
https://github.com/quicwg/base-drafts/pull/129.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/129

---

From: janaiyengar <[email-masked]>
Date: Thu, 05 Jan 2017 21:20:14 -0800

janaiyengar commented on this pull request.

Largely LGTM modulo one comment. Mike was going to take a shot at reworking his PR.

> @@ -424,12 +426,11 @@ The fields in a Regular packet past the Common Header are the following:
   by the sender.  The first packet sent by an endpoint MUST have a packet number
   of 1.
 
-* AEAD Data: A Regular packet's Common Header and fields are authenticated,
-  but not encrypted.  The rest of a Regular packet, starting with the first
-  frame, is both authenticated and encrypted.  Immediately following the header,
-  Regular packets contain AEAD (Authenticated Encryption with Associated Data)
-  data.  After decryption, the plaintext consists of a sequence of
-  frames, as shown below (frames are described in {{frames}}).
+* AEAD Data: The remainder of a Regular packet is both authenticated and
+  encrypted once packet protection keys are available.  {{QUIC-TLS}} describes

QUIC-TLS won't describe the structure of QUIC packets -- I don't think that needs to be referenced here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/129#pullrequestreview-15442979

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Jan 2017 14:26:46 -0800

martinthomson commented on this pull request.

Hmm, you need a normative definition of how to protect/unprotect the plaintext and that is in QUIC-TLS.

---

From: Mike Bishop <[email-masked]>
Date: Sun, 08 Jan 2017 16:11:28 -0800

MikeBishop commented on this pull request.

Should it be?  TLS just provides the keys; QUIC does the actual protect/unprotect work.

---

From: Mike Bishop <[email-masked]>
Date: Sun, 08 Jan 2017 16:17:12 -0800

@MikeBishop pushed 1 commit.

60028fe  Merge branch 'diagrams' into diagrams_mt

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/129/files/1c962148e25d9a99d83f8c435410a6fc4d45b446..60028fe4b3d2386707d8bc612bbe628d34a72f98

---

From: Mike Bishop <[email-masked]>
Date: Sun, 08 Jan 2017 16:19:47 -0800

Merged #129.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/129#event-915397697

---

From: janaiyengar <[email-masked]>
Date: Sun, 08 Jan 2017 16:38:02 -0800

Right, what Mike said. I suggest we leave this sentence out until warranted.

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Jan 2017 17:02:29 -0800

Hmm, so QUIC-TLS actually does describe how to protect/unprotect packets.  We can move that text if you like and make that not-true, but you probably want to move the key schedule as well.  Then we don't have much left in the TLS doc.