Subject: [quicwg/base-drafts] HTTP: Why are we defining CONNECT? (#202)

From: ekr <[email-masked]>
Date: Sun, 22 Jan 2017 22:09:57 -0800

The primary use case for conventional CONNECT proxies is firewall traversal. Is there a big use case for QUIC proxies which we then need to traverse?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 17:39:49 -0800

Is this a suggestion that we don't provide CONNECT?  We had a big discussion about this in HTTP/2 that had all the same basic constraints.  We decided to define it then.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202#issuecomment-274675505

---

From: ekr <[email-masked]>
Date: Mon, 23 Jan 2017 17:41:12 -0800

Yes, it's a suggestion to that effect. I wasn't in the H2 discussion, but I guess I would say that perhaps we now have experience with defining CONNECT for h2. Has that worked out well? Does anyone do CONNECT/h2?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202#issuecomment-274675730

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 17:44:07 -0800

CONNECT/h2 is implemented, but I don't know about usage rates.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202#issuecomment-274676224

---

From: Patrick McManus <[email-masked]>
Date: Mon, 23 Jan 2017 17:46:45 -0800

people definitely do CONNECT over h2.. sometimes yielding h2 in h2.

On Tue, Jan 24, 2017 at 10:44 AM, Martin Thomson <[email-masked]>
wrote:

> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/202#issuecomment-274676224>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AAP5s1fAjledlC2c9j7nAMjSgXqv5Diqks5rVVdmgaJpZM4LqsV9>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202#issuecomment-274676647

---

From: Mike Bishop <[email-masked]>
Date: Tue, 24 Jan 2017 17:02:44 -0800

My question was actually the opposite -- CONNECT gives you a TCP connection through the proxy.  In a hypothetical speaking-QUIC-to-proxy world, would we want an alternative method that let you get a UDP/QUIC connection through the proxy?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202#issuecomment-274989235

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Tue, 24 Jan 2017 20:38:11 -0800

The use case of CONNECT method in h2 is HTTP/2 proxy. Tunneling request (stream?) to the upstream server.  h2 proxy is supported by Chroimium and Firefox.  We have some users doing this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202#issuecomment-275017284

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Jan 2017 20:47:49 -0800

Closed #202.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202#event-935615360

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Jan 2017 20:47:49 -0800

Dup of #95 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/202#issuecomment-275018364