Subject: [quicwg/base-drafts] What do we do if special packets are lost (#241)

From: Subodh Iyengar <[email-masked]>
Date: Wed, 25 Jan 2017 23:26:40 -0800

For example if the version negotiation packet is lost, there's no ACK frame for the receiver to signal anything to the sender, we should specify what the loss recovery behavior for version negotiation and other special packets is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/241

---

From: Mike Bishop <[email-masked]>
Date: Thu, 26 Jan 2017 17:42:16 -0800

I think this is already dealt with -- the server responds with a Version Negotiation packet to *every* packet from the client.  If any packet and its response make it through, the client will know what to do.  If no packet pair makes it through the whole round trip and the client gets no response, the client will assume that its packet was lost and retransmit it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/241#issuecomment-275568477