Subject: [quicwg/base-drafts] Minimum concurrent streams requirment (#186)

From: Igor Lubashev <[email-masked]>
Date: Fri, 20 Jan 2017 17:59:00 -0800

The specification allows endpoints to specify the maximum number of concurrent streams (MSPC), but should not the spec provide for the minimum value of MSPC that all endpoints must support?  If the minimum is 1 (excluding "service" streams), it would be good for the spec to state so explicitly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/186

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 16:49:29 -0800

Hmm, 1 is a valid value.  The only value that doesn't make sense is 0.  HTTP/2 permitted a value of 0, temporarily, but we don't have any way to change settings yet (see #50).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/186#issuecomment-274666824

---

From: Igor Lubashev <[email-masked]>
Date: Mon, 23 Jan 2017 17:03:06 -0800

What you say: "1", do you include STREAM 1?  If so, what does it say about clients not able to start data streams?  It is useful?

If 1 does not include STREAM 1, does it mean we cannot be HTTP anymore?  (Needs a minimum of 3 streams, plus STREAM 1).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/186#issuecomment-274669259