Subject: [quicwg/base-drafts] Receiving WINDOW_UPDATE before the first STREAM frame should not reset connections (#188)

From: Igor Lubashev <[email-masked]>
Date: Fri, 20 Jan 2017 18:20:49 -0800

> **9.1.1. idle**
All streams start in the “idle” state.
...
Receiving any frame other than STREAM or RST_STREAM on a stream in this state MUST be treated as a connection error (Section 11) of type YYYY.

Receiving a WINDOW_UPDATE frame (or probably any other frame) for a stream before the first STREAM frame for that stream due to packet reordering/loss should not be treated as a connection error (causing a connection reset).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/188

---

From: Martin Thomson <[email-masked]>
Date: Mon, 23 Jan 2017 16:55:50 -0800

I think that this is just a bug, do you agree @janaiyengar?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/188#issuecomment-274667954