Subject: [quicwg/base-drafts] Abstraction of TLS (#183)

From: Martin Thomson <[email-masked]>
Date: Thu, 19 Jan 2017 23:47:22 -0800

The question is whether we maintain TLS as some abstract concept or not.

We could talk about "the cryptographic handshake" and features that it provides in the abstract when referring to them in the transport document.  Or we could just describe how this protocol works in concrete terms.

Proponents of the first seem to think that would make replacing TLS easier.  Others disagree.  Others think that replacing TLS would be a bad idea.  Others think that replacing TLS is the only rational choice.  Some people think that people who hold opposing opinions are completely nuts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/183

---

From: Brian Trammell <[email-masked]>
Date: Fri, 20 Jan 2017 07:44:48 -0800

Yay, another vi versus emacs.

I'd submit that completely separate from how the protocol is normatively defined in quic-transport, the exercise of talking about the cryptographic handshake in the abstract (as well as the properties of the interface between QUIC and ~TLS~ ~the cryptographic protocol~ TLS for stream/frame data) is useful its own right, in part to determine how in/dependent the transport/crypto interface is on peculiarities of TLS.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/183#issuecomment-274103810