Subject: [quicwg/base-drafts] TLS 1.3 is the minimum acceptable TLS version (#138)

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Jan 2017 15:32:50 -0800

It was observed that TLS negotiates its version and that a future TLS version might be OK, but an older TLS is definitely not.  We should be explicit about that.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/138

-- Commit Summary --

  * TLS 1.3 is the minimum acceptable TLS version

-- File Changes --

    M draft-ietf-quic-tls.md (14)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/138.patch
https://github.com/quicwg/base-drafts/pull/138.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/138

---

From: Alessandro Ghedini <[email-masked]>
Date: Tue, 10 Jan 2017 15:59:34 -0800

ghedo commented on this pull request.

> @@ -464,6 +464,20 @@ Get Handshake
 {: #exchange-summary title="Interaction Summary between QUIC and TLS"}

+## TLS Version
+
+This document describes how TLS 1.3 {{!I-D.ietf-tls-tls13}} is used with QUIC.
+
+In practice, the TLS handshake will negotiate a version of TLS to use.  This
+could result in a newer version of TLS than 1.3 being negotiated if both
+endpoints support that version.  This is acceptable provided that the features
+of TLS 1.3 that are used by QUIC are supported by the newer version.
+
+A badly configured TLS implementation could negotiate TLS 1.2 or an older

TLS 1.2 *is* an older version, suggest removing "TLS 1.2 or".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/138#pullrequestreview-16042171

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Jan 2017 16:57:53 -0800

martinthomson commented on this pull request.

+## TLS Version
+

Yes, I think that it's helpful to include the reminder that TLS 1.2 isn't acceptable though, changing to "1.2 or another older"

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Jan 2017 16:58:04 -0800

@martinthomson pushed 1 commit.

ff1faa2  Another

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/138/files/d80c268f751ab04bbf00e75c8df9d181c3b66bc6..ff1faa2503e42040d4f95b69a8644523ac684b31

---

From: Alessandro Ghedini <[email-masked]>
Date: Wed, 11 Jan 2017 06:19:15 -0800

+## TLS Version
+
+This document describes how TLS 1.3 {{!I-D.ietf-tls-tls13}} is used with QUIC.
+
+In practice, the TLS handshake will negotiate a version of TLS to use.  This
+could result in a newer version of TLS than 1.3 being negotiated if both
+endpoints support that version.  This is acceptable provided that the features
+of TLS 1.3 that are used by QUIC are supported by the newer version.
+
+A badly configured TLS implementation could negotiate TLS 1.2 or another older
+version of TLS.  An endpoint MUST terminate the connection the handshake if a

"the connection the handshake", pick one :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/138#pullrequestreview-16145520

---

From: Mike Bishop <[email-masked]>
Date: Wed, 11 Jan 2017 09:56:44 -0800

LGTM, modulo ghedo's fix.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/138#issuecomment-271942529

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Jan 2017 14:52:50 -0800

9657bcc  Remove redundancy

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/138/files/ff1faa2503e42040d4f95b69a8644523ac684b31..9657bcce12b8a129d18bbb2cdea730f2a887f1f0

---

From: janaiyengar <[email-masked]>
Date: Wed, 11 Jan 2017 21:57:41 -0800

LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/138#issuecomment-272083076

---

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Jan 2017 22:03:51 -0800

Merged #138.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/138#event-942548682