Subject: Re: [quicwg/base-drafts] QUIC-TLS Extension and version negotiation (#99)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 18:17:17 -0800

I think that this is better off moved to the -transport document.  If it's OK with you, I plan to move your text there.  I think that keeps the separation of concerns cleaner.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/99#issuecomment-270279517

---

From: Mike Bishop <[email-masked]>
Date: Wed, 04 Jan 2017 10:06:27 -0800

I kind of disagree -- I was trying to keep anything TLS-specfic out of the Transport doc.  Remember that QUIC doesn't know that the crypto protocol is necessarily TLS.  Defining that any handshake MUST be able to transport a blob and then defining how TLS will transport the opaque data keeps the components separate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/99#issuecomment-270441432

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jan 2017 17:00:37 -0800

Actually, I made that comment without really reading what you had done.  I prefer this structure.  I've built on and fleshed it out more in #122.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/99#issuecomment-270803108

---

From: Mike Bishop <[email-masked]>
Date: Thu, 12 Jan 2017 16:46:39 -0800

@MikeBishop pushed 1 commit.

2dbdf66  Merge remote-tracking branch 'origin/master' into version_negotiation

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/99/files/eba9e2b821aaaf2d545475d6b8997da52e4b3a64..2dbdf6692c005f117723adf8d9893145b70a922b

---

From: Alessandro Ghedini <[email-masked]>
Date: Sun, 15 Jan 2017 13:25:55 -0800

ghedo commented on this pull request.

-If the server cannot select a combination of ALPN identifier and QUIC version it
-MUST abort the connection.  A client MUST abort a connection if the server picks
-an incompatible version of QUIC version and ALPN.
+If the server cannot select a compatible combination of ALPN identifier and QUIC
+version, it MUST abort the connection. A client MUST abort a connection if the

Should this specify which error to use?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/99#pullrequestreview-16723872

---

From: Martin Thomson <[email-masked]>
Date: Sun, 15 Jan 2017 14:07:26 -0800

martinthomson commented on this pull request.

Yes, generally we need to identify error codes.  But until we have #37 fixed, I think that we can afford to be a little bit lenient on PRs that describe error conditions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/99