Subject: [quicwg/base-drafts] Should HTTP use compressed stream IDs? (#154)

From: Mike Bishop <[email-masked]>
Date: Sat, 14 Jan 2017 15:14:29 -0800

QUIC uses a 32-bit (soon to be 64-bit) stream space.  However, we know that HTTP sessions typically don't use nearly the 31 bits of stream space we have in HTTP/2.  As QUIC continues to expand the number of streams it supports, HTTP/QUIC ends up spending more bits on stream ID overhead (PRIORITY, PUSH_PROMISE, etc.).

Should we consider having variable-length stream ID fields in these frames?  Or is the complexity reduction worth stating the full stream ID, especially since we no longer have an HTTP-level stream ID on every frame?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/154

---

From: Mike Bishop <[email-masked]>
Date: Sat, 14 Jan 2017 15:15:15 -0800

Related to #148, which is trying to take QUIC the other direction.  Is one right, or should we meet in the middle?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/154#issuecomment-272660549

---

From: mirjak <[email-masked]>
Date: Mon, 16 Jan 2017 03:11:18 -0800

Is stream ID space really an issue? Given it's so cheap to open new connections, you could probably seamlessly open a new quic connection...? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/154#issuecomment-272833964

---

From: Mike Bishop <[email-masked]>
Date: Mon, 16 Jan 2017 06:38:11 -0800

That’s a good question for #108; this issue is over whether HTTP needs to spend all the bits to represent the full QUIC stream ID, no matter how large that is.

Sent from my Windows 10 phone

From: mirjak<mailto:[email-masked]>
Sent: Monday, January 16, 2017 3:11 AM
To: quicwg/base-drafts<mailto:[email-masked]>
Cc: Mike Bishop<mailto:[email-masked]>; Author<mailto:[email-masked]>
Subject: Re: [quicwg/base-drafts] Should HTTP use compressed stream IDs? (#154)

—
You are receiving this because you authored the thread.
Reply to this email directly, view it on GitHub<https://github.com/quicwg/base-drafts/issues/154#issuecomment-272833964>, or mute the thread<https://github.com/notifications/unsubscribe-auth/AEE2hSUHmLQl6ZNYSZZ863bqVSkp1k34ks5rS1BWgaJpZM4LjxV2>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/154#issuecomment-272879053