Subject: [quicwg/base-drafts] Each COPT might be better as empty transport parameters (#116)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 23:08:23 -0800

COPT is apparently repeated, once for each option.  

One thing that TLS implementations do is validate that there is only one instance of each extension.  This isn't possible for transport parameters if we require that COPT be used for a list of options.

Also, we can reduce the number of extension points in the protocol, we shouldn't pack a list of options into COPT when we have transport parameters for that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/116

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jan 2017 23:19:49 -0800

Note: If there are values for connection options that should be included in the base specification, each need to be raised separately.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/116#issuecomment-270308795

---

From: Mike Bishop <[email-masked]>
Date: Fri, 13 Jan 2017 18:19:32 -0800

Per discussion with Jana, this isn't what it looks like.  It's basically a tunnel for the client to relay opaque data from Chrome experiment configurations to the server, so the server can behave appropriate to the experiment on the given connection.

I'm not sure opaque data relay is needed in the RFC in the first place.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/116#issuecomment-272594335

---

From: Martin Thomson <[email-masked]>
Date: Sun, 15 Jan 2017 13:36:32 -0800

OK, that is actually entirely appropriate, in a way.  Of course, we would ask that Chrome/Google use an option number from the space reserved for experiments, but they can do what they please in that space.  That said, we don't need to register the number for them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/116#issuecomment-272725704