Subject: Re: [quicwg/base-drafts] Why is packet_number an argument for OnPacketSent? (#107)

From: ianswett <[email-masked]>
Date: Fri, 13 Jan 2017 08:30:30 -0800

It's there so I can store the time when the packet was sent, and then use that later to calculate the RTT.  I'll send out a PR that does that and clarifies some other details and you can see what you think.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/107#issuecomment-272482024

---

From: Aron-Schats <[email-masked]>
Date: Fri, 13 Jan 2017 08:56:02 -0800

I wonder whether the loss detection and recovery mechanisms can be explained without the use of the pseudo-code, which seems like a cop-out.  The pseudo-code does not match what occurs in proto-quic code.  (This is probably OK, as the draft may be describing a future version of QUIC.)

In addition, alarm mode is mentioned, but the different modes are not listed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/107#issuecomment-272487909

---

From: ianswett <[email-masked]>
Date: Fri, 13 Jan 2017 13:36:14 -0800

Closed #107 via #149.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/107#event-922866266