Subject: Re: Last Call: 'IETF Problem Statement' to Informational RFC

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 9 Jan 2004 07:33:36 -0600

I could not agree more (except to emend Brian's quote as "encourage
the IESG and the IETF community as a whole to continue the work").

Without reference to the additional problems raised recently, the
current draft seems sufficient to have kicked off at least four or
five problem resolution efforts (MPOWR, ART, NEWTRK - aren't there
others?). If these efforts bear fruit, identifying other problems is
worthwhile (and there's no reason individuals can't submit drafts on
them now). If not, having a perfect embalmed list of problems that the
IETF used to have, when it was still around, is not.

At the risk of assuming something from a face-to-face meeting, it
seemed in Minneapolis that the working group's energy has moved on.
Continued fiddling with the document risks turning it into the list of
problems that the group should have identified, whether it did or not.

Spencer

----- Original Message ----- 
From: "Brian E Carpenter" <[email-masked]>
To: "Alex Conta" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, January 09, 2004 4:25 AM
Subject: Re: Last Call: 'IETF Problem Statement' to Informational RFC

> Alex,
>
> My personal goal is not to have the document as complete as it can
be,
> but to encourage the IESG to continue the work it has started to
> fix the most serious problems.
>
>    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 07 Jan 2004 11:38:18 +0100

I too have been frustrated in the past (but not in this case) by
comments not being accepted by document editors and/or WG chairs.
But ultimately it is a judgement call: are these commments substantive
enough to merit a new consensus call, or are they relatively unimportant?
Whether other people support the comments is a factor in making that judgement.
So I have some sympathy with a WG chair deciding that last call comments
that do not attract support on the list can be set aside- but it is
of course an appealable decision, at least for a standards track document.

My personal view on the document in question is that we are well
beyond the point of diminishing returns in tuning the text, and it should
be published as it is. That doesn't mean that some of the recent comments 
aren't intrinsically valid - it just isn't worth any more effort. This document
has largely served its purpose as a draft, and all that is usefully left is to 
archive it as an RFC.

   Brian

Robert Snively wrote:
> 
> I share Keith's concern, both about the response to
> his comments, and to the response about my comments
> from about the same time.
> 
> Bob Snively
> +1-408-333-8135
> 
> > -----Original Message-----
> > From: Keith Moore [mailto:[email-masked]]
> > Sent: Tuesday, January 06, 2004 11:16 AM
> > To: [email-masked]
> > Cc: [email-masked]; Keith Moore; [email-masked]
> > > While we did call rough consensus despite your comments,
> > and those of
> > > Todd Glassey and Alex Conta,  we did not ignore your
> > comments and they
> > > were included in the report on the rough consensus:
> > >
> > > http://eikenes.alvestrand.no/pipermail/problem-statement/2003-
> > > December/003245.html
> >
> > that's a stretch.  I certainly didn't recognize a response to
> > any of my
> > comments in this "report".
> >
> > > to which you commented, albeit not in agreement,:
> > >
> > > http://eikenes.alvestrand.no/pipermail/problem-statement/2003-
> > > December/003247.html
> >
> > yes, I was commenting on your complete failure to evaluate my
> > comments.

---

From: Alex Conta <[email-masked]>
Date: Wed, 07 Jan 2004 12:37:00 -0500

Brian,

If I understand correctly, this document is supposed to be a collection 
of descriptions of problems perceived by the IETF community.

If someone makes comments during the last call (WG or IESG), one obvious 
reason is that it was felt/perceived that the collection is incomplete, 
or one or more descriptions are incomplete. So obviously, 
resolving/including the comments is making the document more complete.

If the goal is to have this document as complete as it can be, and as 
inclusive as it can be, as I think the goal is, I do not understand why 
would one, sharing the same goal, oppose the comment resolution. It is 
true the document is not a standard document, but it is an important 
part and important reference in the work being done to resolve the 
current IETF problems.

Furthermore, I am afraid that an action, that could suggest that this 
document is in reality just a formality, is dangerous, in that would 
undermine the confidence of the IETF community that the IETF management 
is genuine in its leading toward resolving the problems which that 
community perceived.

Regards,
Alex

---

From: "Robert Snively" <[email-masked]>
Date: Tue, 6 Jan 2004 12:16:35 -0800

Bob Snively
+1-408-333-8135

---

From: "todd glassey" <[email-masked]>
Date: Wed, 7 Jan 2004 10:46:21 -0800

Alex, the issues is the process for defining what
constrains an acceptable  inclusion. The question is
one of how commentary inside a WG is included into the
formal recorded of that WG and what is edited or
censored out. And this of course is the bigger issue to
address.

Todd Glassey
----- Original Message ----- 
From: "Alex Conta" <[email-masked]>
To: "Brian E Carpenter" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, January 07, 2004 9:37 AM
Subject: Re: Last Call: 'IETF Problem Statement' to
Informational RFC

---

From: Keith Moore <[email-masked]>
Date: Wed, 7 Jan 2004 23:08:18 -0500

> be published as it is.

I'd be fine with that if the document didn't misrepresent what it is.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 09 Jan 2004 11:25:39 +0100

Alex,

My personal goal is not to have the document as complete as it can be,
but to encourage the IESG to continue the work it has started to
fix the most serious problems.

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 

NEW ADDRESS <[email-masked]> PLEASE UPDATE ADDRESS BOOK