Subject: RE: WG Last Call on IETF Problem Statement (small proposal to exp and text in sections 2.2 and 2.3)

From: [email-masked]
Date: Thu, 18 Sep 2003 11:23:06 +0200

Elwyn,
For the dependency issue I am sorry but I carn't find any mention of this
issue in section 2.4 (which is more about the "post-WG approval process"
while I was more concerned about new work still ongoing within a WG) but
agree that this paragraph of 2.1 could be read to cover this issue proved
we agree that recognising this important issue of dependencies between WG
and between IETF and other SDOs is consideration when looking at the
problem of IETF's core mission.  This is more than I was looking for (I was
only considering this to be a process issue and hence for 2.2)

I still think the minor change I propose to 2.2 would both better cover
this issue and send a clear signal to other SDOs that IETF is going to work
to improve its processes handling this dependency issue

For the undated reference issue I note that a similar idea is under
discussion in the solution list (the SSS idea) and I think you will be
surprised to find out how simple changes like this could help us break big
complex issues into smaller pieces.  Many other SDOs use this and it works.

Once again.  Why not add this small change proposal?

See also my comments below marked AUnew>>

- Alistair

P.S. Maybe the fact that small, targetted, change proposals like this can
not easily be included at this stage in the process is also a problem worth
looking at ;-)

                      "Elwyn Davies"                                                                                                   
                      <elwynd@nortelne         To:      Alistair AU URIE/FR/ALCATEL@ALCATEL, avri <[email-masked]>, Melinda Shore        
                      tworks.com>              <[email-masked]>                                                                      
                                               cc:      [email-masked]                                                
                      17/09/2003 17:00         Subject: RE: WG Last Call on IETF Problem Statement (small proposal to exp and text in  
                                               sections 2.2 and 2.3)                                                                   

Hi.

Thanks for the comments.  I think the points you make are indeed valid and
looking back through the mailing list, I believe that they had mostly been
made previously.  I also believe that they are essentially covered by the
existing text, and so I would concur with Dave Crocker that it would be
gilding the lily to make more modifications at this stage.

Regards,
Elwyn

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 15 September 2003 17:16
> To: avri; Melinda Shore; [email-masked]
> Subject: Re: WG Last Call on IETF Problem Statement (small
> proposal to expand text in sections 2.2 and 2.3)
>
>
>
> Although I note that a few people have already said we should
> "just ship
> it", may I please make two, small, last minute, proposals to
> add to this
> draft covering a pair of issues concerning problems effecting
> inter-relationships between WGs and between IETF and other
> bodies?

<<snip>>

> 1) Need for IETF to improve communications between WGs and
> between IETF and
> outside organisation when working on common issues
>
<<snip>>

> AU - add here>>   o  Difficulty in identify dependencies and
> respecting
> milestones between WG outputs and work planning and the work
> of other WGs
> and/or other standards developing bodies outside IETF which are
> collaborating with WGs on common issues

I think the issue for WGs is adequately covered by the equivalent point in
2.4.

AUnew>>> Sorry but carn't see anything under 2.4 on collaborations.

Communications with SDOs is covered in 2.1.  Arguably the equivalent point
to the one in 2.4 for WGs could be made for other SDOs.

AUnew>> But I am not discussing "communications" I am concerned about
mutual agreements that IETF leads on certain topics and that we will
deliver on our promises

>
>    o  Project entry, goal setting, and tracking processes are
> all either
>       missing or implemented less effectively than the norm for
>       commercial organizations in related activities.
>
> AU - replace with>>
>    o  Project entry, goal setting, dependency identification
> and tracking
>       processes are all either missing or implemented less
> effectively than
>       the norm for commercial organizations in related activities."

I think this is also covered by the point in 2.4.

>
> 2) - Lack of "undated" references covering IETF outputs
>
<<snip>>

> To cover this issue I propose we add a new dot point to the
> list in section
> 2.3.
>
> Specific proposed text is:
>
<<snip>>
> AU - add text>>o  The IETF does not have an effective means
> for WGs and
> outside standards bodies to refer to "work in progress" on
> new subjects and
> RFC revisions by means of "undated" references and/or other
> methods that
> allow work to progress independently on individual components
> of a complex
> problem."

This is a useful point but I am not sure that it adds significantly to
point about complex problems.
In terms of solutions this needs to be addressed and various people have
already been airing possibilities.

Regards,
Elwyn.

>
> yours,
>
> Alistair URIE
>
>
>
>
>
>
>
>                       avri <[email-masked]>
>
>
>                       Sent by:
> To:      [email-masked]
>
>                       problem-statement-bounces@al
> cc:      Melinda Shore <[email-masked]>
>
>                       vestrand.no
> Subject: WG Last Call on IETF Problem Statement
>
>
>
>
>
>
>
>                       31/08/2003 04:51
>
>
>
>
>
>
>
>
>
>
>
>
>
> This note marks the beginning of the WG Last call for:
>
>
> >            Title                         : IETF Problem Statement
> >            Author(s)         : E. Davies
> >            Filename          :
> draft-ietf-problem-issue-statement-03.txt
> >            Pages                         : 24
> >            Date                    : 2003-8-26
> >
>
>
> The document can be found at:
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-problem-issue-s
tatement-
03.txt

Because of the US holiday on Monday ,  1- Sept, the last call will
extend from now, 31 August until 16 September (any time zone).

Please send your comments to the WG mailing list
[email-masked]

thanks

a.

Avri Doria
co-chair

---

From: avri <[email-masked]>
Date: Thu, 18 Sep 2003 18:47:32 +0900

> not easily be included at this stage in the process is also a problem 

I think the only problem with including it is determining whether there 
is WG consensus for including it.  Documents can, of course, be changed 
as a result of Last Call comments, but only when there is consensus 
from the WG to do so.  That is indeed what we are trying to determine 
at this point.

Thanks

a.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 18 Sep 2003 09:02:35 -0500

I'm probably not being entirely clear in my postings. Avri may have
said it better.

I happen to agree that the problem Alistair raises is a real problem,
and should be fixed. The question is, is it worth discussing the text,
updating the document, and issuing another WG last call? I don't think
that it is, because

- the text cannot include a solution (out of scope for the document
and for the WG), so nothing will change immediately as a result of
adding the new problem, and

- a problem doesn't have to be documented in this draft in order to be
fixed!

We're talking about the Problem Statement draft as if it was a work
plan for solutions. It's not. It's an attempt to get clarity on a few
serious problems. Nobody is going to oppose a smart process
improvement because the problem wasn't named in the Problem Statement
draft.

So, my suggestion is,

- ship the document,

- discuss the problem on this list, if anyone has feedback - nobody
has said the problem doesn't exist, so I wouldn't expect too much
feedback here - , and

- propose a solution - and I would suggest a brief ID as the format
for the proposal, and [email-masked] as the venue for
discussing the proposal.

IMH,B,BSCO :-} But we really can start proposing solutions. We really
don't have to serialize the first fix behind the final problem
identification, but if we have to have a perfect Problem Statement
before we ship it, we're going to.

Spencer

---

From: Keith Moore <[email-masked]>
Date: Thu, 18 Sep 2003 10:23:29 -0400

I'm in sympathy with this view.  We can't expect to nail down every problem
and get agreement on every problem before we submit a list of problems.
We have a good enough list for the IESG and IAB to start working on solutions,
we should not give them an excuse to delay doing so by delaying this document
any more than necessary.

So my suggestion is that we change the document to state up front a very
clearly that the list is not comprehensive and never will be, and that we
recognize that our descriptions of these problems may be imperfect, and
that any group considering how to solve these problems will certainly need to
consider other input and/or subsequent clarifications, whether from the problem
statement WG or other interested/affected parties.

That, and change the abstract to remove the assumption that this group is
going to dictate the process by which problems are to be addressed.

and ship it.

Those who have comments/clarifications that they wish to submit can do so as
separate internet drafts.  Or if the group would like to set up a web page
where we can keep track of such notes it would be easy to collect them all
into a single draft and/or revise the problem statement document at a later
date, should that be found to be desirable.

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 18 Sep 2003 08:15:50 -0700

Hello folks,

Was it decided that the IETF members cannot solve the
problems, and we have to hand it over to the IESG?

For those who believe that the IESG has too much power
and uses it inappropriately, that doesn't sound very hopeful.
Furthermore, it seems to me that at least some members of
the IESG are _increasing_ their use of that power over the
last year.  Is there anything about the current direction of this
discussion that would encourage them to limit their opportunities?

Regards,
Charlie P.

---

From: Melinda Shore <[email-masked]>
Date: Thu, 18 Sep 2003 13:39:16 -0400

> problems, and we have to hand it over to the IESG?

Not really.  There were the straw polls taken at the plenary
(that is to say, *not* in this working group) which showed that
a slim majority of people in the room at the favored sending
it to the IESG.  Within this working group while there was
agreement that we'd recommend moving ahead immediately with
the recommended short-term solutions, the few concrete
process suggestions that have been made have been shot down and
nobody's been able to come up with something acceptable to the
group.  We need to come to grips with that somehow, but in the
meantime the problem statement document is not gated on the
process document.

Melinda

---

From: Keith Moore <[email-masked]>
Date: Thu, 18 Sep 2003 14:02:23 -0400

> problems, and we have to hand it over to the IESG?

we have to start somewhere.  IESG is not less brain-damaged than the
rest of IETF (they quite possibly may be saner), and they're in a better
position to initiate change than this WG.

of course if you want to form your own design team, you're free to do
so.   best of luck!

Keith