Subject: RE: The IETF's problems

From: "Elwyn Davies" <[email-masked]>
Date: Mon, 21 Jul 2003 14:11:13 +0100

I agree with Melinda.

If you want something altered or included in the problem statement draft,
the combattants on this thread are going to have to state clearly how they
would like the text altered.  I have not yet seen anything that actually
significantly enhances the arguments in the current draft - I believe that
Iljitsch's initial comments are actually all covered by the existing text in
one way or another.

I do not believe that having or not having three short windows in which
drafts cannot be submitted could be considered a 'root cause problem'.
IMHO, it is a useful deadline which concentrates the mind(s) of authors and
editorial teams towards actually getting something out there in a reasonably
timely fashion, and gives the victims who have to read the flood of words
some chance of being uptodate with what has been written by the time it is
discussed in the f2f meetings.   Given the percentage of people who do seem
to read most drafts, anything that helps with this is highly desirable.

I await some well-honed text!

Regards,
Elwyn

> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]]
> Sent: 20 July 2003 18:29
> To: Iljitsch van Beijnum
> Cc: [email-masked]
> Subject: Re: The IETF's problems 
> 
> 
> > This is a prime example of the topic of this list: the IETF 
> is unable 
> > to determine what it should work on and what it shouldn't 
> work on in a 
> > satisfactory way.
> 
> The discussion itself isn't doing much to distill the topic
> down to document text, and we need to stay focused.  Do you
> feel that existing text regarding scope in the problem
> statement document is inadequate?
> 
> Thanks,
> 
> Melinda
>

---

From: "todd glassey" <[email-masked]>
Date: Mon, 21 Jul 2003 08:27:56 -0700

RE: The IETF's problemsElwyn and Melinda
  ----- Original Message ----- 
  From: Elwyn Davies 
  To: 'Melinda Shore' ; Iljitsch van Beijnum 
  Cc: [email-masked] 
  Sent: Monday, July 21, 2003 6:11 AM
  Subject: RE: The IETF's problems 

  I agree with Melinda. 

  If you want something altered or included in the problem statement draft, the combattants on this thread are going to have to state clearly how they would like the text altered.  I have not yet seen anything that actually significantly enhances the arguments in the current draft - I believe that Iljitsch's initial comments are actually all covered by the existing text in one way or another.

Internet Draft Filing process

There are several perceptual problems with the filing of Internet Drafts that must be normalized across the entire IETF in order to meet the requirements of being fair to all. As well as being open to all submissions.

The first of these is that No I-D can be refused publication since its purpose is to solicit the creation of a vetting group and to create a formal initiative. With the current process for introducing a technology to the IETF, that is filing an I-D, no I-D's filed can be supressed for any reasons except improper IP releases against them. No other justifications are reasonable and in fact constitiute a restraint of someone's abilities to create an initiative creating an adversarial role for the IETF itself.

The Second issue here is that likewise, no Working Group can refuse the Publication of a I-D to it as a proposal to create a vetting team and run the vetting as a formal initiative within the IETF. This also constitutes a restraint of trade in the form of quashing critical business development in the form of creating Industry Standards.

  I do not believe that having or not having three short windows in which drafts cannot be submitted could be considered a 'root cause problem'.  

I do - It has to do with whether the publishing team is the publishing team or not. It seems that they have other roles as well and may not be available to manage the publishing efforts during meetings, and that's fine, but there is no reason to bounce any filings or throw them away becuase the I-D team is busy elsewhere. Its reasonable with modern technology to allow them to sit there while the IETF meeting is in pro, no matter what is going on in the IETF (meeting in progress or not). 

IETF meeting Agenda's obviously have a cut-off date, but that is relative to the periodic meetings only regarding consideration in that meeting itself, and should have no impact on the filing of the I-D itself. It is fine to tell people that the IETF's publishing team is elsewise engaged during a meeting but to make people refile them.

  IMHO, it is a useful deadline which concentrates the mind(s) of authors and editorial teams towards actually getting something out there in a reasonably timely fashion, and gives the victims who have to read the flood of words some chance of being uptodate with what has been written by the time it is discussed in the f2f meetings.   

This is already addressed by the "dropdead" date for inclusion in the Meeting Agenda's... Nothing else is needed to satisfy this requirement.

  Given the percentage of people who do seem to read most drafts, anything that helps with this is highly desirable.

  Regards, 
  Elwyn 

  > > to determine what it should work on and what it shouldn't 

Which is why the IETF has no real say in what it works on. The IETF is not a political or commercial lobby. It is a standards platform with a practice model.