Subject: RE: Doing the Right Things?

From: <[email-masked]>
Date: Mon, 2 Jun 2003 15:39:20 +0300

Hi Margaret,

I generally agree with your points below, but I would like to add 
one to the near-term:

0) Improving the quality of communications in the IETF.

In following this list, and getting reading for the IETF, I
realised that the only time I have 'quality' discussions with
my ADs / the IESG / the IAB tends to be at the IETF meetings
(3 times a year) - but even then, it is haphazard because
everyone is serious overload during the meeting.

My AD is overloaded currently (and has been for a number of
years) so it is very difficult to get input / thoughts on
the technical direction of my WG.

My sent an updated charter for approval & I secretely hoped
that the IESG / IAB would engage me on the direction of WG ..
but that didn't really happen.

So, this makes me think your points below will not have much
of an impact if we don't address some other things as well.
It seems to me that the current way of working in the IETF
was designed many years ago, for a much smaller IETF & the
process is showing its age.  

I am not sure about solutions, but I do have some ideas.
However, before offering them, I wonder what others think
about communications within the IETF, in general?

thanks,
John

> I have a concern about the type of discussions that we've
> been having regarding the process document, so far...
> 
> The discussion has focused quite heavily on who should
> manage the improvement processes and very little on what
> those improvement processes should be.
> 
> The process document currently recommends four separate,
> parallel near-term efforts and a longer-term effort, as
> follows:
> 
>     Near-Term:
>        (1) Form a WG intended to improve the quality,
> 		timeliness and predictability of IETF
> 		WG output, by improving our quality and
> 		review processes.
> 
> 	(2) Continue and expand our ongoing educational
> 		efforts for WG chairs and participants,
> 		including the addition of education for
> 		editors.  A BOF request for Vienna has
> 		already been circulated regarding this
> 		work.
> 
> 	(3) Encourage grass-roots efforts to deploy
> 		tools for voluntary use by WGs and
> 		IETF participants, particularly for
> 		issue tracking and document sharing.
> 
> 	(4) Continue efforts to promote communication
> 		between WG chairs.  This section is very
> 		weak, and additional suggestions would
> 		be appreciated.
> 
> 	Longer-Term:
> 
> 	(5) Form an IETF Improvement WG that will
> 		undertake a two phase process:
> 
> 		- Understand the mission, values and
> 		  goals of the IETF, and develop metrics
> 		  to measure and evaluate our current
> 		  performance.
> 		- Make changes the organizational
> 		  structure of the IETF and/or our
> 		  standards-track processes to
> 		  improve the efficiency and
> 		  scalability of the IETF.
> 
> So, regardless of exactly _how_ we organize to do these
> things and/or _who_ does them...  Do people think that
> these are the right things to do?
> 
> Margaret
> 
> 
> 
> 
>

---

From: Melinda Shore <[email-masked]>
Date: Mon, 02 Jun 2003 08:47:34 -0400

I'm concerned that we may be wandering a bit far into
solutions.  Part of the problem reflects a broader IETF
problem with getting things done in a timely way; that
spinning off a new effort to identify short-term changes may
simply take too long.  It may be worth talking specifically
about how a short-term effort can be initiated without all
the overhead associated with wg creation, etc.

Melinda

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 02 Jun 2003 15:11:16 +0200

> the overhead associated with wg creation, etc.

speaking strictly as a participant....

I think that for each solution path to be pursued, a core team with 
competence and energy to drive the process is needed, no matter what - and 
that once we have that, it almost doesn't matter how long the formal 
process to start the thing is; they can go to work right away, and do 
course corrections as part of the chartering process, rather than waiting 
for the "formalities" to complete before starting work.

Of course, that depends on there actually being some common understanding 
that this is the right path to take.....

                     Harald

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 2 Jun 2003 09:28:33 -0500

Dear Melinda,

I might suggest backing up one more step, and cataloging the reasons we need
to do a small chunk of work in the IETF. My cotribution is

- relatively minor updates to an existing protocol

I'm a TSV guy, mostly, and there's ongoing TSV work on TCP mechanisms for
spurious timeout detection and recovery, for instance. Most of it gets done
in TSVWG, which was created specifically as a catch-all for small chunks of
work in TSV.

What are the "small chunk" needs of other communities?

Spencer