Subject: RE: Staying on Track (Re: Documenting pilots (RE: pausable explanation for the Document Series))

From: "Bound, Jim" <[email-masked]>
Date: Sat, 7 Jun 2003 23:10:54 -0400

I am ok with them except the process doc on "Core Values"  I just don't
agree.

/jim

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]] 
> Sent: Friday, June 06, 2003 8:46 AM
> To: [email-masked]
> Subject: Staying on Track (Re: Documenting pilots (RE: 
> pausable explanation for the Document Series))
> 
> 
> 
> 
> I hate to do this, but...
> 
> Not that I have any official authority to say this, but...
> 
> At this point, this mailing list is almost exclusively 
> discussing solutions to problems, and refinements to those solutions.
> 
> I, too, find it more fun and constructive to discuss
> solutions, but this WG is only chartered to produce:
> 
> 	1 - A problem statement
> 	2 - Recommendations for a process to solve
> 		the problems.
> 
> Are people happy enough with those documents that we're
> ready to publish them and move on?  If so, let's do
> that. If not, please send feedback on the documents to
> this list, and keep solutions discussions on the solutions 
> mailing list.
> 
> Thanks,
> Margaret
> 
> 
>

---

From: <[email-masked]>
Date: Mon, 9 Jun 2003 13:59:20 +0300

Hi Margaret,

> The process document currently suggests forming a WG to evaluate
> improvements to the WG process, develop metrics, run experiments,
> etc...  IMO, the group should focus on making iterative
> improvements to the quality, timeliness and predictability of
> WG output that are expected to have near-term results.  I think
> that there is a lot of low-hanging fruit regarding the process
> used by WGs, including milestone management, reviews, etc.  So,
> I think that we can make quite an improvement in the operation
> of the IETF through process improvements in this area.
> 
> There has been some support for the creation of this WG, and for
> holding a BOF in Vienna.  However, there have also been folks who
> have argued that a WG is "too heavyweight" to do this, and
> that we should be performing this function in a more adhoc manner.
> In particular, John has suggested that the IESG run the process.
> 
> Although I accept that it is within the area of responsibility
> of the IESG to run this function, we also have an acknowledged
> overload problem for individual IESG members.  So, I think that
> this is a perfect example of a responsibility that the IESG can,
> and should, delegate to members of the community with expertise
> in process improvement, metrics development, etc.
> 
> Because I think that this activity should be open to the
> community, I favor a WG.
> 
> What do others think?
> 
> It would be nice to get some consensu on this, so I know what to
> say in the document.

I think that this would be a definate good use of face-to-face
time in Vienna.  I do not have enough foresight to know if
there will be support to create a working group around it,
but I think we should consider doing something along the lines
that you have proposed.

John L.