Subject: RE: Doing the Right Things?

From: "Bound, Jim" <[email-masked]>
Date: Sun, 1 Jun 2003 12:46:59 -0400

I need more time to think about this.  I think Keith raised good issues.
I think we are missing something but I am not sure right now how to put
it.  But I agree we need to do soemthing.

Are we in that mode now?

I think the bar for PS is to HIGH as one input that keeps going thru my
mind, but that might be fixed with what Keith suggested.  I need most of
this week before I can respond with real thought and contemplation.  I
assume that is ok with the chairs.  Lets not rush this one, but get it
done in timely manner too.

/jim

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]] 
> Sent: Saturday, May 31, 2003 9:53 PM
> To: [email-masked]
> Subject: Doing the Right Things?
> 
> 
> 
> Hi All,
> 
> I have a concern about the type of discussions that we've
> been having regarding the process document, so far...
> 
> The discussion has focused quite heavily on who should
> manage the improvement processes and very little on what
> those improvement processes should be.
> 
> The process document currently recommends four separate, 
> parallel near-term efforts and a longer-term effort, as
> follows:
> 
>     Near-Term:
>        (1) Form a WG intended to improve the quality,
> 		timeliness and predictability of IETF
> 		WG output, by improving our quality and
> 		review processes.
> 
> 	(2) Continue and expand our ongoing educational
> 		efforts for WG chairs and participants,
> 		including the addition of education for
> 		editors.  A BOF request for Vienna has
> 		already been circulated regarding this
> 		work.
> 
> 	(3) Encourage grass-roots efforts to deploy
> 		tools for voluntary use by WGs and
> 		IETF participants, particularly for
> 		issue tracking and document sharing.
> 
> 	(4) Continue efforts to promote communication
> 		between WG chairs.  This section is very
> 		weak, and additional suggestions would
> 		be appreciated.
> 
> 	Longer-Term:
> 
> 	(5) Form an IETF Improvement WG that will
> 		undertake a two phase process:
> 
> 		- Understand the mission, values and
> 		  goals of the IETF, and develop metrics
> 		  to measure and evaluate our current
> 		  performance.
> 		- Make changes the organizational
> 		  structure of the IETF and/or our
> 		  standards-track processes to
> 		  improve the efficiency and
> 		  scalability of the IETF.
> 
> So, regardless of exactly _how_ we organize to do these
> things and/or _who_ does them...  Do people think that
> these are the right things to do?
> 
> Margaret
> 
> 
> 
> 
>

---

From: <[email-masked]>
Date: Mon, 2 Jun 2003 15:31:08 +0300

Hi Jeanette,

> > Agreed.  Also, I think it is the WG chairs' job to be list 
> moderators as well.
> > That means interveaning before the attacks get personal; 
> summarizing the
> > discussions; etc.  When the mailing list becomes free-form 
> & unstructured,
> > I doubt much can come from it.
> 
> Do you think that all working groups should appoint a moderator? 

Well, perhaps I've naively assumed that the WG chairs were the
moderator.  In fact, I think the moderator MUST be the chair(s),
as the chair needs to work out the consensus.  Part of moderating
is calling consensus.

> > > b. It's been repeatedly observed for several years that 
> face-to-face meeting
> > > time isn't used effectively - it's often taken up almost 
> entirely by
> > > presentations of material that could have been read in 
> advance, leaving very
> > > little time for activities that really do need 
> face-to-face interaction -
> > > like resolving tricky technical disagreements.  
> Persistent instructions from
> > > various ADs to WGs have had little effect.
> > > 
> > > Powerpoint-style presentations (not that it really 
> matters which tool is used)
> > > tend to lull people into passivity, if not sleep.  Video 
> projectors can be
> > > great for high quality drawings, or very occasionally, 
> animations to
> > > illustrate how something works - but using them to put up 
> words (with fancy
> > > backgrounds) that are just repeated by the speaker is to 
> make a really
> > > ineffective use of high-bandwidth meeting time.
> > > 
> > > We need to understand why we are stuck in these ineffective modes,
> 
> Judging from the improvements you and Keith suggest, the answer seems to 
> be simple: making effective use of face-to-face meeting time means more 
> preparatory work. 

One would assume (or at least hope) that would be self-evident...

John