Subject: Wording of Engineering Processes Problem

From: Margaret Wasserman <[email-masked]>
Date: Tue, 10 Jun 2003 09:58:21 -0400

As I mentioned in SF, I think we may want to change the
wording of the "Engineering Processes" problem...

IMO, the problem isn't that we don't use effective
engineering processes (although using them may be part
of the solution).  I'd state the problem as:

"WGs do not consistently produce timely, high-quality
and predictable output."

Solutions to this problem might include:  adoption of
quality processes, training, better review during document
production, flogging WG chairs who produce crap, etc.

What do others think?

Margaret

---

From: Scott W Brim <[email-masked]>
Date: Tue, 10 Jun 2003 11:03:59 -0400

> production, flogging WG chairs who produce crap, etc.

Fine with me.  It avoids straying into solutions.

---

From: Keith Moore <[email-masked]>
Date: Tue, 10 Jun 2003 11:26:40 -0400

> "WGs do not consistently produce timely, high-quality

there's more to engineering than these considerations.  two things
come to mind immediately: cost-effectiveness and responsibility to the
public.

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 10 Jun 2003 09:44:50 -0700

Hello Margaret,

I am reminded of the story about the start-up where things
were finally getting taken care of, loose ends straightened
out, and so on.  They folded soon after.  The moral is that
work on the edge of technology is messy and unpredictable.

I'd rather encourage timeliness than predictability, because
the latter probably means that the timeline by which the
predictions are made will be expanded to assure success.
It seems to me that once interoperability is achieved and
major technical difficulties are overcome, the process should
be oriented towards expedient publication.

Regards,
Charlie P.

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 10 Jun 2003 12:48:05 -0400

>predictions are made will be expanded to assure success.

I would also prefer to think about timeliness rather than
predictability.  But, it can be quite difficult to make
trade-offs between feature level and timeliness if you
don't have any schedule predictability...

Also, several people have said, on this list, that their
(large) companies sometimes have problems with the lack of
predictability of IETF output.  They don't understand how much
they need to invest to get certain results, which makes it
difficult to imply traditional ROI (return on investment)
thinking to IETF activities.

Margaret

---

From: Randy Bush <[email-masked]>
Date: Wed, 11 Jun 2003 03:27:06 +0900

> "WGs do not consistently produce timely, high-quality

or "we do not know how to help wgs to consistently ..."

or s/know how/have processes and incentives in place/

randy