Subject: RE: ISSUE: Goal of problem-statement document

From: "Bound, Jim" <[email-masked]>
Date: Sat, 7 Jun 2003 23:17:23 -0400

One thing I thing we should ask if we have consensus on and that is the
bar for PS is to high.  Fixing that is a solution we have to work.  But
it should be documented as a problem just based on the fact that it
created much discussion and the issue of maturity levels.  So I think we
found another problem to add.

thanks
/jim

> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]] 
> Sent: Friday, June 06, 2003 10:47 AM
> To: Harald Tveit Alvestrand
> Cc: [email-masked]
> Subject: Re: ISSUE: Goal of problem-statement document 
> 
> 
> > SUGGESTED RESOLUTION: Change this section to say that the document 
> > attempts to be a basis for consensus on the root causes.
> 
> One of the things that's of concern here is an interest in 
> trying to find ways to make progress in the absence of 
> consensus about each identified problem, the dependency 
> analysis, and a ranking.  We absolutely do believe that the 
> document will provide guidance, but it's reasonable to 
> suspect that it's likely that the only way we'll be able to 
> reach real consensus on some of it is if we dilute the 
> discussion to the point it isn't useful.
> 
> Melinda
>

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 7 Jun 2003 23:19:43 -0400

no expliciy agreed mission is wishy washy with no meet and we will never
figure that out but get close by documenting our bullets.

Saying PS bar is to high now that has some meat.

/jim

> From: Harald Tveit Alvestrand [mailto:[email-masked]] 
> Sent: Friday, June 06, 2003 10:55 AM
> To: Melinda Shore
> --On fredag, juni 06, 2003 10:47:01 -0400 Melinda Shore 
> <[email-masked]> 
> wrote:
> 
> trying to 
> > find ways to make progress in the absence of consensus about each 
> > identified problem, the dependency analysis, and a ranking.  We 
> > absolutely do believe that the document will provide guidance, but 
> > it's reasonable to suspect that it's likely that the only 
> way we'll be 
> > able to reach real consensus on some of it is if we dilute the
> I think we do have consensus on a fair number of points 
> (including the "no 
> explicit agreed mission", for instance) - I'd like to probe 
> and try to 
> refine some more of these points before declaring that this 
> document is "as 
> good as we can make it".
> 
> We might quickly come to consensus about what we can't come 
> to consensus on 
> :-)
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 8 Jun 2003 08:44:06 -0400

I agree with you Spencer.  If we have to have total consensus on root
cause it is death. I think when you see 5 or 6 bright people from
multiple vantage points say something is at the root it warrants at
least being on the list for now.

/jim

> From: Spencer Dawkins [mailto:[email-masked]] 
> Sent: Sunday, June 08, 2003 12:45 AM
> To: [email-masked]
> Dear Randy,
> I'm reading your note as carefully as I can, and see you are 
> asking that we understand needs and requirements well. I 
> agree, and want to focus on the definition of "well enough".
> 
> Speaking only for myself, I agreed with our text (and may
> have suggested it) because I strongly suspected that the 
> engineering alternative was discussing each problem, 
> determining its root cause, and agreeing on a prioritized 
> list of root causes before we did anything.
> 
> I would love to be wrong.
> 
> I can't speak for others, but my goal here was to avoid
> having to figure out what the IETF consensus was on a 
> prioritized root cause list before moving on any root cause. 
> This looked like death to me. I don't believe there are ANY 
> scope limits on discussions about the relative priority of 
> root IETF problems, unlike our normal engineering work.
> 
> So I thought developing a root cause list (which we have
> done, at least at some level) was sufficient, without 
> spending time trying to determine priorities. I thought this 
> was "good enough".
> 
> I would love to hear other opinions.
> 
> Spencer Dawkins
> 
> ----- Original Message ----- 
> From: "Randy Bush" <[email-masked]>
> To: "Harald Tveit Alvestrand" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Saturday, June 07, 2003 4:21 PM
> > >    We, in line with many contributors to the mailing list, do not
> > >    believe that the process of problem resolution will be helped
> > >    by continued rework of the root issues in what would probably
> > >    be a vain attempt to achieve any sort of consensus.  Instead,
> > >    the general tenor and scope of the problems identified will
> > >    provide a guide in setting up the processes needed to resolve
> > >    the problems and provide input to the resolvers.
> > 
> > i always found this part particularly amusing considering 
> it is being 
> > pushed by the same folk who so strongly push for a classic software 
> > engineering management view of the wg product process. how can we 
> > think we will produce a good result if we do not first define the 
> > needs and requirements well?
> > 
> > randy
> > 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 8 Jun 2003 08:45:49 -0400

I think long discussion on this list and clear disagreement means there is a problem. So lets call it list debate consensus?

/jim

> Sent: Sunday, June 08, 2003 7:35 AM
> To: Spencer Dawkins; [email-masked]
> --On lørdag, juni 07, 2003 23:45:08 -0500 Spencer Dawkins 
> <[email-masked]> wrote:
> 
> > I can't speak for others, but my goal here was to avoid having to 
> > figure out what the IETF consensus was on a prioritized root cause 
> > list before moving on any root cause. This looked like 
> death to me. I 
> > don't believe there are ANY scope limits on discussions about the 
> > relative priority of root IETF problems, unlike our normal 
> engineering 
> > work.
> >
> > So I thought developing a root cause list (which we have done, at 
> > least at some level) was sufficient, without spending time 
> trying to 
> > determine priorities. I thought this was "good enough".
> 
> actually I tend to agree with your sentiment, but not with 
> the text of the 
> document as written.
> 
> if we can formulate the text as saying "we think there is 
> IETF consensus 
> that this statement of root causes is good enough to guide us 
> into the 
> process of what to try to fix first", I think it would be better.
> 
> What I reacted most strongly to was the statement "a vain attempt to 
> achieve any sort of consensus" - we need SOME sort of consensus.
> 
>               Harald
> 
> 
>