Subject: RE: Wording of Engineering Processes Problem

From: <[email-masked]>
Date: Tue, 10 Jun 2003 18:40:44 +0300

Hi Margaret,

> As I mentioned in SF, I think we may want to change the
> wording of the "Engineering Processes" problem...
> 
> IMO, the problem isn't that we don't use effective
> engineering processes (although using them may be part
> of the solution).  I'd state the problem as:
> 
> "WGs do not consistently produce timely, high-quality
> and predictable output."

I could buy that.
 
> Solutions to this problem might include:  adoption of
> quality processes, training, better review during document
> production, flogging WG chairs who produce crap, etc.

Or how about simple checks & balances?

John

---

From: Eric Rescorla <[email-masked]>
Date: 10 Jun 2003 08:53:00 -0700

> Or how about simple checks & balances?

I don't think so. The main function of checks and balances in
most political systems is to stop things from getting done.

If we actually want to produce work that's good, I think we'll
have to orient ourselves more towards that goal.

-Ekr

-- 
[Eric Rescorla                                   [email-masked]]
                http://www.rtfm.com/