Subject: Quality of WG Output (Was: RE: OPEN ISSUE: Standards Track)

From: Margaret Wasserman <[email-masked]>
Date: Thu, 22 May 2003 16:05:28 -0400

Hi Basavaraj,

At 01:55 PM 5/22/2003 -0500, [email-masked] wrote:
>Maybe. But the key lesson to be learn here is that the Mobile IP WG
>spent about 3 years or more before the IESG said that the security
>solution based on IPsec was broken. The timeline to arrive at such
>a conclusion is a serious problem for any standards work.

I agree that it is a serious problem that there was no
adequate security review of this proposal for three
years while it was being processed by the WG.

But, I don't think that this is a problem with:

         - The IESG, or
         - The IETF standards track.

Instead, I consider this a problem with the quality
processes (or lack thereof) used by our WGs.  We
need to find ways to make sure that documents are
adequately reviewed during different phases of
WG development, so that these "late surprises" don't
occur.  In other words, we need to determine ways
to increase the quality and integrity of WG output.

This is dealt with in the problem statement
and the process document in the discussion of WG
engineering practices.

Margaret

---

From: "James Kempf" <[email-masked]>
Date: Thu, 22 May 2003 13:37:38 -0700

Margaret,

Well stated. Introduction of more structured, formal reviews at a
selected, very fiew points in the development process could help to
reduce the late suprise factor. Of course, it is possible to go
overboard and slow down the development with too much process, so care
is needed.

            jak

----- Original Message -----
From: "Margaret Wasserman" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Thursday, May 22, 2003 1:05 PM
Subject: Quality of WG Output (Was: RE: OPEN ISSUE: Standards Track)