Subject: RE: Quality of WG Output (Was: RE: OPEN ISSUE: Standards Track)

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 23 May 2003 14:25:52 +0200

Mmmm... maybe this is just me...

But what is wrong with WG members and WG chairs to seek 
early help from the Security Area Advisors and ADs or 
from some specific WG in the security area?

I.e. WG chairs should feel free to try and find help in
other places in the IETF.

Thanks,
Bert 

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: donderdag 22 mei 2003 22:38
> To: [email-masked]; Margaret Wasserman
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: Quality of WG Output (Was: RE: OPEN ISSUE: 
> Standards Track)
> 
> 
> Margaret,
> 
> Well stated. Introduction of more structured, formal reviews at a
> selected, very fiew points in the development process could help to
> reduce the late suprise factor. Of course, it is possible to go
> overboard and slow down the development with too much process, so care
> is needed.
> 
>             jak
> 
> ----- Original Message -----
> From: "Margaret Wasserman" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>;
> <[email-masked]>
> Sent: Thursday, May 22, 2003 1:05 PM
> Subject: Quality of WG Output (Was: RE: OPEN ISSUE: Standards Track)
> 
> 
> >
> > Hi Basavaraj,
> >
> > At 01:55 PM 5/22/2003 -0500, [email-masked] wrote:
> > >Maybe. But the key lesson to be learn here is that the Mobile IP WG
> > >spent about 3 years or more before the IESG said that the security
> > >solution based on IPsec was broken. The timeline to arrive at such
> > >a conclusion is a serious problem for any standards work.
> >
> > I agree that it is a serious problem that there was no
> > adequate security review of this proposal for three
> > years while it was being processed by the WG.
> >
> > But, I don't think that this is a problem with:
> >
> >          - The IESG, or
> >          - The IETF standards track.
> >
> > Instead, I consider this a problem with the quality
> > processes (or lack thereof) used by our WGs.  We
> > need to find ways to make sure that documents are
> > adequately reviewed during different phases of
> > WG development, so that these "late surprises" don't
> > occur.  In other words, we need to determine ways
> > to increase the quality and integrity of WG output.
> >
> > This is dealt with in the problem statement
> > and the process document in the discussion of WG
> > engineering practices.
> >
> > Margaret
> >
> >
> >
> >
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 23 May 2003 17:09:47 +0200

Bert, they are free to do it today, but the problem is
the ones who don't.

However, I would rather fix this problem with a carrot
than with a stick (hence the SIRs draft).

   Brian

---

From: Scott W Brim <[email-masked]>
Date: Fri, 23 May 2003 11:16:45 -0400

> than with a stick (hence the SIRs draft).

which technically includes a stick, since documents MUST be reviewed
before publication.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 23 May 2003 18:00:42 +0200

> which technically includes a stick, since documents MUST be reviewed

Actually, wait for the -01 version. We've had comments on that point.
   Brian

---

From: "James Kempf" <[email-masked]>
Date: Mon, 26 May 2003 13:34:50 -0700

Bert,

Sure. Putting on my WG chair hat, I do this informally all the time.
But my milage does vary, depending on how busy the people are who I
contact.

I still think it makes a certain amount of sense to have some more
formal design reviews earlier in the process, to avoid the "late
suprise" problem. After a WG has been running for a while (where "a
while" needs some definition), I think they are obligated to show some
results. Making the design review formal assures that the relevent
IETF people (Security ADs, SAAG, etc.) can commit time, gives the
shepherding AD leverage if the WG is not performing for some judicious
early pruning, or, less drastically, for some midcourse corrections.

            jak

----- Original Message -----
From: "Wijnen, Bert (Bert)" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, May 23, 2003 5:25 AM
Subject: RE: Quality of WG Output (Was: RE: OPEN ISSUE: Standards
Track)