Subject: RE: OPEN ISSUE: Appeals Path

From: "Bound, Jim" <[email-masked]>
Date: Fri, 16 May 2003 21:29:23 -0400

The IETF plenary is less than a jesters court and I cannot think of one
thing that has changed because of it?  Be glad to hear if others can
tell us?  

Why do any beleive the current appeals process does not work?  I say it
does.  

This is not broken in the IETF is my view.  I find plenary's totally
boring though usually, and it should also not be a forum to trash the
IESG that is not good I believe today.  The IESG is trying to do a job
if there is an issue take it to them if one still has an issue use the
appeals.

For example running code I believe has been forgotten as good input to
whether a standards tracked document is in fact useful as input.
Whether that is true or not is not the debate here but going to the
plenary and complaining about it is stupid and a waste of ones time. We
also don't want PS to become held up for running code in most cases.Also
if I were IESG member and someone said they had running code I would
grill them to prove it and demonsrate it, or point to bake-off where it
is running.  Just because one hacks up a kernel for one part of a spec
does not mean the spec or code is correct for the standard. But, it does
demonstrate a serious effort and belief in the work.

But Avri's talk on the IETF problem space work was an EXCELLENT use of
IESG Plenary time at the San Francisco meeting.  That is what it can do
well which is the communications to masses stated below.  That I agree
with.  Also Haralds update on the finanical condition. Those talks were
useful information.  But in Yokohamma the implementors were completely
misrepresented for IPv6 and the community heard only one side of that
story it was completely biased.  Nothing is perfect so I for one let it
go though I was prodded by well over 20 members to go bitch about it to
the IESG I just stated it is not worth our time nor will it affect
anything regarding IPv6 implementation momentum.   

Also getting any real work done in a room with > 300 people is absurd.

/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Friday, May 16, 2003 7:48 PM
> To: Dave Crocker; Margaret Wasserman
> Cc: [email-masked]; Dave Crocker
> Subject: Re: OPEN ISSUE: Appeals Path
> 
> 
> At 4:22 PM -0700 5/16/03, Dave Crocker wrote:
> >Margaret,
> >
> >
> >MW> I think that a well-defined appeals process is needed for any 
> >MW> activity the size and scope of the proposed Improvement WG.
> >
> >There is no higher appeal than the IETF Plenary.
> 
> Dave,
> 
> Could you expand on how that actually works?
> 
> I see the IETF plenary as a very important tool for ensuring 
> that anyone in the community has a voice that carries beyond 
> a particular working group or area.  I am not sure that it 
> can be an effective appeals body or what process it would use 
> if we decided it should be one. Fundamentally, the time 
> allotted to Plenary meetings by our current schedule is very 
> short, and the issues we are dealing with very complex.  Even 
> assuming that we limited folks' time and trips to the 
> microphone, we seem unlikely to resolve any substantive 
> issues inside a meeting.  The one appeal I heard in my short 
> term on the IAB took a great deal of both focused time 
> discussing the issue and even more wording a response; I 
> don't think we have that in Plenary meetings.
> 
> To put it another way, the open mic at a plenary ensures that 
> issues can be raised, but it seems a poor context for 
> actually resolving the issues or appeals.
> 
> It also fundamentally misses our usual point that 
> participating in the IETF can take place outside the 
> face-to-face meetings, as it requires those not attending a 
> particular meeting to make some other arrangements for 
> participation.  With the jabber conferences, it is easier, 
> though time shifting and other barriers remain.
> 
> 			regards,
> 				Ted Hardie
> 
> 
> >Worrying about invoking "normal" appeals processes entirely 
> misses the 
> >nature of this IETF change effort.
> >
> >This effort is not a typical technical specification effort, 
> so let's 
> >not pretend that it must conform to our typical working 
> group process.
> >
> >
> >
> >d/
> >--
> >  Dave Crocker <mailto:[email-masked]>
> >  Brandenburg InternetWorking <http://www.brandenburg.com>
> >  Sunnyvale, CA  USA <tel:+1.408.246.8253>, <fax:+1.866.358.5301>
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 16 May 2003 23:27:29 -0400

the member should go to the AD, if the AD is not enough the IETF Chair
and if that don't work go to IAB and if that don't work feed WG chair to
pig or give up :--) 

the key is that there is no conflict of interest in the chain and all
parties are in positions based on absolute skill set and a nomcom
process that has no conflict of interest to elect IAB and IESG updates
who in turn appoints WG chairs.

/jim

> From: Margaret Wasserman [mailto:[email-masked]] 
> Sent: Friday, May 16, 2003 10:59 PM
> To: Dave Crocker
> Cc: [email-masked]
> At 04:22 PM 5/16/2003 -0700, Dave Crocker wrote:
> So, if a WG member has a problem with an action taken by the
> WG chair, how will that be appealed to the plenary?
> 
> Or will the aggrieved party have to wait until the conclusion 
> of the process, when consensus on the results is sought 
> during the plenary?  At that point, how would an appeal on a 
> months- old action be constructively raised?
> 
> Margaret
> 
> 
> 
>

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 16 May 2003 23:27:10 -0400

Hi Jim,

>and if that don't work go to IAB and if that don't work feed WG chair to

The only case where we are currently discussing the appeals process
is the ISOC-driven approach.  In this case, the ISOC President
serves as the "responsible AD".  So, the appeals process would go
to the ISOC President, then to the IESG, then up the chain?

This might work if we choose this approach, but it would need to
be documented.

>who in turn appoints WG chairs.

The question of whether the process will be IESG-driven or ISOC-driven
is separate from chair selection.  We could use a nomcom-like method
to select the WG chairs, regardless of which group provides WG
oversight.

Margaret

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 16 May 2003 23:56:01 -0400

OK.  I am not in favor of ISOC being brought into the loop till the very
end.  But they should be part of the process as logic check for sure if
required.

Why do you up the chain?  It is going down the chain?  

I don't think nomcom process for wg chairs is good idea and overkill. 

The process should be as follows for all grievances by a member.

WG Chair
IESG
IAB
ISOC

THis is standard open door policy in any company I know of too.

thanks
/jim

> Sent: Friday, May 16, 2003 11:27 PM
> To: Bound, Jim
> Cc: Dave Crocker; [email-masked]
> Subject: RE: OPEN ISSUE: Appeals Path
> 
> 
> 
> Hi Jim,
> 
> >and if that don't work go to IAB and if that don't work feed 
> WG chair 
> >to pig or give up :--)
> 
> The only case where we are currently discussing the appeals 
> process is the ISOC-driven approach.  In this case, the ISOC 
> President serves as the "responsible AD".  So, the appeals 
> process would go to the ISOC President, then to the IESG, 
> then up the chain?
> 
> This might work if we choose this approach, but it would need 
> to be documented.
> 
> The question of whether the process will be IESG-driven or 
> ISOC-driven is separate from chair selection.  We could use a 
> nomcom-like method to select the WG chairs, regardless of 
> which group provides WG oversight.
> 
> Margaret
> 
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 19 May 2003 08:53:00 -0400

I agree I stated it so someone else would say this not me.  Your a brave
man :--)
OK thats over.
thanks
/jim

> From: Brian E Carpenter [mailto:[email-masked]] 
> Sent: Monday, May 19, 2003 3:15 AM
> To: [email-masked]
> "Bound, Jim" wrote:
> > Yep I knew that about tech appeals.  Suggesting we discuss 
> if we want 
> > ISOC also for tech appeals but did not directly in the mail.  Sorry.
> 
> Not if you believe that technical appeals should be heard by 
> people who understand them. The ISOC Board is simply not 
> competent for technical discussions; it relies on the IAB for 
> technical advice.
> 
>    Brian
> 
> > /jim
> > 
> > > From: Pekka Savola [mailto:[email-masked]]
> > > Sent: Saturday, May 17, 2003 10:48 AM
> > > To: Margaret Wasserman
> > > Cc: Bound, Jim; Dave Crocker; [email-masked]
> > > On Sat, 17 May 2003, Margaret Wasserman wrote:
> > > > >WG Chair
> > > > >IESG
> > > > >IAB
> > > > >ISOC
> > > > >
> > > > >This is standard open door policy in any company I know of too.
> > > >
> > > > Yes, and this also matches the standard appeals process 
> for IETF 
> > > > WG activities.
> > >
> > > "IETF WG activities" is ambiguous.  The path holds for process 
> > > appeals, but for technical appeals, the IAB is the 
> highest you can 
> > > go.
> > >
> > > --
> > > Pekka Savola                 "You each name yourselves 
> king, yet the
> > > Netcore Oy                    kingdom bleeds."
> > > Systems. Networks. Security. -- George R.R. Martin: A 
> Clash of Kings
>