Subject: OPEN ISSUE: Quality Process WG Charter

From: Margaret Wasserman <[email-masked]>
Date: Thu, 15 May 2003 11:49:56 -0400

Currently the process document says:

>A working group should be formed in the General Area of the IETF to
>oversee improvements to the quality processes used in IETF WGs, and
>to increase the effectiveness of IETF reviews at all levels.  This
>group should take an experimental, iterative approach to these
>improvements:

[...]

>     [OPEN ISSUE: Should the Problem Statement WG propose a charter for
>     this group, or leave that to the General AD and selected chair(s)?]

I think that developing a charter for this group should be
done by the ADs and chair(s), probably through the normal
BOF process.

Margaret

---

From: Keith Moore <[email-masked]>
Date: Fri, 16 May 2003 11:42:46 -0400

> >     [OPEN ISSUE: Should the Problem Statement WG propose a charter
> >     for this group, or leave that to the General AD and selected
> >     chair(s)?]
> 

I don't think this group should propose a charter for that group.

And I'm not sure I even agree with the text in the process document
about how that group should proceed.

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 16 May 2003 11:54:31 -0400

Hi Keith,

>about how that group should proceed.

Would you like to propose an alternative?

Margaret

---

From: Keith Moore <[email-masked]>
Date: Fri, 16 May 2003 13:11:45 -0400

> Would you like to propose an alternative?

maybe, but I need more time to think about it.

---

From: John C Klensin <[email-masked]>
Date: Sun, 18 May 2003 10:51:37 -0400

--On Friday, 16 May, 2003 11:54 -0400 Margaret Wasserman 
<[email-masked]> wrote:

>> And I'm not sure I even agree with the text in the process
>> document about how that group should proceed.
>

Margaret, I'd like to propose something as a strawman, partially 
based on further thought after my comments about process 
yesterday.  This is a radical suggestion and may not be a good 
idea, but I'd like to see if it resonates with others or at 
least stimulates some discussion and other suggestions.

We seem to have three perspectives/ camps at the moment:

	(1) Use the normal process, including assigning these
	working groups to the IETF Chair (i.e., the "General
	Area").  That means having the Chair appointed by, and
	serving at the pleasure of, the IETF Chair, the IETF
	Chair making decisions about what WG decisions get
	processed by the IESG, etc.
	
	(2) Some people are deeply concerned about this, seeing
	the IESG as the problem and resistant to reform and the
	IESG generally, and perhaps the Chair in particular, as
	subject to inherent conflicts of interest in a reform
	process.   Many of them lean toward an ISOC-controlled
	process.
	
	(3) Some (perhaps very few) of us are more trustful of
	the IESG as a group, but are uncomfortable about the
	General Area, the notion of the IETF Chair wearing this
	hat in addition to all of the others, and the
	implications the first approach causes with the appeals
	process.  We also don't see an ISOC-based approach as
	really being feasible.

So, again, at least as something to think about, I suggest a 
fourth option:  We ask the IESG to expeditiously create a new, 
but temporary, area for process review and reform, with, say, a 
one-year expiration period requiring community assent to keep it 
going any longer.  We ask the Nomcom to select an AD for that 
area, again asking them to expedite the action.  The IESG 
appoints one of its number (with the Chair/ General Area AD 
being the obvious choice since the workload would be the same as 
under option (1)) to fill in during the interim.

What does this do for us?

	* Like the ISOC plan, it puts someone in as "responsible
	AD" for this work who is selected/ designated for the
	purpose and who is not part of the existing IESG.  The
	reduces suspicions about conflicts of interest.  And...
	
	* It also reduces concerns about available skill sets
	(since the Nomcom would be selecting someone
	specifically for this role) and time availability (since
	the chosen AD would have no other WG or external
	responsibilities).
	
	* It is very much part of the existing process model,
	doesn't raise special concerns about appeals, etc.
	
	* And I think we can assume that a person who was
	designated as responsible for this area would raise a
	public outcry --if necessary to the point of filing
	recall petitions-- if any of the blocking actions of
	which the IESG has been accused occurred wrt the outputs
	these relevant WGs.   Indeed, if I were to advise the
	Nomcom, I would suggest that willingness to go that far
	--and good sense about when or whether to do so-- would
	be an important criterion for a prospective candidate.

And, to preempt any paranoid speculations, I don't want the job.

       john

---

From: Keith Moore <[email-masked]>
Date: Sun, 18 May 2003 12:31:31 -0400

I think John's proposal is a reasonable way to proceed.   It is as fair 
and impartial as we can hope to be, and it gets us past this issue so 
we can actually start to do the work.

Keith

---

From: "Jeanette Hofmann" <[email-masked]>
Date: Sun, 18 May 2003 19:36:31 +0200

On 18 May 2003 at 10:51, John C Klensin wrote:

John, your fourth option sounds like a very good solution to me. For principle 
reasons, the IESG should rather not lead the reform process. Even if the 
IESG members in general, and the General Area AD in particular, are wise, 
experienced and diplomatic enough to lead this process in a neutral way, a 
new AD selected specifically for this purpose would provide for a  cleaner 
mechanism, which gave less reason for suspicion. 

Jeanette

---

From: Dave Crocker <[email-masked]>
Date: Sun, 18 May 2003 12:41:55 -0700

John,

JCK> fourth option:  We ask the IESG to expeditiously create a new,
JCK> but temporary, area for process review and reform, with, say, a 
JCK> one-year expiration period requiring community assent to keep it 
JCK> going any longer.

very creative.

I like it a lot.

d/
--
 Dave Crocker <mailto:[email-masked]>
 Brandenburg InternetWorking <http://www.brandenburg.com>
 Sunnyvale, CA  USA <tel:+1.408.246.8253>, <fax:+1.866.358.5301>

---

From: Margaret Wasserman <[email-masked]>
Date: Sun, 18 May 2003 20:55:40 -0400

Hi John,

First, a point of clarification...

The current process document suggests two WGs:

         - A long-term WG to work on IETF organization
                 and standards-track process.
         - A near-term WG to focus on iterative
                 improvements to WG quality processes.

Would your proposal apply to both WGs?  Would it apply to other
ongoing process-oriented WGs, such as the nomcom WG?

At 10:51 AM 5/18/2003 -0400, John C Klensin wrote:
>Margaret, I'd like to propose something as a strawman, partially based on 
>further thought after my comments about process yesterday.  This is a 
>radical suggestion and may not be a good idea, but I'd like to see if it 
>resonates with others or at least stimulates some discussion and other 
>suggestions.

I think that this is an interesting suggestion.  It may present
a reasonable compromise between the people who would demand
that an "outsider" (i.e. someone who isn't a current I*
member) oversee this process, and those who would insist on
keeping control of the IETF's process definition inside the
IETF.

Honestly, I don't know enough about the IETF Chair's work load
to know if serving as the responsible AD for these WGs would
present an overloading problem for the IETF chair, and I would
trust the IETF chair to run this process both fairly and
openly, but I do understand that having the IETF chair serve
as a responsible AD effectively removes one step in the appeals
process (since responsible AD == IETF chair), which isn't
great.

>         process.  We also don't see an ISOC-based approach as

I don't really fall into this area -- I'm trust the IESG
both individually and as a group.  However, I consider your
alternative _much_ better than the ISOC-driven approach.

>So, again, at least as something to think about, I suggest a fourth 
>option:  We ask the IESG to expeditiously create a new, but temporary, 
>area for process review and reform, with, say, a one-year expiration 
>period requiring community assent to keep it going any longer.  We ask the 
>Nomcom to select an AD for that area, again asking them to expedite the 
>action.  The IESG appoints one of its number (with the Chair/ General Area 
>AD being the obvious choice since the workload would be the same as under 
>option (1)) to fill in during the interim.

In general, this looks like a workable proposal to me. I'm not
sure that your approach is necessary, but I also don't have
any serious objections to it.

I am not sure about the one year period -- I think that two years
is a better initial period, given the scope of this work, perhaps
with one year extensions after that?  We also might want to
consider something like a ~1-1/2 year initial term to sync up
the renewals with the regular nomcom cycle.

Would this person serve like a regular member of the IESG in
other respects (i.e. attend IESG meetings, review documents, etc.)?

I've been told that there are already some problems with the
size of the IESG -- too many people for certain types of
decision making.  How bad is this problem?  And how much
would it affect the group to add one more IESG member?

[...]
>         doesn't raise special concerns about appeals, etc.

This is very important.  Inventing a new process, or
making major modifications to an existing process, just for
one or two WGs seems like a very bad idea.

>And, to preempt any paranoid speculations, I don't want the job.

...which might be an important qualification ;-).

Margaret

---

From: John C Klensin <[email-masked]>
Date: Sun, 18 May 2003 21:26:17 -0400

> ongoing process-oriented WGs, such as the nomcom WG?

I believe that current procedure leaves the decision as to which 
WGs to assign to a particular area in the hands of the IESG.  I 
don't see any reason to change that.  From my point of view, 
this special/temporary area should be a "normal" as possible and 
should not require exceptional procedures.  I do assume that the 
community would form opinions about the IESG -- opinions that 
might potentially alter the results of the problem-statement WG 
-- but the community is free to form such opinions about 
unrelated WG assignments and other IESG actions as well.

That is, I guess, my advice to this WG if the WG wants to make 
that "temporary area" recommendation to the IESG: assignment of 
WGs to areas is an IESG responsibility, not something that is 
appropriately micromanaged from the bottom up.

If I were advising the IESG on the subject, I would suggest to 
them that this area get all of the process-related activities 
now assigned to (and being contemplated in/for) the General 
Area, include both of the above, problem-statement, IPR, nomcom 
and any other vestiges of Poission,  and, if they determine that 
it should involve a WG or BOF, rather than just a Last Call, any 
review efforts on the IESG Charter or related documents.  I 
would also suggest to them that, if they retained some of these 
WGs in the General Area or elsewhere --which I believe they 
should continue to have the perfect right to do-- a brief 
explanation to the community would be courteous and appropriate.

regards,
    john

---

From: "James Kempf" <[email-masked]>
Date: Mon, 19 May 2003 08:05:38 -0700

John,

I like this idea. We should kick it around a little to see if anybody
comes up with any potential unintended consequences, but I can't think
of any.
            jak