Subject: RE: OPEN ISSUE: Quality Process WG Charter

From: <[email-masked]>
Date: Thu, 15 May 2003 18:57:20 +0300

Hi Margaret,

> >A working group should be formed in the General Area of the IETF to
> >oversee improvements to the quality processes used in IETF WGs, and
> >to increase the effectiveness of IETF reviews at all levels.  This
> >group should take an experimental, iterative approach to these
> >improvements:
> 
> [...]
> 
> >     [OPEN ISSUE: Should the Problem Statement WG propose a charter for
> >     this group, or leave that to the General AD and selected chair(s)?]
> 
> 
> I think that developing a charter for this group should be
> done by the ADs and chair(s), probably through the normal
> BOF process.

I agree with you on this.

John

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 15 May 2003 22:40:06 +0200

> I agree with you on this.

timing issue.....

is the creation of the Quality WG dependent on IETF consensus on the 
Problem and Process documentson this WG?
If yes - the WG cannot be started until after Vienna.
If no - the WG process can be started as soon as there appears to be 
reasonable consensus that the WG should be formed. It seems reasonable to 
expect that the WG could start before this WG produces its final output.

identity issue....

is this WG in parallel to, in cooperation with, or orthogonal to, the 
proposal to form a WG (that is, an activity with a charter) focusing on 
training/education/leader development for the IETF?

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 16 May 2003 04:57:23 -0400

Hi Harald,

>expect that the WG could start before this WG produces its final output.

IMO, we should start the near-term efforts described in this document
(all four of them) as soon as there is community consensus to start
them.  In fact, at least two of them are already underway.

I don't think that the problem-statement group should cause a delay
in our efforts to improve outselves.

>training/education/leader development for the IETF?

There are four near-term efforts identified in the document that
can proceed immediately and in parallel:

         - WG quality processes (the WG you're talking about).
         - Training/Education (this is only defined as an
                 "effort" in the document, not explicitly as
                 a WG -- that discussion didn't start until
                 after I published the document).
         - Identifying/deploying tools for issue tracking and
                 document revision control.
         - Promoting/increasing communication between WG chairs.

Hopefully all of the near-term efforts will spin-up while we are
still trying to define and start the longer-term effort which
will:

         - Improve the scalability and effectiveness of the
                 management structure of the IETF (i.e.
                 reorganize).
         - Update the standards-track document processes to
                 be more effective and timely.

If you've read the document carefully and this is unclear, please
let me know, so that I can attempt to make it clearer.

Thanks,
Margaret

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 May 2003 15:05:42 +0200

> I agree with you on this.

ditto
   Brian

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 29 May 2003 07:25:14 -0400

So, do we have consensus to start the near-term WG to
improve the WG quality processes and IETF review
processes?

Several people agreed with the idea, folks seemed to
think that we should use the normal IETF process to
start this effort, and we have at least one proposal
on the table that could be considered (SIRs).  So,
is it worth holding a BOF to determine if we have
IETF consensus to start this work?

If so, has anyone proposed a BOF on this subject for
Vienna?

It would be great to see some work start up in this
area.  How can I help?

Margaret

---

From: Keith Moore <[email-masked]>
Date: Thu, 29 May 2003 09:04:54 -0400

> improve the WG quality processes and IETF review

I fear that if we do this, the WG will spend too much time on review processes
and not enough time on WG operation.  But I'm not sure what to do about it:
both subjects need attention, and if we created two separate WGs then the one
working on extra-WG review might attract a lot more interest than the one
working on WG operation.

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 29 May 2003 09:11:17 -0400

I don't believe that adding extra review at the end of
the WG process will improve anything...

We need to establish some quality processes to be used
during WG document production that will include (among
other things) appropriately scoped reviews of documents
at specific milestones.  So, I don't see these two
concepts (WG processes and review processes) as
separable.

Margaret

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 29 May 2003 15:23:16 +0200

--On torsdag, mai 29, 2003 09:04:54 -0400 Keith Moore <[email-masked]> 
wrote:

> I fear that if we do this, the WG will spend too much time on review
> processes and not enough time on WG operation.  But I'm not sure what to
> do about it: both subjects need attention, and if we created two separate
> WGs then the one working on extra-WG review might attract a lot more
> interest than the one working on WG operation.

I think this WG would/should be focused on the WG process, and review as 
one tool to improve that process.
This should not be confused with the issues surrounding end-of-line IESG 
review (although one hopes that improving one would make the other far less 
problematic).

My understanding....

               Harald

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 29 May 2003 09:22:23 -0400

>one tool to improve that process.

Sold.

So, Harald, do you know if there is any effort underway to
actually _start_ this WG?  Any hope for a BOF in Vienna?

Margaret

---

From: Keith Moore <[email-masked]>
Date: Thu, 29 May 2003 09:28:15 -0400

> the WG process will improve anything...

agree with that.  by "extra-WG review" I meant review from outside of the WG,
i.e. I was separating what goes on within a WG from what goes on outside of the
WG...and lumping IESG in with the latter.  and if the intention is to create
a WG that looks at how WGs operate, I'm generally in favor of that.

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 29 May 2003 09:34:52 -0400

>a WG that looks at how WGs operate, I'm generally in favor of that.

Well, this was _my_ intention when I wrote the process
document...  If that wasn't clear to you, though, maybe
my document needs to be clarified?

The purpose of this WG would be to improve the quality
processes (including review process) used by WGs, with
the goals of increasing the quality, timeliness and
predictability of WG output.

Margaret

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 29 May 2003 16:01:24 +0200

> actually _start_ this WG?  Any hope for a BOF in Vienna?

as far as I know, the line of volunteers is completely empty.... but the 
deadline for scheduling BOFs in Vienna is not yet over (the scheduling 
officially closes on June 20).

              Harald

---

From: "James Kempf" <[email-masked]>
Date: Thu, 29 May 2003 08:45:15 -0700

Agree.

            jak

----- Original Message -----
From: "Harald Tveit Alvestrand" <[email-masked]>
To: "Keith Moore" <[email-masked]>; "Margaret Wasserman"
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, May 29, 2003 6:23 AM
Subject: Re: OPEN ISSUE: Quality Process WG Charter

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 29 May 2003 12:28:50 -0400

Well, if we're going to try to put a BOF together for Vienna,
we better start soon...

The scheduling cut-off is looming, and it would also be good for
people to have time to get proposals/ideas documented before the
-00 I-D cut-off on June 23rd.

Who has cycles and would be willing to help?

Margaret

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 29 May 2003 13:56:19 -0500

Dear Harald,

Ouch!

My understanding was that we were thinking "request NOMCOM to provide
co-chairs
for the WG". I guess I assumed this would happen before Vienna.

Are you requesting volunteers (or, more likely, nominees) to chair a BoF in
Vienna?

Spencer

----- Original Message -----
From: "Harald Tveit Alvestrand" <[email-masked]>
To: "Margaret Wasserman" <[email-masked]>;
<[email-masked]>
Sent: Thursday, May 29, 2003 9:01 AM
Subject: Re: OPEN ISSUE: Quality Process WG Charter

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 29 May 2003 15:01:48 -0400

Hi Spencer,

There is no suggestion in our process document that the nomcom
should choose the chairs for the near-term WG to improve the
quality processes used by WGs.  That is the WG we are discussing
here...

The problem-statement did list an open issue about how the
charter for this WG should be determined.  I proposed that
the charter should be determined by the AD and chairs, probably
through the normal BOF process.  Several people agreed, and
no one disagreed.

The usual BOF process typically involves someone (or a group
of people) proposing a BOF to the relevant AD (in this case,
Harald).

There is a suggestion that the nomcom (or a similar mechanism)
could be used to choose chairs for the longer-term
Improvement WG -- the one that will start by determining
our mission/values/goals...  There are still a lot of open
question about how that longer term group will be managed,
chartered, etc.

Does this clear up your issue, or are you concerned that we
may not be ready to hold a BOF for the near-term WG?

Margaret

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 29 May 2003 14:34:37 -0500

Dear Margaret,

Ah, I see - I WAS confused.

Thanks,

Spencer

----- Original Message -----
From: "Margaret Wasserman" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, May 29, 2003 2:01 PM
Subject: Re: OPEN ISSUE: Quality Process WG Charter

> > > >> I think this WG would/should be focused on the WG process, and
review
> >as