Subject: [pm-dir] Performance Metrics Directorate is getting popular

From: Benoit Claise <[email-masked]>
Date: Wed, 10 Apr 2013 15:56:39 +0200

Dear directorate,

>From 
https://docs.google.com/spreadsheet/ccc?key=0AmKrqWIOBsprdGZqMnB6dmx5bFJvVUhta3VLSjl3SkE#gid=0 
(which I updated a little right now), we would still need 2 volunteers for
     - draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-05
     - draft-ietf-xrblock-rtcp-xr-discard-11

Regards, Benoit

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 10 Apr 2013 14:21:16 +0000

Benoit,

Are reviews supposed to be also sent to [email-masked]? I do not believe
I have seen the ones that show as "Sent".

Thanks,

-- Carlos.

On 4/10/13 9:56 AM, "Benoit Claise (bclaise)" <[email-masked]> wrote:

>_______________________________________________
>pm-dir mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pm-dir
>

---

From: Benoit Claise <[email-masked]>
Date: Wed, 10 Apr 2013 17:44:36 +0200

Carlos,

Good question: where to send the reviews?
I propose that we apply the rule similar the one in the OPS directorate 
and MIB doctors.
So

    Send your review to the performance metrics directorate mailing list
    ([email-masked] <mailto:[email-masked]>) and to the authors, WG
    chairs, and respective AD.
    The way to reach the authors, WG chairs, and respective AD is to
    send an email to <draft-name>[email-masked]
    <mailto:[email-masked]>

We could add this to our page 
http://www.ietf.org/iesg/directorate/performance-metrics.html

Regards, Benoit

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 11 Apr 2013 14:55:10 +0000

PM-dir'ers

I was very relieved when RFC 6815 was finally published, since we finally convinced had a document
that clearly stated that measuring throughput of operational networks as if they were devices on a workbench was a bad idea.

I must have been sleeping to have missed it, but now I discovered the draft mentioned in the subject line,
which is attempting to bring back 2544 for operational networks, without addressing the main reason that it is such a bad idea.

Not only is this draft not aligned with IPPM work since the original 2544,
but also it rehashes the RFC 2544 method of blasting the network at physical line speed for a long time
instead of proposing the use of any of the modern mechanisms that discover throughput with minimum impact on the network
(e.g., MOSEAB, FORECASTER, etc).

Needless to say it doesn't consider the impact of such blasting without TCP-friendliness on neighboring TCP flows,
nor of dimming the lights in the entire neighborhood.

I think this is a draft that the PM directorate needs to discuss.

Y(J)S

---

From: "MORTON JR., ALFRED C (AL)" <[email-masked]>
Date: Thu, 11 Apr 2013 12:48:50 -0400

Hi Yaakov, (sorry for the rant, but there's some history here)

Glad to hear you were relieved when http://tools.ietf.org/html/rfc6815
was approved and published. So were all the authors and Ron Bonica,
who saw this through a very difficult IESG review. Stewart Bryant
held a DISCUSS for months, and in the end Ron brokered a deal where
Ron and Stewart would write the draft you found, and Stewart would
clear his DISCUSS. It was exasperating. Stewart's nit-picking technical
commentary was motivated only by ego and narrow-interest (pseudo-wires) IMO,
precipitating his desire to block the draft or cripple its message
though he was/is no more than a tourist in this area. Before we were done,
MEF and ITU-T SG15 accepted the message that Stewart could not.

Part of the deal Ron brokered was that some OPS wg would pick-up and
work this draft, but that has not happened and it doesn't seem likely
to happen.

IETF processes will send this draft to expiration in a couple of weeks,
http://tools.ietf.org/html/draft-bb-2544like-production-tests-00
and I suggest we simply let that happen. If it's brought back to life
and reviewed in any working group, then we should assign a reviewer
or two and let the comments fall where they may.  Preferably, no progress
will take place while Stewart is still on the IESG.

Al

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Thursday, April 11, 2013 10:55 AM
To: [email-masked]
Subject: [pm-dir] draft-bb-2544like-production-tests

PM-dir'ers

Y(J)S

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 18 Apr 2013 15:40:18 +0000

Al,

As one of the fathers of pseudowires and a long time personal friend of Stewart, I can almost understand his desires.
This has nothing to do with pseudowires (which have no QoS features at all), but rather of MPLS-TE.
Had they said something about such testing only being carried out when there is hard policing of the throughput,
then I could have understood. But since this is a minority case, I believe that this draft needs to be considered harmful.

Anyway, I am willing to play along as you suggest.
If it is re-opened, I volunteer to perform a review...

Y(J)S

From: MORTON JR., ALFRED C (AL) [mailto:[email-masked]]
Sent: 11 April, 2013 19:49
To: Yaakov Stein; [email-masked]
Subject: RE: draft-bb-2544like-production-tests

Al

PM-dir'ers

Y(J)S

---

From: "MORTON JR., ALFRED C (AL)" <[email-masked]>
Date: Thu, 18 Apr 2013 12:26:28 -0400

Thanks for your consideration and agreement, Yaakov.
Al

From: Yaakov Stein [mailto:[email-masked]]
Sent: Thursday, April 18, 2013 11:40 AM
To: MORTON JR., ALFRED C (AL); [email-masked]
Subject: RE: draft-bb-2544like-production-tests

Al,

Y(J)S

Al

PM-dir'ers

Y(J)S