Subject: [payload] draft-ietf-payload-rtp-ancillary-07: Comments on header layout

From: Kjetil Oftedal <[email-masked]>
Date: Tue, 14 Mar 2017 00:01:00 +0100

Hi,

I have earlier commented upon the size of the line number/offset fields and
their counterparts in RFC4175, and with the latest changes to the ANC RTP
layout an new opportunity to address this has arrived.

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|C|   Line_Number       |   Horizontal_Offset   |    reserved   |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Moving some of the reserved bits and aligning to the 16-bit boundary will both
make it easier for software to build the header, and will
allow these Line_Number/Horizontal_Offset fields to easily be expanded in the
future if the need for ANC transport with higher resolution images should
arise:

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|C| rsvd  |     Line_Number     | rsvd  |   Horizontal_Offset   |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

The only issue is handling the special value cases such as 0xFFF/0xFFE,
Expanding the fields to 15-bits at this time would maybe just be easier,
as there is no bandwidth penalty of doing so.

Best regards,
Kjetil Oftedal

---

From: Thomas Edwards <[email-masked]>
Date: Wed, 29 Mar 2017 03:18:20 +0000

Unfortunately, I think we have too many working implementations now based on the draft-ietf-payload-rtp-ancillary-07 to make a change like this that breaks existing code.  It would invalidate the work of the Joint Task Force on Networked Media interop event.  The goal is that the -08 revision would be backwards compatible with -07.

-Thomas

-- 
Thomas Edwards 
VP Engineering & Development
FOX Networks Engineering and Operations
[email-masked]
Phone: +1.310.369.6696
10201 West Pico Blvd.
Los Angeles, CA 90035

On 3/13/17, 4:01 PM, "payload on behalf of Kjetil Oftedal" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    

    
    Best regards,
    Kjetil Oftedal
    
    _______________________________________________
    payload mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_payload&d=DwICAg&c=uw6TLu4hwhHdiGJOgwcWD4AjKQx6zvFcGEsbfiY9-EI&r=lekNOOM5noV61zrPH3rwPyhtNnLLWoLEHgd0quQxly8&m=GekN5chRhz0WLf7WrPw08CEQd4tCW-_ZV01rcvLe7A4&s=fY_InbtX874voLEkB9cpscbnyKgFPON7RhUvJvKu-lg&e=