Subject: [payload] draft-ietf-payload-rtp-ancillary-08 info

From: Thomas Edwards <[email-masked]>
Date: Wed, 29 Mar 2017 03:58:33 +0000

I have submitted draft-ietf-payload-rtp-ancillary-08.

The changes to this version were based on feedback after the Joint Task Force on Network Media (http://jt-nm.org) interop held last month in Houston, TX.

Most changes are editorial, or requested clarifications to -07.

But there is one I’d call a “substantial” change.  This an addition of two field bits (F) carved out of former reserved bits to optionally identify the field in interlaced signal interfaces.  This is done in a backwards compatible way with -07. If a -07 sender properly filled in those (F) bits with ‘00’, the field bits are not considered to carry additional information.  Only if the first bit is a ‘1’ would the second bit indicate the first or second interlaced field.

I will mention that we expect a substantial number of professional broadcast vendors to be demonstrating interoperability of this RTP payload type at NAB 2017 in Las Vegas April 24-27 at the IP Showcase:

http://www.nabshow.com/show-floor/attractions-pavilions/ip-showcase

Thanks to everyone who has contributed to this effort, I believe we can see the light at the end of the tunnel now!

-Thomas

--
Thomas Edwards
VP Engineering & Development
FOX Networks Engineering and Operations
[email-masked]
Phone: +1.310.369.6696
10201 West Pico Blvd.
Los Angeles, CA 90035

---

From: Kjetil Oftedal <[email-masked]>
Date: Wed, 29 Mar 2017 08:05:21 +0200

On 29/03/2017, Thomas Edwards <[email-masked]> wrote:
> ,..
> But there is one I’d call a “substantial” change.  This an addition of two
> field bits (F) carved out of former reserved bits to optionally identify the
> field in interlaced signal interfaces.  This is done in a backwards
> compatible way with -07. If a -07 sender properly filled in those (F) bits
> with ‘00’, the field bits are not considered to carry additional
> information.  Only if the first bit is a ‘1’ would the second bit indicate
> the first or second interlaced field.
> ...

This change, due to the placement of the field bits, indirectly adds a
requirement
that all ANC packets within a RTP frame is from the same video field,
as it is not possible to specify the field bits per ANC packet.

This was not a requirement earlier, and for interlaced the field
polarity could be
discovered from the Line_Number field.

I believe this should at least be clarified in the RFC that it is now required
that all ANC packets in a RTP frame are from the same video field.

Best regards,
Kjetil Oftedal

---

From: Thomas Edwards <[email-masked]>
Date: Wed, 29 Mar 2017 06:10:39 +0000

Since draft-ietf-payload-rtp-ancillary- 00 the requirement has been:

“RTP packets MUST NOT include ANC data from multiple fields, and all RTP packets belonging to the same field MUST have the same timestamp.”

-Thomas

On 3/28/17, 11:05 PM, "Kjetil Oftedal" <[email-masked]> wrote:

    

    Best regards,
    Kjetil Oftedal