Subject: Re: [payload] WGLC for VP8 Payload

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 6 Dec 2012 02:20:57 +0000

I have not seen any comments on the list. Please review the draft and post
your comments on the list.

Thanks.
-acbegen

-----Original Message-----
From: "Ali C. Begen" <[email-masked]>
Date: Monday, November 19, 2012 3:15 PM
To: "[email-masked]" <[email-masked]>
Subject: [payload] WGLC for VP8 Payload

>Hi everyone,
>
>We had a WGLC for this draft earlier this year and there have been a few
>updates to the document. I am starting a 2nd WGLC. Please review and
>comment on the list by December 10th.
>
>https://datatracker.ietf.org/doc/draft-ietf-payload-vp8/?include_text=1
>
>
>-acbegen
>
>_______________________________________________
>payload mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/payload

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 10 Dec 2012 17:36:25 +0000

I have not seen any comments on the list. There were some issues raised in
the previous call. I am assuming all parties are happy with the current
version.

I will prepare the document write-up.

-acbegen

---

From: Tom Harper <[email-masked]>
Date: Mon, 10 Dec 2012 12:39:25 -0800

> I will prepare the document write-up.

Hi,

I have no further feedback at this time- it seems that all of the concerns
from before have been addressed, and we are working with the current draft
version.

Thanks!

Tom

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 11 Dec 2012 14:33:02 +0100

> I will prepare the document write-up.
Thank you. I'm looking forward to closing off this item.

---

From: Jonathan Lennox <[email-masked]>
Date: Tue, 11 Dec 2012 11:49:05 -0500

Hi -- I have two comments on this draft.  Sorry for being late.

First of all, an editorial matter: Section 6 says the format has no parameters, but section 6.1 lists two optional parameters (max-fr and max-fs).

Secondly, more substantively, I note that the payload format's rules on KEYIDX and TL0PICIDX impose a fair bit of overhead on boxes that wish to splice together VP8 streams, since both values are required to always increment consecutively in a bitstream (if they're being used).

By contrast, the equivalent fields of the H.264 SVC payload format (in the PACSI) just say that IDRPICID must be different in consecutive IDR frames, without requiring that the value increment by 1; and TL0PICIDX resets to 0 on every IDR frame, rather than carrying on continuously.  (H.264's IDR frames are analogous for these purposes to VP8's essential keyframes).

This means that an H.264 SVC splicer -- as long as it doesn't get unlucky, such that the two streams it's splicing happen to have identical IDRPICID values at the splice point -- can just transition from one bitstream to another at any IDR frame.

By contrast, following a splice, a VP8 splicer must re-write both these fields for the rest of the lifetime of the stream, since they each have only one valid possible value following the splice.

The VP8 payload format's decision is a reasonable design choice -- as compared to the H.264 SVC rules, it removes some ambiguity between splice points and packet loss, giving decoders somewhat greater visibility as to what's going on in the bitstream, and also allows TL0PICIDX and KEYIDX to be orthogonal options because they increment independently.  However, I wanted to make sure this had been considered explicitly by the working group, and we had consensus that it was the right decision.

(Note well disclaimer: Vidyo has an IPR declaration against the VP8 payload -- see <http://tracker.tools.ietf.org/ipr/1622/>.)

--
Jonathan Lennox
[email-masked]

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 12 Dec 2012 00:13:19 +0000

The first one should be fixed by the authors thru a quick revision. As for
the second one, I will ask the authors reply. Also if there are others who
strongly think one way or another, lets discuss it.

Jonathan, are you ok if the authors simply acknowledge this in the draft
(assuming they agree with you) or do you actually not like this at all?

-acbegen

-----Original Message-----
From: Jonathan Lennox <[email-masked]>
Date: Tuesday, December 11, 2012 11:49 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [payload] WGLC for VP8 Payload

>First of all, an editorial matter: Section 6 says the format has no
>parameters, but section 6.1 lists two optional parameters (max-fr and
>max-fs).
>
>
>Secondly, more substantively, I note that the payload format's rules on
>KEYIDX and TL0PICIDX impose a fair bit of overhead on boxes that wish to
>splice together VP8 streams, since both values are required to always
>increment consecutively in a bitstream (if they're being used).
>
>By contrast, the equivalent fields of the H.264 SVC payload format (in
>the PACSI) just say that IDRPICID must be different in consecutive IDR
>frames, without requiring that the value increment by 1; and TL0PICIDX
>resets to 0 on every IDR frame, rather than carrying on continuously.
>(H.264's IDR frames are analogous for these purposes to VP8's essential
>keyframes).
>
>This means that an H.264 SVC splicer -- as long as it doesn't get
>unlucky, such that the two streams it's splicing happen to have identical
>IDRPICID values at the splice point -- can just transition from one
>bitstream to another at any IDR frame.
>
>By contrast, following a splice, a VP8 splicer must re-write both these
>fields for the rest of the lifetime of the stream, since they each have
>only one valid possible value following the splice.
>
>The VP8 payload format's decision is a reasonable design choice -- as
>compared to the H.264 SVC rules, it removes some ambiguity between splice
>points and packet loss, giving decoders somewhat greater visibility as to
>what's going on in the bitstream, and also allows TL0PICIDX and KEYIDX to
>be orthogonal options because they increment independently.  However, I
>wanted to make sure this had been considered explicitly by the working
>group, and we had consensus that it was the right decision.
>
>(Note well disclaimer: Vidyo has an IPR declaration against the VP8
>payload -- see <http://tracker.tools.ietf.org/ipr/1622/>.)
>
>

---

From: Jonathan Lennox <[email-masked]>
Date: Thu, 13 Dec 2012 11:29:07 -0500

Hi, Ali --

I just wanted to make sure the issue had been considered; if the WG agrees that the current design is okay given the limitations I've mentioned, I'm not going to object.

Discussion of the issue might be helpful in the document.

-----Original Message-----
From: Ali C. Begen (abegen) [mailto:[email-masked]] 
Sent: Tuesday, December 11, 2012 7:13 PM
To: Jonathan Lennox; [email-masked]
Cc: [email-masked]
Subject: Re: [payload] WGLC for VP8 Payload

The first one should be fixed by the authors thru a quick revision. As for the second one, I will ask the authors reply. Also if there are others who strongly think one way or another, lets discuss it.

Jonathan, are you ok if the authors simply acknowledge this in the draft (assuming they agree with you) or do you actually not like this at all?

-acbegen

-----Original Message-----
From: Jonathan Lennox <[email-masked]>
Date: Tuesday, December 11, 2012 11:49 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [payload] WGLC for VP8 Payload

>KEYIDX and TL0PICIDX impose a fair bit of overhead on boxes that wish 
>to splice together VP8 streams, since both values are required to 
>always increment consecutively in a bitstream (if they're being used).
>
>unlucky, such that the two streams it's splicing happen to have 
>identical IDRPICID values at the splice point -- can just transition 
>from one bitstream to another at any IDR frame.
>
>compared to the H.264 SVC rules, it removes some ambiguity between 
>splice points and packet loss, giving decoders somewhat greater 
>visibility as to what's going on in the bitstream, and also allows 
>TL0PICIDX and KEYIDX to be orthogonal options because they increment 
>independently.  However, I wanted to make sure this had been considered 
>explicitly by the working group, and we had consensus that it was the right decision.
>
>> I have not seen any comments on the list. Please review the draft and 
>>post  your comments on the list.
>> 
>> Thanks.
>> -acbegen
>> 
>>> We had a WGLC for this draft earlier this year and there have been a 
>>>few  updates to the document. I am starting a 2nd WGLC. Please review 
>>>and  comment on the list by December 10th.
>>>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 13 Dec 2012 16:55:41 +0000

Thanks, the authors just rev'ed the draft to fix the first issue. I hope
they will address the second issue first in the list and then reflect the
agreement in the next revision. I will hold on to the doc write-up till
then.

-acbegen

-----Original Message-----
From: Jonathan Lennox <[email-masked]>
Date: Thursday, December 13, 2012 11:29 AM
To: "Ali C. Begen" <[email-masked]>, "[email-masked]"
<[email-masked]>
Cc: "[email-masked]"
<[email-masked]>
Subject: RE: [payload] WGLC for VP8 Payload

>Hi, Ali --
>
>I just wanted to make sure the issue had been considered; if the WG
>agrees that the current design is okay given the limitations I've
>mentioned, I'm not going to object.
>
>The first one should be fixed by the authors thru a quick revision. As
>for the second one, I will ask the authors reply. Also if there are
>others who strongly think one way or another, lets discuss it.
>

---

From: Patrik Westin <[email-masked]>
Date: Thu, 13 Dec 2012 08:57:17 -0800

Thanks for pointing out the inconsistency. We've submitted a new
draft that fixes that problem.

The second issue was intentional. We'll keep it this way.

On Thu, Dec 13, 2012 at 8:29 AM, Jonathan Lennox <[email-masked]> wrote:

> Hi, Ali --
>
> I just wanted to make sure the issue had been considered; if the WG agrees
> that the current design is okay given the limitations I've mentioned, I'm
> not going to object.
>

---

From: Patrik Westin <[email-masked]>
Date: Fri, 14 Dec 2012 13:53:10 -0800

Trying to send this again since my previous message did not reach the list.

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 14 Dec 2012 22:30:19 +0000

Are you at least planning to put some text around the point Jonathan brought up?

From: Patrik Westin <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 14, 2012 4:53 PM
To: "Ali C. Begen" <[email-masked]<mailto:[email-masked]>>
Cc: Jonathan Lennox <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [payload] WGLC for VP8 Payload

On Thu, Dec 13, 2012 at 8:55 AM, Ali C. Begen (abegen) <[email-masked]<mailto:[email-masked]>> wrote:
Thanks, the authors just rev'ed the draft to fix the first issue. I hope
they will address the second issue first in the list and then reflect the
agreement in the next revision. I will hold on to the doc write-up till
then.

-acbegen

-----Original Message-----
From: Jonathan Lennox <[email-masked]<mailto:[email-masked]>>
Date: Thursday, December 13, 2012 11:29 AM
To: "Ali C. Begen" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>"
<[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>"
<[email-masked]<mailto:[email-masked]>>
Subject: RE: [payload] WGLC for VP8 Payload

>From: Ali C. Begen (abegen) [mailto:[email-masked]<mailto:[email-masked]>]
>To: Jonathan Lennox; [email-masked]<mailto:[email-masked]>
>Cc: [email-masked]<mailto:[email-masked]>
>From: Jonathan Lennox <[email-masked]<mailto:[email-masked]>>
>To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
>>> From: "Ali C. Begen" <[email-masked]<mailto:[email-masked]>>
>>> To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
>>[email-masked]<mailto:[email-masked]>
>>
>>
>>[email-masked]<mailto:[email-masked]>

_______________________________________________
payload mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/payload

---

From: Patrik Westin <[email-masked]>
Date: Fri, 14 Dec 2012 14:46:49 -0800

Well he did not have a point in my mind. This is what he wrote.

"The VP8 payload format's decision is a reasonable design choice -- as
compared to the H.264 SVC rules, it removes some ambiguity between splice
points and packet loss, giving decoders somewhat greater visibility as to
what's going on in the bitstream, and also allows TL0PICIDX and KEYIDX to
be orthogonal options because they increment independently."

The worst thing that can happen in a draft is to leave ambiguity, which we
don't have in the current draft. However if we do it the way H.264 SVC do
we could introduce such ambiguity

On Fri, Dec 14, 2012 at 2:30 PM, Ali C. Begen (abegen) <[email-masked]>wrote:

>   From: Patrik Westin <[email-masked]>
> Reply-To: "[email-masked]" <[email-masked]>
> To: "Ali C. Begen" <[email-masked]>
> Cc: Jonathan Lennox <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>
>

---

From: Jonathan Lennox <[email-masked]>
Date: Fri, 14 Dec 2012 17:55:27 -0500

What I think Ali meant was to add some text describing the implications of this design choice for splicers - i.e., if these features are in use, they must re-write packets indefinitely following a splice.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Patrik Westin
Sent: Friday, December 14, 2012 5:47 PM
To: Ali C. Begen (abegen)
Cc: Jonathan Lennox; [email-masked]; [email-masked]
Subject: Re: [payload] WGLC for VP8 Payload

"The VP8 payload format's decision is a reasonable design choice -- as compared to the H.264 SVC rules, it removes some ambiguity between splice points and packet loss, giving decoders somewhat greater visibility as to what's going on in the bitstream, and also allows TL0PICIDX and KEYIDX to be orthogonal options because they increment independently."

The worst thing that can happen in a draft is to leave ambiguity, which we don't have in the current draft. However if we do it the way H.264 SVC do we could introduce such ambiguity

On Fri, Dec 14, 2012 at 2:30 PM, Ali C. Begen (abegen) <[email-masked]<mailto:[email-masked]>> wrote:
Are you at least planning to put some text around the point Jonathan brought up?

-acbegen

---

From: Patrik Westin <[email-masked]>
Date: Fri, 14 Dec 2012 15:06:27 -0800

Ali do you really want me to add that to the draft?

On Fri, Dec 14, 2012 at 2:55 PM, Jonathan Lennox <[email-masked]> wrote:

> What I think Ali meant was to add some text describing the implications of
> this design choice for splicers – i.e., if these features are in use, they
> must re-write packets indefinitely following a splice.****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Patrik
> Westin
> *Sent:* Friday, December 14, 2012 5:47 PM
> *To:* Ali C. Begen (abegen)
> *Cc:* Jonathan Lennox; [email-masked];
> [email-masked]
>
> *Subject:* Re: [payload] WGLC for VP8 Payload****
>
> ** **
>
> Well he did not have a point in my mind. This is what he wrote.****
>
> ** **
>
> be orthogonal options because they increment independently."****
>
> ** **
>
> we could introduce such ambiguity****
>
> ** **
>
> On Fri, Dec 14, 2012 at 2:30 PM, Ali C. Begen (abegen) <[email-masked]>
> wrote:****
>
> Are you at least planning to put some text around the point Jonathan
> brought up?****
>
> ** **
>
> *From: *Patrik Westin <[email-masked]>
> *Reply-To: *"[email-masked]" <[email-masked]>
> *Date: *Friday, December 14, 2012 4:53 PM****
>
>
> *To: *"Ali C. Begen" <[email-masked]>****
>
> *Cc: *Jonathan Lennox <[email-masked]>, "[email-masked]" <
> [email-masked]>****
>
>
> *Subject: *Re: [payload] WGLC for VP8 Payload****
>
> ** **
>
> draft that fixes that problem. ****
>
>
> The second issue was intentional. We'll keep it this way.****
>
> ** **
>
> On Thu, Dec 13, 2012 at 8:55 AM, Ali C. Begen (abegen) <[email-masked]>
> wrote:****
>
> then.****
> From: Jonathan Lennox <[email-masked]>****
>
> <[email-masked]>****
>
> https://www.ietf.org/mailman/listinfo/payload****
>
> ** **
>
> ** **
>
> ** **
>
> ** **
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 14 Dec 2012 23:09:20 +0000

Personally (chair-hat off), I think we should. It does not harm anything but provides clarification to someone who is not deep down in every detail.

From: Patrik Westin <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 14, 2012 6:06 PM
To: Jonathan Lennox <[email-masked]<mailto:[email-masked]>>
Cc: "Ali C. Begen" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [payload] WGLC for VP8 Payload

On Fri, Dec 14, 2012 at 2:55 PM, Jonathan Lennox <[email-masked]<mailto:[email-masked]>> wrote:
What I think Ali meant was to add some text describing the implications of this design choice for splicers – i.e., if these features are in use, they must re-write packets indefinitely following a splice.

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Patrik Westin
Sent: Friday, December 14, 2012 5:47 PM
To: Ali C. Begen (abegen)
Cc: Jonathan Lennox; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

-acbegen

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 14 Dec 2012 23:27:08 +0000

Hi,
I'm with Ali here.  The design choice that has been made in the VP8 payload is different from the one in the SVC payload, despite similarity in codepoint names and functionality.  The reasoning for that ought to be documented.  In the SVC payload format, we didn't need to, because we were first in describing something like this :-)
A sentence or two should suffice, along the lines Jonathan proposed.
Stephan

From: "Ali C. Begen (abegen)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, 14 December, 2012 15:09
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Jonathan Lennox <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [payload] WGLC for VP8 Payload

-acbegen

---

From: Glen Zorn <[email-masked]>
Date: Sat, 15 Dec 2012 20:11:15 +0700

On 12/15/2012 06:27 AM, Stephan Wenger wrote:

> Hi, I'm with Ali here.

Me, too.

> The design choice that has been  made in the VP8 payload is different
 > from the one in the SVC payload, despite similarity in codepoint
 > names and functionality. The reasoning for that ought to be
 > documented. In the SVC payload format, we didn't need to, because we
 > were first in describing something like this :-) A sentence or two
 > should suffice, along the lines Jonathan proposed. Stephan
 >
 > From: "Ali C. Begen (abegen)" <[email-masked]
 > <mailto:[email-masked]>> Date: Friday, 14 December, 2012 15:09 To:
 > "[email-masked] <mailto:[email-masked]>" <[email-masked]
 > <mailto:[email-masked]>>, Jonathan Lennox <[email-masked]
 > <mailto:[email-masked]>> Cc:
 > "[email-masked]
 > <mailto:[email-masked]>"
 > <[email-masked]
 > <mailto:[email-masked]>>, "[email-masked]
 > <mailto:[email-masked]>" <[email-masked]
 > <mailto:[email-masked]>> Subject: Re: [payload] WGLC for VP8
 > Payload
 >
 > Personally (chair-hat off), I think we should. It does not harm
 > anything but provides clarification to someone who is not deep down
 > in every detail.
 >
 > From: Patrik Westin <[email-masked] <mailto:[email-masked]>>
 > Reply-To: "[email-masked] <mailto:[email-masked]>"
 > <[email-masked] <mailto:[email-masked]>> Date: Friday,
 > December 14, 2012 6:06 PM To: Jonathan Lennox <[email-masked]
 > <mailto:[email-masked]>> Cc: "Ali C. Begen" <[email-masked]
 > <mailto:[email-masked]>>, "[email-masked]
 > <mailto:[email-masked]>" <[email-masked]
 > <mailto:[email-masked]>>, "[email-masked]
 > <mailto:[email-masked]>"
 > <[email-masked]
 > <mailto:[email-masked]>> Subject: Re:
 > [payload] WGLC for VP8 Payload
 >
 > What I think Ali meant was to add some text describing the
 > implications of this design choice for splicers – i.e., if these
 > features are in use, they must re-write packets indefinitely
 > following a splice.
 >
 >
 >
 > *From:[email-masked] <mailto:[email-masked]>
 > [mailto:[email-masked] <mailto:[email-masked]>] *On Behalf Of
 > *Patrik Westin *Sent:* Friday, December 14, 2012 5:47 PM *To:* Ali C.
 > Begen (abegen) *Cc:* Jonathan Lennox; [email-masked]
 > <mailto:[email-masked]>; [email-masked]
 > <mailto:[email-masked]>
 >
 >
 > *Subject:* Re: [payload] WGLC for VP8 Payload
 >
 >
 >
 > "The VP8 payload format's decision is a reasonable design choice --
 > as compared to the H.264 SVC rules, it removes some ambiguity between
 > independently."
 > The worst thing that can happen in a draft is to leave ambiguity,
 > which we don't have in the current draft. However if we do it the way
 > H.264 SVC do we could introduce such ambiguity
 >
 >
 >
 > On Fri, Dec 14, 2012 at 2:30 PM, Ali C. Begen (abegen)
 > <[email-masked] <mailto:[email-masked]>> wrote:
 >
 > brought up?
 > *From: *Patrik Westin <[email-masked]
 > <mailto:[email-masked]>> *Reply-To: *"[email-masked]
 > <mailto:[email-masked]>" <[email-masked]
 > <mailto:[email-masked]>> *Date: *Friday, December 14, 2012 4:53
 > PM
 >
 >
 > *To: *"Ali C. Begen" <[email-masked] <mailto:[email-masked]>>
 >
 > *Cc: *Jonathan Lennox <[email-masked]
 > <mailto:[email-masked]>>, "[email-masked]
 > <mailto:[email-masked]>" <[email-masked]
 > <mailto:[email-masked]>>, "[email-masked]
 > <mailto:[email-masked]>"
 > <[email-masked]
 > <mailto:[email-masked]>>
 >
 >
 > *Subject: *Re: [payload] WGLC for VP8 Payload
 >
 >
 >
 > On Thu, Dec 13, 2012 at 8:55 AM, Ali C. Begen (abegen)
 > <[email-masked] <mailto:[email-masked]>> wrote:
 >
 > Thanks, the authors just rev'ed the draft to fix the first issue. I
 > hope they will address the second issue first in the list and then
 > reflect the agreement in the next revision. I will hold on to the doc
 > write-up till then.
 >
 >
 > -acbegen
 >
 > -----Original Message----- From: Jonathan Lennox <[email-masked]
 > <mailto:[email-masked]>>
 >
 > Date: Thursday, December 13, 2012 11:29 AM To: "Ali C. Begen"
 > <[email-masked] <mailto:[email-masked]>>, "[email-masked]
 > <mailto:[email-masked]>" <[email-masked]
 > <mailto:[email-masked]>> Cc: "[email-masked]
 > <mailto:[email-masked]>"
 > <[email-masked]
 > <mailto:[email-masked]>>
 >
 >> I just wanted to make sure the issue had been considered; if the
 >> WG agrees that the current design is okay given the limitations
 >> I've mentioned, I'm not going to object.
 >>
 >> -----Original Message----- From: Ali C. Begen (abegen)
 >> [mailto:[email-masked] <mailto:[email-masked]>] Sent: Tuesday,
 >> December 11, 2012 7:13 PM To: Jonathan Lennox; [email-masked]
 >> <mailto:[email-masked]> Cc: [email-masked]
 >> <mailto:[email-masked]> Subject: Re:
 >> [payload] WGLC for VP8 Payload
 >>
 >> The first one should be fixed by the authors thru a quick revision.
 >> As for the second one, I will ask the authors reply. Also if there
 >> are others who strongly think one way or another, lets discuss it.
 >>
 >> Jonathan, are you ok if the authors simply acknowledge this in the
 >> draft (assuming they agree with you) or do you actually not like
 >> this at all?
 >>
 >> -acbegen
 >>
 >> -----Original Message----- From: Jonathan Lennox
 >> <[email-masked] <mailto:[email-masked]>> Date: Tuesday,
 >> December 11, 2012 11:49 AM To: "[email-masked]
 >> <mailto:[email-masked]>" <[email-masked]
 >> <mailto:[email-masked]>> Subject: Re: [payload] WGLC for VP8
 >> Payload
 >>
 >>> First of all, an editorial matter: Section 6 says the format has
 >>> no parameters, but section 6.1 lists two optional parameters
 >>> (max-fr and max-fs).
 >>>
 >>>
 >>> Secondly, more substantively, I note that the payload format's
 >>> rules on KEYIDX and TL0PICIDX impose a fair bit of overhead on
 >>> boxes that wish to splice together VP8 streams, since both values
 >>> are required to always increment consecutively in a bitstream (if
 >>> they're being used).
 >>>
 >>> By contrast, the equivalent fields of the H.264 SVC payload
 >>> format (in the PACSI) just say that IDRPICID must be different in
 >>> consecutive IDR frames, without requiring that the value
 >>> increment by 1; and TL0PICIDX resets to 0 on every IDR frame,
 >>> rather than carrying on continuously. (H.264's IDR frames are
 >>> analogous for these purposes to VP8's essential keyframes).
 >>>
 >>> This means that an H.264 SVC splicer -- as long as it doesn't
 >>> get unlucky, such that the two streams it's splicing happen to
 >>> have identical IDRPICID values at the splice point -- can just
 >>> transition from one bitstream to another at any IDR frame.
 >>>
 >>> By contrast, following a splice, a VP8 splicer must re-write both
 >>> these fields for the rest of the lifetime of the stream, since
 >>> they each have only one valid possible value following the
 >>> splice.
 >>>
 >>> The VP8 payload format's decision is a reasonable design choice
 >>> -- as compared to the H.264 SVC rules, it removes some ambiguity
 >>> between splice points and packet loss, giving decoders somewhat
 >>> greater visibility as to what's going on in the bitstream, and
 >>> also allows TL0PICIDX and KEYIDX to be orthogonal options because
 >>> they increment independently. However, I wanted to make sure
 >>> this had been considered explicitly by the working group, and we
 >>> had consensus that it was the right decision.
 >>>
 >>> (Note well disclaimer: Vidyo has an IPR declaration against the
 >>> VP8 payload -- see <http://tracker.tools.ietf.org/ipr/1622/>.)
 >>>
 >>>
 >>>> I have not seen any comments on the list. Please review the
 >>>> draft and post your comments on the list.
 >>>>
 >>>> Thanks. -acbegen
 >>>>
 >>>> -----Original Message----- From: "Ali C. Begen"
 >>>> <[email-masked] <mailto:[email-masked]>> Date: Monday,
 >>>> November 19, 2012 3:15 PM To: "[email-masked]
 >>>> <mailto:[email-masked]>" <[email-masked]
 >>>> <mailto:[email-masked]>> Subject: [payload] WGLC for VP8
 >>>> Payload
 >>>>
 >>>>> Hi everyone,
 >>>>>
 >>>>> We had a WGLC for this draft earlier this year and there have
 >>>>> been a few updates to the document. I am starting a 2nd
 >>>>> WGLC. Please review and comment on the list by December
 >>>>> 10th.
 >>>>>
 >>>>> https://datatracker.ietf.org/doc/draft-ietf-payload-vp8/?include_tex
 >
 >>>>>
 >>>> t=1
 >>>>>
 >>> -- Jonathan Lennox [email-masked]
 >>> <mailto:[email-masked]>
 >>>
 >>>
 >>> _______________________________________________ payload mailing
 >>> list [email-masked] <mailto:[email-masked]>
 > _______________________________________________ payload mailing list
 > [email-masked] <mailto:[email-masked]>
 > _______________________________________________ payload mailing list
 > [email-masked] https://www.ietf.org/mailman/listinfo/payload

---

From: Patrik Westin <[email-masked]>
Date: Wed, 19 Dec 2012 15:06:47 -0800

Would you be happy with adding paragraph saying something like this?

"People doing splicing of VP8 streams will have to make sure the rules for
incrementing TL0PICIDX and KEYIDX are obeyed across the splice. This may
require rewriting values of TL0PICIDX and KEYIDX after the splice."

On Sat, Dec 15, 2012 at 5:11 AM, Glen Zorn <[email-masked]> wrote:

> > "draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>
> >"
> > <draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>>>,
> "[email-masked]
> > <mailto:[email-masked]>>, "draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>
> >"
> > <draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>>>
> Subject: Re:
>
> > <mailto:[email-masked]>; draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>
> >
> >
> >
> > <mailto:[email-masked]>>, "draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>
> >"
> > <draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>
> >>
> >
> >
> > <mailto:[email-masked]>> Cc: "draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>
> >"
> > <draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> > <mailto:[email-masked]<[email-masked]>
> >>
>
> >
> >> <mailto:[email-masked]> Cc: draft-ietf-payload-vp8@tools.**ietf.org<[email-masked]>
> >> <mailto:[email-masked]<[email-masked]>>
> Subject: Re:
>
> >>> VP8 payload -- see <http://tracker.tools.ietf.**org/ipr/1622/<http://tracker.tools.ietf.org/ipr/1622/>
> >.)
> >>>
> >>>
> >>>>> https://datatracker.ietf.org/**doc/draft-ietf-payload-vp8/?**
> include_tex<https://datatracker.ietf.org/doc/draft-ietf-payload-vp8/?include_tex>
> >
> >>>>>
> >>>> t=1
> >>>>>
> >>>> https://www.ietf.org/mailman/**listinfo/payload<https://www.ietf.org/mailman/listinfo/payload>
> >>>>
> >>>
> >>> ______________________________**_________________ payload mailing
> >>> https://www.ietf.org/mailman/**listinfo/payload<https://www.ietf.org/mailman/listinfo/payload>
> >>
> >
> > ______________________________**_________________ payload mailing list
> > https://www.ietf.org/mailman/**listinfo/payload<https://www.ietf.org/mailman/listinfo/payload>
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > ______________________________**_________________ payload mailing list
> > [email-masked] https://www.ietf.org/mailman/**listinfo/payload<https://www.ietf.org/mailman/listinfo/payload>
>
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Sat, 29 Dec 2012 20:02:04 +0000

From: Patrik Westin <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 19, 2012 6:06 PM
To: Glen Zorn <[email-masked]<mailto:[email-masked]>>
Cc: Stephan Wenger <[email-masked]<mailto:[email-masked]>>, "Ali C. Begen" <[email-masked]<mailto:[email-masked]>>, Jonathan Lennox <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [payload] WGLC for VP8 Payload

"People doing splicing of VP8 streams will have to make sure the rules for incrementing TL0PICIDX and KEYIDX are obeyed across the splice. This may require rewriting values of TL0PICIDX and KEYIDX after the splice."

Slight rewording:

Implementations doing splicing of VP8 streams will have to make sure the rules for incrementing TL0PICIDX and KEYIDX are obeyed across the splice. This will likely require rewriting values of TL0PICIDX and KEYIDX after the splice.

BTW, just out of curiosity, as vp9 is surfacing soon, is there any implication on this draft?

-acbegen

On Sat, Dec 15, 2012 at 5:11 AM, Glen Zorn <[email-masked]<mailto:[email-masked]>> wrote:
On 12/15/2012 06:27 AM, Stephan Wenger wrote:

Hi, I'm with Ali here.

Me, too.

> From: "Ali C. Begen (abegen)" <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> Date: Friday, 14 December, 2012 15:09 To:
> "[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>, Jonathan Lennox <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> Cc:
> "[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>"
> <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> Subject: Re: [payload] WGLC for VP8

> From: Patrik Westin <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
> Reply-To: "[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>"
> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> Date: Friday,

> December 14, 2012 6:06 PM To: Jonathan Lennox <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> Cc: "Ali C. Begen" <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>"
> <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> Subject: Re:

> On Fri, Dec 14, 2012 at 2:55 PM, Jonathan Lennox <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
> *From:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
> [mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>] *On Behalf Of
> Begen (abegen) *Cc:* Jonathan Lennox; [email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>
>
>

> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
> *From: *Patrik Westin <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> *Reply-To: *"[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> *Date: *Friday, December 14, 2012 4:53
> PM
>
>
> *To: *"Ali C. Begen" <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>
> *Cc: *Jonathan Lennox <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>"
> <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>
>
>

> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
> -----Original Message----- From: Jonathan Lennox <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>

> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>, "[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> Cc: "[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>"
> <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>

>> [mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>] Sent: Tuesday,

>> December 11, 2012 7:13 PM To: Jonathan Lennox; [email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>> Cc: [email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>> Subject: Re:

>> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> Date: Tuesday,

>> December 11, 2012 11:49 AM To: "[email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>>> Subject: Re: [payload] WGLC for VP8

>>>> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> Date: Monday,

>>>> November 19, 2012 3:15 PM To: "[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>> Subject: [payload] WGLC for VP8

>>> -- Jonathan Lennox [email-masked]<mailto:[email-masked]>
>>> <mailto:[email-masked]<mailto:[email-masked]>>
>>>
>>>
>>> list [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>

> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>

> [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/payload