Subject: [nmrg] I-D Action: draft-irtf-nmrg-autonomic-sla-violation-detection-09.txt

From: [email-masked]
Date: Sun, 25 Jun 2017 19:54:36 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Management of the IETF.

        Title           : Autonomic Networking Use Case for Distributed Detection of SLA Violations
        Authors         : Jeferson Campos Nobre
                          Lisandro Zambenedetti Granvile
                          Alexander Clemm
                          Alberto Gonzalez Prieto
	Filename        : draft-irtf-nmrg-autonomic-sla-violation-detection-09.txt
	Pages           : 15
	Date            : 2017-06-25

Abstract:
   This document describes a use case for autonomic networking
   concerning monitoring of Service Level Agreements (SLAs).  The use
   case aims to detect violations of SLAs in a distributed fashion,
   striving to optimize and dynamically adapt the autonomic deployment
   of active measurement probes in a way that maximizes the likelihood
   of detecting service level violations with a given resource budget to
   perform active measurements, and is able to do so without any outside
   guidance or intervention.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-nmrg-autonomic-sla-violation-detection/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-nmrg-autonomic-sla-violation-detection-09
https://datatracker.ietf.org/doc/html/draft-irtf-nmrg-autonomic-sla-violation-detection-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-nmrg-autonomic-sla-violation-detection-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Jun 2017 12:12:09 +1200

Hi,

> 7.  Implementation Considerations
> 
>    The active measurement model assumes that a typical infrastructure
>    will have multiple network segments and Autonomous Systems (ASs), and
>    a reasonably large number of routers.

Could the authors clarify what they mean by Autonomous System?
Is this intended in the precise sense of a BGP4 AS or in a more
general way?

This is important for the applicability of the ANIMA solutions to
this use case, since it is hard to imagine an ANIMA Autonomic Control
Plane extending beyond a single BGP4 AS, and certainly not beyond
a single administrative domain.

Have the authors already studied the applicability of the ANIMA
solutions?

Regards
   Brian Carpenter

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Wed, 28 Jun 2017 17:54:24 +0000

Hi Brian.
Thanks for the comments.
Answers below.

Em seg, 26 de jun de 2017 às 21:12, Brian E Carpenter <
[email-masked]> escreveu:

> >    The active measurement model assumes that a typical
> infrastructure will have multiple network segments and Autonomous Systems
> (ASs), and  a reasonably large number of routers.
>

Yes, AS in the I-D can be read as a BGP AS. In any case, we are just
describing a active measurement model at this point.

> a single administrative domain.

Agreed, but the solution described in our I-D considers cooperative peers.
Thus, it is safe to say that it targets single administrative domains which
means that the ACP could be used.

> Have the authors already studied the applicability of the ANIMA

We did not study the applicability of ANIMA solutions for this I-D, but we
have plans to do in a new one if a new ANIMA charter allow such possibility.

>    Brian Carpenter

Best.
Jéferson

>
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg
>

---

From: Alexander Clemm <[email-masked]>
Date: Wed, 28 Jun 2017 18:03:22 +0000

Hello Brian,

Just to add to Jeferson’s response, to your comment re: whether there is applicability of ANIMA.  This is clearly specified in the draft in several places, e.g. section 5 top of page 9: “The provisioning of the P2P overlay should be transparent for the
   network administrator.  An Autonomic Control Plane such as defined in
   [I-D.anima-autonomic-control-plane<https://tools.ietf.org/html/draft-irtf-nmrg-autonomic-sla-violation-detection-09#ref-I-D.anima-autonomic-control-plane>] provides an ideal candidate for
   the P2P overlay to run on.”

In other words, this is clearly a decentralized autonomic application which requires a secure overlay for nodes (Autonomic Service Agents, in RFC 7575 parlance – come to think of it, we should add a reference to RFC 7575) to communicate with one another that could run on top of the ANIMA ACP. Really, very complementary.

Thanks
--- Alex

From: nmrg [mailto:[email-masked]] On Behalf Of Jéferson Campos Nobre
Sent: Wednesday, June 28, 2017 10:54 AM
To: Brian E Carpenter <[email-masked]>; [email-masked]
Subject: Re: [nmrg] I-D Action: draft-irtf-nmrg-autonomic-sla-violation-detection-09.txt

Hi Brian.
Thanks for the comments.
Answers below.

Em seg, 26 de jun de 2017 às 21:12, Brian E Carpenter <[email-masked]<mailto:[email-masked]>> escreveu:
Hi,

>    The active measurement model assumes that a typical infrastructure will have multiple network segments and Autonomous Systems (ASs), and  a reasonably large number of routers.

Yes, AS in the I-D can be read as a BGP AS. In any case, we are just describing a active measurement model at this point.

Agreed, but the solution described in our I-D considers cooperative peers. Thus, it is safe to say that it targets single administrative domains which means that the ACP could be used.

We did not study the applicability of ANIMA solutions for this I-D, but we have plans to do in a new one if a new ANIMA charter allow such possibility.

Regards
   Brian Carpenter

Best.
Jéferson

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg