Subject: Re: [netmod] intended status of the tree diagram document

From: Lou Berger <[email-masked]>
Date: Thu, 7 Dec 2017 17:13:21 -0500

Hi Juergen,

    Sorry for the slow response, I missed this message.

Circling back to this discussion made me go revisit RFC2026.  Based on
all the factors/discussions I agree  that standards track isn't quite
right for this document, but I also think informational isn't quite
right either.  I do think BCP would as described in RFC2026 fits.  This
said, I think it would be good to hear from at least Kent (as Chair) and
Benoit (as AD) if they agree/disagree with publishing as a BCP.

Kent, Benoit?

Thanks,

Lou

On 11/17/2017 1:54 AM, Juergen Schoenwaelder wrote:
> Lou,
>
> right now, the document says standards track, Martin's proposal was to
> move to informational. So how do I parse "I think you are correct.  We
> should leave as is."?
>
> /js
>
> On Fri, Nov 17, 2017 at 07:36:58AM +0800, Lou Berger wrote:
>> Martin,
>> 	I think you are correct.  We should leave as is.
>>
>> I'm sure Kent/the document Shepherd makes sure whatever we do is right
>> before publication in any case.
>>
>> Lou (as contributor)
>>
>> On 11/15/2017 8:58 PM, Martin Bjorklund wrote:
>>> Hi,
>>>
>>> Currently, draft-ietf-netmod-yang-tree-diagrams has intended status
>>> Standards Track.  I think I heard during the meeting today that it
>>> ought to be Informational.  I think this makes sense.  It would then
>>> imply that other standards track documents will have the tree diagram
>>> document as an informative reference.
>>>
>>> Should we make this change?
>>>
>>>
>>> /martin
>>>
>>> _______________________________________________
>>> netmod mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/netmod
>>>
>> _______________________________________________
>> netmod mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netmod

---

From: Kent Watsen <[email-masked]>
Date: Fri, 8 Dec 2017 00:05:53 +0000

BCP for tree-diagrams?   This doesn't seem like an appropriate application of that designation.  I don't view the format for tree diagrams to be a "practice", whereas it definitely seems "informational".

Looking more deeply at RFC2026, I can see how Section's 4.2.2's "...does not represent an Internet community consensus or recommendation" could be cause for objection, since this draft is obviously going through a WG (NETMOD) and therefore does, in fact, represent some form of consensus, but I'm willing to gloss over that line as, clearly, many Informational RFCs are published by WGs, which wouldn't be possible if that line were taken literally.  Perhaps we should file Errata against it?

Kent // co-chair

===== original message =====

Hi Juergen,

Kent, Benoit?

Thanks,

Lou

On 11/17/2017 1:54 AM, Juergen Schoenwaelder wrote:
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=3BCNpvoumTA-4yjD5n04CSFPUs2jLAlNoj5OIoOXDkU&s=Pi6G9uzvFRpUNkgaZa2tRR07sP7byEskonoVDeyYcQE&e=
>>>
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=3BCNpvoumTA-4yjD5n04CSFPUs2jLAlNoj5OIoOXDkU&s=Pi6G9uzvFRpUNkgaZa2tRR07sP7byEskonoVDeyYcQE&e=

---

From: Lou Berger <[email-masked]>
Date: Thu, 07 Dec 2017 20:04:33 -0500

Umm, bcp covers process and consensus agreement while informational 
typically does not*.  I also don't see how 6087bis would be a more suited 
to be a bcp than this document.

Lou

On December 7, 2017 7:06:35 PM Kent Watsen <[email-masked]> wrote:

>
> BCP for tree-diagrams?   This doesn't seem like an appropriate application 
> of that designation.  I don't view the format for tree diagrams to be a 
> "practice", whereas it definitely seems "informational".
>
> Looking more deeply at RFC2026, I can see how Section's 4.2.2's "...does 
> not represent an Internet community consensus or recommendation" could be 
> cause for objection, since this draft is obviously going through a WG 
> (NETMOD) and therefore does, in fact, represent some form of consensus, but 
> I'm willing to gloss over that line as, clearly, many Informational RFCs 
> are published by WGs, which wouldn't be possible if that line were taken 
> literally.  Perhaps we should file Errata against it?
>
> Kent // co-chair
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 7 Dec 2017 20:07:04 -0500

Kent:

A common way to express tree-diagrams in Yang documents provides a common
and clear to describe the models.  This would be really helpful to those
using these yang models.  Seems like a standard or a BCP to me.  

Sue Hares 

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Kent Watsen
Sent: Thursday, December 7, 2017 7:06 PM
To: Lou Berger; [email-masked]; Benoit Claise; Juergen Schoenwaelder
Subject: Re: [netmod] intended status of the tree diagram document

Looking more deeply at RFC2026, I can see how Section's 4.2.2's "...does not
represent an Internet community consensus or recommendation" could be cause
for objection, since this draft is obviously going through a WG (NETMOD) and
therefore does, in fact, represent some form of consensus, but I'm willing
to gloss over that line as, clearly, many Informational RFCs are published
by WGs, which wouldn't be possible if that line were taken literally.
Perhaps we should file Errata against it?

Kent // co-chair

Hi Juergen,

Circling back to this discussion made me go revisit RFC2026.  Based on all
the factors/discussions I agree  that standards track isn't quite right for
this document, but I also think informational isn't quite right either.  I
do think BCP would as described in RFC2026 fits.  This said, I think it
would be good to hear from at least Kent (as Chair) and Benoit (as AD) if
they agree/disagree with publishing as a BCP.

Kent, Benoit?

Thanks,

Lou

On 11/17/2017 1:54 AM, Juergen Schoenwaelder wrote:
>> I'm sure Kent/the document Shepherd makes sure whatever we do is 
>> right before publication in any case.
>>
>> Lou (as contributor)
>>
>>> imply that other standards track documents will have the tree 
>>> diagram document as an informative reference.
>>>
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_ma
>>> ilman_listinfo_netmod&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voD
>>> TXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=3BCNpvoumTA
>>> -4yjD5n04CSFPUs2jLAlNoj5OIoOXDkU&s=Pi6G9uzvFRpUNkgaZa2tRR07sP7byEsko
>>> noVDeyYcQE&e=
>>>
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mai
>> lman_listinfo_netmod&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTX
>> cWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=3BCNpvoumTA-4y
>> jD5n04CSFPUs2jLAlNoj5OIoOXDkU&s=Pi6G9uzvFRpUNkgaZa2tRR07sP7byEskonoVD
>> eyYcQE&e=

---

From: "Mehmet Ersue" <[email-masked]>
Date: Fri, 8 Dec 2017 11:36:49 +0100

I think the rules and recommendations in this document should be used, once
agreed and published, by all YANG module drafts within and outside of IETF.
As such its content is BCP.
IETF consensus will be achieved during IETF LC.

Cheers,
Mehmet

> From: netmod [mailto:[email-masked]] On Behalf Of Susan Hares
> Sent: Friday, December 8, 2017 2:07 AM
> To: 'Kent Watsen' <[email-masked]>; 'Lou Berger' <[email-masked]>;
> [email-masked]; 'Benoit Claise' <[email-masked]>; 'Juergen
> Schoenwaelder' <[email-masked]>
> A common way to express tree-diagrams in Yang documents provides a
> common and clear to describe the models.  This would be really helpful to
> those using these yang models.  Seems like a standard or a BCP to me.
> 
> Sue Hares
> 
> 
not
> represent an Internet community consensus or recommendation" could be
> (NETMOD) and therefore does, in fact, represent some form of consensus,
> but I'm willing to gloss over that line as, clearly, many Informational
RFCs are
> published by WGs, which wouldn't be possible if that line were taken
literally.
> Circling back to this discussion made me go revisit RFC2026.  Based on all
the
> factors/discussions I agree  that standards track isn't quite right for
this
> document, but I also think informational isn't quite right either.  I do
think
> BCP would as described in RFC2026 fits.  This said, I think it would be
good to
> hear from at least Kent (as Chair) and Benoit (as AD) if they
agree/disagree
> with publishing as a BCP.
> 
> Kent, Benoit?
> 
> Thanks,
> 
> Lou
> 
> >>> -
> 4yjD5n04CSFPUs2jLAlNoj5OIoOXDkU&s=Pi6G9uzvFRpUNkgaZa2tRR07sP7byE
> sko
> >>> noVDeyYcQE&e=
> >>>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 8 Dec 2017 17:11:41 +0100

Dear all,

I believe BCP is correct for the tree diagram document.
Exactly as this is the right status for RFC6087bis, as discussed on the 
list.

Regards, Benoit.
> .