Subject: [netmod] Query about augmenting 'config false' YANG

From: "Ivory, William" <[email-masked]>
Date: Fri, 15 Dec 2017 14:02:26 +0000

Hi,

I'm running into a problem where my YANG is being rejected by a NETCONF client that claims it can't find the node being augmented.  The YANG snippet below shows the problem which relates specifically to augmenting a node that is 'config false'.  AFAICT from reading RFC 6020, this is valid YANG, but I would appreciate confirmation from the experts!

Pyang is quite happy with this.

Thanks,

William

--- sample yang to show problem ---

                grouping state-grouping {
                                container state {
                                                config false;
                                                leaf state-grp-state-leaf {
                                                                type string;
                                                }
                                }
                }

                container test {
                                container state-cont {
                                                config false;
                                                leaf state-leaf {
                                                                type string;
                                                }
                                }
                }

                augment /test/state-cont {
                                // Augment 'config false' container directly works.
                                leaf augmented-state-leaf {
                                                type string;
                                }
                }

                augment /test {
                                uses state-grouping {
                                                // Augment here fails - 'state' not found.
                                                augment state {
                                                                leaf aug-state-grp-leaf {
                                                                                type string;
                                                                }
                                                }
                                }
                }

---

From: Robert Wilton <[email-masked]>
Date: Fri, 15 Dec 2017 17:41:57 +0000

Looks valid to me.

Thanks,
Rob

On 15/12/2017 14:02, Ivory, William wrote:
>
> Hi,
>
> I’m running into a problem where my YANG is being rejected by a 
> NETCONF client that claims it can’t find the node being augmented.  
> The YANG snippet below shows the problem which relates specifically to 
> augmenting a node that is ‘config false’. AFAICT from reading RFC 
> 6020, this is valid YANG, but I would appreciate confirmation from the 
> experts!
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: "Ivory, William" <[email-masked]>
Date: Fri, 15 Dec 2017 17:43:36 +0000

Hi Rob,

Thanks - that's what I thought but wanted a second opinion.  Fortunately we can expand the groupings in-place to work around this, but obviously at the cost of lower maintainability and with the risk of divergence if the grouping content ever changes.

William

From: Robert Wilton [mailto:[email-masked]]
Sent: 15 December 2017 17:42
To: Ivory, William <[email-masked]>; [email-masked]' <[email-masked]>
Subject: Re: [netmod] Query about augmenting 'config false' YANG

Looks valid to me.

Thanks,
Rob

Thanks,

William

--- sample yang to show problem ---

                container test {
                                container state-cont {
                                                config false;
                                                leaf state-leaf {
                                                                type string;
                                                }
                                }
                }

                augment /test {
                                uses state-grouping {

netmod mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/netmod<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwMD-g&c=LFYZ-o9_HUMeMTSQicvjIg&r=p8kyeK3u4ZYiaQ2ZPGqwkyXmQgBH6r5jpYiYWzhqJ48&m=HCzkzCTDorlm-kZkArWnL8xiokaSmvuSB46O7_s22rI&s=VuNhyO6EwnN1CvYSx3ydeNZavvaemy1ReKEwVNaFMBc&e=>