Subject: Re: [netmod] WG Last Call: draft-ietf-netmod-rfc8022bis-01

From: Lou Berger <[email-masked]>
Date: Fri, 15 Dec 2017 15:55:19 -0500

All,
	This last call is closed.

We note that there was an update during the LC and that no comments were
received during the LC period.  As this is simply a mechanical update
that has been discussed in the WG we plan to proceed with the
publication process.

Authors,
	Please let/us the WG know when you have published a version ready for
publication.  Also please let the WG know what has changed in the
document since the start of LC (rev -01)

Thank you,
NetMod Chairs

On 11/29/2017 12:26 PM, Lou Berger wrote:
> All,
> 
> This starts a two-week working group last call on
> draft-ietf-netmod-rfc8022bis-01.
> 
> Please recall that this update's intention is to 
> modify the YANG module to be in line with the NMDA
> guidelines [1].  Reviewing the diff between the two
> drafts [2] should reveal just this.
> 
> The working group last call ends on December 13.
> Please send your comments to the netmod mailing list.
> 
> Positive comments, e.g., "I've reviewed this document
> and believe it is ready for publication", are welcome!
> This is useful and important, even from authors.
> 
> [1] https://tools.ietf.org/html/draft-dsdt-nmda-guidelines-01
> [2] https://tools.ietf.org/rfcdiff?difftype=--hwdiff&url1=rfc8022.txt&url2=draft-ietf-netmod-rfc8022bis-01.txt
> 
> Thank you,
> Netmod Chairs
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sun, 17 Dec 2017 16:57:59 +0000

Hi Lou, et al, 

The only issue we are struggling with is whether we need to specify the
version in the ietf-interfaces import. We have noted that
draft-ietf-netmod-rfc7277bis-01.txt does not import by revision.

We also have so nits:

   1. Add an informative reference for
[I-D.ietf-netmod-yang-tree-diagrams].
   2. Based on a comment from Vladimir, we added the prefix for
ietf-routing.yang, “rt:”, to several references within ietf-routing.yang.
Was this necessary? Of course, the model compiles with or without the
prefix. 

Thanks,
Acee

On 12/15/17, 3:55 PM, "netmod on behalf of Lou Berger"
<[email-masked] on behalf of [email-masked]> wrote:

>> [2] 
>>https://tools.ietf.org/rfcdiff?difftype=--hwdiff&url1=rfc8022.txt&url2=dr
>>aft-ietf-netmod-rfc8022bis-01.txt
>> 
>> Thank you,
>> Netmod Chairs
>> 
>
>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: Vladimir Vassilev <[email-masked]>
Date: Mon, 18 Dec 2017 12:24:09 +0100

> Was this necessary? Of course, the model compiles with or without the
I reverted this in a follow-up comment on the same thread. I believe the 
local prefixes are redundant.

Vladimir

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 18 Dec 2017 12:54:48 +0000

Hi Vladimir, 

>local prefixes are redundant.

I’d already updated the git repository and neglected to revert it. I will
revert after reviewing RFC6087BIS rules.

Thanks,
Acee

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 18 Dec 2017 13:19:42 +0100

Hi Acee,

> draft-ietf-netmod-rfc7277bis-01.txt does not import by revision.

I would suggest to import *without* revision but add a description
indicating that the NMDA-compatible revisions are needed.

Importing by revision is clearly suboptimal. Hopefully a new mechanism
such as semantic versioning will be introduced soon to alleviate this
issue.

> Was this necessary? Of course, the model compiles with or without the

RFC6087bis has some rules in sec. 4.2, and these should be followed.

Also, the security considerations should IMO be changed, see my recent
message:

https://www.ietf.org/mail-archive/web/netmod/current/msg19610.html

Of course, the NEW formulation needn't be exactly as I suggested, but
the text "The YANG module [...] is designed to be accessed ..." is
apparently wrong and shouldn't be used any more.

Thanks, Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 18 Dec 2017 12:56:34 +0000

Hi Lada, 

>such as semantic versioning will be introduced soon to alleviate this

I agree and will update the description.
>RFC6087bis has some rules in sec. 4.2, and these should be followed.

Will review these. 
>apparently wrong and shouldn't be used any more.

Ok - I will also review the “Security Considerations” template.

Thanks,
Acee