Subject: [netmod] YANG module security considerations

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 01 Dec 2017 13:13:02 +0100

Hi,

the security considerations template text [1] that has already been used in a
number of documents is apparently incorrect - YANG modules aren't accessed by NM
protocols. Hence

OLD

The YANG module defined in this document is designed to be accessed via network
management protocols such as ...

NEW

The YANG module specified in this document defines a schema for data that is
designed to be accessed via network management protocols such as ...

[1] https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines

Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 11 Dec 2017 18:43:51 +0000

Hi Lada, et al, 

I haven’t seen any response to this. Your suggestion seems to me to be
more technically accurate.

Thanks,
Acee 

On 12/1/17, 7:13 AM, "netmod on behalf of Ladislav Lhotka"
<[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: Benoit Claise <[email-masked]>
Date: Thu, 21 Dec 2017 11:16:20 +0100

Dear all,

The proposed change has been applied to 
https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines
For all document authors, please apply the new template.

Diff at 
https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines?action=diff&version=13&old_version=12

Regards, Benoit