Subject: [netmod] draft-ietf-netmod-yang-tree-diagrams - IPR verfication request

From: joel jaeggli <[email-masked]>
Date: Tue, 19 Dec 2017 10:39:43 -0800

Authors, Contributors, WG,

As part of the preparation for WG Last Call:

Are you aware of any IPR that applies to drafts identified above?

Please state either:

"No, I'm not aware of any IPR that applies to this draft"
or
"Yes, I'm aware of IPR that applies to this draft"

If so, has this IPR been disclosed in compliance with IETF IPR rules
(see RFCs 3669, 5378 and 8179 for more details)?

If yes to the above, please state either:

"Yes, the IPR has been disclosed in compliance with IETF IPR rules"
or
"No, the IPR has not been disclosed"

If you answer no, please provide any additional details you think
appropriate.

If you are listed as a document author or contributor please answer the
above by responding to this email regardless of whether or not you are
aware of any relevant IPR. This document will not advance to the next
stage until a response has been received from each author and listed
contributor. NOTE: THIS APPLIES TO ALL OF YOU LISTED IN THIS MESSAGE'S
TO LINES.

If you are on the WG email list or attend WG meetings but are not listed
as an author or contributor, we remind you of your obligations under
the IETF IPR rules which encourages you to notify the IETF if you are
aware of IPR of others on an IETF contribution, or to refrain from
participating in any contribution or discussion related to your
undisclosed IPR. For more information, please see the RFCs listed above
and
http://trac.tools.ietf.org/group/iesg/trac/wiki/IntellectualProperty.

Thank you,
NetMod WG Chairs

PS Please include all listed in the headers of this message in your
response.

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 19 Dec 2017 21:12:53 +0100 (CET)

> Are you aware of any IPR that applies to drafts identified above?

No, I'm not aware of any IPR that applies to this draft

/martin

---

From: Lou Berger <[email-masked]>
Date: Thu, 21 Dec 2017 16:07:33 -0500

Lou
(co-author)

On 12/19/2017 1:39 PM, joel jaeggli wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 22 Dec 2017 14:23:40 +0000

Hi,
I have a question for the authors.
Today a yang-tree-diagram represents extended  YANG groupings , which often makes a tree hard to read/ understand. Do you think there could be a way to represent groupings as collapsed?

Thanks,
Igor
From:Lou Berger
To:joel jaeggli,[email-masked],[email-masked],
Date:2017-12-21 16:07:58
Subject:Re: [netmod] draft-ietf-netmod-yang-tree-diagrams - IPR verfication request

Lou
(co-author)

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 22 Dec 2017 15:33:49 +0100 (CET)

Igor Bryskin <[email-masked]> wrote:
> Today a yang-tree-diagram represents extended YANG groupings , which
> often makes a tree hard to read/ understand. Do you think there could
> be a way to represent groupings as collapsed?

In draft -03, we added the option of printing the "uses statement",
e.g.:

    |        +---x active-route
    |        |  +--ro output
    |        |     +--ro route
    |        |        +--ro next-hop
    |        |        |  +---u next-hop-state-content
    |        |        +---u route-metadata

instead of:

    |        +---x active-route
    |        |  +--ro output
    |        |     +--ro route
    |        |        +--ro next-hop
    |        |        |  +--ro (next-hop-options)
    |        |        |     +--:(simple-next-hop)
    |        |        |     |  +--ro outgoing-interface?   if:interface-ref
    |        |        |     +--:(special-next-hop)
    |        |        |     |  +--ro special-next-hop?     enumeration
    |        |        |     +--:(next-hop-list)
    |        |        |        +--ro next-hop-list
    |        |        |           +--ro next-hop*
    |        |        |              +--ro outgoing-interface?   if:interface-ref
    |        |        +--ro source-protocol    identityref
    |        |        +--ro active?            empty
    |        |        +--ro last-updated?      yang:date-and-time

/martin

> 
> Thanks,
> Igor
> From:Lou Berger
> To:joel
> jaeggli,[email-masked],[email-masked],
> Date:2017-12-21 16:07:58

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 22 Dec 2017 15:34:41 +0100

Hi,

this got added in the latest version:

         -u  for uses of a grouping

2.2.  Groupings

   Nodes within a used grouping are normally expanded as if the nodes
   were defined at the location of the "uses" statement.  However, it is
   also possible to not expand the "uses" statement, but instead print
   the name of the grouping.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 22 Dec 2017 15:07:30 +0000

Great, this works,

Igor
From:Martin Bjorklund
To:Igor Bryskin,
Cc:[email-masked],[email-masked],[email-masked],[email-masked],
Date:2017-12-22 09:34:04
Subject:Re: [netmod] draft-ietf-netmod-yang-tree-diagrams - IPR verfication request

    |        +---x active-route
    |        |  +--ro output
    |        |     +--ro route
    |        |        +--ro next-hop

instead of:

    |        +---x active-route
    |        |  +--ro output
    |        |     +--ro route
    |        |        +--ro next-hop

/martin