Subject: [netmod] ietf-yang-library edit

From: Andy Bierman <[email-masked]>
Date: Tue, 14 Nov 2017 18:33:38 -0800

Hi,

The ietf-yang-library module relies on "yang-identifier", which was added
to the 2nd
version of the ietf-yang-types. It does not compile unless that version is
used.

OLD:

    import ietf-yang-types {
        prefix yang;
    }

NEW:

    import ietf-yang-types {
        prefix yang;
        revision-date "2013-07-15";
        reference "RFC 6991: Common YANG Data Types";
    }

There are other modules such as ietf-ip that rely on RFC 6991 additions
and the import-stmt (in every case) should be changed to specify the
required revision-date.

Andy

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 15 Nov 2017 12:48:58 +0800

Hello,

I though our strategy was to always use the latest revision
available. At least till now that works for me.

regards Balazs

On 2017-11-15 10:33, Andy Bierman
wrote:

Hi,

The ietf-yang-library module relies on "yang-identifier",
which was added to the 2nd

version of the ietf-yang-types. It does not compile unless
that version is used.

OLD:

import ietf-yang-types {

prefix yang;

}

NEW:

import ietf-yang-types {

prefix yang;

}

There are other modules such as ietf-ip that rely on RFC
6991 additions

and the import-stmt (in every case) should be changed to
specify the

required revision-date.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: Robert Wilton <[email-masked]>
Date: Wed, 15 Nov 2017 13:04:54 +0800

On 15/11/2017 12:48, Balazs Lengyel wrote:
>
> Hello,
>
> I though our strategy was to always use the latest revision available. 
> At least till now that works for me.
>
Yes, I'm not convinced that the import by revision is really that 
helpful since it states that it must pull in exactly that version, but 
really the dependency is "at least version X, assuming newer revisions 
are backwards compatible".

E.g. if/when ietf-yang-types is updated again, it would be 
cleaner/simpler if the server could just use the latest version rather 
than having to potentially import multiple revisions.

Thanks,
Rob

> regards Balazs
>
>
> On 2017-11-15 10:33, Andy Bierman wrote:
>> Hi,
>>
>> The ietf-yang-library module relies on "yang-identifier", which was 
>> added to the 2nd
>> version of the ietf-yang-types. It does not compile unless that 
>> version is used.
>>
>>
>> OLD:
>>
>>     import ietf-yang-types {
>>         prefix yang;
>>     }
>>
>>
>> NEW:
>>
>>     import ietf-yang-types {
>>         prefix yang;
> Mobile: +36-70-330-7909              email:[email-masked]  
>
>

---

From: Andy Bierman <[email-masked]>
Date: Tue, 14 Nov 2017 21:20:02 -0800

Hi,

The entire reason for import-by-revision is to make sure that
the importing module can safely use definitions that have been added after
the first revision of the imported module.

Andy

On Tue, Nov 14, 2017 at 9:04 PM, Robert Wilton <[email-masked]> wrote:

> I though our strategy was to always use the latest revision available. At
> least till now that works for me.
>
> Yes, I'm not convinced that the import by revision is really that helpful
> since it states that it must pull in exactly that version, but really the
> dependency is "at least version X, assuming newer revisions are backwards
> compatible".
>
> E.g. if/when ietf-yang-types is updated again, it would be cleaner/simpler
> if the server could just use the latest version rather than having to
> potentially import multiple revisions.
>
> Thanks,
> Rob
>
>
> regards Balazs
>
> netmod mailing [email-masked]://www.ietf.org/mailman/listinfo/netmod
>
>
> --
> netmod mailing [email-masked]://www.ietf.org/mailman/listinfo/netmod
>
>
>

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 15 Nov 2017 07:19:44 +0100 (CET)

Hi,

I agree w/ Balazs and Robert.

> the first revision of the imported module.

I don't think this is correct; the reason for import-by-revision is to
protect against a newver revision being used.

/martin