Subject: [netmod] WG Last Call resolutions incorporated in draft-ietf-tictoc-1588v2-yang-06

From: Jiangyuanlong <[email-masked]>
Date: Fri, 27 Oct 2017 02:21:04 +0000

Dear all,

Based on all the comments we received during the WG Last Call process, we've updated the document to version 6.
We believe all the LC comments are resolved and the consensus is reflected in this new revision. 
Many thanks to Martin, Tal, Opher, Alex, John and many others who had reviewed and commented on this draft.

Cheers,
Yuanlong on behalf of all coauthors

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, October 27, 2017 9:48 AM
To: Xian Liu; Rodney Cummings; [email-masked]; Jiangyuanlong; Xujinchun
Subject: New Version Notification for draft-ietf-tictoc-1588v2-yang-06.txt

A new version of I-D, draft-ietf-tictoc-1588v2-yang-06.txt
has been successfully submitted by Yuanlong Jiang and posted to the IETF repository.

Name:		draft-ietf-tictoc-1588v2-yang
Revision:	06
Title:		YANG Data Model for IEEE 1588-2008
Document date:	2017-10-26
Group:		tictoc
Pages:		30
URL:            https://www.ietf.org/internet-drafts/draft-ietf-tictoc-1588v2-yang-06.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-tictoc-1588v2-yang/
Htmlized:       https://tools.ietf.org/html/draft-ietf-tictoc-1588v2-yang-06
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-tictoc-1588v2-yang-06
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-tictoc-1588v2-yang-06

Abstract:
   This document defines a YANG data model for the configuration of
   IEEE 1588-2008 devices and clocks, and also retrieval of the
   configuration information, data set and running states of IEEE
   1588-2008 clocks.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Alex Campbell <[email-masked]>
Date: Mon, 30 Oct 2017 02:15:11 +0000

Hi,
I've reviewed this latest draft and have some more comments.

1. I find the introduction to be unnecessarily wordy; it feels like it was written with a view of not missing any information out, rather than trying to keep it concise.
   For example, there is no need to elaborate on YANG data types here. It is also not here to sell YANG.

OLD:

   As a synchronization protocol, IEEE 1588-2008 [IEEE1588] is widely
   supported in the carrier networks, industrial networks, automotive
   networks, and many other applications. It can provide high
   precision time synchronization as fine as nano-seconds. The
   protocol depends on a Precision Time Protocol (PTP) engine to
   decide its own state automatically, and a PTP transportation layer
   to carry the PTP timing and various quality messages. The
   configuration parameters and state data sets of IEEE 1588-2008 are
   numerous.

   According to the concepts described in [RFC3444], IEEE 1588-2008
   itself provides an information model in its normative
   specifications for the data sets (in IEEE 1588-2008 clause 8). Some
   standardization organizations including the IETF have specified
   data models in MIBs (Management Information Bases) for IEEE 1588-
   2008 data sets (e.g. [RFC8173], [IEEE8021AS]). These MIBs are
   typically focused on retrieval of state data using the Simple
   Network Management Protocol (SNMP), furthermore, configuration of
   PTP data sets is not considered in [RFC8173].

   Some service providers and applications require that the management
   of the IEEE 1588-2008 synchronization network be flexible and more
   Internet-based (typically overlaid on their transport networks).
   Software Defined Network (SDN) is another driving factor, which
   demands an improved configuration capability of synchronization
   networks.

   YANG [RFC6020] is a data modeling language used to model
   configuration and state data manipulated by network management
   protocols like the Network Configuration Protocol (NETCONF)
   [RFC6241]. A small set of built-in data types are defined in
   [RFC6020], and a collection of common data types are further
   defined in [RFC6991]. Advantages of YANG include Internet based
   configuration capability, validation, rollback and so on. All of
   these characteristics make it attractive to become another
   candidate modeling language for IEEE 1588-2008.

NEW:

   IEEE 1588-2008 is a time protocol that provides high precision time
   synchronization as fine as nano-seconds.

   IEEE 1588-2008 itself provides an information model in its normative
   specifications for the data sets (IEEE 1588-2008 clause 8).
   Standard information models (e.g. [RFC8173], [IEEE8021AS]) have been
   previously defined as MIBs focused on the retrieval of state data using
   SNMP [RFC1157].

   YANG [RFC6020] is a data modeling language used to model configuration
   and state data manipulated by network management protocols like NETCONF
   [RFC6241].

2. Can we refer to the system as simply PTP rather than IEEE 1588(-2008)?

3. There is insufficient spacing here to separate the terms from their definitions:
OLD

   PTP dataset  Structured attributes of clocks (an OC, BC or TC) used
   for PTP protocol decisions and for providing values for PTP message
   fields, see Section 8 of [IEEE1588].

   PTP instance A PTP implementation in the device (i.e., an OC or BC)
   represented by a specific PTP dataset.

NEW

   PTP dataset
     Structured attributes of clocks (an OC, BC or TC) used
     for PTP protocol decisions and for providing values for PTP message
     fields, see Section 8 of [IEEE1588].

   PTP instance
     A PTP implementation in the device (i.e., an OC or BC)
     represented by a specific PTP dataset.

4. There's a singular/plural mismatch here:

   module. Query and configuration of device wide or port specific
   configuration information and clock data set is described for this
   version.

and here:

   Query and configuration of clock information include:

5. The choice of uint16 as instance-number limits implementations to 65536 distinct instances.
   While I have a hard time imagining a system with more than 65536 PTP instances, I would prefer to avoid imposing arbitrary limits.
   I would recommend changing instance-number to a string (and renaming it to instance-name or just name).

6. I still recommend removing -ds from the YANG element names that still include it. It doesn't appear to add any value.

7. What;s the relevance of injection attacks relevant to this YANG module?

Alex

________________________________________
From: netmod <[email-masked]> on behalf of Jiangyuanlong <[email-masked]>
Sent: Friday, 27 October 2017 3:21 p.m.
To: [email-masked]
Cc: Xian Liu; Xujinchun; [email-masked]
Subject: [netmod] WG Last Call resolutions incorporated in draft-ietf-tictoc-1588v2-yang-06

Dear all,

Cheers,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, October 27, 2017 9:48 AM
To: Xian Liu; Rodney Cummings; [email-masked]; Jiangyuanlong; Xujinchun
Subject: New Version Notification for draft-ietf-tictoc-1588v2-yang-06.txt

Abstract:

The IETF Secretariat

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod