Subject: Re: [netmod] WG Last Call: draft-ietf-netmod-acl-model-14

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 25 Oct 2017 13:21:44 +0000

Hi Kent, Mahesh, et al,

I have read the draft and support publication. I have two comments on the
-14 version. 

  1. The tree diagrams do not fit within the draft pages. Note that recent
versions of pyang support the —tree-line-length parameter and this may
help. 
  2. While it is non-normative, I’d prefer to have appendix A.1 removed.
It was a mistake for vendors to mix packet filtering and route filtering
in the first place and the draft should not insinuate that the model will
be augmented to do this.

Thanks,
Acee 

On 10/20/17, 5:37 PM, "netmod on behalf of Kent Watsen"
<[email-masked] on behalf of [email-masked]> wrote:

>
>All,
>
>This starts a two-week working group last call on
>draft-ietf-netmod-acl-model-14.
>
>The working group last call ends on November 3.
>Please send your comments to the netmod mailing list.
>
>Positive comments, e.g., "I've reviewed this document
>and believe it is ready for publication", are welcome!
>This is useful and important, even from authors.
>
>Could the authors, explicitly CC-ed on this email, please
>also confirm at this time that they are unaware of any
>IPR related to this draft.
>
>Thank you,
>Netmod Chairs
>
>
>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 25 Oct 2017 18:22:56 -0700

Acee,

Thanks for reviewing the draft.

> On Oct 25, 2017, at 6:21 AM, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Hi Kent, Mahesh, et al,
> 

I used the —tree-line-length=72 as the parameter to generate the tree, and that is why you see the line wrap around.

> in the first place and the draft should not insinuate that the model will

The example is just an example of how the model can be extended. There is no implication that the model will be augmented to support mixing of packet filtering with route filtering.

>> IPR related to this draft.

Mahesh Jethanandani
[email-masked]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 26 Oct 2017 09:46:55 +0000

Hi Mahesh, 

On 10/25/17, 9:22 PM, "Mahesh Jethanandani" <[email-masked]>
wrote:

>I used the —tree-line-length=72 as the parameter to generate the tree,
>and that is why you see the line wrap around.

I guess then you need to manually format it so it fits.

>The example is just an example of how the model can be extended. There is
>no implication that the model will be augmented to support mixing of
>packet filtering with route filtering.

I understand that. However, it is more an example of how it should not be
used. Do you really want to publish this?

Thanks,
Acee

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 26 Oct 2017 12:09:20 +0200 (CEST)

> I guess then you need to manually format it so it fits.

Try --tree-line-length 69.   The reason for this is that the figures
are indented by xml2rfc.  I added this as a recommention to the
tree-diagram draft as well the other day.

/martin

---

From: "Einar Nilsen-Nygaard (einarnn)" <[email-masked]>
Date: Fri, 27 Oct 2017 08:17:02 +0000

I agree with Acee, would like to see the example he mentions removed in case people try to copy it. But otherwise I am happy to see this document published.

Cheers,

Einar

On 26 Oct 2017, at 10:46, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mahesh,

On 10/25/17, 9:22 PM, "Mahesh Jethanandani" <[email-masked]<mailto:[email-masked]>>
wrote:

Acee,

On Oct 25, 2017, at 6:21 AM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Kent, Mahesh, et al,

I have read the draft and support publication. I have two comments on
the
-14 version.

1. The tree diagrams do not fit within the draft pages. Note that
recent
versions of pyang support the —tree-line-length parameter and this may
help.

2. While it is non-normative, I’d prefer to have appendix A.1 removed.
It was a mistake for vendors to mix packet filtering and route filtering
in the first place and the draft should not insinuate that the model
will
be augmented to do this.

Thanks,
Acee

Thanks,
Acee

On 10/20/17, 5:37 PM, "netmod on behalf of Kent Watsen"
<[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

All,

Thank you,
Netmod Chairs

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod