Subject: Re: [netmod] I-D Action: draft-ietf-netmod-schema-mount-07.txt

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 05 Oct 2017 14:52:31 +0200

Martin Bjorklund <[email-masked]> writes:

> Hi,
>
> This version fixes the XPath context for parent-reference.
>
>
> However, there is one more thing to discuss, which is the term "mount
> point".  
>
> The current text says:
>
>    - mount point: container or list node whose definition contains
>      the "mount-point" extension statement. The argument of the
>      "mount-point" statement defines the name of the mount point.
>
>
> So if we have:
>     
>   container top {
>     container root {
>       yangmnt:mount-point ni;
>     }
>   }
>     
> There is one mount point, the node /top/root, with the name "ni".
>
> Pretty confusing...   Does anyone have any comments around this?

What about this?

OLD

    - mount point: container or list node whose definition contains
      the "mount-point" extension statement. The argument of the
      "mount-point" statement defines the name of the mount point.

NEW

    - mount point: container or list node whose definition contains
      the "mount-point" extension statement. The argument of the
      "mount-point" statement defines a label that is used for
      referencing the mount point.

Lada

>
>
>
> /martin
>
>
>
>
>
> [email-masked] wrote:
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the Network Modeling WG of the IETF.
>> 
>>         Title           : YANG Schema Mount
>>         Authors         : Martin Bjorklund
>>                           Ladislav Lhotka
>> 	Filename        : draft-ietf-netmod-schema-mount-07.txt
>> 	Pages           : 27
>> 	Date            : 2017-09-27
>> 
>> Abstract:
>>    This document defines a mechanism to combine YANG modules into the
>>    schema defined in other YANG modules.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-netmod-schema-mount/
>> 
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-netmod-schema-mount-07
>> https://datatracker.ietf.org/doc/html/draft-ietf-netmod-schema-mount-07
>> 
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-schema-mount-07
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________
>> netmod mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netmod
>> 
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: "t.petch" <[email-masked]>
Date: Fri, 6 Oct 2017 12:39:01 +0100

----- Original Message -----
From: "Ladislav Lhotka" <[email-masked]>
Sent: Thursday, October 05, 2017 1:52 PM

Lada

Trouble is 'label' is not a defined term in RFC7950 which leaves me (and
others) wondering what is this undefined concept.  I know plenty of
languages that have the concept of a label but YANG is not one of them.

I looked to see what the ABNF says for inspiration but there isn't
any:-)  I think that there should be.

I looked for a worked example for inspiration, nope, none of them
either!   What I mean is that in e.g. A.3  mount point with name root
appears, but that is the only instance of 'root'.  The whole point is
that root should appear more than once, once for where the mount will
be, and then once or more times for the part that will be mounted, so an
example where name appears once is not an example IMHO!

Tom Petch

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 09 Oct 2017 10:44:35 +0200

t.petch píše v Pá 06. 10. 2017 v 12:39 +0100:
> > > However, there is one more thing to discuss, which is the term
> 
> "mount
> > > point".
> > > 
> > > The current text says:
> > > 

The argument of the "schema-mount" extension is used exclusively for the
purposes of schema mount so it is fully appropriate that the term "label" is
unknown to RFC 7950. In fact, the problem that Martin pointed to is that data
nodes in RFC 7950 already have their name and now we are introducing the same
term with a different meaning.

Lada

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 10 Oct 2017 13:47:54 +0200 (CEST)

> languages that have the concept of a label but YANG is not one of them.

As Lada explained, currently we have two meanings of the term "mount
point name" - it means both the name of the container/list node, and
the argument to the extension.  So the idea is to have a different
term for the latter.

> example where name appears once is not an example IMHO!

I don't understand this.  Can you elaborate?

/martin