Subject: [netmod] Clarification wanted regarding applicability of YANG 1.1 issues list to YANG 1.0 implementations

From: "Ivory, William" <[email-masked]>
Date: Fri, 20 Oct 2017 09:57:27 +0000

Hi,

I've asked about evaluating must statements on unconfigured non-presence containers here before, but realise I never got a definitive answer on whether the clarification in the YANG 1.1 issues list actually applies to YANG 1.0, or only YANG 1.1:

YANG 1.0 XPATH context: https://tools.ietf.org/html/rfc6020#section-6.4.1

  *   No mention of non-presence containers

YANG 1.0 errata: https://www.rfc-editor.org/errata_search.php?rfc=6020

  *   No mention of non-presence containers

YANG 1.1 Issues list: http://svn.tools.ietf.org/svn/wg/netmod/yang-1.1/issues.html#sec-42

  *   Clarification of handling of non-presence containers for XPATH context / validation

YANG 1.1 XPATH context: https://tools.ietf.org/html/rfc7950#section-6.4.1

  *   'If a node that exists in the accessible tree has a non-presence container as a child, then the non-presence container also exists in the accessible tree.'

As you can see from the links above, the errata for YANG 1.0 does NOT include the clarification, whereas the text of YANG 1.1 (RFC 7950) does.

Thanks,

William

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 23 Oct 2017 10:38:09 +0200 (CEST)

Hi,

The problem is that this behavior was underspecified in YANG 1.  Fixed
in YANG 1.1, but it means that you can't expect the behavior for YANG
1 modules to be the same in different servers.

/martin

"Ivory, William" <[email-masked]> wrote:
> Hi,
> 
> I've asked about evaluating must statements on unconfigured
> non-presence containers here before, but realise I never got a
> definitive answer on whether the clarification in the YANG 1.1 issues
> list actually applies to YANG 1.0, or only YANG 1.1:
> 
> YANG 1.0 XPATH context:
> https://tools.ietf.org/html/rfc6020#section-6.4.1
> 
> YANG 1.1 Issues list:
> http://svn.tools.ietf.org/svn/wg/netmod/yang-1.1/issues.html#sec-42
> 
>   *   Clarification of handling of non-presence containers for XPATH context
>   *   / validation
> 
> YANG 1.1 XPATH context:
> https://tools.ietf.org/html/rfc7950#section-6.4.1
> 
>   *   'If a node that exists in the accessible tree has a non-presence
>   *   container as a child, then the non-presence container also exists in
>   *   the accessible tree.'
> 
> As you can see from the links above, the errata for YANG 1.0 does NOT
> include the clarification, whereas the text of YANG 1.1 (RFC 7950)
> does.
> 
> Thanks,
> 
> William