Subject: [netmod] comments to draft-ietf-netmod-revised-datastores-01 on the IETF98 meeting

From: "Zhengguangying (Walker)" <[email-masked]>
Date: Tue, 28 Mar 2017 15:03:55 +0000

Hi Martin,

      My comments is why it need YANG modules change there definition?  datastore is the conception of system datastore mechinism,  we can use filter or common top level YANG modul to support multi datastore.

     But, if ask YANG modules to change their definition to use split tree, it will bound the datastore logic to YANG modules, it not looks like a good idea,  because all YANG modules should change and know the datastore.

     So, my suggestion is not sue split tree in YANG modules, but support it by netconf or another new TOP level YANG module.

Thanks

Zheng guangying (walker)  From Huawei

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 28 Mar 2017 10:30:04 -0500

> On Mar 28, 2017, at 10:03 AM, Zhengguangying (Walker) <[email-masked]> wrote:
> 
> Hi Martin,
>  

I do not think there is anything in the proposal that says that YANG modules will be bound to a particular datastore, or that they need to know about the different datastores a particular implementation supports.

The suggestion to collapse the config and state part of the tree is to avoid data getting duplicated as a result of implementation of the new datastore concept.

> _______________________________________________
> Netconf mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
Mahesh Jethanandani
[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 28 Mar 2017 11:52:43 -0400

I2RS Topology modules are being design to work in configuration datastore or
I2RS datastore. 

Sue 

From: Netconf [mailto:[email-masked]] On Behalf Of Mahesh
Jethanandani
Sent: Tuesday, March 28, 2017 11:30 AM
To: Zhengguangying (Walker)
Cc: [email-masked]; [email-masked]
Subject: Re: [Netconf] comments to draft-ietf-netmod-revised-datastores-01
on the IETF98 meeting

On Mar 28, 2017, at 10:03 AM, Zhengguangying (Walker)
<[email-masked]> wrote:

Hi Martin,

      My comments is why it need YANG modules change there definition?
datastore is the conception of system datastore mechinism,  we can use
filter or common top level YANG modul to support multi datastore.

     But, if ask YANG modules to change their definition to use split tree,
it will bound the datastore logic to YANG modules, it not looks like a good
idea,  because all YANG modules should change and know the datastore.

I do not think there is anything in the proposal that says that YANG modules
will be bound to a particular datastore, or that they need to know about the
different datastores a particular implementation supports.

The suggestion to collapse the config and state part of the tree is to avoid
data getting duplicated as a result of implementation of the new datastore
concept.

     So, my suggestion is not sue split tree in YANG modules, but support it
by netconf or another new TOP level YANG module.

Thanks

_______________________________________________
Netconf mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/netconf>
https://www.ietf.org/mailman/listinfo/netconf

Mahesh Jethanandani

[email-masked]