Subject: [netmod] I-D Action: draft-ietf-netmod-entity-03.txt

From: [email-masked]
Date: Mon, 13 Mar 2017 00:43:53 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the NETCONF Data Modeling Language of the IETF.

        Title           : A YANG Data Model for Hardware Management
        Authors         : Andy Bierman
                          Martin Bjorklund
                          Jie Dong
                          Dan Romascanu
	Filename        : draft-ietf-netmod-entity-03.txt
	Pages           : 40
	Date            : 2017-03-13

Abstract:
   This document defines a YANG data model for the management of
   hardware on a single server.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-entity/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-netmod-entity-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-entity-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 13 Mar 2017 08:46:51 +0100 (CET)

Hi,

This version addresses the comments from Bart and Juergen.

I think that this document is now ready for WGLC.

/martin

[email-masked] wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Benoit Claise <[email-masked]>
Date: Mon, 13 Mar 2017 10:26:37 +0100

Hi Martin,

[email-masked] fails yanglint validation.
See http://www.claise.be/IETFYANGPageCompilation.html

Regards, Benoit
> .

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 13 Mar 2017 10:43:36 +0100 (CET)

> See http://www.claise.be/IETFYANGPageCompilation.html

This is a bug in yanglint.  The leafref is marked as 'require-instance
false', which means it can refer to a non-config leaf.

/martin

---

From: Benoit Claise <[email-masked]>
Date: Wed, 22 Mar 2017 16:25:50 +0100

Tim, William,

Are we good from a Broadband Forum point of view?
I remember some discussions during the last IETF meeting regarding this 
entity YANG module.

Regards, Benoit

---

From: William Lupton <[email-masked]>
Date: Wed, 22 Mar 2017 15:28:03 -0500

Yes thanks. We are good with it. W.

> On 22 Mar 2017, at 10:25, Benoit Claise <[email-masked]> wrote:
> 
> Tim, William,
> 
> I remember some discussions during the last IETF meeting regarding this entity YANG module.
> 
> Regards, Benoit
>> Hi,
>>

---

From: Alex Campbell <[email-masked]>
Date: Wed, 22 Mar 2017 23:13:30 +0000

Hi,

In the description of /hardware-state/component, which describes the procedure for matching newly added hardware components with pre-configured entries in /hardware/component:

What happens if hardware-config is supported, and there is no entry with matching values for the nodes 'class', 'parent', and 'parent-rel-pos'? (i.e. step 1's condition is not true)
Why is mfg-name treated specially - and not, for example, serial-num?
Why is it recommended for implementations to warn about a mfg-name mismatch, but not a class mismatch?

________________________________________
From: netmod <[email-masked]> on behalf of Martin Bjorklund <[email-masked]>
Sent: Monday, 13 March 2017 8:46 p.m.
To: [email-masked]
Subject: Re: [netmod] I-D Action: draft-ietf-netmod-entity-03.txt

Hi,

/martin