Subject: Re: [netmod] Toolchain upgraded to yangdump-pro 16.10-5 => 16.10-5.1

From: Benoit Claise <[email-masked]>
Date: Mon, 6 Mar 2017 21:50:34 +0100

Dear all,

yangdump-pro upgraded to 16.10-5.1
The stats look better: http://claise.be/IETFYANGPageCompilation.png
See http://www.claise.be/IETFYANGPageCompilation.html for the remaining 
open issues on your YANG modules.
Still a week to improve them.

Regards, Benoit
> Dear all,
>
> See http://www.claise.be/IETFYANGPageCompilation.html
> At least two bugs related to the IETF YANG modules are fixed.
> Please check your YANG modules.
>
> Regards, Benoit
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
> .
>

---

From: Kent Watsen <[email-masked]>
Date: Mon, 6 Mar 2017 22:41:21 +0000

Hi Benoit,

You seem to know the ins and outs of many tools these days, maybe you can point me in the right direction...which tool is able to validate instance documents against YANG 1.1 modules?  

I've always used `yang2dsdl`, but currently it outputs "DSDL plugin supports only YANG version 1".

Kent // contributor

---

From: Radek Krejčí <[email-masked]>
Date: Tue, 7 Mar 2017 11:05:37 +0100

Hi Kent,
yanglint should be able to do it for you. Preferably, use the current devel branch (it should be merged into master within a few days).

https://github.com/CESNET/libyang

Regards,
Radek

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 07 Mar 2017 13:42:11 +0100

Kent Watsen <[email-masked]> writes:

> Hi Benoit,
>
> You seem to know the ins and outs of many tools these days, maybe you
> can point me in the right direction...which tool is able to validate
> instance documents against YANG 1.1 modules?

Yangson can validate JSON documents:

https://github.com/CZ-NIC/yangson

> supports only YANG version 1".

I considered updating the DSDL plugin to 1.1 but it turned up to be
immensely difficult - it would basically require a complete rewrite. And
even then, the Schematron implementation that is included in pyang
distribution won't support the new XPath functions.

Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67