Subject: [netmod] ietf-ip open issue

From: Martin Bjorklund <[email-masked]>
Date: Mon, 10 Dec 2012 21:04:38 +0100 (CET)

Hi,

One WGLC comment was if the prefix-length really should have a default
value (32 resp. 128).  There are two options:

  1.  Keep the defaults

  2.  Make prefix-length mandatory

I think I agree with Lada that we should do (2).  The current defaults
are not so common that it saves lots of config to use the default
values.  Comments?

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 10 Dec 2012 21:08:56 +0100

> are not so common that it saves lots of config to use the default

I generally agree with the direction. But how would this work for IPv4
where we have either a prefix-length or a netmask?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 10 Dec 2012 22:18:23 +0100 (CET)

> where we have either a prefix-length or a netmask?

It actually works fine:

        choice subnet {
          mandatory true;
          ...
          leaf prefix-length { ... }
          leaf netmask {
            if-feature ipv4-non-contiguous-netmasks;
            ...
          }
        }

/martin