Subject: [netmod] Fwd: I-D Action: draft-bierman-netconf-yang-api-00.txt

From: Andy Bierman <[email-masked]>
Date: Wed, 30 May 2012 12:53:56 -0700

FYI,

Martin and I wrote a draft defining an HTTP-based API integrated
with NETCONF, using YANG data models.  We would like to discuss
this draft at the Vancouver IETF meeting.

thanks,
Andy

-------- Original Message --------
Subject: 	I-D Action: draft-bierman-netconf-yang-api-00.txt
Date: 	Wed, 30 May 2012 12:45:10 -0700
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : YANG-API Protocol
	Author(s)       : Andy Bierman
                           Martin Bjorklund
	Filename        : draft-bierman-netconf-yang-api-00.txt
	Pages           : 83
	Date            : 2012-05-30

    This document describes a RESTful protocol that provides a
    programmatic interface over HTTP for accessing data defined in YANG,
    using the datastores defined in NETCONF.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-bierman-netconf-yang-api-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-bierman-netconf-yang-api-00.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-bierman-netconf-yang-api/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Kent Watsen <[email-masked]>
Date: Wed, 30 May 2012 13:51:11 -0700

The email from Mehmet on Mar 30 indicated that, in the WG session in Paris, it had "been proposed, for the time being, to not plan the REST API as a chartered document".   I'd assumed that "for the time being" would be more than two months, or was it intended to bring a more concrete proposal to the next IEFT meeting?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Wednesday, May 30, 2012 3:54 PM
To: NETCONF; NETMOD Working Group
Subject: [Netconf] Fwd: I-D Action: draft-bierman-netconf-yang-api-00.txt

FYI,

thanks,
Andy

-------- Original Message --------
Subject: 	I-D Action: draft-bierman-netconf-yang-api-00.txt
Date: 	Wed, 30 May 2012 12:45:10 -0700
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Andy Bierman <[email-masked]>
Date: Wed, 30 May 2012 14:05:13 -0700

> The email from Mehmet on Mar 30 indicated that, in the WG session in Paris, it had "been proposed, for the time being, to not plan the REST API as a chartered document".   I'd assumed that "for the…

Maybe NETCONF is not the proper WG to propose an HTTP/REST protocol.
That is one of the open issues.  A concrete proposal is needed to move
discussion forward, regardless of the mailing list used.

Anyone can propose a draft at any time.
Whether or not (and when) it gets chartered by a WG is another matter.
We've been discussing Netconf Light for almost a year, and it isn't
chartered yet. The SNMP config draft in NETMOD  was first published in October 2010
and that is not chartered yet.  We have a long history of creating long history
out of the standards process ;-)

Andy