Subject: [netmod] common yang data types - 6021bis

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 30 Mar 2012 12:27:06 +0200

Hi,

I have been working with Martin on some of the data models and it
turns out there are some types that we forgot to define when RFC 6021
was created. The most visible example is a hex-string data type.

While we could put missing type definitions in more or less random
places, it seems a cleaner approach would be to start a 6021bis where
we add more common types and which we submit for publication about the
time we are done with all the other modules. (Since the 6021bis will
only contain some additional type definitions, I assume it will be
easy to progress it through the IESG.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Fri, 30 Mar 2012 09:45:49 -0400

This isn't directly related to 6021 data types, more of an addition to the ietf-inet-types , however one datatype that I found myself implementing that would be nice to have as a standard type would be a ip/prefix type that isn't limited to just specifying the prefix,  There is currently the ipv4-prefix and ipv6-prefix which has the exact syntax that I'm looking for however the stipulation that all lower bits past the prefix length means that I have to define my own data type to allow someone to apply an IP address using the notation "dead:beef::1/64"

Thanks,
-Jeff

Jeff Lange
Lead Software Engineer
GE Digital Energy - MDS
 
T: +1 585 242 8375
F: +1 585 241 5590
E: [email-masked] 
www.GEDigitalEnergy.com
 
175 Science Parkway
Rochester, NY, 14620, USA

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Friday, March 30, 2012 6:27 AM
To: [email-masked]
Subject: [netmod] common yang data types - 6021bis

Hi,

I have been working with Martin on some of the data models and it turns out there are some types that we forgot to define when RFC 6021 was created. The most visible example is a hex-string data type.

While we could put missing type definitions in more or less random places, it seems a cleaner approach would be to start a 6021bis where we add more common types and which we submit for publication about the time we are done with all the other modules. (Since the 6021bis will only contain some additional type definitions, I assume it will be easy to progress it through the IESG.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod