Subject: Re: [netext] Consensus call on adopting I-D draft-liebsch-netext-pmip6-qos as WG document

From: <[email-masked]>
Date: Tue, 5 Jun 2012 16:37:03 +0000

I support the adoption of this I-D as a WG document. I would however, recommend to the authors to 
consider the following RFC in their next design steps!

Requirements of a Quality of Service (QoS) Solution for Mobile IP, see:
http://www.rfc-editor.org/rfc/rfc3583.txt

This RFC provides an useful insight into the Mobile IP QoS issue, which could also apply for the Proxy Mobile IP QoS issue!

 Should the Netext WG adopt this I-D as a WG document?
 
Yes   [X]
 No    [  ]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Carl Williams
> Sent: woensdag 30 mei 2012 15:51
> To: [email-masked]; [email-masked]
> Subject: Re: [netext] Consensus call on adopting I-D draft-liebsch-netext-
> pmip6-qos as WG document
> 
> I support the adoption of this I-D as a WG document.
> 
> Please review the I-D and respond by June 6th with your opinion.
> Respond to the following question:
> 
> Should the Netext WG adopt this I-D as a WG document?
> 
> Yes   [X]
> No    [  ]
> 
> 
> 
> On 5/23/12 3:01 PM, "[email-masked]"
> <[email-masked]> wrote:
> 
> >
> >Please review the I-D and respond by June 6th with your opinion.
> >Respond to the following question:
> >
> >Should the Netext WG adopt this I-D as a WG document?
> >
> >Yes   [  ]
> >No    [  ]
> >
> 
> 
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 6 Jun 2012 09:30:49 +0000

Hi Dirk,
while looking at your comments again to compile an update of the draft,
I saw that I did not address your question..

I understand your question addresses two situations: 
(1) The FMC (or better: FMInterworking), where the handover target for
non-cellular access may be in a different administrative domain as the LMA
(2) Your second scenario seems to address a DMM case where handover
results in assignment of a new LMA, possibly in a different administrative
domain.

Is this correct?

As for (1) I see definitely an advantage in using the QoS option for bootstrapping
QoS in the handover target network without being dependent on a PCC system.

For (2) the proposed mechanisms work if there is transfer of QoS context between
LMAs during handover, in my opinion, as we consider the LMA as controlling instance (initiation of
QoS settings and validation in case the MAG proposes QoS settings). 

marco

>Of Marco Liebsch
>Sent: Mittwoch, 30. Mai 2012 14:43
>To: [email-masked]; [email-masked]; [email-masked]
>Hi Dirk,
>thanks for spotting the nits, we'll take them into account in the next revision.
>
>marco
>
>>From: [email-masked] [mailto:[email-masked]] On
>>Behalf Of [email-masked]
>>Sent: Mittwoch, 30. Mai 2012 10:32
>>Subject: Re: [netext] Consensus call on adopting I-D
>>draft-liebsch-netext- pmip6-qos as WG document
>>
>>Hi all, chairs and authors,
>>
>>Yes   [x ]
>>I also agree to accept the draft as WG document since the proposal
>>extends
>>PMIP6 signaling but does not require new MN interaction for QoS support
>>during HO between cellular and non-cellular (and vice versa as proposed
>>in Use Case B, right?).
>>If I understood correctly a HO between networks under different
>>operators control (and between different LMAs) is not within scope, right?
>>
>>Some nits I detected ...
>>On p.10:
>>, which is is a => , which is a
>>(i.e. pBA). => (i.e. PBA). (assuming it is Proxy Binding
>>Acknowledgement) On
>>p.20:
>>Priority-Level: is of type unsigned 32 bit integer, and it used => Priority-Level:
>>is of type unsigned 32 bit integer, and is used
>>
>>Thanks and best regards!
>>Dirk
>>
>>-----Ursprüngliche Nachricht-----
>>Von: [email-masked] [mailto:[email-masked]] Im
>>Auftrag von [email-masked]
>>Gesendet: Mittwoch, 23. Mai 2012 21:02
>>An: [email-masked]
>>Betreff: [netext] Consensus call on adopting I-D
>>draft-liebsch-netext-pmip6- qos as WG document
>>
>>
>>Hello,
>>
>>The authors of the I-D: Quality of Service Option for Proxy Mobile IPv6
>><draft-
>>liebsch-netext-pmip6-qos> http://www.ietf.org/id/draft-liebsch-netext-
>>pmip6-qos-01.txt
>>
>>have requested the adoption of this I-D as a WG document.
>>The I-D itself has been presented at IETF83 and has also been reviewed
>>by multiple WG members.
>>
>>The crux of the proposal is to extend PMIP6 signaling to enable support
>>for QoS.
>>
>>Abstract
>>
>>   This specification defines a new mobility option that can be used by
>>   the mobility entities in the Proxy Mobile IPv6 domain to exchange
>>   Quality of Service parameters associated with a subscriber's IP
>>   flows.  Using the QoS option, the local mobility anchor and the
>>   mobile access gateway can exchange available QoS attributes and
>>   associated values.  This enables QoS policing and labeling of packets
>>   to enforce QoS differentiation on the path between the local mobility
>>   anchor and the mobile access gateway.  Furthermore, making QoS
>>   parameters available on the MAG enables mapping these parameters to
>>   QoS rules being specific to the access technology which operates
>>   below the mobile access gateway.  After such mapping, QoS rules can
>>   be enforced on the access technology components, such as an IEEE
>>   802.11e Wireless LAN controller.
>>
>>
>>Thank you.
>>-Chairs

---

From: <[email-masked]>
Date: Wed, 6 Jun 2012 17:43:23 +0200

Hi Marco,
Thanks, right - my original question was on different LMAs not mentioned in the draft. So the answer is: handover and subsequent exchange of the QoS context between MAGs belonging to LMAs within different domains is not excluded, right?
I think that the reason why it is not mentioned explicitly is that just standard PMIPv6 procedures apply. The new MAG after MN attachment will via PBU/PBA to its (new) LMA learn about the old LMA (Similarily to MIP6 any MAG can perform dynamic LMA discovery via the LMA list available at the serving LMA to dettect an other LMA related to the MNs HNP) - and subsequently via PBU/PBA between new MAG and old LMA exchange QoS context. This allows for (indirect) transfer of QoS oprions between LMAs at different administrative domains (without both being connected to same PCF), right?
However it seems that such a procedure may take some time before the new QoS is established at the new LMA ... And for to achieve a more seamless handover an optimization may be up for future work  - or have I missed something?
Thanks a lot for clarification (or confirmation ;-))

Best regards
Dirk
-----Ursprüngliche Nachricht-----
Von: Marco Liebsch [mailto:[email-masked]]
Gesendet: Mittwoch, 6. Juni 2012 11:31
An: von Hugo, Dirk; [email-masked]; [email-masked]
Betreff: RE: [netext] Consensus call on adopting I-D draft-liebsch-netext-pmip6-qos as WG document

Hi Dirk,

Is this correct?

marco

---

From: Marco Liebsch <[email-masked]>
Date: Fri, 8 Jun 2012 14:42:27 +0000

Dirk, please see inline.

>From: [email-masked] [mailto:[email-masked]]
>Sent: Mittwoch, 6. Juni 2012 17:43
>To: Marco Liebsch; [email-masked]; [email-masked]
>Subject: AW: [netext] Consensus call on adopting I-D draft-liebsch-netext-
>pmip6-qos as WG document
>
>Hi Marco,
>Thanks, right - my original question was on different LMAs not mentioned in
>the draft. So the answer is: handover and subsequent exchange of the QoS
>context between MAGs belonging to LMAs within different domains is not
>excluded, right?

We don't describe this case in the document but refer to a stable anchor
in the current description and handover between MAGs according to
RFC5213 operation.

>I think that the reason why it is not mentioned explicitly is that just standard
>PMIPv6 procedures apply. The new MAG after MN attachment will via
>PBU/PBA to its (new) LMA learn about the old LMA (Similarily to MIP6 any
>MAG can perform dynamic LMA discovery via the LMA list available at the
>serving LMA to dettect an other LMA related to the MNs HNP) - and
>subsequently via PBU/PBA between new MAG and old LMA exchange QoS
>context. This allows for (indirect) transfer of QoS oprions between LMAs at
>different administrative domains (without both being connected to same
>PCF), right?

If you consider sequential operation, first moving to a different MAG, then
subsequently moving to a different LMA while remaining at the current MAG,
I think the option can help to convey the QoS context (from previous LMA to
new MAG, then to the new LMA) to a new peer of LMA/MAG.

>However it seems that such a procedure may take some time before the new
>QoS is established at the new LMA ... And for to achieve a more seamless
>handover an optimization may be up for future work  - or have I missed
>something?

If my understanding of your proposal according to my feedback above is correct,
there is more to be done than establishing QoS context at a new LMA. This looks
more like a DMM use case to me.

>Thanks a lot for clarification (or confirmation ;-))

Hope it was clarification or confirmation and no confusion ;-)

marco

>while looking at your comments again to compile an update of the draft, I saw
>that I did not address your question..
>
>(1) The FMC (or better: FMInterworking), where the handover target for non-
>cellular access may be in a different administrative domain as the LMA
>As for (1) I see definitely an advantage in using the QoS option for
>bootstrapping QoS in the handover target network without being dependent
>on a PCC system.
>
>For (2) the proposed mechanisms work if there is transfer of QoS context
>between LMAs during handover, in my opinion, as we consider the LMA as
>controlling instance (initiation of QoS settings and validation in case the MAG
>proposes QoS settings).
>
>marco
>
>>Behalf Of Marco Liebsch
>>>PMIP6 signaling but does not require new MN interaction for QoS
>>>support during HO between cellular and non-cellular (and vice versa as
>>>proposed in Use Case B, right?).
>>>The crux of the proposal is to extend PMIP6 signaling to enable
>>>support for QoS.
>>>
>>>Abstract
>>>

---

From: <[email-masked]>
Date: Mon, 11 Jun 2012 11:06:11 +0200

Hi Marco,
Thanks for your time and effort to clarify. I agree that with increasing amount of LMAs in (parallel) operation we clearly arrive at (here: PMIP-based) DMM use cases.
No confusion any more :-)

Thanks again and Best regards
Dirk
-----Ursprüngliche Nachricht-----
Von: Marco Liebsch [mailto:[email-masked]]
Gesendet: Freitag, 8. Juni 2012 16:42
An: von Hugo, Dirk; [email-masked]; [email-masked]
Betreff: RE: [netext] Consensus call on adopting I-D draft-liebsch-netext-pmip6-qos as WG document

Dirk, please see inline.

marco