Subject: Re: [netext] AD review of draft-ietf-netext-bulk-re-registration

From: Jari Arkko <[email-masked]>
Date: Mon, 02 Jan 2012 13:02:02 +0200

Sri: any updates on the draft coming soon? I'd like to move the draft forward.

Jari

On 23.11.2011 02:41, Jari Arkko wrote:
> Ok.  You have clearly understood the issue, and I'll wait until you've updated the draft. Thanks.
>
> jari
>

---

From: Sri Gundavelli <[email-masked]>
Date: Mon, 02 Jan 2012 11:16:41 -0800

Hi Jari:

Sorry for the delay. This is just on time, was about to post it today and I
just did (draft-ietf-netext-bulk-re-registration-09). This should address
all the issues that you have identified in your review.

- Clarification on MAG sending the Bulk binding update identifiers
- Example call flow with details
- Number of editorial changes for consistency
- Updates to processing rules

This should be technically correct, I'm hoping, ignoring any nits.

Regards
Sri

---

From: Jari Arkko <[email-masked]>
Date: Tue, 03 Jan 2012 10:33:14 +0200

Sri:

Thanks for the update! I have reviewed the changes and they look good to me with one exception (below). I have in any case requested an IETF Last Call to be initiated and expect that you fix the remaining issues by issuing yet another draft quickly.

But the changes are pretty big -- it would also be useful if members of the WG reviewed the document while it is in the Last Call.

> o  When sending the Mobile Node Group Identifier option in the
>   binding update messages related to the individual session
>   establishment, the Bulk-Binding-Update (B) flag in the request
>   MUST be set to a value of (1).  However, when initiating any
>   binding update operations with group specific scope, the Bulk-
>   Binding-Update (B) flag in the request MUST always be set to a
>   value of (0), with the Mobile Node Group Identifier option present
>   in the request.

There is something wrong with the above text. B must be set in the session establishment, but not with "binding update operations with group specific scope"? (And what are those?)

Jari

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 03 Jan 2012 08:32:41 -0800

> 
> There is something wrong with the above text. B must be set in the session
> establishment, but not with "binding update operations with group specific
> scope"? (And what are those?)
> 

Hi Jari:

Thanks for the review.

There are two cases here:

1.) Establishment of the initial session for a given mobile node as in today
- the approach of group id exchange for that session to be established

2.) Performing a bulk binding operation on a group of mobile nodes/sessions
that are part of a given group - Ex: Periodic BU for lifetime extension

In both these cases, there is a PBU and there is the Group Identifier
option. In #1, the MAG presents the group identifier for that mobile node,
so the LMA can associate the group id with that session.  In #2, the MAG
wants the binding operation to be performed on a set of nodes/sessions
identified by the group id, that was previously exchanged.

The (B) flag for #1 is enabled. It serves as the means to request the LMA to
enable bulk binding operation for a given mobility session. The LMA can
accept the request, set the (B) flag in the PBA and return its own local
group id for that session. Or, simply can decide not to enable bulk binding
update feature for that session, by turning of the (B) flag in the PBA.

In case of #2, once the sessions are established and associated with a group
id, the Group Identifier in the option alone is sufficient, there is no need
for toggling the (B) flag in the PBU/PBA.

We can make the logic work, eliminating the (B) flag entirely, even for #1,
but the logic gets complex, looking at individual session identifier
presence (Mobile Node identifier option ..IPv4 Home Address option) ..etc.

Regards
Sri

On 1/3/12 12:33 AM, "Jari Arkko" <[email-masked]> wrote:

> Sri:
> 
> Thanks for the update! I have reviewed the changes and they look good to me
> with one exception (below). I have in any case requested an IETF Last Call to
> be initiated and expect that you fix the remaining issues by issuing yet
> another draft quickly.
> 
> But the changes are pretty big -- it would also be useful if members of the WG
> reviewed the document while it is in the Last Call.
> 
> There is something wrong with the above text. B must be set in the session
> establishment, but not with "binding update operations with group specific
> scope"? (And what are those?)
> 
> Jari
>

---

From: <[email-masked]>
Date: Fri, 6 Jan 2012 09:51:19 +0100

Dear all,

Referring to the suggested additional WG reviews of the updated draft I want to share with you the minor nits I found ;-)

1. Intro

provides a more optimal mechanism => provides a considerably improved mechanism
(afaik 'optimal' already denotes the best)

3.1. Motivation

revocation operations on a group on mobility sessions => revocation operations on a group of mobility sessions

3.2. General Operation

P.7
respectively, while the LMA assigns them both to the same to the
bulk
=> respectively, while the LMA assigns them both to the same bulk

part of bulk binding update group, L1.  =>  part of bulk binding update group, (L1).

4.1 Extensions to Proxy Binding Update Message

Figure 2 => Figure 2: Proxy Binding Update Message
(to have consistency to 4.2.)

'bulk binding operation group' (occurs 3 times in the draft, see p.12) is not defined?! Shouldn't it read => 'bulk binding update group' ?

group and thus any any binding update => group and thus any binding update

5.1 MAG Considerations

identifies the list of bulk binding update group specific to each
=> identifies the list of bulk binding update groups specific to each

5.1.1

Proxy Binding Update message.  If there is no such grouping is
=> Proxy Binding Update message.  If there is no such grouping

5.2.1.

given mobility session to a specific bulk binding update group is
=> given mobility session to a specific bulk binding update group are

P.16
if the if the received Proxy Binding Update from the new mobile
=> if the received Proxy Binding Update from the new mobile

5.2.2

Currently, this specification only support sub-type value of (1)
=> Currently, this specification only supports sub-type value of (1)

0 (Proxy Binding Update accepted).  => (0) (Proxy Binding Update accepted).

6.2. Mobile Access Gateway - Configuration Variables

this flag is set to (1), indicating that the the mobile access
=> this flag is set to (1), indicating that the mobile access

9. Acknowledgements

Patil Carlos Jesus Bernardos Cano and Jari Arkko for their reviews
=> Patil, Carlos Jesus Bernardos Cano, and Jari Arkko for their reviews

Thanks and best regards
Dirk

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Jari Arkko
Gesendet: Dienstag, 3. Januar 2012 09:33
An: Sri Gundavelli
Cc: [email-masked]; [email-masked]
Betreff: Re: [netext] AD review of draft-ietf-netext-bulk-re-registration

Sri:

Jari

_______________________________________________
netext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netext

---

From: Jari Arkko <[email-masked]>
Date: Fri, 06 Jan 2012 12:15:28 +0200

Thanks for your detailed review.

Jari

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 06 Jan 2012 07:53:49 -0800

Hi Dirk:

Thanks for the review. I'm working on an update, will fix these issues.

Regards
Sri

On 1/6/12 12:51 AM, "[email-masked]" <[email-masked]>
wrote:

> Dear all,
> 
> Referring to the suggested additional WG reviews of the updated draft I want
> to share with you the minor nits I found ;-)
> 
> 1. Intro
> 
> 'bulk binding operation group' (occurs 3 times in the draft, see p.12) is not
> defined?! Shouldn't it read => 'bulk binding update group' ?
>

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 10 Jan 2012 23:01:16 -0800

Hi Jari:

Updated doc posted. Addressed all the comments from Dirk. Mostly editorial,
expect one change. Diff appears to be large, given that I touched many part
of the doc.

- Change from a 16-bit sub-type to a 8-bit value, and the use of reserved
field, in the Mobile Node Group Identifier option
- Editorial changes for consistency with some minor rewrites

Regards
Sri

---

From: Jari Arkko <[email-masked]>
Date: Wed, 11 Jan 2012 09:42:56 +0200

Thanks for the update!

Jari

On 11.01.2012 09:01, Sri Gundavelli wrote:
> On 1/3/12 12:33 AM, "Jari Arkko"<[email-masked]>  wrote:
>
>> Sri:
>>