Subject: Fwd: [midcom] DHCP option - trying again

From: Melinda Shore <[email-masked]>
Date: Sat, 3 Apr 2004 07:40:00 -0500

Begin forwarded message:

> From: "Vikram Nair" <[email-masked]>
> Date: Sat Apr 3, 2004  2:09:56 AM US/Eastern
> To: "Melinda Shore" <[email-masked]>, <[email-masked]>
> Subject: Re: [midcom] DHCP option - trying again
> Reply-To: "Vikram Nair" <[email-masked]>
>
> Hi,
>
>     Myself always in favour of autoconfiguration as much
>     as possible.
>
>     No reservation as such to go with extending DHCP. Definitely
>     a plus for midcom.
>
>     But just wondering, IPv6 itself advocates autoconfiguration
>     of the clients (including next-hops). Why not explore the
>     extension on the same lines.
>
> regards,
> - Vikram
>
> ----- Original Message -----
> From: "Melinda Shore" <[email-masked]>
> To: <[email-masked]>
> Sent: Friday, April 02, 2004 11:30 PM
> Subject: [midcom] DHCP option - trying again
>
>
>> As I mentioned earlier this week, there's a new proposal to use DHCP 
>> to
>> configure middlebox addresses into endpoints.  Is this something the 
>> WG
>> should take on?
>>
>> Melinda
>>
>>
>> _______________________________________________
>> midcom mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/midcom
>>
>

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 05 Apr 2004 16:11:20 +0200

Hi all,

|
|> From: "Vikram Nair" <[email-masked]>
|> Date: Sat Apr 3, 2004  2:09:56 AM US/Eastern
|> To: "Melinda Shore" <[email-masked]>, <[email-masked]>
|> Subject: Re: [midcom] DHCP option - trying again
|> Reply-To: "Vikram Nair" <[email-masked]>
|>
|> Hi,
|>
|>     Myself always in favour of autoconfiguration as much
|>     as possible.

I'm too.

|>
|>     No reservation as such to go with extending DHCP. Definitely
|>     a plus for midcom.
|>
|>     But just wondering, IPv6 itself advocates autoconfiguration
|>     of the clients (including next-hops). Why not explore the
|>     extension on the same lines.

Yes, IPv6 does offer stateless autoconfiguration. Anyway, transporting IP 
addresses of MIDCOM-type middleboxes is more a 'service' configuration and 
probably not at the level of IPv6 address autoconfiguration. The MIDCOM 
service would be more like SIP proxy, meaning that this should go to DHCP 
instead of IPv6 autoconfiguration.

Regards,

  Martin

Martin Stiemerling

NEC Europe Ltd. -- Network Laboratories [email-masked]
PGP Key at:        http://www.stiemerling.org/stiemerling_nec.gpg
IPv4: http://www.ccrle.nec.de  IPv6: http://www.ipv6.ccrle.nec.de

|>
|> regards,
|> - Vikram
|>
|> ----- Original Message -----
|> From: "Melinda Shore" <[email-masked]>
|> To: <[email-masked]>
|> Sent: Friday, April 02, 2004 11:30 PM
|> Subject: [midcom] DHCP option - trying again
|>
|>
|>> As I mentioned earlier this week, there's a new proposal to use DHCP
|>> to
|>> configure middlebox addresses into endpoints.  Is this something the
|>> WG
|>> should take on?
|>>
|>> Melinda
|>>
|>>
|>> _______________________________________________
|>> midcom mailing list
|>> [email-masked]
|>> https://www1.ietf.org/mailman/listinfo/midcom
|>>
|>
|
|
| _______________________________________________
| midcom mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/midcom

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 05 Apr 2004 19:39:47 +0200

Vikram,

>>     extension on the same lines.

Thank you for this hint.

Yes, you are right: IPv6 offers stateless autoconfiguration.  This is a
feature that is very useful for open network, such as dial-in access or
WLAN hot spots, but not for any controlled infrastructue.  In a company
network you would not like to allow any host to connect to the LAN without
checking its MAC address or other authentication.  That's when you need
DHC for IPv6 address assignment.

    Juergen