Subject: [midcom] Re: [MMUSIC] Status of TURN

From: "Pete Cordell" <[email-masked]>
Date: Wed, 15 Oct 2003 13:47:09 +0100

Dear Jon,

I'm very surprised to see that TURN is being encouraged to be put forward as
an individual submission.  We believe that TURN has major security flaws, is
incomplete, and there are better ways of achieving Symmetric NAT traversal.
Suggesting it should become an RFC without debate and full consideration
would be wrong.

If you remember, TURN was just one of the candidates put forward as a
pre-Midcom solution that at that time was put aside in favour of developing
a consensus protocol.   Despite our commitment, consensus wasn't reached,
mainly due to the amount of effort that was being put into SIP (RFC3261) by
other important stake holders.

We feel that to arbitrarily promote TURN at this time is short cutting the
consensus making process.  Surely, if there is sufficient interest in a
standard of this nature, the correct way forward is to assign it as a work
item in a suitable group and re-start the consensus process. If so, we
remain willing to help with time, resource and considerable technical
know-how. Several significant developments have meant the world of Symmetric
NAT traversal has advanced considerably since the pre-Midcom days.

Regards,

Pete.

=============================================
Pete Cordell
Ridgeway
=============================================

----- Original Message -----
From: "Peterson, Jon" <[email-masked]>
To: "'Joel Tran'" <[email-masked]>; "Jonathan Rosenberg"
<[email-masked]>; "Mmusic" <[email-masked]>
Sent: 09 October 2003 17:08
Subject: RE: [MMUSIC] Status of TURN

>
> The Transport Area Directors understand that this document will proceed as
> an individual submission, outside the context of any of the working groups
> in the Transport Area. It is clearly of interest to a number of these
> working groups.
>
> I gather that at least one more revision needs to be undertaken before
this
> document will be considered for publication as an RFC, but we're very
> interested to see it go forward.
>
> Jon Peterson
> NeuStar, Inc.
> (co-AD for Transport)
>
> > -----Original Message-----
> > From: Joel Tran [mailto:[email-masked]]
> > Sent: Tuesday, October 07, 2003 11:08 AM
> > To: Jonathan Rosenberg; Mmusic
> > Subject: [MMUSIC] Status of TURN
> >
> >
> > Hi Jonathan,
> >
> > I would like to ask you two little questions concerning TURN.
> >
> > First, I would like to know what is the exact status of TURN?
> > Will it be
> > adopted as a Workgroup item of MMUSIC since TURN is refeered
> > in various
> > documents?
> >
> > Second, I would like to ask you if there is a reason why the
> > lastest version
> > of the draft is not on the IETF web and only available throught
> > http://www.jdrosen.net/papers/draft-rosenberg-midcom-turn-02.txt?
> >
> > Thanks,
> > ...J
> >
> > _______________________________________________
> > mmusic mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mmusic
> >
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: "Pete Cordell" <[email-masked]>
Date: Thu, 16 Oct 2003 09:49:26 +0100

Paul,

Yes - I think it would be worth capturing this sort of thing as part of
starting a work item.  We would be happy to create an appropriate draft.

Pete.

+44 1473 635863

----- Original Message -----
From: "Paul Francis" <[email-masked]>
To: "Pete Cordell" <[email-masked]>; "Peterson, Jon"
<[email-masked]>
Cc: <[email-masked]>
Sent: 15 October 2003 14:46
Subject: Re: [midcom] Re: [MMUSIC] Status of TURN

> Could you briefly list these significant developments in Symmetric NAT
> traversal?
>
> Thanks,
>
> PF
>
>
> From: "Pete Cordell" <[email-masked]>
> To: "Peterson, Jon" <[email-masked]>; "Mmusic" <[email-masked]>
> Cc: <[email-masked]>; "Jonathan Rosenberg" <[email-masked]>
> Sent: Wednesday, October 15, 2003 8:47 AM
> Subject: [midcom] Re: [MMUSIC] Status of TURN
>
>
> > Dear Jon,
> >
> > I'm very surprised to see that TURN is being encouraged to be put
forward
> as
> > an individual submission.  We believe that TURN has major security
flaws,
> is
> > > The Transport Area Directors understand that this document will
proceed
> as

---

From: Melinda Shore <[email-masked]>
Date: Thu, 16 Oct 2003 08:34:00 -0400

> starting a work item.  We would be happy to create an appropriate 

We've been around this track a few times and I think it
would be a mistake to take a few more laps.  I would oppose
revisiting it yet again unless there's been substantial
progress in the arguments for taking this on.

Melinda

---

From: "Paul Francis" <[email-masked]>
Date: Thu, 16 Oct 2003 08:59:09 -0400

I wasn't suggesting a draft...I was just hoping you'd answer with an email
containing a list of these significant developments.

PF

----- Original Message ----- 
From: "Pete Cordell" <[email-masked]>
To: "Paul Francis" <[email-masked]>; "Peterson, Jon"
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, October 16, 2003 4:49 AM
Subject: Re: [midcom] Re: [MMUSIC] Status of TURN

> > > mainly due to the amount of effort that was being put into SIP
(RFC3261)
> > by

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 16 Oct 2003 21:16:34 -0400

Just because its an individual submission does not mean that comments 
and criticisms are not welcome. Please feel free to send me a note.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Pete Cordell" <[email-masked]>
Date: Fri, 17 Oct 2003 16:04:22 +0100

Hi Melinda,

I don't think we really did that many laps.  There was a bit of debate while
we were trying to understand what we wanted to do and people were tuning
into the same wavelength, but once we decided to move forward on a common
objective, we put a lot of material out and received hardly any comments
back.

I put that down to the SIP RFC being finalised at that time.  Key players in
the pre-midcom work were also key players in the SIP work and just didn't
have the spare cycles.

So I certainly don't think that we have done enough laps to say that we
can't reach consensus here (the SIP user=phone debate alone has probably had
more discussion!), and if there is interest in a solution we should do it
via the proper consensus making process rather than arbitrarily picking one
of the initial candidate solutions.

Pete.

----- Original Message -----
From: "Melinda Shore" <[email-masked]>
To: "Pete Cordell" <[email-masked]>
Cc: "Paul Francis" <[email-masked]>; "Peterson, Jon"
<[email-masked]>; <[email-masked]>
Sent: 16 October 2003 13:34
Subject: Re: [midcom] Re: [MMUSIC] Status of TURN

---

From: "Pete Cordell" <[email-masked]>
Date: Mon, 20 Oct 2003 15:01:05 +0100

Hi Jonathan,

That's generous of you, but I basically feel that there is either a need for
this work, in which case it should be done as part of the normal open IETF
process, or there isn't a need, in which case it should go no further.

As I've said elsewhere, I think the reason the effort failed last time was
because people were working on the SIP RFC.  I know you're superhuman (I am
impressed by your output), but I think even you were saturated at that time.
And I actually agree with your prioritisation at the time (there's no point
in having a traversal solution if there is nothing that needs traversing!)

However, to put it bluntly, I would feel aggrieved if those circumstances
were later used to justify fast tracking a proposal that did not represent
consensus of the interested parties involved.

Pete.

----- Original Message -----
From: "Jonathan Rosenberg" <[email-masked]>
To: "Pete Cordell" <[email-masked]>
Cc: "Peterson, Jon" <[email-masked]>; "Mmusic" <[email-masked]>;
<[email-masked]>
Sent: 17 October 2003 02:16
Subject: [midcom] Re: [MMUSIC] Status of TURN

> > I'm very surprised to see that TURN is being encouraged to be put
forward as
> > an individual submission.  We believe that TURN has major security
flaws, is

---

From: Melinda Shore <[email-masked]>
Date: Mon, 20 Oct 2003 10:27:25 -0400

> process, or there isn't a need, in which case it should go no further.

I hope it's understood that the publication of individual
submissions (i.e. not working group output) is in fact part of
the normal open IETF process, available to anybody who wishes
to jump through the various hoops to do it.  RFC 2026 mentions
it but probably doesn't make it as clear as it should.

Melinda

---

From: "Pete Cordell" <[email-masked]>
Date: Mon, 20 Oct 2003 16:47:12 +0100

Melinda,

I would argue that individual submissions are part of the IETF process, but
are not necessarily open.  If we and Jonathan were to evolve TURN (or
something similar) outside of a working group item, that would effectively
be a behind closed doors effort, and would not be open in the sense that
most IETF working group work is.

Publishing TURN as an individual submission would also set a bad precedent.
There's been a significant boom in the number of traversal solution
providers lately.  Publishing TURN would set the precedent that it is OK to
bypass the open process (at least in the traversal space) and use the
individual submission process to get that attractive RFC number (marketing
people and buyers don't really care what type it is).  True, the individual
process requires a lot of patience.  However, the open process requires a
thick skin, a willingness to compromise, re-writing code, possibly delayed
launch dates and ... a lot of patience!

Pete.

----- Original Message -----
From: "Melinda Shore" <[email-masked]>
To: "Pete Cordell" <[email-masked]>
Cc: "Jonathan Rosenberg" <[email-masked]>; "Peterson, Jon"
<[email-masked]>; "Mmusic" <[email-masked]>; <[email-masked]>
Sent: 20 October 2003 15:27
Subject: Re: [midcom] Re: [MMUSIC] Status of TURN

---

From: Melinda Shore <[email-masked]>
Date: Mon, 20 Oct 2003 12:11:15 -0400

> most IETF working group work is.

That's one way to look at it, I suppose, but the point really
is that publication of individual submissions is a route open
to anybody and that there's no process subversion here.  Note
as well that it's being published in draft form and he's
solicited input.

I'm actually not very happy about this, myself, and would
oppose pretty much any relaying technology.  Aside from the
technical issues, among the unfortunate consequences of all
this pre-midcom stuff has been that it's taken the pressure
off of firewall/NAT vendors to do something useful.  That's
not good.  But regardless of how I feel personally about all
this stuff I really think that advancing an individual draft
towards publication is not even remotely an abuse of IETF
process.

Melinda

---

From: "Pete Cordell" <[email-masked]>
Date: Mon, 20 Oct 2003 18:13:02 +0100

I agree that the process allows this.  However, I believe it would be unwise
to take this route.

The IESG can recommend that a draft not be published if (among other
reasons) it conflicts with work in the IETF.

The effort was stopped because people were too busy doing other things,
rather than it was not possible to reach consensus, hence it is not a failed
effort in that sense.  Now that people have more time, it seems that there
is still interest in it from more than one group.  Hence the correct thing
to do is see whether the work should be resumed.  (If you like, the work
should have been considered paused rather than stopped.)

It seems an act of considerable bad faith to stop a piece of work going
forward because you are busy, and then later claim that your individual
submission should be adopted because the work was stopped.

There seems only two options: the work item is re-started, or all work is
stopped.  To do otherwise would be an abuse of the spirit of the IETF even
if it is not in violation of the written rules.

Pete.

----- Original Message -----
From: "Melinda Shore" <[email-masked]>
To: "Pete Cordell" <[email-masked]>
Cc: "Jonathan Rosenberg" <[email-masked]>; "Peterson, Jon"
<[email-masked]>; "Mmusic" <[email-masked]>; <[email-masked]>
Sent: 20 October 2003 17:11
Subject: Re: [midcom] Re: [MMUSIC] Status of TURN

---

From: "Pete Cordell" <[email-masked]>
Date: Tue, 21 Oct 2003 12:11:40 +0100

> towards publication is not even remotely an abuse of IETF

Just to answer to the point you raised here Melinda, I think one of the
reasons FW/NAT vendors have not done useful things is that there isn't much
VoIP traffic out there.  There's not much VoIP traffic out there because it
doesn't go through FW/NAT very well!

My hope is that pre-midcom solutions will break that cycle.  They have their
limitations and that's what will move the technology on.

In other words, it might not be where you want to end up, but it's a
necessary stop on the way.

Pete.