Subject: Re: [midcom] Comments on the semantics draft: flow specification issues

From: Martin Stiemerling <[email-masked]>
Date: Tue, 05 Aug 2003 17:34:22 +0200

Hi,

| ==============================================
| Response (probably leading to more discussion)
| ==============================================
|
| There is an issue with complete generalization here.  SCTP was on the
| list earlier, and concern was expressed that there is as yet no
| specification for how NATs handle SCTP when it involves multihoming.
| Alain's issue 6 regarding encapsulation seems to have somewhat of the
| same flavour -- that is, it requires an additional description of
| middlebox functionality to serve as a starting point*.  The Midcom
| protocol is supposed to be about controlling that functionality, not
| defining it.  In other words, any middlebox capability we invoke should
| itself be specified in some other document, which we should include as a
| reference in this one.

I have to agree with Tom.

Any other protocol/encapsulation and their application in firewalls and NATs
should be defined in some other documents before MIDCOM is using them.
In view of the NAT-MIB, which may be used as part of the MIDCOM MIB module
solution, only TCP, UDP, and IP are supported.

Martin

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Alain Durand <[email-masked]>
Date: Tue, 05 Aug 2003 10:45:50 -0700

> Hi,

IPv6 in IPv4 encapsulation is well defined in RFC2893.

	- Alain.

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 06 Aug 2003 09:18:33 +0200

Hi Alian,

--On Dienstag, 5. August 2003 10:45 -0700 Alain Durand 
<[email-masked]> wrote:

|
|> I have to agree with Tom.
|>
|> Any other protocol/encapsulation and their application in firewalls
|> and NATs
|> should be defined in some other documents before MIDCOM is using them.
|> In view of the NAT-MIB, which may be used as part of the MIDCOM MIB
|> module
|> solution, only TCP, UDP, and IP are supported.
|>
|> Martin
|
| IPv6 in IPv4 encapsulation is well defined in RFC2893.

thanks for hint, but SCTP (another candidate) is defined as well in RFC 
2960.
The handling of these protocols in NATs remains unclear, i.e. there is no 
RFC
describing that.

Martin

|
| 	- Alain.
|

Martin Stiemerling

NEC Network Laboratories