Subject: RE: [midcom] RE: midcom digest, Vol 1 #688 - 1 msg

From: "Christian Huitema" <[email-masked]>
Date: Sat, 14 Jun 2003 23:42:59 -0700

> That's exactly the kind of thing I'm wondering about.  And to me it seems
> likely that in the common case, most of the internal hosts behind these NATs
> will be web browsers - each initiating HTTP-over-TCP sessions from many
> different client-side port numbers to port 80 at many different external
> servers, rendering the "NAT port frugality" benefits of cone NAT mostly
> useless. 
 
The whole argument is about the handling of UDP, not TCP. Nobody insists for cone behavior in the case of TCP.
 
-- Christian Huitema
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Bryan Ford <[email-masked]>
Date: Sun, 15 Jun 2003 12:20:37 -0400

Hi Christian,

> for cone behavior in the case of TCP.

Excellent point - thanks.  Once again I seem to be guilty of forgetting what 
utterly different beasts TCP and UDP are, particularly in light of the 
radically different usage models they have evolved historically.

Cheers,
Bryan