Subject: [midcom] Re: some comments on stun 01

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 08 Apr 2002 11:30:59 -0400

Cedric Aoun wrote:
> 
> Jonathan,
> 
> I'm refering to the bind timeout calculation algorithm
> 
> <JR> "How about this:
> 
> 1. the client sends a request to the server, from socket X. It is sent
> to address/port C,D. The response is sent from C,D. From the response,
> the client learns the public IP/port for this request, say thats A,B.
> 
> 2. after T seconds, the client sends a second request, from a different
> socket (Y), to the server at C,D. This one has a RESPONSE-ADDRESS of
> A,B. The server sends a response from C,D to A,B. If the old binding
> still exists, it is matched for all nat types, and the response goes to
> socket X. If the binding had timed out, the response will either be
> discarded, or it is possible that it might get sent to socket Y. In
> either case, the client knows that the binding has expired.
> 
> I believe that will work."
> </JR>
> 
> I agree with the approach, this is the right way to do it. I have a
> small comment on
> "or it is possible that it might get sent to socket Y", it won't since
> the datagram sent from Y
> created a new bind that didn't allocate A/B (that's how most NATs will
> normally behave).

I didn't want to make any assumptions on how they might behave. I was
worried that it may very well get reallocated. The text in the document
does clarify that this is teh reason it might go to Y.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: "Cedric Aoun"<[email-masked]>
Date: Mon, 8 Apr 2002 16:07:29 +0100

Jonathan,

<JR> "How about this:

I agree with the approach, this is the right way to do it. I have a small
comment on 
"or it is possible that it might get sent to socket Y", it won't since the
datagram sent from Y
created a new bind that didn't allocate A/B (that's how most NATs will
normally behave).

Thanks
Cedric