Subject: [Mathmesh] Lets get started

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 13 Aug 2019 12:09:31 -0400

I have just submitted a new set of the first five drafts in the series.

As far as the text goes, Parts I, II and III are pretty much complete and
consistent and the other two are works in progress which I hope to get into
a consistent state by the end of next week.

The drafts are written in anticipation of the HTML based RFC format and use
diagrams and mathematical notations for clarity. I strongly recommend
reading the HTML versions which are posted on the project Web site until
the IETF tools are brought up to date.

I. Architecture
http://mathmesh.com/Documents/draft-hallambaker-mesh-architecture.html
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-13>Provides
an overview of the Mesh as a system and the relationship between its
constituent parts.
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-14>II.
Uniform Data Fingerprint
http://mathmesh.com/Documents/draft-hallambaker-mesh-udf.html
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-15>Describes
the UDF format used to represent cryptographic nonces, keys and content
digests in the Mesh and the use of Encrypted Authenticated Resource
Locators (EARLs) and Strong Internet Names (SINs) that build on the UDF
platform.
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-16>III.
Data at Rest Encryption
http://mathmesh.com/Documents/draft-hallambaker-mesh-dare.html
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-17>Describes
the cryptographic message and append-only sequence formats used in Mesh
applications and the Mesh Service protocol.
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-18>IV.
Schema Reference
http://mathmesh.com/Documents/draft-hallambaker-mesh-schema.html
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-19>Describes
the syntax and semantics of Mesh Profiles, Container Entries and Mesh
Messages and their use in Mesh Applications.
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-20>V.
Protocol Reference
http://mathmesh.com/Documents/draft-hallambaker-mesh-protocol.html
<http://localhost:59545/Publish/draft-hallambaker-mesh-architecture-10.html#s-1-21>Describes
the Mesh Service Protocol.
The Mesh is at this point two things:

1) It is a tool designed to serve a specific, limited set of purposes.
2) It is a toolkit that can be used to address multiple purposes.

As far as IETF adoption goes, we could choose to adopt none, part or all as
WG items. However there are some constraints. Since part 5 depends on part
4, 4 on 3, and 3 on 2, it is not possible to choose to do part 4 without
also doing 3 and 2.

One of my greatest disappointments on the Web was that by the time Tim
assembled to team at CERN to fix HTTP, the exponent had already kicked in
and we were prisoners of the user base. So I have been holding off
deployment until at least I was happy with the way the system worked
together. This is now the third major redesign.

We will have to have some users before we can be sure we have a useful
spec. And having users does not mean we can't make breaking changes but we
will at least have to give them an upgrade path. So if anyone has a big
idea that is going to cause breaking changes, if they propose it now, there
will be no need for an upgrade plan which will make it simpler.

Since UDF is the simplest of the proposals and the others depend on it, I
suggest we start by looking at that first.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 14 Aug 2019 19:54:55 -0400

> will be no need for an upgrade plan which will make it simpler.

I agree. We need running code to figure out if it works.
So, a critical thing is to figure out what code should do when it sees
version > expected-version.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-