Subject: RE: more on reclaiming 225/8

From: "Dave Thaler" <[email-masked]>
Date: Fri, 6 Jul 2001 11:42:00 -0700

[mboned list bcc'd, follow up should be on malloc list]

Dave Meyer write:
> >>   225/8 was allocated for experimentation with the MASC protocol.
> >>   In particular, it was to be used to statically assign the top
> >>   level of the MASC infrastructure (statically) so we didn't have
> >>   to deploy a BRIB capable routing system before experimenting
> >>   with the MALLOC architecture. The assignment is (from
> >>   http://www.iana.org/assignments/multicast-addresses):
> >>
> >>   225.0.0.0-225.255.255.255  MALLOC (temp - renew 1/01) [Handley]
> >>
> >>   Since we are not using 225/8 for this purpose (or at all, for
> >>   that matter), I want to reclaim it. Mark Handley suggested that
> >>   I mention this to the list. If you have comments, please
> >>   respond directly to me (copying the list).

I propose that we use 225/8 for unicast-prefix-based IPv4 multicast addresses (since it would be basically a drop-in replacement for MASC).  I mentioned this idea (but not the specific range) at the last MADDOGS meeting where I gave the differences between IPv4 and IPv6 (I think you have the slides on your site Dave).  Since I got favorable feedback about this idea, Andy Adams and Bill Siadak volunteered to go write it up in a draft.  I had suggested to Andy and Bill that they use 225/8 in the draft when they write it up.

-Dave

---

From: David Meyer <[email-masked]>
Date: Fri, 6 Jul 2001 12:43:30 -0700

>> I propose that we use 225/8 for unicast-prefix-based IPv4 multicast addresses (since it would be basically a drop-in replacement for MASC).  I mentioned this idea (but not the specific range) at t…

I don't disagree with the approach (unicast-prefix-based
...). However, the IANA assigned this prefix temporarily for a
different purpose, and since we don't in any way own this (or
really any) prefix, this is what should be done: 

(i).	Return 225/8 to the IANA immediately

(ii).	Request a prefix assignment from the IANA when your
	document is done.  

I will notify the IANA (copied).

Dave

---

From: Mark Handley <[email-masked]>
Date: Fri, 06 Jul 2001 14:57:28 -0700

>I propose that we use 225/8 for unicast-prefix-based IPv4 multicast address
>es (since it would be basically a drop-in replacement for MASC).  I mentioned 
>this idea (but not the specific range) at the last MADDOGS meeting where I gav
>e the differences between IPv4 and IPv6 (I think you have the slides on your s
>ite Dave).  Since I got favorable feedback about this idea, Andy Adams and Bil
>l Siadak volunteered to go write it up in a draft.  I had suggested to Andy an
>d Bill that they use 225/8 in the draft when they write it up.
>>> 
>>> -Dave
>

The point of the allocation was to experiment with whatever address
allocation mechanism the IETF MALLOC group decides on.  We definitely
seem to be lacking consensus on deploying MASC, so the question is can
the MALLOC working group achieve consensus as to an alternative?

If we have consensus on a replacement for MASC, then it makes sense to
me to use 225/8 to experiment with that replacement.  If we don't
agree on a replacement, then we should return 225/8 until such time as
there's some general agreement.

Can we decide this on the list, or do we need to discuss it in London?

Cheers,
	Mark

---

From: Randy Bush <[email-masked]>
Date: Fri, 06 Jul 2001 15:25:44 -0700

> me to use 225/8 to experiment with that replacement.

why not go the straight path.  the allocation was for masc.  if masc is not
flying, return it.  when someone needs space for another experiment, then
do the normal thing, and file a request for it.

hoarding it seems quite rude.

randy