Subject: sdr

From: Ali Boudani <[email-masked]>
Date: Thu, 26 Apr 2001 11:52:04 +0200

hello,
sdr is used to announce an address for an application and that address
is used taking into account different parameters (region, ...). so what
is the difference in general with Malloc and MASC??

thanx

---

From: Pavlin Ivanov Radoslavov <[email-masked]>
Date: Fri, 27 Apr 2001 14:16:58 -0700

> is the difference in general with Malloc and MASC??

sdr is here and works (assuming that everybody uses sdr to allocate
mcast addresses). However, sdr will not scale to a large number of
groups, therefore the need for malloc. Both MASC and AAP, which are
part of the malloc arcitecture, use the same principle for address
allocation as sdr, except that it has been adapted for the
particular requrements for MASC or AAP.

Pavlin