Subject: [lisp] Questions on draft-ietf-lisp-eid-mobility-00.txt

From: Yue LI <[email-masked]>
Date: Thu, 3 Aug 2017 17:51:21 +0200

Dear lispers,

One question on L3 Mobility in the draft-ietf-lisp-eid-mobility-00.txt
<https://tools.ietf.org/html/draft-ietf-lisp-eid-mobility-00>.

How the 1st sequence of the packet flow (1st paragraph on Page 7) can be
achieved please?
The Device 1 keeps its EID=1.0.0.1, but the prefix of Site D is 2.0.0.0/24.
Since 1.0.0.1 is not belongs to 2.0.0.0/24. How the packets can be
exchanged between xTR D and Device 1?

Waiting for your explanations and many thanks.

Best regards,
-- 
Yue LI
PhD student, Telecom ParisTech
Tel: +33 (0)661091840
E-mail: [email-masked]

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 3 Aug 2017 11:57:58 -0700

Thanks for the question Yue. I included the diagram so others can follow easier:

> How the 1st sequence of the packet flow (1st paragraph on Page 7) can be achieved please?

Device 1 is sending packets no matter where it is connected. So it will use its default router to send packets. The first-hop router in Site D will typically have the same Mac address of the default router used in in Site A. 

> The Device 1 keeps its EID=1.0.0.1, but the prefix of Site D is 2.0.0.0/24. Since 1.0.0.1 is not belongs to 2.0.0.0/24. How the packets can be exchanged between xTR D and Device 1?

xTR D discovers EID 1.0.0.1 when Device 1 sends packets. Or, if by chance, xTR D is directly connected to where Device 1 moved to, can use ARP/ND (if Device 1 felt the need to send an ARP request during the move). But xTR D will see packets from 1.0.0.1, apply policy to either permit or deny the roaming of 1.0.0.1, and if permitted, registers EID 1.0.0.1/32 with RLOC IP_D to the mapping system. 

When Device 1 is not directly connected to xTR D, the first-hop-router learns 1.0.0.1 (when Device 1 sends an IP or ARP packet) and must inject the route 1.0.0.1/32 into the IGP so xTR D can learn about the existence of 1.0.0.1 so it can register it.

Does that help?

Dino